TEKLYNX LABEL ARCHIVE 2.0 Label Management Software Administrator's Guide
Anúncio
Anúncio
®
T E K LY NX
LABEL ARCHIVE
V E R S I O N
2 .
.
0
®
A D M I N I S T R A T O R ’ S G U I D E
The information in this manual is not binding and may be modified without prior notice.
Supply of the software described in this manual is subject to a user license. The software may not be used, copied or reproduced on any medium whatsoever, except in accordance with this license.
No portion of this manual may be copied, reproduced or transmitted by any means whatsoever, for purposes other than the personal use of the buyer, unless written permission is obtained from Braton Groupe sarl.
©2006 Braton Groupe sarl,
All rights reserved.
Teklynx and its products are trademarks or registered trademarks of Braton Group sarl or its affiliated companies. All other brands and product names are the trademarks of their respective owners.
Table of Contents
Typographical Conventions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . v
LABEL ARCHIVE Modules. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-2
LABEL ARCHIVE Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-2
LABEL ARCHIVE Client . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-2
LABEL ARCHIVE Web Module . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-2
Chapter 2: LABEL ARCHIVE Server Installation . . . . . . . . . . . . . . . . . . . 2-5
Software License Activation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-14
LABEL ARCHIVE Web Module Configuration . . . . . . . . . . . . . . . . . . . 2-15
LABEL ARCHIVE Modification (Add/Remove Features) . . . . . . . . . . . . . . 2-17
Managing Users and Permissions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-21
Predefined User Profiles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-21
Changing the “Administrator” Password. . . . . . . . . . . . . . . . . . . . . . . . . . . 2-23
How to Update the Config File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-23
ii Administrator’s Guide
Chapter 3: LABEL ARCHIVE Client Installation. . . . . . . . . . . . . . . . . . . 3-27
LABEL ARCHIVE Client Repair . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-33
Chapter 4: LABEL ARCHIVE Server Administration . . . . . . . . . . . . . . . 4-35
Functions Subnode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-38
History Settings Subnode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-40
Watermark Subnode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-41
Database Information Subnode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-43
Workstation Settings Subnode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-44
Connections Subnode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-45
Reset Documents Subnode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-46
Delete History Records Subnode . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-48
Delete Documents And Data Subnode . . . . . . . . . . . . . . . . . . . . . . . . 4-49
Export Database Subnode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-52
Import Database Subnode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-53
Chapter 5: LABEL ARCHIVE Client Administration . . . . . . . . . . . . . . . 5-57
Client Configuration Node . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-59
Approval Rules Node . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-60
Table of Contents
iii
iv Administrator’s Guide
About this Manual
Typographical
Conventions
This manual distinguishes between different types of information using the following conventions:
• Terms taken from the interface itself, such as commands, appear in bold.
• Keys appear in small caps, for example: ”Press the
SHIFT
key”.
• Numbered lists mean there is a procedure to follow.
• When the conjunction -or- appears next to a paragraph, it means there is the choice of another procedure for carrying out a given task.
• When a menu command contains submenus, the menu name followed by the command to select appear in bold. Thus, ”Go to File > Open” means choose the
File menu, then choose the Open command.
This symbol highlights important information on how a particular command or procedure works.
Following this symbol you will find hints and tips for optimizing tasks, speeding up commands, and so on.
vi
About your
Product
Administrator’s Guide
Some of the functions described in this manual may not be available in your product.
For the complete list of specific features available in your software, refer to the specification sheet provided with the product.
C H A P T E R
1
Introduction
Welcome!
Congratulations! You have just acquired a complete and secure product solution to store barcode labels, trace the history of design modifications and print events, manage label versions and set up approval workflows.
LABEL ARCHIVE Server and Clients run on your company's network in conjunction with Teklynx Label
Designers, and an optional Web module can also be used to provide limited access to external users.
The great scalability of this product allows you to also install all components on your PC, and work in standalone mode like a simple desktop application.
Chapter 1 - 2 Administrator’s Guide
LABEL ARCHIVE Modules
The LABEL ARCHIVE package contains several modules:
LABEL ARCHIVE Server, LABEL ARCHIVE Client and
LABEL ARCHIVE Web Module.
LABEL
ARCHIVE
Server
The LABEL ARCHIVE Server is a centralized database driven through a Windows® service. It establishes the connection with the different data sources, and processes all client requests: Check In, Check Out, Print History,
Document Approval, etc. The Server also uses two Teklynx subsystems to operate: UMSS (User Management System) and MSGS (Messaging System). UMSS and MSGS respectively perform user configuration and messaging functions.
LABEL
ARCHIVE
Client
The LABEL ARCHIVE Client is the add-in for the Label
Designer application. When the user invokes LABEL
ARCHIVE from the Label Designer, this add-in connects to the Server and checks user rights. If the connection is successful then the user is allowed to perform different document management actions such as Check In and
Check Out, and is given access to the centralized label storage database. The actions allowed depend upon the security settings and permissions that have been granted to the group to which the user belongs.
LABEL
ARCHIVE Web
Module
The LABEL ARCHIVE Web Module is a Web application accessible from any Web browser on the Internet or an intranet. Upon successful user Web authentication, this module establishes a connection with LABEL ARCHIVE
Server and gives access to limited functions including viewing documents and history records, and approving documents before delivery in production.
How It Works
LABEL ARCHIVE Server typically runs on a server machine. On the internal network, any client station that has a Label Designer and the LABEL ARCHIVE Client add-in can interact with the server at any time. All LABEL
ARCHIVE components can also be installed on a single PC.
In that case the system works in standalone mode, like a simple desktop application.
Introduction Chapter 1 - 3
Product Description
LABEL ARCHIVE is designed to run on any computer running a supported Windows® operating system.
Your product includes the following components:
• a CD-ROM
• complete documentation
• a license agreement
• an activation code, which allows you to activate the license of LABEL ARCHIVE Server on your server machine
Note
If you have not purchased an activation code yet, you can still use LABEL ARCHIVE for 30 days. During this trial period you can install as many clients as you want, and the system will accept up to 3 simultaneous connections to the server. After the trial period you will need to purchase an activation code. All the work that was done during the trial period is kept in the database, and you can continue it after activation without any disruption.
Chapter 1 - 4 Administrator’s Guide
C H A P T E R
2
LABEL ARCHIVE Server
Installation
System Requirements
The basic software and hardware requirements needed to run the Server are:
• A PC with Windows® 2000 SP4, Windows® XP
SP2, or Windows® Server 2003 SP1
• 256 MB RAM minimum (512 MB recommended) and
1 Ghz processor
• A VGA monitor or better
• A hard drive with at least 500 MB of free disk space
• Microsoft® .NET Framework 2.0
• Microsoft® Data Access Components (MDAC) 2.8
• Supported database management systems (DBMS):
Microsoft® SQL Server™ family (Microsoft® SQL
Server™, Microsoft® SQL Server™ Desktop Engine
(MSDE), Microsoft® SQL Server™ Express) or
Microsoft® Access
Note
Access and SQL Server Express are not recommended for a configuration with multiple clients.
Chapter 2 - 6
Installation
Administrator’s Guide
Before running the installation program, check the configuration of your server machine.
LABEL ARCHIVE Server installation requires administration rights on the server machine. Please check that all needed permissions are granted, both at the operating system level, and at the DBMS level, as you will be installing new Windows services, copying program files, setting up a Web module on Internet Information Services
(IIS), and creating new databases on your DBMS.
To install LABEL ARCHIVE Server:
Step 1 > Place the CD-ROM in the appropriate drive.
The LABEL ARCHIVE CD window appears. Select LABEL
ARCHIVE Server and click on Install.
If the CD-ROM does not start up automatically, go to Start
> Run, type cdsetup.exe, and click OK.
Step 2 > The Installation Wizard will appear. Click Next.
Step 3 > Read the license agreement. If you agree with the license agreement, select “I accept the terms of the license agreement“ and click Next.
LABEL ARCHIVE Server Installation Chapter 2 - 7
Figure 1
License Agreement
Step 4 > Select the setup type: Typical or Custom.
Figure 2
Setup Type
Chapter 2 - 8 Administrator’s Guide
If you select Typical, the LABEL ARCHIVE Server component and UMSS/MSGS subsystems will be installed.
You will need to select the database type before the installation can be completed. All other settings are automatically defined during the installation. The path by default on which the files will be installed is “<system drive>\Program Files\Teklynx\.”
Selecting a Custom installation will allow you to select the components you wish to install, and to customize their setup on your machine. If you choose Custom, you will be guided through the following steps:
Step 1 > Choose the Destination Location.
In this step you can choose the folder where the files will be installed. The step is available only with the Custom installation type.
Figure 3
Choose Destination Location
LABEL ARCHIVE Server Installation Chapter 2 - 9
Step 2 > Select the features you wish to install.
Here you can select which components you’d like to install:
• LABEL ARCHIVE Server
• UMSS and MSGS
• LABEL ARCHIVE Web
Depending on the components you choose to install, the following steps may differ in order.
LABEL ARCHIVE Server needs UMSS/MSGS to run. Therefore if you want to install only LABEL
ARCHIVE Server, you must make sure that
UMSS/MSGS has already been installed.
Step 3 > Select the database type that you want to use.
Figure 4
Database Type
Chapter 2 - 10 Administrator’s Guide
If you select an SQL Server type DBMS, you will be asked to enter the instance of the desired SQL Server (choose from the drop-down menu or search for a specific location by clicking on Browse...).
Figure 5
Database Server
Special installation instructions for SQL configurations with “named instances”:
During LABEL ARCHIVE Server installation, the wizard may display several possible Database
Servers, for example:
1 - (Local)/DB instance name
2 -(Workstation name)/DB instance name
You must select an item that contains a workstation name to ensure a correct connection. In our example, you must choose item #2.
Step 4 > Select the Web site on which you want to deploy
LABEL ARCHIVE Web.
LABEL ARCHIVE Server Installation Chapter 2 - 11
Figure 6
Web Site Settings
Step 5 > Enter the name of the Web site’s virtual directory.
Figure 7
Virtual Directory Settings
Chapter 2 - 12
• Installing LABEL
ARCHIVE Web module
Administrator’s Guide
If you are installing the LABEL ARCHIVE Web module
only, you will be prompted with the LABEL ARCHIVE
Server Settings window. This window allows you to select the LABEL ARCHIVE Server address and ensure that
LABEL ARCHIVE is already installed and ready to run.
Figure 8
LABEL ARCHIVE Server Settings
• Installing LABEL
ARCHIVE Server
If you are installing the LABEL ARCHIVE Server component
only, you will be prompted with the UMSS and MSGS
Servers window so that you can specify the location of the
UMSS/MSGS server.
LABEL ARCHIVE Server Installation Chapter 2 - 13
Figure 9
UMSS and MSGS Servers
Step 6 > Final installation step: If you are sure that the parameters entered in the previous steps are correct, click
Install to complete the installation. If you want to review or change any of your installation settings, click Back.
Chapter 2 - 14 Administrator’s Guide
Figure 10
Ready to Install the Program
Software License
Activation
You can use LABEL ARCHIVE in trial mode for 30 days.
After that period the server is blocked. Any connection attempt results in an error message “Maximum number of connections reached,” and if you stop the LABEL ARCHIVE
Windows service, you will not be able to restart it again. To continue to use the software you must activate the license.
To activate the software license:
Step 1 > Go to Start > Programs > Teklynx > License
Manager. A wizard is displayed.
Step 2 > Choose Activate and follow the wizard screens.
You will need to enter the activation code that was provided to you when you purchased the software.
Note
If you activate the license once the trial period is expired, you will need to reboot the LABEL ARCHIVE
Server computer.
LABEL ARCHIVE Server Installation
LABEL ARCHIVE
Web Module
Configuration
Chapter 2 - 15
After installing LABEL ARCHIVE Web Module, you should verify the Web site settings:
Step 1 > Go to Control Panel > Administrative Tools >
Internet Information Services.
Step 2 > In the navigation frame on the left, navigate to the
Web virtual directory folder (i.e., (local computer) \ Web
Sites\ Default Web Site \ LAS).
Step 3 > Right-click on the Web virtual directory folder (i.e., the LAS folder) and select Properties.
Step 4 > Click on the ASP.NET tab.
Step 5 > Verify that the ASP.NET version is set to
2.0.50727.
Figure 11
Web Site Properties
Chapter 2 - 16
Uninstallation
Administrator’s Guide
To remove the different server components from your computer:
Step 1 > Go to Control Panel > Add or Remove Programs.
Step 2 > Select LABEL ARCHIVE Server and click on
Change/Remove.
Step 3 > In the next window, select the Remove option and click on Next.
Figure 12
Modify, Repair, or Remove the Program
The uninstallation program asks you:
• Do you want to delete Databases: LABEL ARCHIVE,
UMSS, MSGS? (if you used SQL Databases)?
- or -
• Do you want to backup Databases: LABEL
ARCHIVE, UMSS, MSGS? (if you used Access
Databases)?
LABEL ARCHIVE Server Installation Chapter 2 - 17
The uninstallation program will delete the installed components from your computer and optionally the databases if specified.
LABEL ARCHIVE Repair
If the installed LABEL ARCHIVE Server components proved to be corrupted, you can fix them by using the
Repair mode (see Figure 12).
In this mode the setup will reprocess the installation of the different components. The installation settings that you entered during the last installation will be reused.
SQL Database: In this mode the structure of SQL Database will be repaired (for example, if your SQL database structure was corrupted).
Access Database: In this mode the Access Database will be overwritten, but before starting the repair process, the setup will propose to “Create backup-files for your
Databases,” and after the repair you will be able to replace the database.
LABEL ARCHIVE Modification (Add/Remove
Features)
If you want to add components which were not previously installed, you can use the Modify mode (see Figure 12). In this mode the setup will propose to select the components to be installed.
Chapter 2 - 18 Administrator’s Guide
Figure 13
Modify Features
Configuring E-mail Sending
In order for LABEL ARCHIVE to send e-mail notifications, an e-mail sending action must be created in the MSGS subsystem. For more details about how to use MSGS, please refer to your MSGS guide.
To configure e-mail sending:
Step 1 > Connect to the MSGS subsystem (accessible from the Teklynx Servers Administration shortcut).
Step 2 > Create a standard filter for the LAS application with the following property:
MSGCODE = MSG_SENDMAIL.
Step 3 > Create an SMTP action handler, and indicate the parameters that your company uses for sending e-mails through SMTP protocol (Configuration button).
LABEL ARCHIVE Server Installation
.
Chapter 2 - 19
Figure 14
SMTP Action Handler Properties
Step 4 > Create an action that uses your filter and your action handler. In the parameters zone, indicate the following four variables:%TONAME%,%TOADDRESS%,
%SUBJECT%,%MSGTEXT%.
Chapter 2 - 20 Administrator’s Guide
Figure 15
E-mail Configuration
Your e-mail sending mechanism is ready for use.
Later on, when LABEL ARCHIVE will need to send e-mail notifications, it will automatically create internal MSGS messages. These MSGS messages will be instantly captured by the MSGS action that you just created and which is permanently waiting in background. The action will populate the different variables and send e-mails via the
SMTP server.
Note
When declaring the SMTP server, make sure that the
SMTP provider allows sending e-mails from the network where LABEL ARCHIVE Server is installed.
LABEL ARCHIVE Server Installation Chapter 2 - 21
Managing Users and Permissions
LABEL ARCHIVE uses the UMSS subsystem to manage all users and permissions. At any time the administrator can create, modify, or delete users, passwords, and user groups. For more details about permissions management, please refer to your UMSS administrator’s guide.
In UMSS, when you create a new user for LABEL
ARCHIVE, you must not choose authentication
“Windows” in the parameters of that user. Please
choose “UMSS” authentication only.
Predefined User
Profiles
At install time, the system creates predefined User Groups.
These groups correspond to typical profiles that a company may need to use to manage the different user permissions for all LABEL ARCHIVE business processes.
Five different user groups are available:
• ADMINISTRATORS
Administrators have all rights on LABEL ARCHIVE, and also on UMSS and MSGS subsystems. Their typical role is to be in charge of the IT responsibility of the entire system.
A default Administrator user is provided. Its initial password is “admin”.
Additional users can be created and assigned to the
Administrators group.
• MANAGERS
Managers’ typical role is to be in charge of the business data and processes of LABEL ARCHIVE. Managers can define system settings, create approval workflows, or be required to approve documents before delivery in production.
Compared to Administrators, Managers do not have permission to administrate the database or define workstation settings. They cannot perform operations like import DB, export DB, force undo check-out, DB archive, or manage workstations.
A default Manager user is provided. Its initial password is empty.
Chapter 2 - 22
• DESIGNERS
• PRINTUSERS
• CUSTOMERS
Administrator’s Guide
Additional users can be created and assigned to the
Managers group.
Designers’ typical role is to be in charge of the creation and management of a document or a set of documents.
Designers can create documents, modify documents, check-in new versions, submit documents for approval, and participate in approval processes.
Compared to Managers, Designers do not have permission to modify system settings, create or modify approval schemes, or modify categories.
A default Designer user is provided. Its initial password is empty.
Additional users can be created and assigned to the
Designers group.
Print Users’ typical role is to open documents and print them in production.
Different from Designers, Print Users do not have permission to modify documents, and they can only access documents that are in Final state.
Print Users can use the Run-Time version of the Label
Designer to carry on their activities.
A default PrintUser user is provided. Its initial password is empty.
Additional users can be created and assigned to the
PrintUsers group.
In some cases, documents may need to be approved by
Customers before delivery in production.
Customers, therefore, are given minimum access to the system, including browsing their documents and all related details, and taking part in an approval workflow.
Customers can use the LABEL ARCHIVE Web Module, through an Internet browser, and receive notifications by email.
LABEL ARCHIVE Server Installation Chapter 2 - 23
A default Customer user is provided. Its initial password is empty.
Additional users can be created and assigned to the
Customers group.
You can freely modify, customize or delete the predefined groups, users and permissions, except for the Administrator.
Note
To view all permissions that are granted to a given User, select the related Group from the “User Groups” node in UMSS, and click on the Permission tab.
Changing the “Administrator” Password
The predefined Administrator user is also used by the
LABEL ARCHIVE system itself.
Its initial password is admin. If you change this password, you will also need to manually change the configuration file of LABEL ARCHIVE Server.
After such an operation, if you do not update the
LABEL ARCHIVE Server configuration file accordingly, the system will not work properly.
How to Update the Config File
The configuration file to be updated is called
“TkxArv.server.config”. It is located in the installation directory (usually Program Files\Teklynx\Label Archive
Server\).
Once you have opened “TkxArv.server.config”, go to the following xml section: <configuration>, then <tkxsvr>,
<umss>, <client>.
You will find the <logonconfig> tag, which has the following elements: defaultusername (Administrator), and defaultpasswordhash, (hash for 'admin' password).
Chapter 2 - 24
Special Notes
Administrator’s Guide
Replace the old password hash value with the new password hash value.
The password hash value is stored in the UMSS ‘USERS’ table, within the ‘PASSWORDHASH’ field.
Once the replacement is done (using copy/paste), you must restart the LABEL ARCHIVE Server Windows service.
Note
Through proper management of security and access rights on the databases and the server system, you can ensure that only authorized users can perform such operations.
Note
You can also create additional users and give them administrator rights, by assigning them to the
Administrators group.
• The user interfaces to administrate LABEL
ARCHIVE Server and Client are made using the
MMC (Microsoft Management Console) snap-in, so they can be manipulated like any standard MMC component in Windows.
• If you want to install the database on a computer that is different from the one that hosts the LABEL
ARCHIVE Server processes and services, then full
SQL Server is required.
• Remote SQL Server running on Windows 2000 should have Service Pack 4 installed.
• If you install LABEL ARCHIVE with the Access database, the database is protected by a password, initially set to tkllas. To replace it with a new password, edit “TkxArv.server.config”. This file is located in the installation directory (usually Program Files\Teklynx\Label Archive Server\). Once the file is opened, type the new password in the following xml section:
LABEL ARCHIVE Server Installation Chapter 2 - 25
<configuration>, then <TkxArv.DataAdapters>,
<DataAdapter name="oledb"....Password=
newpassword>. Then stop/start the “Label Archive
Server” Windows service.
• For SQL Server 2005, make sure that remote connections are allowed (disallowed by default).
• If you have a firewall, you must unblock ports 8088 and 8989.
• “LABEL ARCHIVE Server” Windows service: The
Server program is run through a Windows service named “Label Archive Server,” which is configured by default to automatically start. The service has a dependency link with the UMSS/MSGS Windows service, named “TkxSvr Servers service.” You can start and stop Windows services manually by using the standard Windows administration tool.
Before doing administration work on LABEL
ARCHIVE Server (i.e., changing parameters and options, importing/exporting data, etc.), it is highly recommended to first ensure that all clients are disconnected. If you change some settings, you may then want to stop and restart the “Label
Archive Server” Windows service for all changes to be effective.
Chapter 2 - 26 Administrator’s Guide
C H A P T E R
3
LABEL ARCHIVE Client
Installation
System Requirements
The basic software and hardware requirements needed to run the Client are:
• A PC with Windows® 2000 SP4, Windows® XP
SP2, or Windows® Server 2003 SP1
• 256 MB RAM minimum (512 MB recommended) and
1 Ghz processor
• A VGA monitor or better
• A hard drive with at least 500 MB of free disk space
• Microsoft® .NET Framework 2.0
• A Label Designer product and version that is compatible with this version of LABEL ARCHIVE
Chapter 3 - 28
Installation
Administrator’s Guide
Before running the installation program, check the configuration of your PC.
To install LABEL ARCHIVE Client:
Step 1 > Place the CD-ROM in the appropriate drive.
The LABEL ARCHIVE CD window appears. Select LABEL
ARCHIVE Client and click on Install.
If the CD-ROM does not start up automatically, go to Start
> Run, type cdsetup.exe, and click OK.
Step 2 > The Installation Wizard will appear. Click Next.
Step 3 > Read the license agreement. If you agree with the license agreement, select “I accept the terms of the license agreement“ and click Next.
Figure 16
License Agreement
Step 4 > Enter the required customer information.
LABEL ARCHIVE Client Installation Chapter 3 - 29
Please indicate:
• User Name
• Company Name
• Who will be able to use this application: only you or anyone who uses the computer
Figure 17
Customer Information
Step 5 > Choose the Destination Location.
At this stage you can choose the folder where the files will be installed.
Chapter 3 - 30 Administrator’s Guide
Figure 18
Choose Destination Location
Step 6 > Select the LABEL ARCHIVE Server name.
Select the name of the LABEL ARCHIVE Server machine to which the Client will connect.
Figure 19 LABEL ARCHIVE Server
Settings
LABEL ARCHIVE Client Installation Chapter 3 - 31
If you are sure that the parameters entered in the previous steps are correct, click on Install to continue the installation.
If you want to review or change any of your installation settings, click on Back.
Figure 20
Ready to Install the Program
Chapter 3 - 32
Uninstallation
Administrator’s Guide
To remove the LABEL ARCHIVE Client from your computer:
Step 1 > Go to Control Panel > Add or Remove Programs.
Step 2 > Select LABEL ARCHIVE Client and click on
Change/Remove.
Step 3 > In the next window, select the Remove option and click Next.
Figure 21
Repair or Remove the Program
The uninstallation program will delete the installed components of LABEL ARCHIVE Client from your computer.
LABEL ARCHIVE Client Installation Chapter 3 - 33
LABEL ARCHIVE Client Repair
If the installed LABEL ARCHIVE Client proved to be corrupted, you can fix it using the Repair mode.
In this mode the system will redo the installation of LABEL
ARCHIVE Client. The installation settings that you entered during the last installation will be reused.
Chapter 3 - 34 Administrator’s Guide
C H A P T E R
4
LABEL ARCHIVE Server
Administration
Logging In
Figure 22
LABEL ARCHIVE Server Administration Login
To launch LABEL ARCHIVE Server Administration:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2 > LABEL ARCHIVE Server Administration.
Step 2 > Type a valid user name and password (i.e., defined in UMSS and having appropriate permissions).
The Change check box allows changing the password at any time.
Chapter 4 - 36
General Layout
Administrator’s Guide
Figure 23
LABEL ARCHIVE Server Administration
Upon successful login, the Administration window will appear.
This window allows changing different settings for the
LABEL ARCHIVE Server module.
Note
The settings for the client are accessible from LABEL
ARCHIVE Client Administration.
General Layout
The layout of the Administration window of LABEL
ARCHIVE Server follows the Microsoft Management
Console (MMC) standard.
LABEL ARCHIVE Server Administration Chapter 4 - 37
Three buttons are added to the default set of MMC:
Save: Saves all changes made in the current window.
Refresh: Cancels all changes made in the current window and refreshes its state.
Add: Context-dependent button to create additional items.
Navigation Tree
In this tree control the user can select all functions available in the Administration program.
Depending on the selected node in the navigation tree, the right-side work panes are updated.
Work Pane
Depending on the selected node in the navigation tree, the work pane displays the associated settings.
Navigation
Single functions are chosen by selecting a node in the navigation tree. When there is no functionality for a parent node, a page is shown to indicate that you must select a subnode.
Chapter 4 - 38 Administrator’s Guide
Settings Node
Functions
Subnode
• Archiving
• Approval
To access the Settings node:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Settings node in the navigation tree.
This node allows changing functional, history and watermark settings for LABEL ARCHIVE Server.
When you select the Settings node, the Functions,
History and Watermark subnodes become available.
To access the Functions subnode:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Settings node in the navigation tree.
Step 4 > Select the Functions subnode in the Settings node.
This subnode allows changing functional settings for
LABEL ARCHIVE Server.
The following settings are available in this subnode:
When archiving is switched On, the versioning is active for all documents. At check-in a document can no longer be overwritten and a new version needs to be created. When archiving is switched Off, the document version number is not increased at check-in. New documents overwrite previous ones.
If approval is Off, then only the Final state can be assigned to documents. If approval is On, then at least two document states can be assigned: Draft and Final.
LABEL ARCHIVE Server Administration
• 3-state Approval
Chapter 4 - 39
3-state Approval can only be activated if Approval is enabled. When it is On, the In Approval state can be chosen for documents.
Note
The following settings: Archiving, Approval, and 3-
State Approval are defined both at category level in
LABEL ARCHIVE Client Administration, and at global level in LABEL ARCHIVE Server. To be activated for a given document, they need to be switched ON both at category level and at global level.
• Allow Check-in
• Only work with
LABEL ARCHIVE
When On, LABEL ARCHIVE Server allows read/write access to documents. When switched Off, the documents can only be read. This setting is a global setting for all documents in LABEL ARCHIVE. It overrides the individual user permissions (set in UMSS).
This setting affects the Label Designer application. When switched On, the Label Designer will not allow working with documents that are stored in the Windows file system.
• Password required in approval
Defines whether user password confirmation is required to complete the approval process.
The Languages options allow you to specify the desired language for the user interface.
Note
For a language change to be fully effective you need to close and re-open the application.
Web site settings allows you to set the URL of the LABEL
ARCHIVE Web Module and browse to it using Open.
Chapter 4 - 40
History Settings
Subnode
Administrator’s Guide
Figure 24
History Settings Subnode in Settings
To access the History Settings subnode:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Settings node in the navigation tree.
Step 4 > Select the History Settings subnode in the
Settings node.
This subnode allows changing the history trace settings of
LABEL ARCHIVE.
The following settings are available in this subnode:
Use History writing: This is a global setting that determines whether the client application can write history entries into the database or not. When switched On, the history writing options are enabled, allowing you to define which history entries will be stored. When switched Off (or when no history writing options are selected), future client history events will not be stored in the database.
LABEL ARCHIVE Server Administration Chapter 4 - 41
Print: When switched On, the PRINT HISTORY entry will be written to the database after each print job.
Modifications: When switched On, the MODIFICATION
HISTORY entry will be written to the database after each change saved to any document.
Errors: When switched On, the ERROR HISTORY entry will be written to the database after error events.
Warnings: When switched On, the WARNING HISTORY entry will be written to the database after warning events.
Information: When switched On, the INFO HISTORY entry will be written to the database after information events.
Watermark
Subnode
Figure 25
Watermark Subnode in Settings
To access the Watermark subnode:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Settings node in the navigation tree.
Step 4 > Select the Watermark subnode in the Settings node.
This subnode allows changing watermark printing settings for LABEL ARCHIVE Server.
Chapter 4 - 42 Administrator’s Guide
The following settings are available in this subnode:
TestPrint: Specifies the text which will be printed over the document when a user performs a test print (printing a preview) of the LABEL ARCHIVE document. When it is left empty, no watermark is printed.
Re-print: Specifies the text which will be printed over the document when a user performs a reprint of the LABEL
ARCHIVE document. When it is left empty, no watermark is printed.
Management Node
To access the Management node:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Management node in the navigation tree.
This node allows reviewing the LABEL ARCHIVE database statistics, connection and workstation information.
Figure 26
Management node
When you select the Management node, the Database
Information, Workstation Settings, and Connections subnodes become available.
LABEL ARCHIVE Server Administration
Database
Information
Subnode
Chapter 4 - 43
Figure 27
Database Information subnode in Management
To access the Database Information subnode:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Management node in the navigation tree.
Step 4 > Select the Database Information subnode in the
Management node.
This subnode allows you to view statistical information on the LABEL ARCHIVE tables in the database, tables list and number of records per table.
Chapter 4 - 44 Administrator’s Guide
Note
The tables of the UMSS and MSGS subsystems are not displayed in this subnode.
Workstation
Settings
Subnode
Figure 28
Workstation Settings subnode in Management
To access the Workstation Settings subnode:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Management node in the navigation tree.
Step 4 > Select the Workstation Settings subnode in the
Management node.
This subnode allows defining workstations that will NOT receive notifications about user actions. For example, when setting up an automated system, you may not want document approval prompts to appear for certain workstations.
LABEL ARCHIVE Server Administration Chapter 4 - 45
• Apply
• Refresh
To add a new workstation to the list, click the New button, and then enter the workstation name in the corresponding
Name text box. To save the changes, click Apply.
The following controls are displayed:
Applies any changes made to the workstations list.
Displays the latest information about the workstations list from the database.
• New
• Delete
Adds a new workstation to the list.
Deletes a workstation from the list.
• Auto action popup
When unchecked, the workstation does not receive notifications about user actions.
Connections
Subnode
Figure 29
Connections subnode in Management
To access the Connections subnode:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Management node in the navigation tree.
Step 4 > Select the Connections subnode in the
Management node.
Chapter 4 - 46 Administrator’s Guide
This subnode shows the currently active connections to
LABEL ARCHIVE Server.
The Disconnect button allows disconnecting selected clients from LABEL ARCHIVE Server.
Tasks Node
To access the Tasks node:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Tasks node in the navigation tree.
This node allows performing different operations with database documents, such as resetting states, archiving, import/export, etc.
When you select the Tasks node, the Reset Documents,
Delete History Records, Delete Documents and Data,
Archiving, Export Database, and Import Database subnodes become available.
Reset Documents
Subnode
To access the Reset Documents subnode:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Tasks node in the navigation tree.
Step 4 > Select the Reset documents subnode in the
Tasks node.
This subnode contains two additional subnodes: Check out
state and Valid from date, which allow resetting documents based on the Checkout state or Valid from date.
The Checkout state subnode shows a list of all currently checked out documents.
LABEL ARCHIVE Server Administration Chapter 4 - 47
Figure 30
Checkout State subnode in Reset Documents
If desired, you can select documents using the check box in the Select column, and then reset their state using the
Reset button.
The Valid from Date subnode allows modifying that date for any document that is in Final state.
Figure 31
Valid from Date subnode in Reset Documents
Chapter 4 - 48
Delete History
Records
Subnode
Administrator’s Guide
The Valid from Date subnode contains three tabs:
Filter tab allows filtering Final documents by date interval and by category.
Documents tab allows selecting documents individually.
Change date tab allows changing the Valid from Date of selected documents.
If desired, you can select documents using the check box in the Select column, and then reset their Valid from Date using the Reset button.
To access the Delete History Records subnode:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Tasks node in the navigation tree.
Step 4 > Select the Delete History Records subnode in the Tasks node.
This subnode allows deleting history records using state, date interval and category tree filters.
The Delete History Records subnode contains two tabs:
Filter tab allows filtering documents by date and category.
Documents tab allows selecting documents individually and then clicking on Delete to clear their history entries.
LABEL ARCHIVE Server Administration Chapter 4 - 49
Delete
Documents And
Data Subnode
Figure 32
Delete History Records subnode in Tasks
Figure 33
Delete Documents and Data subnode in Tasks
To access the Delete Documents and Data subnode:
Chapter 4 - 50 Administrator’s Guide
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Tasks node in the navigation tree.
Step 4 > Select the Delete Documents and Data subnode in the Tasks node.
This subnode allows deleting documents from the LABEL
ARCHIVE Server database using state and category tree filters.
The Delete Documents and Data subnode contains two tabs:
Filter tab allows filtering documents by state and category.
Documents tab allows selecting documents individually and then clicking on Delete to delete the documents.
Archiving
Subnode
Figure 34
Archiving subnode in Tasks
LABEL ARCHIVE Server Administration Chapter 4 - 51
To access the Archiving subnode:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Tasks node in the navigation tree.
Step 4 > Select the Archiving subnode in the Tasks node.
This node allows archiving the LABEL ARCHIVE Server database to a Microsoft® Access file (.mdb file). Filtering is performed by document state and by category. Please note that the Archiving task will create a backup of all database tables including approval rules, user actions, etc.
The Archiving subnode contains three tabs:
Filter tab allows selecting documents by document states
(Active versions, Design state, Old final state) from the specified categories.
Documents tab allows selecting the desired documents for archiving manually by selecting check boxes.
Archive Options tab allows specifying the Access database file (.mdb file) for archiving in the Database text field. The Browse button allows selecting a file from the list of existing databases or creating a new database archiving file. The Delete after archive check box allows removing the selected documents from the LABEL ARCHIVE database after performing the archiving operation.
The Archive button performs the archiving operation.
Chapter 4 - 52
Export Database
Subnode
Administrator’s Guide
Figure 35
Export Database subnode in Tasks
To access the Export Database subnode:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Tasks node in the navigation tree.
Step 4 > Select the Export Database subnode in the
Tasks node.
This subnode allows exporting the database to a Microsoft®
Access file (.mdb file). Please note that the Export task creates a backup only for documents, categories and sysdata database tables.
The Export Database subnode contains three tabs:
Filter tab allows selecting documents by document states
(Active versions, Design state, Old final state) from the specified categories.
LABEL ARCHIVE Server Administration Chapter 4 - 53
Documents tab allows selecting the desired documents for exporting manually by selecting check boxes.
Export Options tab allows specifying a database file for exporting in the Database text field. The Browse button allows selecting a file from the list of existing databases or to creating a new database exporting file.
The Export Database button performs the exporting operation.
Import Database
Subnode
Figure 36
Import Database subnode in Tasks
To access the Import Database subnode:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Tasks node in the navigation tree.
Step 4 > Select the Import Database subnode in the
Tasks node.
This node allows importing the existing database from a
Microsoft® Access file (.mdb file) to the LABEL ARCHIVE database. Please note that the Import task works only with a database structure that is compatible with your LABEL
ARCHIVE version.
Chapter 4 - 54 Administrator’s Guide
The Import Database subnode contains three tabs:
Import source tab allows specifying the existing Access database file (.mdb file) in the Database text field or using the Browse button to browse the file system to select a file.
Documents tab allows selecting the desired documents for importing manually from the specified database by selecting check boxes.
Options tab allows specifying the target category in the
LABEL ARCHIVE system database for import. Use the
Target root category tree for this purpose.
Create sub folder check box allows importing the whole categories structure from the source Access database file
(.mdb file) to the LABEL ARCHIVE database. If it is unchecked, no categories will be created and all documents will be written to the target root category.
Conflict resolution options allow setting the behavior of an import when encountering documents that have the same names and versions.
Stop import terminates the import task when a first document conflict is encountered.
Skip documents skips any duplicate conflicting document.
Overwrite target overwrites any target conflicting document.
Import Database button performs the importing operation.
Figure 37
Import Database Options
LABEL ARCHIVE Server Administration
Documents Node
Chapter 4 - 55
Category
• Name
• Application
Figure 38
Documents node
To access the Documents node:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Server Administration.
Step 3 > Select the Documents node in the navigation tree.
This node allows changing document handling settings for
LABEL ARCHIVE.
This Documents node contains two tabs: Category and
Documents.
The name of the currently selected category.
Shows the name of the Label Designer application in which the category was created. It has to be changed if a user wants to work with another Label Designer.
Chapter 4 - 56 Administrator’s Guide
• Handler
• Lock at check out
When On, if a document is checked out by one user, other users can only do a reprint. When Off, other users can also open a document for print only.
• Archiving
Shows the name of the technical class which can work with documents stored in the category.
When archiving is switched On, the versioning is active for all documents. At check-in a document can no longer be overwritten and a new version needs to be created. When archiving is switched Off, the document version number is not increased at check-in. New documents overwrite previous ones.
• Approval
• 3-state Approval
If approval is Off, then only Final state can be assigned to documents. If approval is On, then at least two document states can be assigned: Draft and Final.
3-state Approval can only be activated if Approval is enabled. When it is On, the In Approval state can be chosen for documents, in addition to the Draft and Final states.
Note
The following settings: Archiving, Approval, and 3-
State Approval are defined both at category level in
LABEL ARCHIVE Client Administration, and at global level in LABEL ARCHIVE Server. To be activated for a given document, they need to be switched ON both at category level and at global level.
• Default approval rule
Shows the approval rule selected by default for documents of this category.
• Allow custom rules When On, the user who submits a document for approval can choose a specific approval rule, different from the default one.
Documents
This tab displays the list of documents. You can view document states, versions and other information in the grid.
C H A P T E R
5
LABEL ARCHIVE Client
Administration
Logging In
Figure 39
LABEL ARCHIVE Client Login
To launch LABEL ARCHIVE Client Administration:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2 > LABEL ARCHIVE Client Administration.
Step 2 > Type a valid user name and password (i.e., defined in UMSS and having appropriate permissions).
The Change check box allows changing the password at any time.
Chapter 5 - 58
Administration
Administrator’s Guide
Figure 40
LABEL ARCHIVE Client Administration
Upon successful login, the Administration window will appear.
This window allows changing different settings for the
LABEL ARCHIVE Client module.
Note
The settings for the server are accessible from LABEL
ARCHIVE Server Administration.
General Layout
The layout of the LABEL ARCHIVE Client Administration window follows the Microsoft Management Console
(MMC) standard.
Three buttons are added to the default set of MMC:
Save: Saves all changes made in the current window.
Refresh: Cancels all changes made in the current window and refreshes its state.
Add additional item: This is a content-dependent button which appears on Approval rules and Documents tree screens.
LABEL ARCHIVE Client Administration
• Navigation Tree
• Work Pane
• Navigation
Client
Configuration
Node
• Protocol
• Server Name
• Port
Chapter 5 - 59
In this tree control the user can select all functions available in the Administration program.
Depending on the selected node in the navigation tree, the right-side work panes are updated.
Depending on the selected node in the navigation tree, the work pane displays the associated settings.
Single functions are chosen by selecting a node in the navigation tree. When there is no functionality for a parent node, a page is shown to indicate that you must select a subnode.
To access the Client Configuration node:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Client Administration.
Step 3 > Select the Client Configuration node in the navigation tree.
This node allows the client to set up the connection to the
LABEL ARCHIVE Server.
The type of protocol used for the LABEL ARCHIVE Server connection. It can be TCP, HTTP or HTTPS.
The name of the LABEL ARCHIVE Server machine on the network.
The port used by LABEL ARCHIVE Server to receive client messages. The default port setting is 8088.
The Browse button displays all accessible host computers on the network from which the user will need to select the desired LABEL ARCHIVE Server instance.
The Test button allows testing the connection to the LABEL
ARCHIVE Server.
Chapter 5 - 60 Administrator’s Guide
Approval Rules
Node
The Languages options allow you to specify the desired language for the user interface.
Note
For a language change to be fully effective you need to close and re-open the application.
To access the Approval Rules node:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Client Administration.
Step 3 > Select the Approval Rules node in the navigation tree.
Figure 41
Approval Rules node
This node allows creating custom approval rules, and specifying the number of steps, parameters, notification options, etc. You can see the currently available rules using the Rules drop-down list.
LABEL ARCHIVE Client Administration
• Apply
• Refresh
• New
• Delete
• State
Chapter 5 - 61
The Approval Rules node displays four buttons:
Applies any changes made on this screen.
Displays the latest information from the database about the approval rules.
Creates a new rule. You can specify a rule name in the
Name text box.
Deletes the selected rule.
The main grid in the middle of the Approval Rules work pane displays the steps that make up the currently selected rule.
You can specify the following parameters for each approval step:
Possible values: Always, Failed, One of the steps failed,
One of the steps succeeded, Success.
• Always: The current step will always be executed, no matter if the previous step failed or not.
• Failed: The current step will be executed if the previous one failed.
• One of the steps failed: The current step will be executed if one of the previous steps or substeps failed.
• One of the steps succeeded: The current step will be executed if one of the previous steps or substeps succeeded.
• Success: Works if the previous step or substep succeeded.
• Handler
• Parameter
Defines whether an action is required by a single user or by a user group in order to complete the current step. Possible values: Single User, Usergroup.
Specifies the user name or user group name according to the previous Handler field.
Chapter 5 - 62
• Type
• Stop at one deny
• Reminder
Documents
Node
Administrator’s Guide
Defines the type of user participation in the approval workflow. Possible values are: Can Approve, Must
Approve.
Allows terminating the execution of the entire rule upon first deny of an approval workflow.
Allows setting an approval reminder to appear after the specified number of days.
The e-mail and Action options define the type of approval notification — via e-mail message (single users only) or via an action table on the Label Designer startup.
To access the Documents node:
Step 1 > Go to Start > Programs > Teklynx > LABEL
ARCHIVE 2.
Step 2 > Select LABEL ARCHIVE Client Administration.
Step 3 > Select the Documents node in the navigation tree.
Figure 42
Documents node
The Documents node contains two tabs: Category and
Documents.
LABEL ARCHIVE Client Administration Chapter 5 - 63
Category
• Name
• Application
This tab allows changing document handling settings for
LABEL ARCHIVE.
The name of the currently selected category.
Shows the name of the Label Designer application in which the category was created.
• Handler
• Lock at check out
When On, if a document is checked out by one user, other users can only do a reprint. When Off, other users can also open a document for print only.
• Archiving
Shows the name of the technical class which can work with documents stored in the category.
When archiving is switched On, the versioning is active for all documents. At check-in a document can no longer be overwritten and a new version needs to be created. When archiving is switched Off, the document version number is not increased at check-in. New documents overwrite previous ones.
• Approval
• 3-state Approval
If approval is Off, then only Final state can be assigned to documents. If approval is On, then at least two document states can be assigned: Draft and Final.
3-state Approval can only be activated if Approval is enabled. When it is On, the In Approval state can be chosen for documents, in addition to the Draft and Final states.
Note
The following settings: Archiving, Approval, and 3-
State Approval are defined both at category level in
LABEL ARCHIVE Client Administration, and at global level in LABEL ARCHIVE Server. To be activated for a given document, they need to be switched ON both at category level and at global level.
• Default approval rule
Shows the approval rule selected by default for documents of this category.
Chapter 5 - 64
• Allow custom rules
Documents
Administrator’s Guide
When On, the user who submits a document for approval can choose a specific approval rule, different from the default one.
This tab displays the list of documents. You can view documents states, versions and other information in the grid.
United States
1-414-837-4800
France
33-562-601-080
Germany
49-6103-30026-0
Singapore
65-6477-7293
China
86-21-6100-6588
Japan
81-45-461-3603
Copyright 2012 Teklynx Newco SAS. All rights reserved. Printed in the USA 06/12. TEKLYNX is a trademark of Teklynx Newco SAS. All other brands and product names are trademarks of their respective owners.
www.teklynx.com
Download
Anúncio