OMRON NJ -series Machine Automation Controller, ZW-7000 Series Displacement Sensor Connection Guide
PDF
Tài liệu
Quảng cáo
Quảng cáo
Machine Automation Controller NJ-series EtherCAT(R) Connection Guide OMRON Corporation Displacement Sensor (ZW-7000 Series) P651-E1-01 About Intellectual Property Rights and Trademarks Microsoft product screen shots reprinted with permission from Microsoft Corporation. Windows is a registered trademark of Microsoft Corporation in the USA and other countries. EtherCAT(R) is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany. Sysmac is a trademark or registered trademark of OMRON Corporation in Japan and other countries for OMRON factory automation products. Company names and product names in this document are the trademarks or registered trademarks of their respective companies. Table of Contents 1. Related Manuals ........................................................................................ 1 2. Terms and Definitions ............................................................................... 2 3. Precautions ................................................................................................ 3 4. Overview .................................................................................................... 4 5. Applicable Devices and Device Configuration ....................................... 5 5.1. Applicable Devices ................................................................................ 5 5.2. Device Configuration ............................................................................. 6 6. EtherCAT Settings ..................................................................................... 8 6.1. Parameters ............................................................................................ 8 6.2. Device Variables .................................................................................... 9 7. EtherCAT Connection Procedure ........................................................... 12 7.1. Work Flow ............................................................................................ 12 7.2. Sensor Controller Setup ...................................................................... 13 7.3. Controller Setup ................................................................................... 23 7.4. EtherCAT Communication Status Check ............................................. 32 8. Initialization method ................................................................................ 36 8.1. Initializing Controller ............................................................................ 36 8.2. Initializing Sensor Controller ................................................................ 36 9. Revision History ...................................................................................... 37 1.Related Manuals 1. Related Manuals To ensure system safety, make sure to always read and follow the information provided in all Safety Precautions and Precautions for Safe Use in the manuals for each device which is used in the system. Cat. No. W500 W501 W505 W504 Model Manual name NJ501-[][][][] NJ-series NJ301-[][][][] CPU Unit NJ101-[][][][] Hardware User's Manual NJ501-[][][][] NJ/NX-series NJ301-[][][][] CPU Unit NJ101-[][][][] Software User's Manual NJ501-[][][][] NJ/NX-series NJ301-[][][][] CPU Unit Built-in EtherCAT(R) Port NJ101-[][][][] User's Manual SYSMAC-SE2[][][] Sysmac Studio Version 1 Operation Manual 0969584-7 W4S1-05[] Switching Hub W4S1-03B W4S1-series Users Manual Z362 ZW-7000[] Displacement Sensor ZW-7000 series Confocal Fiber Type Displacement Sensor User’s Manual Z363 ZW-7000[] Displacement Sensor ZW-7000 series Confocal Fiber Type Displacement Sensor User’s Manual for Communications Settings 1 2.Terms and Definitions 2. Terms and Definitions Term PDO communications (Communications using Process Data Objects) Explanation and Definition This method is used for cyclic data exchange between a master unit and slave units. PDO data (i.e., I/O data that is mapped to PDOs) that is allocated in advance is refreshed periodically each EtherCAT process data communications cycle. (i.e., the period of primary periodic task) The NJ-series Machine Automation Controller uses the PDO communications for commands to refresh I/O data in a fixed control period, including I/O data for slave units, and the position control data for servomotors. It is accessed from NJ-series Machine Automation Controller in the following ways. ・With device variables for EtherCAT slave I/O ・With axis variables for a servo drive and an encoder input slave to which assigned as an axis SDO communications (Communications using Service Data Objects) This method is used to read and write the specified slave unit data from a master unit when required. The NJ-series Machine Automation Controller uses SDO communications for commands to read and write data, such as for parameter transfers, at specified times. The NJ-series Machine Automation Controller can read/write the specified slave data (parameters and error information, etc.) with the EC_CoESDORead (Read CoE SDO) instruction or the EC_CoESDOWrite (Write CoE SDO) instruction. Slave unit There are various types of slaves such as servo drives that handle position data and I/O terminals that handle the bit signals. The slave unit receives output data sent from the master, and sends input data to the master. Node address A node address is an address to identify a unit connected to EtherCAT. 2 3.Precautions 3. Precautions (1) Understand the specifications of devices which are used in the system. Allow some margin for ratings and performance. Provide safety measures, such as installing a safety circuit, in order to ensure safety and minimize the risk of abnormal occurrence. (2) To ensure system safety, make sure to always read and follow the information provided in all Safety Precautions and Precautions for Safe Use in the manuals for each device which is used in the system. (3) The user is encouraged to confirm the standards and regulations that the system must conform to. (4) It is prohibited to copy, to reproduce, and to distribute a part or the whole of this document without the permission of OMRON Corporation. (5) The information contained in this document is current as of May 2016. It is subject to change for improvement without notice. The following notations are used in this document. Indicates a potentially hazardous situation which, if not avoided, may result in minor or moderate injury, or may result in serious injury or death. Additionally there may be significant property damage. Indicates a potentially hazardous situation which, if not avoided, may result in minor or moderate injury or property damage. Precautions for Correct Use Precautions on what to do and what not to do to ensure proper operation and performance. Additional Information Additional information to read as required. This information is provided to increase understanding or make operation easier. Symbol The filled circle symbol indicates operations that you must do. The specific operation is shown in the circle and explained in the text. This example shows a general precaution for something that you must do. 3 4.Overview 4. Overview This document describes the procedures for connecting Confocal Fiber Type Displacement Sensor (hereinafter referred to as Sensor Controller) to NJ-series Machine Automation Controller (hereinafter referred to as Controller) via EtherCAT, both produced by OMRON Corporation (hereinafter referred to as OMRON), and for checking their connections. Refer to Section 6. EtherCAT Settings and Section 7. EtherCAT Connection Procedure to understand setting methods and key points to perform PDO Communications via EtherCAT. 4 5.Applicable Devices and Device Configuration 5. Applicable Devices and Device Configuration 5.1. Applicable Devices The applicable devices are as follows: Manufacturer OMRON Name NJ-series CPU Unit Model NJ501-[][][][] NJ301-[][][][] NJ101-[][][][] OMRON Confocal Fiber Type Displacement Sensor Sensor Controller ZW-7000[] Sensor Head ZW-S70[][] Precautions for Correct Use In this document, the devices with models and versions listed in 5.2. Device Configuration are used as examples of applicable devices to describe the procedures for connecting the devices and checking their connections. You cannot use devices with versions lower than the versions listed in 5.2. To use the above devices with models not listed in 5.2. or versions higher than those listed in 5.2., check the differences in the specifications by referring to the manuals before operating the devices. Additional Information This document describes the procedures for establishing the network connections. It does not provide information on operation, installation, wiring method, device functionality, or device operation, which is not related to the connection procedures. Refer to the manuals or contact your OMRON representative. 5 5.Applicable Devices and Device Configuration 5.2. Device Configuration The hardware components to reproduce the connection procedures in this document are as follows: NJ501-1500 (Built-in EtherCAT port) Personal computer (Sysmac Studio Installed, OS: Windows 7) ZW-7000 Ethernet cable USB cable W4S1-05C LAN cable 24 VDC power supply (for Sensor Controller) ZW-S7030 Calibration ROM 24 VDC power supply (for Switching hub) Manufacturer OMRON Name LAN cable Model NJ501-1500 OMRON CPU Unit (Built-in EtherCAT port) Power Supply Unit Sysmac Studio Personal computer (OS: Windows 7) USB cable (USB 2.0 type B connector) LAN cable (STP (shielded, twisted-pair) cable of Ethernet category 5 or higher) Switching hub 24 VDC power supply (for switching hub) Ethernet cable (with industrial Ethernet connector) Sensor Controller OMRON Sensor Head ZW-S7030 OMRON Calibration ROM (Supplied with Sensor Head) OMRON 24 VDC power supply S8VS-06024 OMRON OMRON OMRON OMRON NJ-PA3001 SYSMAC-SE2[][][] W4S1-05C - Version Ver.1.10 Ver.1.15 Ver.1.00 XS5W-T421-[]M[]-K ZW-7000 Rev.1.0 (for Sensor Controller) (DC24V 2.5A 60W) Precautions for Correct Use The connection line of EtherCAT communications cannot be shared with other Ethernet networks. Do not use devices for Ethernet such as a switching hub. Use the Ethernet cable (double shielding with aluminum tape and braiding) of Category 5 or higher, and use the shielded connector of Category 5 or higher. Connect the cable shield to the connector hood at both ends of the cable. 6 5.Applicable Devices and Device Configuration Precautions for Correct Use Update Sysmac Studio to the version specified in this Clause 5.2. or to a higher version. If you use a version higher than the one specified, the procedures and related screenshots described in Section 7. and subsequent sections may not be applicable. In that case, use the equivalent procedures described in this document by referring to the Sysmac Studio Version 1 Operation Manual (Cat. No. W504). Additional Information For specifications of Ethernet cables and network wiring, refer to Section 4. EtherCAT Network Wiring of the NJ/NX-series CPU Unit Built-in EtherCAT(R) Port User's Manual (Cat. No. W505). Additional Information For specifications of 24 VDC power supply available for Sensor Controller, refer to the Displacement Sensor ZW-7000 series Confocal Fiber Type Displacement Sensor User's Manual (Cat. No. Z362). Additional Information The system configuration in this document uses USB for the connection between Personal computer and Controller. For information on how to install the USB driver, refer to A-1 Driver Installation for Direct USB Cable Connection in Appendices of the Sysmac Studio Version 1 Operation Manual (Cat. No. W504). 7 6.EtherCAT Settings 6. EtherCAT Settings This section describes the setting contents of parameters and device variables that are all defined in this document. Hereinafter, Sensor Controller is referred to as "Slave Unit" in some descriptions. 6.1. Parameters The parameters required for connecting Controller and Sensor Controller via EtherCAT are given below. 6.1.1. Communication settings between Personal computer for setting and Sensor Controller The parameters for Sensor Controller are set using the Ethernet communications with Personal Computer for settings. The parameters required for connecting Personal computer for setting and Sensor Controller via Ethernet are shown below. Item Personal Computer for setting Sensor Controller IP address 192.168.250.100 192.168.250.50 (Default) Subnet mask 255.255.255.0 255.255.255.0 (Default) 6.1.2. Setting of EtherCAT The table below shows the settings to use the EtherCAT communications. Device Item Set value Remarks Node address 1 By the node address Sensor setting switches Controller Fieldbus EtherCAT (Default) Using Sysmac Studio. GATE signal ON time 1ms (Default) Using Sysmac Studio. 8 6.EtherCAT Settings 6.2. Device Variables The PDO communications data with Sensor Controller are assigned to the Controller's device variables. The device variables and the data types are shown below. ■Output area (Controller to Sensor Controller) Device variable name E001_Sensor_Head_Control_Signal1 E001_EXE E001_SYNC E001_ERCLR E001_Sensor_Head_Control_Signal2 E001_TIMING Data type DWORD BOOL BOOL BOOL DWORD BOOL Meaning Sensor Head Control Signal 1 Control command execution Measurement synchronous start Error clear Sensor Head Control Signal 2 Timing signal E001_RESET BOOL Reset signal E001_LIGHTOFF BOOL Light metering OFF E001_ZERO_T1 BOOL Zero reset execution signal of task 1 E001_ZERO_T2 BOOL Zero reset execution signal of task 2 E001_ZERO_T3 BOOL Zero reset execution signal of task 3 E001_ZERO_T4 BOOL Zero reset execution signal of task 4 E001_ZEROCLR_T1 BOOL Zero reset cancel signal of task 1 E001_ZEROCLR_T2 BOOL Zero reset cancel signal of task 2 E001_ZEROCLR_T3 BOOL Zero reset cancel signal of task 3 BOOL DWORD UINT UINT DINT Zero reset cancel signal of task 4 Command code Command parameter 1 Command parameter 2 Command parameter 3 E001_ZEROCLR_T4 E001_Command E001_Command_Parameter1 E001_Command_Parameter2 E001_Command_Parameter3 9 6.EtherCAT Settings ■Input area (Sensor Controller to Controller) Device variable name E001_Sensor_Head_Status_Signal1 E001_FLG E001_SYNCFLG E001_READY E001_RUN E001_BANKOUT_A E001_BANKOUT_B E001_BANKOUT_C E001_BANKOUT_D E001_BANKOUT_E E001_ERR E001_Sensor_Head_Status_Signal2 E001_HOLDSTAT E001_RESETSTAT E001_LIGHT E001_STABILITY E001_ENABLE E001_GATE E001_OR E001_TASKSTAT_T1 E001_TASKSTAT_T2 E001_TASKSTAT_T3 E001_TASKSTAT_T4 E001_ZEROSTAT_T1 E001_ZEROSTAT_T2 E001_ZEROSTAT_T3 E001_ZEROSTAT_T4 E001_HIGH_T1 E001_PASS_T1 E001_LOW_T1 E001_HIGH_T2 E001_PASS_T2 E001_LOW_T2 E001_HIGH_T3 E001_PASS_T3 E001_LOW_T3 E001_HIGH_T4 E001_PASS_T4 E001_LOW_T4 E001_Response E001_Response_Code E001_Response_Data1 E001_Output_Data_1 E001_Output_Data_2 E001_Output_Data_3 E001_Output_Data_4 Data type DWORD BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL DWORD BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL BOOL DWORD DWORD DINT DINT DINT DINT DINT Meaning Sensor Head Status Signal 1 Control command completion Measurement synchronization completion Ready RUN screen Current bank number bit0 Current bank number bit1 Current bank number bit2 Current bank number bit3 Current bank number bit4 Error signal Sensor Head Status Signal 2 Hold execution status Reset execution status Light status Measurement position Measurement state Data output completed Overall judgement result TASK status of task 1 TASK status of task 2 TASK status of task 3 TASK status of task 4 Zero reset status of task 1 Zero reset status of task 2 Zero reset status of task 3 Zero reset status of task 4 High output of task 1 Pass output of task 1 Low output of task 1 High output of task 2 Pass output of task 2 Low output of task 2 High output of task 3 Pass output of task 3 Low output of task 3 High output of task 4 Pass output of task 4 Low output of task 4 Command code Response code Response data OUT1 measured value OUT2 measured value OUT3 measured value OUT4 measured value 10 6.EtherCAT Settings ■Status area (Sensor Controller to Controller) Device variable name E001_Sysmac_Error_Status E001_Observation E001_Minor_Fault Data type BYTE BOOL BOOL Meaning Sysmac error status Observation levels of information Minor fault levels of information Additional Information Refer to 3-1 EtherCAT Connection of the Displacement Sensor ZW-7000 series Confocal Fiber Type Displacement Sensor User's Manual for Communications Settings (Cat. No. Z363) for details on assignments of input, output, and status areas. Additional Information The device variables are named automatically from a combination of the device names and the port names. The default device names are "E" followed by a serial number that starts from 001. 11 7.EtherCAT Connection Procedure 7. EtherCAT Connection Procedure This section describes the procedures for connecting Controller and Sensor Controller via EtherCAT. The explanations of procedures for setting up Controller and Sensor Controller given in this document are based on the factory default settings. For the initialization, refer to Section 8. Initialization Method. 7.1. Work Flow Take the following steps to perform the PDO communications by connecting Controller and Sensor Controller via EtherCAT. 7.2. Sensor Controller Setup Set up Sensor Controller. ↓ 7.2.1. Hardware Settings Set the hardware switches on Sensor Controller and connect the cables. ↓ 7.2.2. Parameter Settings Set the parameters for Sensor Controller. ↓ 7.3. Controller Setup Set up Controller. ↓ 7.3.1. Starting Sysmac Studio and Setting up the EtherCAT Start Sysmac Studio and Set up the EtherCAT network configuration. Network Configuration ↓ 7.3.2. Setting the Device Variables Set the device variables to use for Slave Unit. ↓ 7.3.3. Transferring the Project Data Transfer the project data from Sysmac Studio to Controller ↓ 7.4. EtherCAT Communication Status Confirm that the PDO communications performs normally via EtherCAT. Check ↓ 7.4.1. Checking the Connection Status Check the connection status of the EtherCAT network. ↓ 7.4.2. Checking the Sent and Check that the correct data are sent and received. Received Data 12 7.EtherCAT Connection Procedure 7.2. Sensor Controller Setup Set up Sensor Controller. 7.2.1. Hardware Settings Set the hardware switches on Sensor Controller and connect the cables. Precautions for Correct Use Make sure that the power supply is OFF when you set up. 1 2 Make sure that Sensor Controller is powered OFF. *If the power supply is turned ON, the settings described in the following steps and subsequent procedures may not be applicable. Check the positions of the hardware switches and the Node address setting switches (ID) connectors on Sensor Controller by referring to the figure on the Ethernet right. connector EtherCAT input connector ROM connector Fiber adapter 24 V input terminal block 3 Set Node address setting switches (ID) as shown below. x16: 0 x1: 1 *The node address is set to 1. 4 Connect Calibration ROM to ROM connector. 13 7.EtherCAT Connection Procedure 5 Connect Fiber connector on 6 Connect Switching hub to Sensor Head to Fiber adapter. Personal computer and to Ethernet connector on Sensor Controller with LAN cables. Connect 24 VDC power supply LAN cable LAN cable (for Switching hub) to Switching hub. 7 Connect an Ethernet cable to 8 Connect 24 VDC power supply EtherCAT input connector. 24 VDC power supply Ethernet cable to 24 V input terminal block. *For details on specifications of 24 VDC power supply available for Sensor Controller, refer to the Displacement Sensor ZW-7000 series Confocal Fiber Type Displacement Sensor User's Manual (Cat. No. Z362). 24 VDC power supply 14 7.EtherCAT Connection Procedure 7.2.2. Parameter Settings Set the parameters for Sensor Controller. The Parameters are set using Sysmac Studio. Install Sysmac Studio on Personal computer beforehand. Since Personal computer and Sensor Controller are connected with LAN cables, set the IP address of Personal computer to 192.168.250.100. Precautions for Correct Use The parameters for Sensor Controller are checked using the Ethernet communications with Personal computer. Note that there may be some changes required for the Personal computer settings depending on the state of Personal computer. 1 Turn ON Sensor Controller and Switching hub. 15 7.EtherCAT Connection Procedure 2 Set the IP address of Personal Dialog box in (2) computer to 192.168.250.100. *The IP address can be changed in the following way. (1)Start Personal computer and log in using an administrator account. From the Windows Start menu, select Control Panel - Network and Internet - Network and Sharing Center, and click Change Adapter Settings. Double-click Local Area Connection. *The procedure steps may be different depending on the environment settings of Personal computer. Dialog box in (3) (2)The Local Area Connection Status Dialog Box is displayed. Click Properties. (3)The Local Area Connection Properties Dialog Box is displayed. Select Internet Protocol Version 4 (TCP/IPv4), and click Properties. *The display differs depending on the configuration of Personal computer. (4)The Internet Protocol Version 4 (TCP/IPv4) Properties Dialog Box is displayed. Select Use the following IP address, and set the IP address to 192.168.250.100 and the subnet mask to 255.255.255.0. Click OK. Dialog box in (4) (5)Click Close or OK to close all the displayed dialog boxes. 16 7.EtherCAT Connection Procedure 3 4 Start Sysmac Studio. *If the User Account Control Dialog Box is displayed at start, make a selection to start Sysmac Studio. Sysmac Studio starts. Click New Project. 5 The Project Properties Dialog 6 Select Measurement Sensor Box is displayed. from the pull-down list of Category in the Select Device Field. 7 Check that the category and the device in the Select Device Field are set as shown below. Category: Measurement Sensor Device: ZW Click Create. 17 7.EtherCAT Connection Procedure 8 The Select Sensor Dialog Box is displayed. Select Specify a sensor and enter the IP address to 192.168.250.50. Click Confirm. 9 The information of Sensor Controller and Sensor Head is displayed. Check that the information displayed there indicates the connected devices. Click OK. *If Sensor Controller is not specified, the IP address and other settings may not be in the factory default state. Refer to the Displacement Sensor ZW-7000 series Confocal Fiber Type Displacement Sensor User's Manual (Cat. No. Z362) to check the values of IP address and others. 18 7.EtherCAT Connection Procedure 10 The Sensor Controller project is displayed online. Sensing Monitor Pane When an online connection is established, the Edit Pane is surrounded with a yellow frame. The following panes are displayed in this window. Toolbox Multiview Explorer Edit Pane Left: Multiview Explorer Center: Edit Pane The following tab pages are displayed in the Edit Pane. Center: Sensing Monitor Pane Right: Toolbox 11 Double-click 1:ZW-7000(2.0):Online under Configurations and Setup DeviceGroup in the Multiview Explorer. 12 The 1:ZW-7000(2.0):Online Tab Page is displayed. Click the Online Icon. 13 The Online view is displayed. Click Setup in the Operation mode Field. 14 The Operation mode Dialog Box is displayed. Confirm that there is no problem and click Yes. 19 7.EtherCAT Connection Procedure 15 Double-click System data under Configurations and Setup DeviceGroup – 1:ZW-7000(2.0):Online System in the Multiview Explorer. 16 The System data Tab Page is displayed. Click the Ethernet communication settings Icon. 17 The Ethernet communication settings view is displayed. Check that the following fieldbus settings are made. Fieldbus: EtherCAT(Default) GATE signal ON time: 1 ms (Default) *If the fieldbus is not set to EtherCAT, select EtherCAT from the pull-down list of Fieldbus. 18 Double-click 1:ZW-7000(2.0):Online under Configurations and Setup DeviceGroup in the Multiview Explorer. 20 7.EtherCAT Connection Procedure 19 The Online view is displayed on the 1:ZW-7000(2.0):Online Tab Page. Click Save settings (sensor internal memory) in the Save settings Field. 20 The Save settings Dialog Box is displayed. Check the contents and click Yes. 21 Click Run in the Operation mode Field. The Operation mode Dialog Box is displayed. Confirm that there is no problem and click Yes. 22 Check that the Run Button in the Operation mode Field becomes dim. Click Disconnect in the Sensor connection Field. The Disconnect Dialog Box is displayed. Check the contents and click Yes. 21 7.EtherCAT Connection Procedure 23 The online connection is established, and the yellow frame surrounding the Edit Pane disappears. 24 Select Close from the File Menu. The New Project Dialog Box is displayed. Click No if you do not need to save the project. 25 Turn OFF Sensor Controller and 26 Remove the LAN cable from Switching hub. Ethernet connector. 22 7.EtherCAT Connection Procedure 7.3. Controller Setup Set up Controller. 7.3.1. Starting Sysmac Studio and Setting up the EtherCAT Network Configuration Start Sysmac Studio and Set up the EtherCAT network configuration. 1 Connect the Ethernet cable to the built-in EtherCAT port Personal computer (PORT2) on Controller, and connect a USB cable to the Controller CPU Unit End Cover USB cable peripheral (USB) port. As shown in 5.2. Device Configuration, connect Personal computer and Sensor Controller Power Supply Unit Ethernet cable Sensor Controller to Controller. 2 Turn ON Controller and Sensor 3 Click Connect to Device in the Controller. startup window of Sysmac Studio. 4 The Connect to Device Dialog Box is displayed. Select Direct connection via USB in the Connection type Field. Uncheck both Upload the project and Display the Troubleshooting Dialog Box in the Operation after Connection Field. Click Connect. 23 7.EtherCAT Connection Procedure 5 A confirmation dialog box is displayed. Check the contents and click OK. 6 *The displayed dialog depends on the status of Controller. Check the contents and click on an appropriate button to proceed with the processing. The dialog box on the right is displayed. Check the contents and click OK. 7 The Auto Connect Project Dialog Box is displayed online. When an online connection is established, a yellow bar is displayed under the toolbar. Toolbox The following panes are displayed in this window. Left: Multiview Explorer Multiview Explorer Edit Pane Top right: Toolbox Controller Status Pane Bottom right: Controller Status Pane Middle top: Edit Pane The following tabs are displayed in the bottom middle of this window. Output Tab Page Build Tab Page Output Tab Page Build Tab Page Additional Information For details on online connections to Controller, refer to Section 6. Online Connections to a Controller of the Sysmac Studio Version 1 Operation Manual (Cat. No. W504). 8 Double-click EtherCAT under Configurations and Setup in the Multiview Explorer. 24 7.EtherCAT Connection Procedure 9 10 The EtherCAT Tab Page is displayed in the Edit Pane. Right-click Master on the EtherCAT Tab Page in the Edit Pane and select Compare and Merge with Actual Network Configuration. A screen is displayed stating "Get information is being executed". 11 The Compare and Merge with Actual Network Configuration Dialog Box is displayed. Node address 1 and ZW-7000 Rev:1.0 are added to the Actual network configuration after the comparison. Click Apply actual network configuration. 12 A confirmation dialog box is displayed. Check the contents and click Apply. The confirmation dialog box on the right is displayed. Check the contents and click Close. 25 7.EtherCAT Connection Procedure 13 As a node address 1 slave, E001 ZW-7000 Rev:1.0 is added to the Network configuration on Sysmac Studio. Check that the data above is added. Click Close. 14 Node address 1 and E001 ZW-7000 Rev:1.0 are added to the EtherCAT Tab Page in the Edit Pane. 26 7.EtherCAT Connection Procedure 7.3.2. Setting the Device Variables Set the device variables to use for Slave Unit. 1 Select Offline from the Controller Menu. The yellow bar under the toolbar disappears. 2 Select the device with node address 1 added on the EtherCAT Tab Page in Sub-Clause 7.3.1. Check that the device name is E001. *Device name can be changed as desired. 3 Double-click I/O Map under Configurations and Setup in the Multiview Explorer. 4 The I/O Map Tab Page is displayed in the Edit Pane. Check that Node1 is displayed in the Position Column and that the added Slave Unit is displayed in the Port Column. *To manually set a variable name for a slave unit, click an entry cell in the Variable Column and enter a name. 27 7.EtherCAT Connection Procedure 5 6 Right-click Node1 and select Create Device Variable. The variable names and types are set. Additional Information The device variables are named automatically from a combination of the device names and the port names. The default device names are "E" followed by a serial number that starts from 001. Additional Information In this document, device variables are automatically named for a unit (a slave). Device variables can also be manually named for ports. 28 7.EtherCAT Connection Procedure 7.3.3. Transferring the Project Data Transfer the project data from Sysmac Studio to Controller. When you transfer a user program, configuration data, setup data, device variables, or values in memory used for CJ-series Units from Sysmac Studio, the devices or machines may perform unexpected operation regardless of the operating mode of CPU Unit. Always confirm safety at the destination node before you transfer the project data. After you transfer the project data, CPU Unit restarts, and communications with slaves is cut off. During the period, the slave outputs behave according to the slave settings. The time that communications is cut off depends on the EtherCAT network configuration. Before you transfer the project data, confirm that the slave settings will not adversely affect the device. The Slave Unit will be reset after performing the synchronization in step 7 and subsequent steps, which may perform unexpected operation. Always confirm safety before you perform the synchronization. 1 Select Check All Programs 2 The Build Tab Page is displayed. from the Project Menu. Check that "0 Errors" and "0 Warnings" are displayed. 3 Select Rebuild Controller from the Project Menu. 29 7.EtherCAT Connection Procedure 4 A confirmation dialog box is displayed. Confirm that there is no problem and click Yes. 5 Check that "0 Errors" and "0 Warnings" are displayed on the Build Tab Page. 6 Select Online from the Controller Menu. When an online connection is established, a yellow bar is displayed under the toolbar. 7 Select Synchronize from the 8 The Synchronization Dialog Box Controller Menu. is displayed. Check that the data to transfer (NJ501 in the right dialog box) is selected. Then, click Transfer To Controller. *After executing Transfer To Controller, the Sysmac Studio data is transferred to Controller, and the data is compared. 30 7.EtherCAT Connection Procedure 9 A confirmation dialog box is displayed. Confirm that there is no problem and click Yes. A screen stating "Synchronizing" is displayed. A confirmation dialog box is displayed. Confirm that there is no problem and click No. *Do not return to RUN mode. 10 Check that the synchronized data is displayed with the color specified by "Synchronized" and that a message is displayed stating "The synchronization process successfully finished". If there is no problem, click Close. *A message stating "The synchronization process successfully finished" is displayed if the Sysmac Studio project data coincides with the Controller data. *If the synchronization fails, check the wiring and repeat from step 1. 31 7.EtherCAT Connection Procedure 7.4. EtherCAT Communication Status Check Confirm that the PDO communications performs normally via EtherCAT. 7.4.1. Checking the Connection Status Check the connection status of the EtherCAT network. 1 Check with LED indicators on Controller that PDO communications via EtherCAT performs normally. The LED indicators in normal status are as follows: NET RUN: Green lit NET ERR: Not lit LINK/ACT: Yellow flashing 2 Check the LED indicators on Sensor Controller. The LED indicators in normal status are as follows: ECAT RUN: Green lit L/A IN: Green flickering ECAT ERROR: Not lit 32 7.EtherCAT Connection Procedure 7.4.2. Checking the Sent and Received Data Check that the correct data are sent and received. In this document, the system data acquisition command and the number of digits displayed past decimal point for command parameters are set to device variables in the output area where Controller is output to Sensor Controller, and response data (the number of digits displayed past decimal point) from Sensor Controller are checked, which are stored in device variables in the input area. If you change the variable values on a Watch Tab Page when Sysmac Studio is online with CPU Unit, the devices connected to the output unit may operate regardless of the operating mode of CPU Unit. Adequately ensure safety before you change the variable values on a Watch Tab Page when Sysmac Studio is online with CPU Unit 1 Select Watch Tab Page from the 2 Select the Watch1 Tab. 3 Click Input Name and enter the View Menu. following variable names for monitoring. E001_EXE E001_FLG E001_Command E001_Command_Parameter1 E001_Response E001_Response_Code E001_Response_Data1 4 Check that the display formats of the variables you set in step 3 are as follows: E001_EXE:Boolean E001_FLG:Boolean E001_Command:Hexadecimal E001_Command_Parameter1: Decimal E001_Response:Hexadecimal E001_Response_Code: Hexadecimal E001_Response_Data1:Decimal 33 7.EtherCAT Connection Procedure 5 Enter 0040 4000 for E001_Command in the Modify Column. 0040 4000 is displayed for E001_Command in the Online value Column. 6 *The command code 0040 4000 (system data acquisition) is set. In the same way as step 5, set 900 for E001_Command_Parameter1 in the Modify Column. 7 *The system data number 900 (Number of digits displayed past decimal point) is set. Check that the online value of E001_FLG is False. Click TRUE for E001_EXE in the Modify Column. True is displayed for E001_EXE in the Online value Column. When the command execution is complete, True is displayed for E001_FLG in the Online value Column. 8 When the process ends normally, the online values of the response variables are shown below. E001_Response: 0040 4000 (Execution command code) E001_Response_Code: 0000 0000 (Execution result (normal)) E001_Response_Data1: 1 (The number of digits displayed past decimal point is 1. (Default)) Additional Information For details on commands, refer to 3-1 EtherCAT Connection of the Displacement Sensor ZW-7000 series Confocal Fiber Type Displacement Sensor User's Manual for Communications Settings (Cat. No. Z363). 34 7.EtherCAT Connection Procedure Additional Information For details on system data, refer to 8-2 System data list of the Displacement Sensor ZW-7000 series Confocal Fiber Type Displacement Sensor User's Manual for Communications Settings (Cat. No. Z363). 35 8.Initialization method 8. Initialization method The setting procedures in this document are based on the factory default settings. Some settings may not be applicable unless you use the devices with the factory default settings. 8.1. Initializing Controller To initialize the Controller settings, it is necessary to initialize CPU Unit. Change the operating mode of Controller to PROGRAM mode and select Clear All Memory from the Controller Menu in Sysmac Studio. The Clear All Memory Dialog Box is displayed. Check the contents and click OK. 8.2. Initializing Sensor Controller For information on how to initialize Sensor Controller, refer to Initializing Settings in 4-6 Setting Measurement Mode of the Sensor in 4.Settings for Function of the Displacement Sensor ZW-7000 series Confocal Fiber Type Displacement Sensor User's Manual (Cat. No. Z362). 36 9.Revision History 9. Revision History Revision Date of revision Description of revision code A May 13, 2016 First edition 37 38 2016 P651-E1-01 016-(-) ">
/
Tải xuống
Chỉ là một lời nhắc nhở thân thiện. Bạn có thể xem tài liệu ngay tại đây. Nhưng quan trọng nhất, AI của chúng tôi đã đọc nó. Nó có thể giải thích những điều phức tạp bằng những thuật ngữ đơn giản, trả lời các câu hỏi của bạn bằng bất kỳ ngôn ngữ nào và giúp bạn nhanh chóng điều hướng ngay cả những tài liệu dài nhất hoặc phức tạp nhất.
Quảng cáo