Endress+Hauser Field Data Manager Software MS20, MS21 Short Instruction
Endress+Hauser Field Data Manager Software MS20, MS21 is a software tool designed to provide centralized data management and visualization for recorded data. It offers seamless archiving of measurement values, diagnostic events, and logs from various Endress+Hauser devices. The software is compatible with PostgreSQL, Oracle, and Microsoft SQL Server databases, allowing for local or network-based (client/server) operation.
Publicité
Publicité
KA00466C/07/A2/18.17
71356242
Products Solutions
Kurzanleitung
Getting Started
Field Data Manager
Software MS20 / MS21
Services
Diese Anleitung ist eine Kurzanleitung.
Ausführliche Informationen entnehmen Sie bitte der Betriebsanleitung.
Die komplette Produktdokumentation besteht aus:
• Der vorliegenden Kurzanleitung
• Der in die Software integrierten Betriebsanleitung
< These instructions are Brief Operating Instructions.
For detailed information, please read the Operating Instructions.
The complete product documentation comprises:
• These Brief Operating Instructions
• The Operating Instructions integrated in the software
FDM
Inhaltsverzeichnis / Table of contents
Software. . . . . . . . . . . . .4
1.1 Versionen . . . . . . . . . . . . . . . . 4
1.2 Eigenschaften . . . . . . . . . . . . . 6
1.3 Systemanforderungen . . . . . . 7
2 Installation . . . . . . . . . .8
2.1 Installation der Software . . . . 8
2.2 Verwendung der FDM-Software mit einer Oracle
TM -Datenbank
(Version 8i oder höher) . . . . 13
2.3 Verwendung der FDM-Software mit einer Microsoft SQL Server
Datenbank (Version 2005 oder höher) . . . . . . . . . . . . . . . . . . 16
2.4 Remoteverbindungen auf den
Datenbankserver . . . . . . . . . . 19
2.5 Erweiterungen SQL Server und
Automatik: . . . . . . . . . . . . . . 24
2.6 Update der FDM-Software auf eine neue Version . . . . . . . . . 25
3 Schnelleinstieg . . . . . .26
3.1 Bedienoberfläche . . . . . . . . . 26
3.2 Bedienung . . . . . . . . . . . . . . . 27
Software. . . . . . . . . . . .29
4.1 Versions . . . . . . . . . . . . . . . . . 29
4.2 Features . . . . . . . . . . . . . . . . . 31
4.3 System requirements . . . . . . 32
5 Installation . . . . . . . . .33
5.1 Installation of the software . 33
5.2 Operation of the FDM software with Oracle
TM database (version
8i or higher) . . . . . . . . . . . . . . 38
5.4 Enable remote connections to the database server . . . . . . . . 44
5.5 Configuration of Microsoft SQL
Server and automatic actions: . .
5.6 Update of the FDM software to a new version . . . . . . . . . . . . . . 49
6 Getting started . . . . . .50
6.1 User interface . . . . . . . . . . . . 50
6.2 Usage . . . . . . . . . . . . . . . . . . . 51
Endress+Hauser 3
Field Data Manager Software FDM
1 Field Data Manager Software
1.1 Versionen
Die nachfolgende Tabelle zeigt die Funktionen der verschiedenen Softwareversionen.
Funktion Essential Version
(Freeware)
Professional Version (60 Tage
Demoversion + 30
Tage auf Anfrage)
Professional Version mit Reporting
Option
4
Unterstützte Datenbanken
Postgre SQL TM
Oracle TM
Microsoft SQL Server TM
Unterstütze Geräte
Ecograph RSG20
Ecograph A RSG22
Ecograph C RSG24
Ecograph T RSG30
Ecograph T RSG35
Memograph RSG10
Memograph S RSG12
Memograph M RSG40
Memograph M RSG45
EngyCal RH33
EngyCal RS33
RA33
Liquiline CM44x
Liquistation CSFxx
Liquiline System CA80xx
Benutzerverwaltung x x x x x x x x x x x x x x x x x x x x x x x x x x x x x x x x x x x x x x x x x x x
Endress+Hauser
FDM Field Data Manager Software
Funktion
Zugriffe von verschiedenen
PCs auf die Datenbank gleichzeitig möglich
Daten mehrerer Geräte in einem Template (Vorlage)
Automatisches Auslesen
Automatisches Löschen
Automatischer Binär-Export
Automatischer XLS/CSV- und
PDF-Export
Export ready for Energy Software
Import von ReadWin 2000
Daten
Online Visualisierung von
Momentanwerten ("Live Data")
Visualisierung von Standardberichten
Visualisierung von kundenspezifischen Berichten
E-Mail Benachrichtigung
Update-Suche
Essential Version
(Freeware)
Professional Version (60 Tage
Demoversion + 30
Tage auf Anfrage) x
Professional Version mit Reporting
Option x x x x x x x x x x x x x x x x x x x x x x x x x x x
Beachten Sie, dass die Demoversion nach Ablauf des Testzeitraumes aktiviert werden muss, um diese als Professional oder Essential Version (Freeware) nutzen zu können.
Ein Wechsel von der Essential Version (Freeware) zu einer kommerziellen
Version ist mittels Eingabe einer Software-ID und anschließender Produktaktivierung jederzeit möglich.
Ein Wechsel von der Demoversion auf die Essential Version (Freeware) kann zur Folge haben, dass bestimmte Funktionen nicht mehr zur Verfügung ste-
Endress+Hauser 5
Field Data Manager Software FDM hen. So werden z.B. angelegte Templates (Vorlagen) mit Daten von mehreren Geräten und auch automatische Exporte nicht mehr funktionieren.
Geräte, die nur in der Professional Version enthalten sind, können in der
Essential Version (Freeware) nicht mehr ausgelesen werden.
1.2 Eigenschaften
Field Data Manager (FDM) ist eine Software, die eine zentrale Datenverwaltung mit Visualisierung für aufgenommene Daten bietet.
Diese ermöglicht die lückenlose Archivierung der Daten einer Messstelle, z.B.:
• Messwerte
• Diagnoseereignisse
• Protokolle
FDM speichert Daten in eine SQL Datenbank. Die Datenbank kann lokal oder im Netzwerk betrieben werden (Client / Server).
Folgende Datenbanken werden unterstützt:
• PostgreSQL 1) bei allen Versionen
Sie können die auf der FDM-DVD mitgelieferte, freie PostgreSQL Datenbank installieren und nutzen. Hierzu ist keine manuelle Installation und
Konfiguration notwendig. Die Datenbank wird bei der Installation automatisch konfiguriert.
• Oracle 1) bei Demo- und Professional-Version
Version 8i oder höher. Zur Einrichtung der Software mit der Oracle Datenbank wenden Sie sich bitte an Ihren Datenbankadministrator. Die Vorgehensweise für die Installation ist in der beiliegenden Kurzanleitung beschrieben.
• Microsoft SQL Server 1) bei Demo- und Professional-Version
Version 2005 oder höher. Zur Einrichtung der Software mit dem Microsoft
SQL Server wenden Sie sich bitte an Ihren Datenbankadministrator. Die
Vorgehensweise für die Installation ist in der beiliegenden Kurzanleitung beschrieben.
1)
6
Die genannten Produktnamen sind eingetragene Marken der jeweiligen Hersteller.
Endress+Hauser
FDM Field Data Manager Software
1.3 Systemanforderungen
Für die Installation und den Betrieb der PC-Software müssen folgende Hardware- und Software- Voraussetzungen erfüllt sein:
Hardwarevoraussetzungen für die FDM-Software:
• PC mit Pentium TM 4 (
• PC mit Pentium TM M (
• PC mit AMD TM (
≥
≥
≥
2 GHz)
1 GHz)
1,6 GHz)
• Minimum 1 GB RAM Cache
• Minimum 20 GB freier Festplattenspeicher
• Bildschirmauflösung mindestens 1024 x 800 Pixel
• CD/DVD-Laufwerk
Hardwarevoraussetzungen für den Reporting Server:
• Die Installation des Reporting Servers (BPI Dashboard) benötigt etwa 1 GB
Festplattenspeicher. Werden zusätzliche Berichtsprojekte hochgeladen, kommen diese Dateien noch dazu, wobei die Dateien meist nur wenige MB
Festplattenspeicher benötigen.
• Der Tomcat Service des Dashboards benötigt etwa 1,5 GB Arbeistsspeicher.
Falls der Server nur für das Reporting verwendet wird, sind 4 GB Arbeitsspeicher ausreichend. Falls dort weitere Applikationen betrieben werden, muss der Speicherbedarf einberechnet werden.
Betriebssystem/Software für die FDM-Software:
• Microsoft TM Windows TM Server 2003 R2 SP2 Standard, Enterprise (32 Bit)
• Microsoft TM Windows TM Server 2008 (32/64 Bit)
• Microsoft TM Windows TM Server 2012 (64 Bit)
• Microsoft TM XP SP3 (32 Bit)
• Microsoft TM Vista TM (32/64 Bit)
• Windows 7 TM (32/64 Bit)
• Windows 8 TM , Windows 8.1
TM (32/64 Bit)
• Windows 10 TM (32/64 Bit)
• Windows TM .NET 2.0 SP1
Betriebssystem für den Reporting Server:
• Windows 7 TM (64 Bit)
• Microsoft TM Windows TM Server 2008 (64 Bit)
• Microsoft TM Windows TM Server 2012 R2 (64 Bit)
Endress+Hauser 7
Installation FDM
2 Installation
Der Installationsassistent führt durch die Installation der Field Data Manager
Software.
Für die Installation werden Administratorrechte benötigt.
2.1 Installation der Software
1.
Legen Sie die DVD in Ihr CD/DVD-Laufwerk.
Die Installation startet automatisch.
Falls der Autostart nicht aktiv ist, starten Sie Setup.exe von der DVD.
2.
Wählen Sie im angezeigten Dialogfenster die gewünschte Sprache.
Klicken Sie auf OK.
3.
Starten Sie anschließend den Installationsassistent mit Weiter.
4.
Die Lizenzvereinbarung erscheint.
– Lesen Sie die Lizenzvereinbarung.
– Falls Sie die Vereinbarung nicht akzeptieren klicken Sie auf
Abbrechen.
– Falls Sie die Vereinbarung akzeptieren klicken Sie auf Weiter.
Die Endbenutzer-Lizenzvereinbarung kann jederzeit nach der
Installation im Hauptmenü unter „Hilfe -> Lizenzvereinbarung“ aufgerufen werden.
5.
Wenn Sie die FDM Professional-Version haben, geben Sie hier die
Software-ID ein. Sie finden diese Angabe auf der DVD-Hülle.
Falls Sie die FDM Essential-Version (Freeware) haben oder die Angaben zu einem späteren Zeitpunkt eingeben möchten, lassen Sie das
Eingabefeld leer.
Später können Sie die Software-ID über den Menüpunkt "Hilfe É
Lizenzinformationen É Lizenzinformationen É Software-ID" eingeben. Hier können Sie auch von der FDM Essential-Version (Freeware) ohne Eingabe einer Software-ID einmalig auf eine Demoversion mit vollem Funktionsumfang wechseln. Diese Demoversion ist dann für den
Testzeitraum aktiv.
In der Demoversion ist die Reporting-Option nicht enthalten. Die
Reporting-Option kann nur mit einer gültigen Software-ID installiert werden.
8 Endress+Hauser
FDM Installation
Die Demoversion kann nach Ablauf des Testzeitraumes durch
Aktivierung in eine Essential-Version (Freeware) umgewandelt werden, sofern kein Upgrade zur Professional-Version durch
Eingabe einer Software-ID erfolgt.
Da bestimmte Funktionen dann nicht mehr zur Verfügung stehen, werden z. B. angelegte Templates mit Daten von mehreren Geräten und auch automatische Exporte nicht mehr funktionieren.
Klicken Sie auf Weiter.
Endress+Hauser 9
Installation FDM
6.
Geben Sie das Zielverzeichnis an, in welches die Field Data Manager
Software installiert werden soll.
Es wird ein Standardverzeichnis für die Installation vorgeschlagen.
Falls Sie das Programm in ein anderes Verzeichnis installieren möchten, klicken Sie auf Ändern und wählen Sie das gewünschte Verzeichnis.
Klicken Sie auf Weiter.
7.
Wählen Sie aus, ob die mitgelieferte freie PostgreSQL Datenbank installiert werden soll. Die Datenbank wird bei der Installation automatisch konfiguriert.
8.
Wählen Sie aus, ob die Softwarekomponenten für Reporting installiert werden sollen (nur verfügbar, wenn in Lizenz enthalten). Idealerweise sollten diese auf einem Server installiert werden. Die Komponente erlaubt die Erstellung von Berichten und Dashboards. Die zu verwendenden TCP/IP Ports dürfen nicht durch andere Programme belegt sein, können aber bei Bedarf angepasst werden.
10 Endress+Hauser
FDM Installation
Klicken Sie auf Weiter.
9.
Wählen Sie aus, ob die Softwarekomponenten für Automatische
Aktionen installiert werden sollen.
Bestätigen Sie die Installation der Automatik-Komponente, so wird zusätzlich ein Windows Systemdienst eingerichtet. Dieser Systemdienst ermöglicht es, automatische Aktionen durch die Field Data Manager
Software auszulösen und zu steuern - wie z.B. automatisches Auslesen von Geräten, automatischer Druck von Reports, automatisches Generieren von Reports.
Endress+Hauser 11
Installation
Klicken Sie auf Weiter.
10. Der Installationsassistent ist nun zur Installation bereit.
FDM
12 Endress+Hauser
FDM Installation
Zur Korrektur Ihrer Angaben klicken Sie auf Zurück. Klicken Sie auf
Installieren, um die Installation zu starten.
Klicken Sie auf Fertig stellen, um die Installation zu beenden.
2.2 Verwendung der FDM-Software mit einer Oracle
TM
-Datenbank (Version 8i oder höher)
Nur bei Demo- und Professional-Version.
Wenden Sie sich für die Konfiguration der Oracle Datenbank an Ihren
Datenbankadministrator. Die folgenden Schritte können nur vom
Administrator der Datenbank durchgeführt werden.
1.
Installieren Sie die FDM-Software wie im Abschnitt "Installation" beschrieben.
2.
Legen Sie auf der Oracle Datenbank einen User an, unter dem sich die
FDM-Software auf der Datenbank einloggen und zugreifen kann.
Der Benutzer muss über folgende Berechtigungen verfügen:
Roles:
– Connect
– Resource
Direct Granted System Privileges
– Create Table
– Create Procedure
Endress+Hauser 13
Installation FDM
– Create Sequence
Nach dem Anlegen der Schemas (Schritt 3) sind die Rechte Create
Table, Create Procedure und Create Sequence nicht mehr notwendig.
3.
Starten Sie zum Einrichten der notwendigen Tabellen in der Datenbank die mitgelieferte Software "InitOracle.exe". Die Software befindet sich im
Installationsverzeichnis.
4.
Überprüfen Sie den Hostnamen/ IP-Adresse und Portnummer zum
Datenbankserver und korrigieren Sie dies entsprechend.
5.
Tragen Sie den eindeutigen System Identifier der Datenbank ein (siehe
TNSNAMES.ORA).
Zuvor müssen Sie entsprechend einen Benutzer im Datenbank-Server anlegen.
6.
Geben Sie den Benutzernamen und das Passwort für den Benutzer ein, den die FDM-Software für das Login auf die Datenbank verwenden soll.
Benutzen sie hierzu "Benutzerdefiniertes Login"
14 Endress+Hauser
FDM Installation
7.
Betätigen Sie die Schaltfläche "Test". Nach kurzer Zeit erscheint eine
Meldung ob die Software auf die Datenbank zugreifen kann oder nicht.
Ist der Zugriff nicht möglich, prüfen Sie bitte die Verbindungseinstellungen und die Schreibweise des Benutzernamens und des Passworts.
Erst wenn nach Betätigen der Schaltfläche "Test" eine positive Rückmeldung kommt, kann auf die Datenbank zugegriffen werden.
8.
Wenn der Zugriff auf die Datenbank möglich ist, betätigen Sie die
Schaltfläche "Erzeuge Schema". Jetzt werden die notwendigen Tabellen für das Speichern der Daten in der Datenbank eingerichtet. Dies dauert einige Sekunden. Das Fenster der Software wird automatisch geschlossen, wenn die Tabellen angelegt sind.
9.
Starten Sie die Field Data Manager Software.
10. Im Menüpunkt "Extras É Einstellungen É Datenbank": Wählen Sie
"Oracle" aus und tragen Sie die Verbindung zur Datenbank, den
Benutzernamen und das Passwort ein.
Endress+Hauser 15
Installation FDM
11. Prüfen Sie mit der Schaltfläche "Test", ob die FDM-Software auf die
Datenbank zugreifen kann und die notwendigen Tabellen eingerichtet sind. Ist der Zugriff nicht möglich, prüfen Sie die Verbindungseinstellungen und die Schreibweise des Benutzernamens und des Passworts.
Erst wenn nach Betätigen der Schaltfläche "Test" eine positive Rückmeldung kommt, kann auf die Datenbank zugegriffen werden.
12. Wenn eine positive Meldung kommt, beenden Sie die Konfiguration mit
OK. Die FDM-Software ist jetzt für den Betrieb mit der Oracle-Datenbank fertig eingerichtet.
2.3 Verwendung der FDM-Software mit einer Microsoft
SQL Server Datenbank (Version 2005 oder höher)
Nur bei Demo- und Professional-Version.
Wenden Sie sich für die Konfiguration der Microsoft SQL Server Datenbank an Ihren Datenbankadministrator. Die folgenden Schritte können nur vom Administrator der Datenbank durchgeführt werden.
1.
Installieren Sie die FDM-Software wie im Abschnitt "Installation" beschrieben.
2.
Legen Sie auf der Microsoft SQL Server Datenbank einen User an, unter dem sich die FDM-Software auf der Datenbank einloggen und zugreifen kann.
Der Benutzer muss zum Anlegen der Tabellen über die Berechtigung
"db_ddladmin" verfügen:
Für den späteren Zugriff auf die Datenbank muss der Benutzer mindestens die Rollen "db_datareader" und "db_datawriter" haben.
3.
Starten Sie zum Einrichten der notwendigen Tabellen in der Datenbank die mitgelieferte Software "InitSqlServer.exe". Die Software befindet sich im Installationsverzeichnis.
16 Endress+Hauser
FDM Installation
4.
Geben Sie die Verbindung zur Datenbank ein (Servername \ Instanzname). Der Servername ist der Hostname des Rechners, auf dem der
Datenbankserver läuft. Der Instanzname kann bei der Installation angegeben werden und lautet für die SQL Express Installation standardmäßig "SQLEXPRESS". Sie können die installierten Instanznamen auch aus der Registrierung erfahren
(HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL
Server\<Instance Name>).
5.
Tragen Sie den Datenbanknamen ein, den Sie zuvor am Server angelegt haben (z.B. mit Hilfe des ‚Microsoft SQL Server Management Studio’
Tools).
6.
Geben Sie den Benutzernamen und das Passwort für den Benutzer ein, den die FDM-Software für das Login auf die Datenbank verwenden soll.
Benutzen sie hierzu "Benutzerdefiniertes Login"
Endress+Hauser 17
Installation FDM
7.
Betätigen Sie die Schaltfläche "Test". Nach kurzer Zeit erscheint eine
Meldung ob die Software auf die Datenbank zugreifen kann oder nicht.
Ist der Zugriff nicht möglich prüfen Sie bitte die Verbindungseinstellungen und die Schreibweise des Benutzernamens und des Passworts. Erst wenn nach Betätigen der Schaltfläche "Test" eine positive Rückmeldung kommt kann auf die Datenbank zugegriffen werden.
8.
Wenn der Zugriff auf die Datenbank möglich ist, betätigen Sie die
Schaltfläche "Erzeuge Schema". Jetzt werden die notwendigen Tabellen für das Speichern der Daten in der Datenbank eingerichtet. Dies dauert einige Sekunden. Das Fenster der Software wird automatisch geschlossen, wenn die Tabellen angelegt sind.
9.
Starten Sie die Field Data Manager Software.
10. Im Menüpunkt "Extras É Einstellungen É Datenbank": Wählen Sie
"Microsoft SQL Server" aus und tragen Sie die Verbindung zur Datenbank, den Benutzernamen und das Passwort ein.
18 Endress+Hauser
FDM Installation
11. Prüfen Sie mit der Schaltfläche "Test" ob die FDM-Software auf die
Datenbank zugreifen kann und die notwendigen Tabellen eingerichtet sind. Ist der Zugriff nicht möglich, prüfen Sie die Verbindungseinstellungen und die Schreibweise des Benutzernamens und des Passworts.
Erst wenn nach Betätigen der Schaltfläche "Test" eine positive Rückmeldung kommt, kann auf die Datenbank zugegriffen werden.
12. Wenn eine positive Meldung kommt, beenden Sie die Konfiguration mit
OK. Die Auswertesoftware ist jetzt für den Betrieb mit der Microsoft
SQL Server Datenbank fertig eingerichtet.
2.4 Remoteverbindungen auf den Datenbankserver
2.4.1 Remoteverbindungen für PostgreSQL Server ermöglichen
Zuerst müssen Sie das Datenbank-Administrationstool "pgAdmin III" installieren, das sich auf der Setup-DVD befindet.
1.
Starten Sie das pgAdmin-Tool.
2.
Öffnen Sie "Werkzeuge É Serverkonfiguration É postgresql.conf".
Endress+Hauser 19
Installation FDM
3.
Öffnen Sie die Einstellung "listen_addresses" mit einem Doppelklick und tragen Sie einen Stern (*) ein. Damit erlauben Sie alle eingehenden TCP
Verbindungen zu diesem Server. Sie können aber auch einzelne
IP-Adressen zulassen.
4.
Standardmäßig werden alle Verbindungen von entfernten Adressen abgewiesen. Um diese zu erlauben, öffnen Sie "Werkzeuge É
Serverkonfiguration É pg_hba.conf" und fügen Sie folgenden Eintrag hinzu: host all all 0.0.0.0/0 md5
20 Endress+Hauser
FDM Installation
5.
Starten Sie den PostgreSQL durch einen PC-Neustart.
Endress+Hauser 21
Installation FDM
Beachten Sie folgende Hinweise:
• Sie können die Konfiguration der Zugriffsrechte auch direkt in den Dateien
"postgresql.conf" und "pg_hba.conf" vornehmen, die Sie im Installationsverzeichnis des PostgreSQL Server und "data" finden.
• Überprüfen Sie die Änderungen sorgfältig. Falsche Konfigurationen können dazu führen, dass der Zugriff auf den Server nicht mehr möglich ist
(Bsp. Falsche IP-Adresse).
Weiterführende Informationen (Englisch) finden Sie unter: http://www.postgresql.org/docs/9.2/interactive/client-authentication.html
2.4.2 Remoteverbindungen für Oracle Server ermöglichen
Im Unterschied zu PostgreSQL und Microsoft SQL Server sind für den Oracle
Server alle Zugriffe von einem bestehenden, entfernten Oracle Client standardmäßig erlaubt.
2.4.3 Remoteverbindungen für Microsoft SQL Server ermöglichen
Sie müssen Remoteverbindungen für jede Instanz von SQL-Server ermöglichen, zu der Sie eine Verbindung von einem Remote-Computer herstellen möchten. Gehen Sie hierzu folgendermaßen vor:
1.
Start É Programme É Microsoft SQL Server 2005 É Konfigurationstools É SQL Server-Oberflächenkonfiguration.
Das Fenster "SQL Server 2005-Oberflächenkonfiguration" erscheint.
2.
Wählen Sie "Oberflächenkonfiguration für Dienste und Verbindungen".
3.
Öffnen Sie in "Database Engine" die "Remoteverbindungen".
Aktivieren Sie "Lokale Verbindungen und Remoteverbindungen" und das gewünschte Protokoll. Klicken Sie auf Anwenden.
22 Endress+Hauser
FDM Installation
4.
Folgende Meldung erscheint:
"Änderungen der Verbindungseinstellungen werden erst nach einem
Neustart des Datenbankmoduldienstes wirksam."
Klicken Sie auf OK.
5.
Öffnen Sie in "Database Engine" den Menüpunkt "Dienst".
Klicken Sie auf "Beenden" und warten Sie, bis der Dienst "MSSQLSERVER" beendet wird.
Klicken Sie auf "Start", um den Dienst "MSSQLSERVER" neu zu starten.
Überprüfen Sie die Änderungen sorgfältig. Falsche Konfigurationen können dazu führen, dass der Zugriff auf den Server nicht mehr möglich ist (Bsp. Falsche IP-Adresse).
Weiterführende Informationen finden Sie unter: http://support.microsoft.com/kb/914277
Endress+Hauser 23
Installation FDM
2.5 Erweiterungen SQL Server und Automatik:
Bei Verwendung der Windows Authentifikation sind zusätzliche Konfigurationen notwendig:
1.
Starten Sie "SQL Server Management Studio". Sollte diese kostenlose
Software nicht vorhanden sein, müssen Sie diese, entsprechend Ihrer
SQL Server Version nachinstallieren. Erhältlich ist das Programm bei
Microsoft.
2.
Selektieren Sie den Knoten "Anmeldung" unter dem Verzeichnis "Sicherheit".
3.
Legen Sie über die rechte Maustaste auf diesem Verzeichnis eine neue
Anmeldung mit dem Namen NT-AUTORITÄT\ANONYMOUS-ANMEL-
DUNG an oder englisch NT-AUTHORITY\ANONYMOUS.
4.
Selektieren Sie die Datenbank der FDM-Software unter dem "Datenbanken" Knoten.
5.
Legen Sie dort unter "Sicherheit/Benutzer" einen neuen Benutzer mit dem Namen "FdmServerUser" und dem Anmeldenamen NT-AUTO-
RITÄT\ANONYMOUS-ANMELDUNG an.
6.
Abschließend weisen Sie diesem Benutzer unter "Mitgliedschaft in
Datenbankrollen" Besitzerrechte zu (db-owner).
Zu diesen Konfigurationsschritten finden Sie auf der Endress+Hauser Seite
(www.endress.com/ms20) ein kurzes Video.
24 Endress+Hauser
FDM Installation
2.6 Update der FDM-Software auf eine neue Version
Bei der Verwendung des mitgelieferten Postgre DB Server lokal auf Ihrem PC wird bei der Installation der neueren Version die Datenbank bei Bedarf automatisch auf die neue Version gebracht. In diesem Fall (Standardfall) müssen Sie nach der Installation der neuen Version keine weiteren Aktionen durchführen. Alle Daten stehen nach dem Update wieder zur Verfügung.
Verwenden Sie den mitgelieferten Postgre DB Server im Netzwerk (remote) oder eine Oracle oder Microsoft SQL Server Datenbank (lokal oder im Netzwerk), kann nach dem ersten Start der FDM-Software der DB Konfigurationsdialog mit einem Hinweis erscheinen, dass die Datenbank nicht auf dem aktuellen Stand ist.
In diesem Fall muss der Administrator der Datenbank wie oben beschrieben das jeweilige Tool für Ihren Datenbankserver z.B. Init_Oracle starten und damit die Daten der Datenbank auf den aktuellen Stand bringen. Die Daten in der Datenbank bleiben dabei erhalten. Bitte beachten Sie, dass alle Client
Installationen auf die neue Version der FDM-Software upgedatet werden.
Endress+Hauser 25
Schnelleinstieg FDM
3 Schnelleinstieg
Dieser Schnelleinstieg gibt einen kurzen Überblick über die ersten Schritte beim Arbeiten mit der Field Data Manager Software.
Um die Professional-Version bzw. die Reporting Funktion nutzen zu können, muss zunächst eine gültige Software-ID unter "Hilfe É Lizenzinformationen" eingegeben und die Software aktiviert werden.
Detaillierte Informationen zur Softwareaktivierung und Hilfe zu den
Funktionen finden Sie in der integrierten Online-Hilfe unter "Hilfe É
Field Data Manager Software Hilfe” bzw. in den Anleitungen im Installationsverzeichnis z.B. unter
C:\Program Files (x86)\Endress+Hauser\Field Data Manager Software\Documentation.
3.1 Bedienoberfläche
Die Bedienoberfläche von FDM ist in drei Bereiche aufgeteilt:
• Oben befindet sich die Menüleiste mit Funktionsgruppen für Softwareeinstellungen.
Datei É Programm beenden
Ansicht É Einstellungen zur Ansicht
Extras É Einstellungen zur Datenbank, Sprache, Benutzerverwaltung,
Audit Trail
Hilfe É Online-Hilfe starten, Lizenzinformationen
• Links befindet sich die Aufgabenleiste. Durch Klicken auf eine Aufgabe
öffnet sich diese. Die enthaltenen Funktionen werden angezeigt:
Visualisierung É Visualisierungstemplate neu erstellen, öffnen oder löschen
Daten auslesen É Auslesen über Speicherkarte oder online-Verbindung zum Gerät
Datenverwaltung É Anlagenansicht, Export und Import von Gerätedaten
• Rechts befindet sich der Arbeitsbereich
Alle aktiven Aufgaben werden hier geöffnet. Sind mehrere Aufgaben aktiv, so werden diese in Tabs hintereinander geöffnet.
26 Endress+Hauser
FDM Schnelleinstieg
3.2 Bedienung
Bei allen gewählten Funktionen führt ein Assistent durch die benötigten
Angaben. Zur Korrektur Ihrer Angaben können Sie jederzeit auf Zurück klicken oder den Assistenten beenden durch Abbrechen.
Endress+Hauser 27
Schnelleinstieg FDM
28 Endress+Hauser
FDM Field Data Manager Software
4 Field Data Manager Software
4.1 Versions
The following table shows the different functions of the diverse versions of the Field Data Manager Software.
Function Essential Version
(Freeware)
Professional
Version (Trial period: 60 days + 30 on request)
Professional
Version with reporting option
Supported databases:
Postgre SQL TM
Oracle TM
Microsoft SQL Server TM
Supported devices:
Ecograph RSG20
Ecograph A RSG22
Ecograph C RSG24
Ecograph T RSG30
Ecograph T RSG35
Memograph RSG10
Memograph S RSG12
Memograph M RSG40
Memograph M RSG45
EngyCal RH33
EngyCal RS33
RA33
Liquiline CM44x
Liquistation CSFxx
Liquiline System CA80xx
User administration
Endress+Hauser x x x x x x x x x x x x x x x x x x x x x x x x x x x
29 x x x x x x x x x x x x x x x x
Field Data Manager Software FDM
Function
Several accesses to the database from various
PCs at the same time possible
Data of more than one device inside a template
Automatic readout
Automatic deletion
Automatic binary export
Automatic XLS/CSV and
PDF export
Export ready for Energy
Software
Import of ReadWin 2000 data
Online visualization of current measured values
("Live Data")
Visualization of standard reports
Visualization of customer-specific reports
E-mail notification
Update search
Essential Version
(Freeware)
Professional
Version (Trial period: 60 days + 30 on request) x x x x x x x x x x x x x x x
Professional
Version with reporting option x x x x x x x x x x x x x
Please note that in order to use the Demo version as a Professional or Essential version (freeware), it must be activated after the trial period has elapsed.
It is possible to switch from the Essential version (freeware) to a commercial version at any time by entering a software ID and then activating the product.
Switching from the Demo version to the Essential version (freeware) may result in certain functions no longer being available. For example, templates created with data from multiple devices will no longer work and neither will
30 Endress+Hauser
FDM Field Data Manager Software automatic exports. Devices that are included only in the Professional version can no longer be read out in the Essential version (freeware).
4.2 Features
Field Data Manager (FDM) is a software package offering central data management and visualization of stored data. This allows complete documentation of the data from a measuring point, e.g.:
• measurement values
• diagnostics events
• protocols
FDM stores the data in a SQL database. The database can be installed locally or in a network (Client/Server).
Following data bases are supported:
• PostgreSQL 1) at all versions
You can use the PostgreSQL database provided on the Field Data Manager
Software DVD. During installation the database will be automatically configured. That means there is no need for manual installation and configuration.
• Oracle 2) at Trial and Professional version
Version 8i or higher. For the login account please contact your database administrator. For installation instructions see chapter "Installation".
• Microsoft SQL Server 1) at Trial and Professional version
Version 2005 or higher. For the login account please contact your database administrator. For installation instructions see chapter "Installation".
2) The products referred to are trademarks of their respective companies.
Endress+Hauser 31
Field Data Manager Software FDM
4.3 System requirements
For installation and use of the software, the following hardware and software requirements have to be fulfilled:
Hardware prerequisites for FDM software:
• PC with Pentium TM 4 (
• PC with Pentium TM M (
• PC with AMD TM (
≥
≥
≥
2 GHz)
1 GHz)
1.6 GHz)
• At least 1 GB RAM cache
• At least 20 GB free hard disk space
• Display resolution at least 1024 x 800 pixel
• CD/DVD drive
Hardware prerequisites for reporting server:
• The installation of the reporting server (BPI dashboard) requires approx. 1
GB of hard disk memory. If additional report projects are uploaded, these files are also factored in, although they usually require only a few MB of hard disk memory.
• The dashboard's Tomcat service requires approx. 1.5 GB of working memory. If the server is used only for reporting, 4 GB of working memory are sufficient. If other applications are run on it, the memory requirement must be factored in.
Operating system/software for FDM software:
• Microsoft TM Windows TM 2003 Server R2 SP2 Standard, Enterprise (32 bit)
• Microsoft TM Windows TM 2008 Server (32/64 bit)
• Microsoft TM Windows TM Server 2012 (64 Bit)
• Microsoft TM XP SP3 (32 bit)
• Microsoft TM Vista TM (32/64 bit)
• Windows 7 TM (32/64 bit)
• Windows 8 TM Windows 8.1
TM (32/64 bit)
• Windows 10 TM (32/64 bit)
• Windows TM .NET 2.0 SP1
Operating system for reporting server:
• Windows 7 TM (64 Bit)
• Microsoft TM Windows TM Server 2008 (64 Bit)
• Microsoft TM Windows TM Server 2012 R2 (64 Bit)
32 Endress+Hauser
FDM Installation
5 Installation
The installation wizard guides you through the installation of the Field Data
Manager Software.
You need administrator rights for the installation.
5.1 Installation of the software
1.
Insert the DVD in your CD/DVD-drive. The Installation starts automatically.
If autostart is not active, start Setup.exe directly from the DVD.
2.
In the dialog window select the language for the installation.
Click OK.
3.
Start the installation wizard with Next.
4.
The licensing agreement appears.
– Please read the license agreement carefully.
– Mark if you accept or do not accept the licensing agreement.
– If you do not accept the licensing agreement click on Cancel.
– If you do accept the licensing agreement click on Next.
The end-user license agreement can be called up anytime after installation in the main menu under "Help -> License agreement".
5.
If you use the Professional version enter the software ID of your FDM software. You can find the information on the DVD cover of the software.
If you use the Essential version (Freeware) or you want to enter these information later please leave the entry field empty.
You can enter the software ID any time in the menu "Help É License
Information É License Information É software ID". Here also you can once-only switch to the Trial version. The Trial version runs for the trial period with full functionality.
The reporting option is not included in the Trial version. The reporting option can be installed only using a valid software ID.
Endress+Hauser 33
Installation FDM
If the Demo version is not upgraded to the Professional version by entering a software ID, it can be converted to an Essential version
(freeware) after the trial period by activating it.
This means that certain functions will no longer available. For example, templates created with data from multiple devices will no longer work and neither will automatic exports.
Click on Next.
6.
Enter the destination folder in which you want to install the Field Data
Manager Software.
34 Endress+Hauser
FDM Installation
A default location will be displayed. If you want to install the software in a different folder click Change and choose the desired folder.
Change and choose the desired folder.
Click on Next.
7.
Select if you want to install the free of charge PostgreSQL database. The database is configured automatically during the installation.
8.
Select if you want to install software components for automatic actions.
If you select the installation, a Windows system service will be configured. This service enables Field Data Manager Software to start automatic actions, e.g. automatic read out of device data, automatic printing of reports or automatic generation of reports.
Endress+Hauser 35
Installation FDM
Click on Next.
9.
Choose whether or not the software components used for reporting are to be installed (available only if included in the license). Ideally, these should be installed on a server. The component enables the generation of reports and dashboards. TCP/IP ports to be used must not be occupied by other programs. However, they can be adapted if necessary.
36 Endress+Hauser
FDM Installation
Click on Next.
10. The installation wizard is ready for the installation.
To review or change any of your installation settings click Back. Click
Install to start the installation.
Endress+Hauser 37
Installation FDM
The installation is completed.
Click on Finish.
5.2 Operation of the FDM software with Oracle
TM
database (version 8i or higher)
Only at Trial and Professional version.
For the configuration of the database and the FDM software please contact your database administrator. The following steps should only be done by the administrator of the database.
1.
Install the FDM software. Please refer to the chapter "Installation".
2.
Create a user in the oracle database which the FDM software may use for login and access to the database.
The user must have the following rights:
Roles:
– Connect
– Resource
Directly Granted System Privileges:
– Create Table
– Create Procedure
– Create Sequence
38 Endress+Hauser
FDM Installation
The privileges Create Table, Create Procedure and Create
Sequence are necessary to create the tables and schemas (step 3).
Afterwards for the access to the database these privileges are not necessary.
3.
In the installation folder of the FDM software the program
"InitOracle.exe" supports the creation of the tables and schemas on the
Oracle database. After starting the program the following window appears:
4.
Please set the correct host name / IP address and port number of the database server.
5.
Please set the unique system identifier of the database (see
TNSNAMES.ORA). Please create the user for the database in advance.
6.
Set user name and password which the FDM software will use for login on the database. Please use the "user custom login".
Endress+Hauser 39
Installation FDM
7.
Click on the test button. After a few seconds a message will show whether the software is able to access the database or not. If the access is not possible please verify the settings of the connection and the spelling of user name and password. The software can only access the database when there is a positive message after clicking the "test" button.
8.
After the access to the database is established, please click on the button "Create schema". The necessary tables for the storage of the data will be created in the database. After a few seconds, when all tables are created, the window is closed automatically.
9.
Launch the Field Data Manager software.
10. In the menu "Extras É Settings É Database" select Oracle and configure the connection to the database. Enter the user name and password.
11. Click on the "test" button and check whether the FDM software can connect to the database and whether the necessary tables are created.
If the access to the database is not successful please verify the settings of the connection and the spelling of the user name and password. Only in case of a positive message the access to the database is possible.
12. After a positive message please click on OK to close the configuration dialog. The FDM software in now configured to access the Oracle database.
40 Endress+Hauser
FDM Installation
5.3 Operation of the FDM software with Microsoft SQL
Server database (version 2005 or higher)
Only at Trial and Professional version.
For the configuration of the database and the FDM software please contact your database administrator. The following steps should only be done by the administrator of the database.
1.
Install the FDM software. Please refer to the chapter "Installation".
2.
Create a user in the Microsoft SQL server database which FDM software may use for login and access to the database.
For the creation of the tables the user must have the following right
"db_ddladmin" in the database. Later after the initialization of the database the user must have at least the roles "db_datareader" and
"db_datawriter" to access the database.
3.
In the installation folder of the FDM software the program
"InitSqlServer.exe" supports the creation of the tables and schemas on the Microsoft SQL server database. After starting the program the following window appears:
Endress+Hauser 41
Installation FDM
4.
Please configure the connection to the database (server name\instance). The server name is the hostname of the computer on which the database server is running. The instance can be set during the installation of the database server and is for SQL Express by default
"SQLEXPRESS". You can see the installed name of the instance in the registration
(HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL
Server\<Instance Name>).
5.
Configure the name of the database, which you created in the database server before (i.e. with Microsoft SQL Server Management Studio’ tools).
6.
Set user name and password which the FDM software will use for login on the database. Please use the "user custom login".
7.
Click on the test button. After a few seconds a message will show whether the software is able to access the database or not. If the access is not possible please verify the settings of the connection and the spelling of user name and password. The software can only access the database when there is a positive message after clicking the "test" button.
8.
After the access to the database is established, please click on the button "Create schema". The necessary tables for the storage of the data will be created in the database. After a few seconds, when all tables are created, the window is closed automatically.
9.
Launch the FDM software.
10. In the menu "Extras É Settings É Database" select "Microsoft SQL
Server" and configure the connection to the database. Enter the user name and password.
42 Endress+Hauser
FDM Installation
11. Click on the "test" button and check whether the FDM software can connect to the database and whether the necessary tables are created.
If the access to the database is not successful please verify the settings of the connection and the spelling of the user name and password. Only in case of a positive message the access to the database is possible.
12. After a positive message please click on OK to close the configuration dialog. The FDM software in now configured to access the Microsoft
SQL Server.
Endress+Hauser 43
Installation FDM
5.4 Enable remote connections to the database server
5.4.1 Enable remote connection to PostgreSQL server
First install the database administration tool "pgAdmin III". The tool is located on the setup DVD.
1.
Start the "pgAdmin III" tool.
2.
Open "Tools É Server Configuration É postgresql.conf".
44 Endress+Hauser
FDM Installation
3.
Open the settings "listen_addresses" with double click and enter an asterisk (*). This enables all incoming TCP connections to this server. It is also possible to accept individual IP addresses.
4.
Per default all connections to remote addresses are rejected. To allow these, open "Tools É Server Configuration É pg_hba.conf" and add the following entry: host all all 0.0.0.0/0 md5
Endress+Hauser 45
Installation FDM
5.
Start "PostgreSQL" with PC new start.
Pay attention to:
• The configurations which are described in the steps above can directly be done in the files "postgresql.conf" and "pg_hba.conf". These files are located in the installation folder of PostgreSQL Server under "data".
• Check the changes you made very carefully. Wrong settings can disable the access to the server (e.g. wrong IP address).
For further information see: http://www.postgresql.org/docs/9.2/interactive/client-authentication.html
5.4.2 Enable remote connection for Oracle server
For Oracle Server the access from a remote Oracle client is allowed per default in contrast to PostgreSQL and Microsoft SQL Server.
5.4.3 Enable remote connection for Microsoft SQL server
You have to enable remote connections to every instance of SQL server you want access to from a remote computer. Perform the following steps:
1.
Start É Programs É Microsoft SQL Server 2005 É Configuration tools
É SQL Server surface configuration.
The window "SQL Server 2005 Surface Area Configuration" opens.
2.
Select "Surface configuration for services and connections".
3.
In "Database Engine" open "Remote connections".
Activate "Local connections and remote connections" and the appropriate protocol. Click on Apply.
46 Endress+Hauser
FDM Installation
4.
The message opens:
"Changes of the connection settings become effective after a restart of the database module service."
Click on OK.
5.
On "Database Engine" open "Services".
Click on Finish and wait until the service MSSQLSERVER terminates.
Click on Start, to restart the service MSSQLSERVER.
Check the changes you made very carefully. Wrong settings can disable the access to the server (e.g. wrong IP address).
For further information see: http://support.microsoft.com/kb/914277
Endress+Hauser 47
Installation FDM
5.5 Configuration of Microsoft SQL Server and automatic actions:
When using Windows Authentication the additional configurations are necessary:
1.
Start the "SQL Server Management Studio". If this software is not installed on your PC you can download the software from the website of
Microsoft free of charge. Please take care that you download the software for your version of the SQL Server. Install the software on your
PC.
2.
Select the node "Login/Account" in the folder "Security".
3.
Create with the right mouse click in this folder an additional account
NT-AUTHORITY\ANONYMOUS.
4.
Now select the database of the reporting software in the node
"databases".
5.
Please create in "Security/User" a new user with the name
"FdmServiceUser" and the name NT_AUTHORITY\ANONYMOUS.
6.
Finally assign to the user in "member of database roles" the rights db-owner.
For this configuration steps you can find a video on the website of
Endress+Hauser
(www.endress.com/ms20).
48 Endress+Hauser
FDM Installation
5.6 Update of the FDM software to a new version
When the FDM software works with the delivered Postgre DB Server local on your computer, the database is updated to the new version if necessary automatically. In this case (standard case) it is not necessary that you do any additional steps after the installation. The data in the database remain available after the update.
When you use the delivered Postgre DB Server in the network (remote) or an
Oracle or Microsoft SQL Server database (local or remote) it may be that after the first start of the FDM software the configuration dialog of the database connection comes up with a hint that the database is not updated to the current version.
In this case the administrator of the database has to run the corresponding tool for the database server i.e. Init_Oracle in order to update the database schema to the new version. The database administrator should follow the steps described above. After the update all data remain available in the database.
Make sure that all client PCs of the FDM software are updated to the new version.
Endress+Hauser 49
Getting started FDM
6 Getting started
This introduction provides a brief overview of the first steps using Field Data
Manager Software.
In order to use the Professional version or the reporting function, a valid software ID must first be entered under "Help É License Information" and the software activated.
Detailed information on software activation and help for the functions can be found in the integrated online help under "Help É Field Data
Manager software help" or in the instructions in the installation folder e.g. under
C:\Program Files (x86)\Endress+Hauser\Field Data Manager
Software\Documentation.
6.1 User interface
The user interface of FDM is divided into three areas
• At the top is the menu bar with function groups for the settings:
File É Program end
View É Settings of the display
Extras É Settings of database, language, user administration, audit trail
Help É Online help, License Information
• On the left hand side is the task pane. By clicking on a task the contained functions are displayed:
Visualization É Visualization template new, open or delete
Read out data É read out data from a mass storage or online connection to the device
Data management É open plant view, export or import of device data
• On the right hand side is the working area:
All active tasks are opened here. If multiple tasks are open, they are displayed in different tabs.
50 Endress+Hauser
FDM Getting started
6.2 Usage
With all functions a wizard guides you through the needed inputs. To correct you inputs click on Back. To abort the wizard click on Cancel.
Endress+Hauser 51
www.addresses.endress.com
Télécharger
Publicité