AMS TMD2620EvalKit Light Sensor User Guide
Pubblicità
Pubblicità
User guide
TMD2620 EVM
TMD2620 Proximity Sensor Evaluation Module
Version 1.0
Contents
3
1
2
Establishing basic functionality ............................................................................................ 5
TMD2620 EVM graphical user interface (GUI) .................................................................... 5
2.1
Software overview ................................................................................................................ 5
2.1.1
Device ID Information........................................................................................................... 6
2.1.2
Log Status and Control Information ..................................................................................... 7
2.1.3
System Menus ..................................................................................................................... 7
2.1.4
System Level Controls ......................................................................................................... 9
2.1.5
“Prox” Tab .......................................................................................................................... 10
Resources .......................................................................................................................... 13 page 2/13
TMD2620
The TMD2620 device features advanced proximity measurement. The slim module incorporates an
IR LED and factory calibrated LED driver.
Initial hardware setup
The software should be installed prior to connecting any hardware to the computer. Follow the instructions found in the Quick Start Guide (QSG). This will load the required driver for the USB interface and also the control software and graphical user interface (GUI).
The hardware consists of the EVM Controller v2.2a, the TMD2620 EVM daughterboard and a USB interface cable. page 3/13
When the USB cable is connected, the green LED should flash indicating that power is being received via the USB interface, and the controller board processor is running. If the green LED does not flash, check the USB cable connections; unplug the USB cable and try again. If the green LED still does not flash, check the PC for USB error messages. See the Resources section at the end of this document for additional assistance. page 4/13
1 Establishing basic functionality
The software should be started selecting ams->TMD2620 EVM->TMD2620 EVM command in the
Windows menu or by double clicking the AOS_EVM.exe file from the installation directory. The default installation directory, depending on the device and the operating system you are using, is:
C:\Program Files\ams\TMD2620_EVM Windows 32 bit operating systems
C:\Program Files (x86)\ams\TMD2620_EVM Windows 64 bit operating systems
A different install path may be selected by the user. When started, the TMD2620 window will open on the PC.
The balance of this document identifies and describes the controls available on the GUI. In combination with the TMD2620 datasheet, the QSG and application notes available on the ams website, www.ams.com. There should be enough information to allow evaluation of the TMD2620 device.
2 TMD2620 EVM graphical user interface (GUI)
2.1 Software overview
On successful initialization, the software displays a main window, containing controls pertinent to the connected device. If the software detects an error, it will display an error window.
If “Device not found or is unsupported” appears, verify that the correct daughterboard is properly connected to the motherboard. If “Cannot connect to EVM board” appears, verify the USB cable is connected. A green LED on the EVM Controller will flash to indicate that the USB cable is connected and providing power to the system.
If the EVM board is disconnected from the USB bus while the program is running it will display an error message and then terminate. Reconnect the EVM board and restart the program. page 5/13
The main window for the TMD2620 is shown below.
Clicking on the red “X” will close the window and terminate the application.
The checkboxes near the top of the window power on the chip and enable the Prox function. The
Prox tab contains controls for the remaining functions and displays status and data from the device as it operates.
2.1.1 Device ID Information
The lower left corner of the window displays the ID number of the EVM motherboard, identifies the device being used and displays the ID of the device. page 6/13
2.1.2 Log Status and Control Information
The lower right corner of the window contains status information and controls for the logging function:
This section contains two text boxes that are stored in the log file data and used to build the file name for the log file. If you change the data in these fields, the new values will be stored with all new log data. The default log file name will be based on these values at the time the log file is written. If nothing is entered in these boxes they default to a period (“.”).
Sample default file name:
TMD2620_1-2-3_Log_HH_MM_SS.csv
From AOS_EVM.exe
From User Input
The Count value displayed is a count of the number of samples currently in the log buffer.
The Elapsed Time value indicates the elapsed time since data logging was started.
The final field in this section controls the number of log samples that will be collected before logging is automatically stopped and the log data is stored. If the count of log entries reaches the amount shown in this field, the program will stop the logging function and pop up a window asking for a file name to save the collected data. After saving the collected data the log is cleared and the count is set back to 0.
2.1.3 System Menus
At the top of the window there are three pull-down menus labeled “File”, “Log”, and “Help”. The File menu provides basic application-level control. The Log menu is used to control the logging function, and the Help menu provides version and copyright information for the application.
2.1.3.1 File Menu
The File menu contains the following functions: page 7/13
The Reread Registers function forces the program to re-read all of the control registers from the device and display them on the screen. This does not read the status or PROX result registers, because those registers are continually read while the program is running.
Click on the Exit command to close the main window and terminate the application. Any unsaved log data will be cleared.
2.1.3.2 Log Menu
The Log menu is used to control the logging function and to save the log data to a file. Log data is accumulated in memory until it is discarded or written to a data file.
Click Start Logging to start the logging function. Each time the program polls the Prox information from the device, it will create a new log entry showing the raw data values, the values of various control registers, and the values entered by the user into the text fields near the bottom right corner of the window.
Click Stop Logging to stop the logging function. Once logging is stopped, the data can be written to a file, or you can continue collecting additional data by clicking Start Logging again.
The Log a Single Entry command will cause logging to start, collect one single entry, and immediately stop again. This function is not available when logging is already running.
Click Clear Log to discard any data that has already been collected. If there is data in memory, which has not been saved to disk, this function will display a prompt asking you to verify that it is OK to discard the data. If the log is running when this function is clicked, the log will continue running after the existing data is discarded.
Click Save Log to save the collected log data to a data file. This will stop the logging function, if it is active, and display a file dialog box for you to specify where to store the logged data. The default file name, as described above, will be displayed, but you may change the file name if you wish. page 8/13
2.1.3.3 Help Menu
The Help menu contains a single function; About.
The About function displays a dialog box showing the version and copyright information for the
AOS_EVM program and library.
Click the OK button to close this window and continue.
2.1.4 System Level Controls
Immediately below the top menu bar there are two checkboxes that are used to control the system level functions of the TMD2620 device.
The Power-On checkbox controls the PON function of the TMD2620. When this box is checked, the power is on and the device can operate. When this box is unchecked, the power is off and the device will not operate (The control registers can still be written, but the device will not function).
The Prox Enable checkbox controls the PEN function of the TMD2620. Proximity detection is enabled when this box is checked or disabled when unchecked. page 9/13
2.1.5 “Prox” Tab
The main portion of the screen contains a tab labeled Prox. The controls in this tab are divided into
3 sections, each performing a separate function.
2.1.5.1 Prox Controls
The left side of the Prox tab contains controls to set various Prox settings.
The PPULSE controls the maximum number of pulses used for each prox cycle. To avoid saturating the prox sensor, the Automatic Pulse Control (APC) feature of the device may reduce the number of pulses in real-time. The maximum number of pulses selected, which is one more than the value in the register (PPULSE = 0
→
1 pulse), is displayed immediately to the right of the box.
The PPULSE_LEN control sets the width of all IR LED pulses within the proximity cycle. Longer pulses result in increased proximity range and typically result in less electrical noise generated in the analog front end.
The PGAIN control is a pulldown menu that lets you select the analog gain of the proximity IR sensor. The values that can be chosen are 1x, 2x, 4x and 8x. page 10/13
The PLDRIVE control sets the drive strength of the IR LED current. Values are approximate; actual current through LED is factory trimmed to normalize IR intensity. The values range from 0 (6mA
LED Current) to 31 (192mA LED Current).
The WEN checkbox enables the wait time between proximity cycles. The WTIME control sets the duration of the wait time using the formulas in Table 1. When WLONG is checked the wait time is multiplied by 12.
Table 1. Wait Time Formulas
WLONG Wait time (ms)
Unchecked (WTIME + 1) * 2.778ms
Checked (WTIME + 1) * 2.778ms * 12
The HW Prox Averaging control is a pulldown menu that lets you defines the number of ADC samples collected and averaged during a cycle, which become the proximity result. The averaging is calculated in the hardware. The values range from 0 (Disabled) to 7 (128 samples) where each value is the exponent of 2 (2 value
).
The PRATE control sets the duration of 1 Prox Sample, which is (PRATE + 1) * 87
µ s. The Prox
Cycle Time is the duration to output the HW averaging data, which is the PRATE time multiplied by the HW Prox averaging number.
The POFFSET control sets the magnitude that adjusts PDATA to remove crosstalk from the proximity data. The values range from -255 to 255.
The Cal button triggers the sensor’s proximity offset calibration sequence.
The Auto Offset Adjust checkbox causes the POFFSET value to be decremented if PDATA ever becomes zero.
The Prox Threshold controls the high and low thresholds values. If the PDATA value is above the high threshold or below the low threshold the proximity interrupt is asserted (PINT).
The PPERS control set the persistence interrupt filter. The interrupt (PINT) asserts when PDATA crosses a threshold for consecutive PPERS number of reads. Example: if PPERS is set to 3, then
PINT asserts when PDATA crosses a threshold and stays past the threshold for 3 consecutive reads.
The Dynamic checkbox moves the high and low thresholds when PINT is triggered. PINT is cleared automatically. page 11/13
2.1.5.2 Prox Output Data
The top right corner of the Prox tab displays the data that is output by the device.
PDATA displays the Proximity ADC channel data count.
ProxAvg displays the average of the last 32 PDATA samples displayed above.
StDev displays the standard deviation of the last 32 PDATA samples displayed above.
Note: If HW Prox Averaging is enabled, then the ProxAvg and StDev is calculated based on the last
32 PDATA averages read.
The Det/Rel box is the detect/release indicator. It turns red when PDATA is above the high threshold and stays red until PDATA falls below the low threshold.
The Status section displays the interrupt status. An ‘x’ inside the box indicates the interrupt flag is set. To clear an interrupt, click the ‘x’ in the box. If the condition causing the interrupt is still present the box gets set to an “x’ again. The PINT box is the proximity interrupt that is set when PDATA exceeds the high or low threshold. The CINT box is the calibration interrupt that is set when a calibration sequence is complete. The PSAT box is the saturation interrupt to indicate an ambient or reflective event cause the ADC data to saturation. The Reflective and Ambient boxes indicate which type of PSAT event occurred.
2.1.5.3 Prox Data Plot
The remaining portion of the Prox tab is used to display a running plot of the collected PROX values. The last 350 values are collected and plotted on the graph. As additional values are added, the old values will be deleted from the left side of the graph.
The Enable Plot checkbox activates the plotting function. Data will only be plotted when this box is checked.
Click the Clear Plot button to discard the current data and continue plotting the new data. Note, if the Clear Plot button is clicked while the plot is disabled, the data is discarded, but the actual plot will not be updated until the plot function is re-enabled. page 12/13
The Scale of the Y-axis of the plot can be adjusted by clicking on the small up and down arrows at the top left corner of the plot. The scale can be set to any power of 2 from 64 through 65536.
The Prox and ProxAvg checkboxes enable/disable the lines on the graph. The Prox (black line) data is the PDATA read from the part. The ProxAvg (red line) data is the average of the last 32
PDATA read.
3 Resources
TMD2620 datasheet
TMD2620 EVM Quick Start Guide (QSG)
Designer’s Notebooks
For additional information regarding the TMD2620, please refer to the datasheet. For information regarding the installation of the TMD2620 EVM host application software please refer to the
TMD2620 EVM Quick Start Guide.
Designer’s Notebooks dealing with various aspects of optical measurement and optical measurement applications are available. All content is available on the ams
website www.ams.com
. page 13/13
Scarica
Pubblicità