Sophos Enterprise Console server to server migration Guide
Sophos Enterprise Console server to server migration allows you to migrate your existing Sophos Enterprise Console to a new server.
You can use this to migrate Sophos Enterprise Console between any supported Windows operating system, 32-bit or 64-bit.
This migration guide applies to Sophos Enterprise Console 5.5 and later.
This guide will teach you how to migrate your existing version of Sophos Enterprise Console to another server. You cannot upgrade Sophos Enterprise Console to another major, minor, or maintenance version during the migration process described in this guide.
Anúncio
Anúncio
Sophos Enterprise Console migration guide
product version: 5.5
Contents
(2018/12/17)
Sophos Enterprise Console
1 About this guide
This guide describes how to migrate Sophos Enterprise Console (SEC) from one server to another.
You can use this guide to migrate Sophos Enterprise Console between any supported Windows operating system, 32-bit or 64-bit.
This guide applies to Sophos Enterprise Console 5.5 and later.
Note
This guide describes how to migrate your existing version of Sophos Enterprise Console to another server. You cannot upgrade Sophos Enterprise Console to another major, minor, or maintenance version during the migration process described in this guide. To upgrade, see the
Sophos Enterprise Console upgrade guide.
Sophos Enterprise Console documentation is published at https://www.sophos.com/en-us/support/ documentation/enterprise-console.aspx
.
Copyright © Sophos Limited 1
Sophos Enterprise Console
2 Terminology
The following table lists terms that have specific meanings for this guide:
Term old server new server old identity new identity
Meaning
The existing Sophos Enterprise Console server.
A new server onto which the existing installation of Sophos
Enterprise Console will be migrated.
The old server's identification details: name, domain and IP address (if fixed).
A new server's new identification details: name, domain and IP address (if fixed). Name (and IP address) must differ from the old identity but domain must be the same.
2 Copyright © Sophos Limited
Sophos Enterprise Console
3 Assumptions
This guide assumes the following:
• You are migrating the version of Sophos Enterprise Console installed on the old server to a new server.
• All components of Sophos Enterprise Console (Management Console, Management Server, and
Database) are installed on a single server, the old server, and are operational.
• The same version of Sophos Enterprise Console will be installed on the new server that has no other Sophos software. If the new server has or had any Sophos products or components installed,
see Appendix A: Prepare a new server (page 24)
• Sophos Enterprise Console will be migrated to the new server with a new identity.
• If a new user account is created, it is based on the network environment. For example, a local account in a workgroup environment and a domain account in a domain environment.
• If you are using or installing a custom database on the old or new server, you must make sure the collation settings match between them.
Note
The default collation settings of SQL server can differ when installing on a computer with different locale.
• Sophos Enterprise Console is installed on the old server in the default location and will be installed in the default location on the new server. If a different location is used then any folder paths referenced in this guide must be modified accordingly.
• There is local Sophos Update Manager (SUM) installed on the old server. If there are any other
SUM installations on the network, they update from the SUM installed on the old server.
• Both the old server and new server are in the same domain or workgroup.
• Neither the old server or new server are a domain controller.
• You have the necessary administrator privileges on both the old server and new server.
• All the files that are transferred between the old server and new server during the migration process are stored and transferred using a secure location or device.
Copyright © Sophos Limited 3
Sophos Enterprise Console
4 Prerequisite
If User Account Control (UAC) is enabled on the server, turn off UAC and restart the server.
You can turn UAC on again after the migration is complete.
4 Copyright © Sophos Limited
Sophos Enterprise Console
5 What are the key steps?
To migrate Enterprise Console to a new server, you carry out these steps:
• Prepare the old server (this includes checking the Update Manager password and backing up data).
• Install the Enterprise Console database component on the new server.
• Restore the database and certificate registry key on the new server.
• Install the Enterprise Console management server and management console components on the new server.
• Back up data on the new server.
• Import registry and Secure Store from the old server to new server.
• Switch endpoint computers to be updated by the new Update Manager.
• Change updating policy details.
• Switch endpoint computers to be managed by the new Enterprise Console.
• Switch any unprotected child SUMs to the new Update Manager.
• Switch remote consoles to the new server.
These steps are described in the sections that follow.
Copyright © Sophos Limited 5
6
Sophos Enterprise Console
6 Prepare the old server for migration
To prepare the old server for migration, do the following:
•
Check Update Manager password (page 6)
•
(page 6)
•
Back up data, registry and Secure Store
(page 7)
6.1 Check Update Manager password
The Sophos Update Manager (SUM) password is set in updating policies and is used to authenticate endpoints so that they can receive updates from SUM.
If you do not know your SUM password, you can reset it. You should be aware that if you do this, your endpoint computers will fail authentication when they next update.
To reset the SUM password:
1. On the old server, create a new Windows account so the account name and password are known.
This account will be used as your Update Manager account.
2. Using Windows Explorer, navigate to the update share location. The default location is: C:
\ProgramData\Sophos\Update Manager\Update Manager .
3. Right-click the Update Manager folder, select Properties. In the Properties window, on the
Sharing tab, click Permissions.
4. Add the newly created Windows account and set Read access.
5. In Sophos Enterprise Console, find each updating policy that uses the previous Windows account and edit it so that it uses the new Windows account, as follows: a) Open the updating policy, and select the Primary Server tab.
b) Change the Username to the new account.
c) Click Change to set a new password.
6. Push the policy or policies out to all endpoints (right-click on all groups then Comply with > Group
Updating Policy).
7. Confirm that all endpoints are compliant with the revised updating policy (there are no "Computers that differ from policy").
If you are using a workgroup/local account on the new server, you must create a new Windows user account with the same account name and password on the new server as on the old server.
You have finished resetting the Update Manager password.
6.2 Stop Sophos services
On the old server:
1. Close Enterprise Console.
2. Open a command prompt window.
Copyright © Sophos Limited
Sophos Enterprise Console
3. Stop the endpoint communication services. To do this, type the following commands: net stop "Sophos Message Router" net stop "Sophos Patch Endpoint Communicator" net stop "Sophos Certification Manager"
Note
Sophos recommends that you wait for several minutes after you stop the endpoint communication services. This will help process any messages that may be cached in the memory queues.
4. Stop the data processing and front end services. To stop the services, type the following commands: net stop "Sophos Patch Server Communicator" net stop "Sophos Management Host" net stop "Sophos Patch Endpoint Orchestrator" net stop "Sophos Management Service" net stop "Sophos Update Manager"
You have finished stopping Sophos services.
6.3 Back up data, registry and Secure Store
On the old server:
1. Open a command prompt at the Enterprise Console installation directory.
Windows version
Default location
32-bit C:\Program Files\Sophos\Enterprise Console
64-bit C:\Program files (x86)\Sophos\Enterprise Console
2. Type the following command to back up the database:
DataBackupRestore.exe -Action=backup
A confirmation message is displayed and a Backup folder is created with a Database subfolder, registry keys, and Secure Store information in the following location:
%ALLUSERSPROFILE%\Sophos\ManagementServer\
3. In the Backup folder that has been created, create two new folders:
• Router
• DataBackupRestore
4. Copy the table_router.txt file to the Router folder created earlier. The default location of the
table_router.txt file is:
%ALLUSERSPROFILE%\Sophos\Remote Management System\3\Router
\table_router.txt
5. Copy the Envelopes folder to the Router folder created earlier. The default location of the
Envelopes folder is:
Copyright © Sophos Limited 7
Sophos Enterprise Console
%ALLUSERSPROFILE%\Sophos\Remote Management System\3\Router\Envelopes
Note
The Envelopes folder will be empty if you have no outstanding messages.
6. Browse to the Sophos Enterprise Console installation directory.
Windows version
Default location
32-bit C:\Program Files\Sophos\Enterprise Console
64-bit C:\Program files (x86)\Sophos\Enterprise Console
7. Copy the following files and folders to the DataBackupRestore folder created earlier.
• Metadata (entire folder along with its contents)
• BackupRestore.proj
• DataBackupRestore.exe
• DataBackupRestore.exe.config
• ResetUserMappings.sql
• TBK.bat
• TRS.bat
You have finished taking backup of data, registry, and Secure Store.
8 Copyright © Sophos Limited
Sophos Enterprise Console
7 Install Enterprise Console database component
On the new server:
1. Download the Sophos Enterprise Console installer from the Sophos Enterprise Console Downloads page: http://www.sophos.com/en-us/support/downloads/console/sophos-enterprise-console.aspx
.
You will need to enter your MySophos credentials.
2. Locate the installer and double-click on it.
3. In the Sophos Endpoint Security and Control network installer dialog box, click Install.
The installation files are copied to a location and an installation wizard starts.
4. In the Sophos Enterprise Console dialog box, click Next.
5. A wizard guides you through installation. You should do as follows: a) Accept the defaults wherever possible.
b) In the Components selection dialog box, select only the Database component.
c) In the Database details dialog box, provide the username for database access.
6. When installation is complete, click Yes or Finish.
You have finished installing the Sophos Enterprise Console database component.
Copyright © Sophos Limited 9
Sophos Enterprise Console
8 Restore database and certificate registry key
To restore database and certificate registry key from the old server to new server:
1. Create a new folder called ManagementServer in the following location: %ALLUSERSPROFILE%
\Sophos\
2. Copy the Backup folder from the old server to the ManagementServer folder on the new server that has been created.
The folder path should be ...\Sophos\ManagementServer\Backup
3. Open a command prompt at the DataBackUpRestore folder location: %ALLUSERSPROFILE%
\Sophos\ManagementServer\Backup\DataBackUpRestore\ .
4. Type the following command to restore the database. DataBackupRestore -Action=Restore
-DataSourceType=Database Confirm by typing y.
5. Browse to the Backup folder. %ALLUSERSPROFILE%\Sophos\ManagementServer\Backup .
6. Right-click the registry file CertificationManager.reg, select Merge and confirm.
Note
If you are migrating between 32-bit and 64-bit computers, you must edit the registry key. For more information, see
Appendix B: Modify exported registry files (page 25).
You have finished restoring the database and certificate registry key.
10 Copyright © Sophos Limited
Sophos Enterprise Console
9 Install Sophos Enterprise Console server and console components
On the new server:
1. Locate the Sophos Enterprise Console installer and double-click on it.
2. In the Sophos Enterprise Console dialog box, click Next.
3. A wizard guides you through installation. You should do as follows: a) Accept the defaults wherever possible.
b) In the Components selection dialog box, select Management Server and Management
Console.
c) In the Database details dialog box, enter the credentials for database access.
d) In the Sophos Update Manager Credentials dialog box, enter the Windows user account that is used as the Update Manager account set earlier in
(page
6) and continue with the installation.
4. When installation is complete, you may be prompted to restart. Click Yes or Finish.
Note
When you log back on (or restart) for the first time after installation, dismiss the warning message saying that the update manager is not configured and close Sophos Enterprise
Console.
You have finished installing the Sophos Enterprise Console management server and management console components.
9.1 Stop Sophos services
1. Ensure Enterprise Console is closed.
2. Stop the endpoint communication services. To do this: a) Open a command prompt window.
b) Type the following commands: net stop "Sophos Message Router" net stop "Sophos Patch Endpoint Communicator" net stop "Sophos Certification Manager"
3. Stop the data processing and front end services. To stop the services, type the following commands in the command prompt window: net stop "Sophos Patch Server Communicator" net stop "Sophos Management Host" net stop "Sophos Patch Endpoint Orchestrator" net stop "Sophos Update Manager"
You have finished stopping Sophos services.
Copyright © Sophos Limited 11
Sophos Enterprise Console
10 Back up data on the new server
You must take a backup of the data on the new server. The backup will be used later for importing registry values.
1. Rename the existing Backup folder at the following location to Old_Server_Backup.
%ALLUSERSPROFILE%\Sophos\ManagementServer\Backup
2. Open a command prompt at the Enterprise Console installation directory.
Windows version
32-bit
Default location
C:\Program Files\Sophos\Enterprise Console
64-bit C:\Program files (x86)\Sophos\Enterprise Console
3. Type the following command to back up the database:
DataBackupRestore.exe -Action=backup
A confirmation message is displayed and a Backup folder is created with a Database subfolder, registry keys, and Secure Store information in the following location:
%ALLUSERSPROFILE%\Sophos\ManagementServer\
4. Rename the new Backup folder that has been created to New_Server_Backup .
5. Now rename the Old_Server_Backup folder to Backup .
6. Stop the Sophos Management Service. To do this: a) Open a command prompt window.
b) Type the following command: net stop "Sophos Management Service"
You have finished taking backup of data on the new server.
12 Copyright © Sophos Limited
Sophos Enterprise Console
11 Import registry and Secure Store
1. Open a command prompt at the Enterprise Console installation directory.
Windows version
32-bit
Default location
C:\Program Files\Sophos\Enterprise Console
64-bit C:\Program files (x86)\Sophos\Enterprise Console
2. Verify the Management Service database connection string value in the registry. To do this: a) Open Registry Editor and navigate to the Sophos registry key:
Windows version
32-bit
64-bit
Default location
HKEY_LOCAL_MACHINE\SOFTWARE\Sophos\EE\Management Tools\
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos\EE
\Management Tools\ b) In the right pane, select the entry DatabaseConnectionMS.
The DatabaseConnectionMS value will contain a string of text similar to:
Provider=SQLOLEDB;Integrated Security=SSPI;Initial Catalog=SOPHOS550;Data
Source=(local)\SOPHOS; c) On the Edit menu, click Modify.
d) In Value data ensure that the DataSource field is set to point to the new server hostname and
SQL instance. For example Data Source=(local)\SOPHOS;
If the SQL server instance is hosted on a remote server, substitute (local) for the server name. Check whether the database is using an existing or new instance and modify the value if needed.
3. Modify the ServerLocation registry value to have the new server hostname. To do this a) Go to the Sophos registry key:
Windows version
32-bit
64-bit
Default location
HKEY_LOCAL_MACHINE\SOFTWARE\Sophos\EE\Management Tools\
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos\EE
\Management Tools\ b) In the right pane, select the entry ServerLocation.
c) On the Edit menu, click Modify.
d) In Value data, find your old server hostname, and then replace it with the new server hostname.
Copyright © Sophos Limited 13
Sophos Enterprise Console
4. Modify the Instance registry value to have the new server hostname. To do this: a) Navigate to the Sophos registry key:
Windows version
32-bit
Default location
64-bit
HKEY_LOCAL_MACHINE\SOFTWARE\Sophos\EE\ManagementTools
\Database Installer
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos\EE
\Management Tools\Database Installer b) In the right pane, select the entry Instance.
c) On the Edit menu, click Modify.
d) In Value data, find your old server instance name, and then replace it with the new server instance name. For example: Data Source=(local)\SOPHOS;
5. If the Sophos Update Manager uses a workgroup/local account, modify the SumUser registry values. To do this: a) Navigate to the Sophos registry key. The registry keys are at the following location:
Windows version
32-bit
Default location
HKEY_LOCAL_MACHINE\SOFTWARE\Sophos\EE\Management Tools
\SumUser
64-bit HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos\EE
\Management Tools\SumUser b) Retrieve the registry values for SumUserName and SumUserData from the
ManagementTools.reg file.
The ManagementTools.reg file is located in the New_Server_Backup folder created as part
of Back up data, registry and Secure Store
(page 7).
c) Replace the existing SumUserName and SumUserData values with those specified in the
ManagementTool.reg file.
6. If the database uses a workgroup/local account, modify the DatabaseUser registry value to contain the new server hostname. To do this: a) Navigate to the Sophos registry key:
Windows version
32-bit
Default location
64-bit
HKEY_LOCAL_MACHINE\SOFTWARE\Sophos\EE\Management Tools
\DatabaseUser
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos\EE
\Management Tools\DatabaseUser b) In the right pane, select the entry DatabaseUserDomain.
c) On the Edit menu, click Modify.
14 Copyright © Sophos Limited
Sophos Enterprise Console d) In Value data, find your old server hostname, and then replace it with the new server hostname.
Note
If you have used a different database account during the installation on the new server, you must do the following additional steps: e) Retrieve the registry values for the DatabaseUserName and DatabaseUserPassword from the ManagementTools.reg file.
The ManagementTools.reg file is located in the New_Server_Backup folder created as part
of Back up data on the new server
(page 12).
f) Replace the existing DatabaseUserName and DatabaseUserPassword values with those specified in the ManagementTool.reg file.
7. Modify the PatchServerURL registry value to have the new server hostname and port (if a different port was set during installation). To do this: a) Navigate to the Sophos registry key:
Windows version
32-bit
64-bit
Default location
HKEY_LOCAL_MACHINE\SOFTWARE\Sophos\EE\Patch\
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos\EE\Patch\ b) In the right pane, select the entry PatchServerURL.
c) On the Edit menu, click Modify.
d) In Value data, find your old server hostname, and then replace it with the new server hostname and port (if using a different port).
8. Restore the table_router.txt file from the old server's Router folder to the new server at the following location:
%ALLUSERSPROFILE%\Sophos\Remote Management System\3\Router
\table_router.txt
9. Restore the contents of the Envelopes from the old server's Router folder to the new server at the following location:
%ALLUSERSPROFILE%\Sophos\Remote Management System\3\Router\Envelopes
Note
The Envelopes folder will be empty if you have no outstanding messages.
10. Open a command prompt at the Sophos Enterprise Console installation directory.
11. Open a command prompt at the Sophos Enterprise Console installation directory.
12. Type the following command to import Secure Store.
DataBackupRestore -Action=Restore -DataSourceType=SecureStore
Confirm by typing y.
You have finished importing registry and Secure Store.
Copyright © Sophos Limited 15
Sophos Enterprise Console
11.1 Start all Sophos services
On the new server:
1. Start the endpoint communication services. To do this, open a command prompt window and type the following commands: net start "Sophos Message Router" net start "Sophos Patch Endpoint Communicator" net start "Sophos Certification Manager"
2. Start the data processing and front end services. To start the services, type the following commands in the command prompt window: net start "Sophos Patch Server Communicator" net start "Sophos Management Host" net start "Sophos Patch Endpoint Orchestrator" net start "Sophos Management Service" net start "Sophos Update Manager"
You have started all Sophos services.
16 Copyright © Sophos Limited
Sophos Enterprise Console
12 Redirect endpoints to the new Update
Manager
You must configure endpoint computers to be updated by the new Sophos Update Manager (SUM) and configure it to download updates from Sophos.
1. On the new server open Sophos Enterprise Console.
2. On the View menu, click Update managers.
The Update Managers list is displayed with the new SUM.
3. Double-click the old SUM and remove all entries on the Sources tab. Click OK.
4. Double-click the new SUM and setup the Sources, Subscriptions, Distributions, and other details as required.
5. Wait until the Last Updated column changes from Never to the current date/time for the new
SUM.
6. If there are child SUMs, configure each child SUM to point to the new SUM.
You have finished redirecting endpoints to the new Update Manager.
Copyright © Sophos Limited 17
Sophos Enterprise Console
13 Configure updating policy
You must configure the updating policy account details on the new server. To do this:
1. In Enterprise Console, double-click on the updating policy you want to edit.
The Updating Policy dialog box is displayed.
Note
Do not change the updating policies that point to child SUMs.
2. In the Primary Server tab, change Address to point to the new server location.
3. Modify the Username and click Change to set a new password.
4. If necessary, modify the settings for Secondary Server.
5. Click OK to save the settings.
6. On the View menu, click Update managers, in the update manager list, right-click the old SUM and click Delete.
You have finished configuring the updating policy.
18 Copyright © Sophos Limited
Sophos Enterprise Console
14 Redirect endpoints to the new
Enterprise Console
To redirect endpoints to the new Sophos Enterprise Console you can reprotect the endpoint computers from the new Sophos Enterprise Console.
Note
If you have a large number of endpoints or if reprotection is not possible due to any other reason, an alternative procedure is described in Sophos support knowledgebase article 116737 ( http:// www.sophos.com/en-us/support/knowledgebase/116737.aspx
).
If you need detailed information on how to protect computers, see Protect computers section in the
Sophos Enterprise Console Help.
To protect computers:
1. Depending on whether or not the computers you want to protect are already in a group, do one of the following:
• If the computers you want to protect are in the Unassigned group, drag the computers onto a group.
• If the computers you want to protect are already in a group, select the computers, right-click and click Protect Computers.
The Protect computers wizard is launched.
2. On the Installation type page, select the security software that you want to use for reprotection.
3. Follow the instructions in the wizard. On the Select features page, select the features you want.
Note
For a list of system requirements for the features, see the system requirements page on the
Sophos website ( http://www.sophos.com/en-us/products/all-system-requirements.aspx
).
The anti-virus protection is always selected and must be installed. You can also select to install the features listed below. Some of the features are available only if your license includes them.
• Firewall
• Patch
• Third-Party Security Software Detection
4. On the Protection summary page, any problems with installation are shown in the Protection
issues column. Click Next.
5. On the Credentials page, enter details of an account which can be used to install software.
This account is typically a domain administrator account. It must:
• Have local administrator rights on computers you want to protect.
• Be able to log on to the computer where you installed the management server.
• Have read access to the Primary server location specified in the Updating policy.
Copyright © Sophos Limited 19
Sophos Enterprise Console
Note
If you are using a domain account, you must enter the username in the form domain\user .
You have finished redirecting endpoints to the new Enterprise Console.
20 Copyright © Sophos Limited
Sophos Enterprise Console
15 Redirect any unprotected child SUMs to the new Update Manager
Child Sophos Update Managers protected by Sophos Endpoint Security and Control are automatically redirected to the new parent SUM by their updating policies.
For any unprotected SUMs, configure them manually to connect to the new parent SUM as follows:
1. On the new server, copy the mrinit.conf
and cac.pem
files from the Enterprise Console folder.
Windows version
32-bit
Default location
C:\Program Files\Sophos\Enterprise Console
64-bit C:\Program files (x86)\Sophos\Enterprise Console
2. Go to each child SUM and carry out the following steps: a) Paste the mrinit.conf
and cac.pem
files to the Remote Management System folder.
Windows version
32-bit
64-bit
Default location
C:\Program Files\Sophos\Remote Management System
C:\Program files (x86)\Sophos\Remote Management System b) Open a command prompt window at the Remote Management System directory.
c) Run the command ClientMrInit.exe -update .
You have finished redirecting unprotected child SUMs to the new Update Manager.
Copyright © Sophos Limited 21
Sophos Enterprise Console
16 Redirect remote consoles to the new server
For each remote Enterprise Console installation, at the remote computer:
1. Run the Enterprise Console installer package.
2. Extract the installation files to the suggested destination folder or another one of your choice. The folder must be on the computer to be upgraded.
The installation wizard starts.
3. In the Sophos Enterprise Console dialog box, click Next.
4. A wizard guides you through installation. You should do as follows: a) Accept the defaults wherever possible.
b) In Components selection dialog box, select Management Console and click Next.
c) In the Management Console dialog box, enter the name of the new server. If the new server is using a different port, update the port number.
Note
If the remote console and the new server are part of an Active Directory domain, you will be prompted to enter the Database details. If prompted, ensure you use the same account details used for database access during the installation of Enterprise Console on the new server.
5. Continue the installation wizard to update the console installation with the new settings.
You have finished redirecting remote consoles to the new server.
22 Copyright © Sophos Limited
Sophos Enterprise Console
17 Decommission the old server
Note
If the old server is protected, and if you do not plan to decommission it after the migration, the old server must be reprotected from the new Enterprise Console server in order for it to become a managed computer.
To decommission the old server:
1. If you are disposing of an old server, it is advisable to securely wipe or destroy its hard drives(s).
2. If you are reusing the old server, uninstall Sophos Enterprise Console and Microsoft SQL Server using Windows Control Panel and later delete the database.
You have finished decommissioning the old server.
Copyright © Sophos Limited 23
Sophos Enterprise Console
18 Appendices
24
18.1 Appendix A: Prepare a new server
If you are using a server that has or had any Sophos products installed, ensure all the components are uninstalled and do the following:
1. Open the Registry Editor. To open click Start, Run, type regedit and then click OK.
2. Take a backup of the registry.
For information on how to take a registry backup, refer to Microsoft documentation.
3. In the Registry Editor window, browse to the Sophos registry key location:
Windows version
32-bit
64-bit
Registry key location
HKEY_LOCAL_MACHINE\SOFTWARE\Sophos
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos
If it exists, delete the Sophos registry key. Close the Registry Editor window.
4. Browse to the Sophos installation folder location:
Default path Windows version
32-bit
64-bit
C:\Program files\Sophos
C:\Program files (x86)\Sophos
If it exists, take a backup of its contents, including all subfolders, save it to a safe and secure location, and then delete the folder.
5. Browse to the Sophos common installation location:
Default path Windows version
32-bit
64-bit
C:\Program files\Common Files\Sophos
C:\Program files (x86)\Common Files\Sophos
If it exists, take a backup of its contents, including all subfolders, save it to a safe and secure location, and then delete the folder.
6. Browse to the database backup location, for example (depending on your SQL Server version):
Default path Windows version
32-bit C:\Program Files\Microsoft SQL Server\MSSQL10.SOPHOS\MSSQL\Backup
Copyright © Sophos Limited
Sophos Enterprise Console
Windows version
64-bit
Default path
C:\Program Files\Microsoft SQL Server\MSSQL10.SOPHOS\MSSQL\Backup
If it exists, take a backup of its contents, including all subfolders, and save it to a safe and secure location. Delete Enterprise Console database backup files (.bak files).
The file names begin with "SOPHOS" and usually contain the Enterprise Console version number. For information about the database file names for different console versions, see
Sophos support knowledgebase article 17323 ( http://www.sophos.com/en-us/support/ knowledgebase/17323.aspx
). For example, the database backup files for Enterprise Console
5.5.0 are:
• SOPHOS550.bak
• SOPHOSPATCH52.bak
• SophosSecurity.bak
7. Browse to the database data location, for example (depending on your SQL Server version):
Default path Windows version
32-bit
64-bit
C:\Program Files\Microsoft SQL Server\MSSQL10.SOPHOS\MSSQL\DATA
C:\Program Files\Microsoft SQL Server\MSSQL10.SOPHOS\MSSQL\DATA
If it exists, take a backup of its contents, including all subfolders, and save it to a safe and secure location. Delete the Enterprise Console database files (.mdf files) and transaction log files (.ldf
files).
The file names begin with "SOPHOS" and usually contain Enterprise Console version number. For information about the database file names for different console versions, see
Sophos support knowledgebase article 17323 ( http://www.sophos.com/en-us/support/ knowledgebase/17323.aspx
). For example, the database files and transaction log files for
Enterprise Console 5.5.0 are:
• SOPHOS550.mdf
• SOPHOS550_log.ldf
• SOPHOSPATCH52.mdf
• SOPHOSPATCH52_log.ldf
• SophosSecurity.mdf
• SophosSecurity_log.ldf
You have finished preparing the new server.
18.2 Appendix B: Modify exported registry files
If you are migrating between 32-bit and 64-bit computers, when exporting and importing registry keys, you will need to open any exported registry files in a text editor and change the Sophos registry values as shown below. The easiest and most reliable way to do this is by using search and replace.
Copyright © Sophos Limited 25
Sophos Enterprise Console
Windows version
Default installation path
Sophos registry location
32-bit
64-bit
C:\Program files
C:\Program files
(x86)
HKEY_LOCAL_MACHINE\SOFTWARE\Sophos
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos
Migrating from a 32-bit to 64-bit computer
1. Open the saved registry exported file with Windows Notepad.
2. Click on the Edit menu and click Replace.
3. In Find what type \SOFTWARE\Sophos\ and in Replace with type \SOFTWARE\Wow6432Node
\Sophos\ .
4. Click Replace all.
5. In Find what type C:\\Program Files\\Sophos\\Update Manager and in Replace with type C:\\Program Files (x86)\\Sophos\\Update Manager .
6. Click Replace all.
7. Save the file and close Notepad.
Migrating from a 64-bit to 32-bit computer
1. Open the saved registry exported file with Windows Notepad.
2. Click on the Edit menu and click Replace.
3. In Find what type \Wow6432Node\Sophos\ and in Replace with type \Sophos\ .
4. Click Replace all.
5. In Find what type C:\\Program Files (x86)\\Sophos\\Update Manager and in Replace
with type C:\\Program Files\\Sophos\\Update Manager .
6. Click Replace all.
7. Save the file and close Notepad.
26 Copyright © Sophos Limited
Sophos Enterprise Console
19 Technical support
You can find technical support for Sophos products in any of these ways:
• Visit the Sophos Community at community.sophos.com/ and search for other users who are experiencing the same problem.
• Visit the Sophos support knowledge base at www.sophos.com/en-us/support.aspx
.
• Download the product documentation at www.sophos.com/en-us/support/documentation.aspx
.
• Open a ticket with our support team at https://secure2.sophos.com/support/contact-support/ support-query.aspx
.
Copyright © Sophos Limited 27
Sophos Enterprise Console
20 Legal notices
Copyright © 2018 Sophos Limited. All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or by any means, electronic, mechanical, photocopying, recording or otherwise unless you are either a valid licensee where the documentation can be reproduced in accordance with the license terms or you otherwise have the prior permission in writing of the copyright owner.
Sophos, Sophos Anti-Virus and SafeGuard are registered trademarks of Sophos Limited, Sophos
Group and Utimaco Safeware AG, as applicable. All other product and company names mentioned are trademarks or registered trademarks of their respective owners.
28 Copyright © Sophos Limited
Download
Anúncio