HPE IMC Intelligent Analysis Report V2 User Guide
Advertisement
Advertisement
HPE IMC
Intelligent Analysis Report V2 Quick
Start Guide
Abstract
This document provides instruction for the iAR V2 report designer used to create customized report template based on
IMC data sources.
.
Part number: 5200-0926
Software Version: IMC PLAT 7.2 (E0402)
Document version: 1.0
© Copyright 2014, 2016 Hewlett Packard Enterprise Development LP
The information contained herein is subject to change without notice. The only warranties for Hewlett Packard
Enterprise products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. Hewlett
Packard Enterprise shall not be liable for technical or editorial errors or omissions contained herein.
Confidential computer software. Valid license from Hewlett Packard Enterprise required for possession, use, or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software
Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor’s standard commercial license.
Links to third-party websites take you outside the Hewlett Packard Enterprise website. Hewlett Packard
Enterprise has no control over and is not responsible for information outside the Hewlett Packard Enterprise website.
Acknowledgments
Intel®, Itanium®, Pentium®, Intel Inside®, and the Intel Inside logo are trademarks of Intel Corporation in the
United States and other countries.
Microsoft® and Windows® are trademarks of the Microsoft group of companies.
Adobe® and Acrobat® are trademarks of Adobe Systems Incorporated.
Java and Oracle are registered trademarks of Oracle and/or its affiliates.
UNIX® is a registered trademark of The Open Group. i
Contents
Overview ························································································ 2
Using iAR V2 ··················································································· 3
Configuration example ······································································ 6
About HPE IMC documents ······························································ 50
Document conventions ···································································· 53
Support and other resources ···························································· 54
i
Overview
Intelligent Analysis Report V2 (iAR V2) is a report designer that enables you to customize report templates based on IMC data sources.
This document assumes that you have basic knowledge of SQL and relational databases.
2
Using iAR V2
iAR V2 allows you to customize report templates in JRXML format and add them to IMC for central management and reporting.
Configuration process and guidelines
Figure 1 illustrates the process of using iAR V2 to customize a report template for IMC.
Figure 1 Using iAR V2 to customize a report template for IMC
Preparation
Launch iAR V2
JDBC Database
Connection view
SQL statements
Design a report template
JRXML file
Add the report template to IMC
View the report
IMC accesses the database through JDBC. To generate report templates, iAR V2 must also access data sources through JDBC.
3
When JDBC is used to access data, follow these restrictions and guidelines:
•
For SQL Server, connect to the database objects under report in the report_db database in the IMC system.
•
For Oracle and MySQL, connect to the database objects under report .
•
Because IMC has permission control of operators, all report templates customized in iAR V2 must use the operator parameter to control the access rights. For more information, see
Configuring JDBC
1. Launch iAR V2.
2. In the repository explorer area, right-click Data Adapters and then select Create Data
Adapter .
3. Select Database JDBC Connection and then click Next .
The page for configuring the JBDC connection parameters appears as shown in Figure 2 .
Figure 2 Configuring JDBC connection parameters
4.
Select a JDBC driver and configure the JDBC URL by following the requirements in Table 1 .
4
Table 1 JDBC drivers and URL configurations for different database types
Database JDBC driver JDBC URL configuration
SQL Server
•
MS SQLServer (2005-2012)
(com.microsoft.sqlserver.jdbc.SQLServerD
river)
•
MS SQLServer
(net.sourceforge.jtds.jdbc.Driver) jdbc:sqlserver://IP:1433;database
Name=database name
Oracle Oracle (oracle.jdbc.driver.OracleDriver) jdbc:oracle:thin:@IP:1521:databa se name
MySQL MySQL (com.mysql.jdbc.Driver) jdbc:mysql://IP/Database name
5. Enter the username report and the password iMCV7_report_imc_com .
6. Click Test
to verify the parameter configuration as shown in Figure 3 .
Figure 3 Verifying the parameter configuration
7. Click OK to confirm the test result.
8. Click Finish .
The data adapter is successfully created and appears in the repository explorer area.
5
Configuration example
This example describes how to use iAR V2 and IMC to create a report that meets the following requirements:
•
The report displays the device category statistics in a bar chart as shown in Figure 4 .
•
Each bar in the chart provides access to a detailed device list of the selected category.
Figure 4 Device category statistic report-bar chart
Creating a report template
Adding a report page
1. Launch iAR V2.
2. In the project explorer area, right-click a project, and then select New > Jasper Report .
The report designer manages reports in projects; you must create reports under projects.
This example uses the default project MyReports .
To create a new project, select File > New > Project .
3. Select a report template and then click Next
This example uses the default template named Blank A4 .
6
Figure 5 Selecting the report template
4. Select a parent folder for the report, enter a report name, and then click Next as shown in
NOTE:
To complete adding the report page, you can directly click Finish in this step. The following steps are available later when you edit the report page.
7
Figure 6 Configuring the parent folder and name for the report
5.
Select a data adapter as shown in Figure 7 .
To create a data adapter, next to the data adapter list click New . For more information about
creating a data adapter, see " Configuring JDBC ."
Figure 7 Selecting a data adapter
6. In the input area below the data adapter, compile an SQL query on one of the following tabs to get database objects for the report:
Texts —Enter SQL statements on the Texts tab.
Outline —Fill in standard SQL structures with data objects, such as fields and tables, on the Outline tab. You can drag data objects from the list on the left to the input area.
Diagram —Uses the visualized interface on the Diagram tab. You can drag views from the list on the left to the input area and then select fields to create SQL queries.
8
Figure 8 Compiling SQL queries
7. Click Next .
The Fields
page appears as shown in Figure 9 .
8. Click the icon to select all fields that are read from the dataset.
In this example, only the vendor_name field is read.
9
Figure 9 Selecting SQL fields
9. Click Finish .
The report designer page appears for further configuration as shown in Figure 10 .
Figure 10 Report designer page
10
Add parameters
1. In the Outline area, under the report name, right-click Parameters and select Create
Parameter .
2. Add a parameter named cName and then select the class java.long.String
for the parameter
The parameter name must be cName or a character string starting with predefine plus a dot
(for example, predefine.
). The cName parameter is used to get the name of a new tab created after data drilling. In this example, the name of the new tab is the device category (for example,
Switch or Router ). Names starting with predefine.
are typically used for logic calculation in data drilling.
Figure 11 Adding the cName parameter
3. Add a parameter named operator , select the class java.long.String
, and select the Is For
Prompting
option as shown in Figure 12 .
When the report obtains device data for an operator, the operator parameter: o Provides access permission information. o Is also required in the report preview.
Figure 12 Adding the operator parameter
11
Adding the report title
1. On the right in the Palette area, click Text Field and then drag it to the Title band in the Main
Report area.
2. Modify the position and size of the text box.
3. Select the text box and then set the properties of the text field on the Text Field tab in the
Properties area.
4. Manually enter a report name or next to the Expression field, click the icon to generate
the name as shown in Figure 13 .
Figure 13 Setting the properties of the text field
5. On the left list, click Fields , and in the middle area, double-click vendor_name Field String .
The expression of this field is automatically generated in the upper edit box as shown in Figure
12
Figure 14 Expression editor
6. Click Finish .
Adding a diagram
1. In the Outline area, right-click the report name and select Create Dataset .
The page for creating a dataset appears.
2. Enter a dataset name (in this example , Dataset4Chart ) and then click Next as shown in
13
Figure 15 Creating a dataset
3.
Select the data adapter configured in " Adding a report page " and enter SQL statements as
Figure 16 Selecting a data adapter and entering SQL statements
14
The example includes the following views:
The plat_v_dev view stores information about all devices such as IP addresses, categories, and labels.
The plat_v_operator_dev view stores access permission information for operators and device resources accessible to the operators. This view is required in the SQL statement for IMC to correctly control access permission of operators.
For the description of fields in the views, see iAR Data Source Description (Platform
Volume_IMC PLAT 7.2) .
4. Click Next and select all fields that are read from the dataset.
5. Click Finish .
The dataset is created.
6. In the Palette area, select Char and then drag it to the Detail 1 band in the Main Report area.
Figure 17 Selecting the chart element
The Chart Wizard page appears.
7. Select Bar3D Chart and then click Next
15
Figure 18 Chart Wizard page
8.
Configure the following parameters for the chart as shown in Figure 19 :
Dataset —Select the dataset for the chart. This example uses Dataset4Chart .
Category —Click the icon to configure the horizontal axis. This example uses category_name .
Value —Click the icon to configure the formula for different types of values. This example uses ip_count to calculate the total number of devices in each category.
Series —Click the icon to configure the identifier of each bar. Before you configure the identifier of each bar, delete the default name SERIES 1 . This example uses category_name as the identifier.
16
Figure 19 Configuring the chart data
9. Click Finish .
10. In the Main Report area, modify the size of the chart.
11. In the Outline area, right-click Parameters and then select Create Parameter as shown in
Figure 20 Creating a parameter
12. Modify the parameter name to operator .
When the report obtains device data for an operator, the operator parameter provides access permission information. It is also required in the report preview.
13. Create the cName parameter in the same way the operator parameter is created.
The cName parameter is used for data drilling.
14. In the Main Report area, click the Preview tab to enter the preview view.
15. In the operator field, enter admin and then click the Run the report icon as shown in
17
Figure 21 Previewing the report
The report preview page appears with obtained data as shown in Figure 22 .
Figure 22 Report preview page
Adding a logo
To add a logo to the report, the following methods are available:
•
Method 1 —Drag the image element from the Palette area to the report.
•
Method 2 —Add the table element to the report and then add the image element to the table.
To ensure the correct display of the logo, this example uses Method 2 because the logo is obtained from the IMC database and its size is unknown.
To add a logo:
1. Right-click the report name and then select Create Dataset
This dataset is used to obtain the logo from IMC.
18
Figure 23 Creating a dataset
2. Enter the dataset name Dataset4Logo and then click Next
Figure 24 Configuring the dataset name
3. Select New Data Adapter - Database JDBC Connection .
4. Compile an SQL query to get the vendor logo from IMC and then click Next .
To get the logo correctly, you must select the vendor_logo column in the rptviewer_v_vendor_logo view. The vendor_logo field records the file storage path of the logo on the IMC server.
19
Figure 25 Compiling an SQL query
5. To select the vendor_logo field, click the
Figure 26 Selecting a field
6. Click Finish .
7. On the page that appears, drag the table element from the Palette area to the Title band as
20
Figure 27 Dragging the table element
8. On the page that appears, select Create a Table using an existing dataset and the dataset
Dataset4Logo
from the list as shown in Figure 28 .
Figure 28 Selecting a dataset
9. Click Next .
The Connection
page appears as shown in Figure 29 .
21
Figure 29 Connection configuration page
10. Use the default settings on the page and then click Finish .
11. In the Main Report area, modify the size of the table element and drag the table element to modify its location.
12.
Double-click the table element to open the editing page as shown in Figure 30 .
Figure 30 Editing the table element
13. Right-click the blank area of the table and then select Create Column At The Beginning to add a column.
22
Figure 31 Adding a column
14. In the Outline area, delete all table elements except Detail .
Figure 32 Deleting redundant table elements
15. Adjust the size of the column to fill up the table.
16. Drag the image element to the table, select No image as the image creation mode, and then click OK
23
Figure 33 Dragging the image element
17.
Adjust the image size to fill up the table as shown in Figure 34 .
Figure 34 Adjusting the image
18. Select the image and then edit the expression of the image on the Image tab of the Properties
This example uses the vendor_logo field.
Figure 35 Configuring the image properties
19. In the Project Explorer area, create a file folder named Images under the report project, and
then copy the image to this folder as shown in Figure 36 .
The image will fit the image element in report preview.
24
Figure 36 Creating a file folder and copying the logo
20. Preview the report.
The report displays the logo correctly as shown in Figure 37 .
Figure 37 Previewing the logo
Configuring data drilling
To enable operators to open the detailed device list of each category by clicking each bar in the report, perform the following task:
1. Configure the chart data as follows: a. Double-click the chart. b. On the Chart Data Configuration page, click Hyperlink for $F{category_name} next to
Series
25
Figure 38 Selecting the hyperlink c. On the Hyperlink definition page, select Self for Link Target and ReportExecution for
Link Type
Figure 39 Configuring the hyperlink d. In the Parameters field, click the icon to add the following parameters as shown in
−
Add the cName parameter and from Recent Expressions on the Expression Editor page, select the parameter expression $F{category_name} .
−
Add the operator parameter and from Parameters on the Expression Editor page, select the parameter expression $P{operator} . e. Click Finish .
26
Figure 40 Adding parameters f. For other parameters on the Hyperlink definition page, use the default settings.
2. Click OK .
The Chart Data Configuration page appears.
3. Next to Dataset, click Parameter .
The Dataset Parameters page appears.
4. Add the parameter operator and expression $P{operator}
as shown in Figure 41 and then
click Finish .
27
Figure 41 Configuring the operator parameter
5. On the Chart Data Configuration page, click Finish .
6. Before you add a table, add a new dataset for the table as follows: a. In the Outline area, right-click the report name and then select Create Dataset . b. Configure the name of the dataset.
This example uses Dataset4Table . c. Click Next . d. Keep the default setting on the page and then click Finish . e. In the Outline area, under Dataset4Table , right-click Parameters and then select Create
Parameter . f. Create parameters cName and operator . (Details not shown.) g. In the Outline area, right-click Dataset4Table and then select Dataset and Query . h. On the page that appears, enter an SQL statement for data drilling. i. Click Read Fields . j. Click OK .
28
Figure 42 Creating a dataset
7. Drag the table element to the Main Report area.
8. On the page that appears, select Create a Table using an existing dataset and
Dataset4Table and then click Next
29
Figure 43 Selecting a dataset
9. On the Connection page, use the default settings and then click Next .
Figure 44 Connection configuration
10. On the page for configuring table columns, do not select any fields and then click Next as
30
Figure 45 Column configuration
11. On the page for configuring the table layout, clear all options and then click Finish as shown in
31
Figure 46 Layout configuration
12. Adjust the table size.
13. Select Create Column At The End to insert a column to the table.
14. To add the other three columns, repeat step 13.
Figure 47 Adding a column
32
15. In the Outline area, select Column1 and Column2 , right-click the columns, and then select
Group Columns
Column 1 and Column 2 are grouped into Column [2].
Figure 48 Grouping columns
16. Right-click Column [2] and then select Create Cell
33
Figure 49 Creating a cell
17. Group Column 3 and Column 4 in the same way that Column 1 and Column 2 are grouped.
Then create a cell for the new column.
18. In the Outline area, under Dataset4Table , right-click Parameters and then select Create
Parameter .
19. Modify the parameter name to operator .
Use default properties of the parameter.
20. Add the cName parameter in the same way the operator parameter is added.
21. In the Outline area, under Dataset4Table , right-click Variables and then select Create
Variable .
22.
Configure the following parameters for the variable as shown in Figure 50 :
a. In the Name field, enter the variable name row_num . b. From the Value Class Name list, select java.lang.Integer
. c. From the Calculation list, select Count . d. In the Expression field, enter $F{device_ip} . e. From the Increment type list, select None . f. From the Reset type list, select Report . g. For other parameters, use default settings.
34
Figure 50 Creating a variable
23. Edit the table and then drag the Text Field element to the table.
24. Edit each text field in the same way the report title is edited.
For more information about editing the report title, see " Adding the report title ."
Figure 51 Editing the table
25. To open the Main Report page, click Main Report and configure parameters that the main report passes to the table.
26. In the Outline area, select Table .
35
Figure 52 Selecting the table
27. In the Properties area, on the Dataset tab, click Parameters .
Figure 53 Configuring the table properties
28. Add parameters cName and operator and their expressions.
36
Figure 54 Adding parameters
29. Click Finish .
The report data drilling configuration is finished. Data drilling does not support preview.
37
Adding the report template to IMC
1. Log in to IMC.
2. Click the Report tab and from the navigation tree, select Report > Add Report Template .
The Add Report Template page appears.
Figure 55 Add Report Template page
3. Next to the Template File field, click Upload .
The Upload Template page appears.
Figure 56 Uploading the template
4. In the Template File area, click Choose File to upload the template file
DeviceStatistics.jrxml
.
38
Figure 57 Selecting the template file
5. Click Open .
The template file has been selected.
Figure 58 Selecting the report template file
6. In the Parameter File area, click Choose File to upload a parameter file. The parameter file is required only when template parameters are configured.
39
Figure 59 Selecting a parameter file
The parameter file contains parameters that you want the operator to configure before using the template to generate a report.
For example, to require the operator to specify a statistics time range before generating a report, customize the parameter settings, and then upload the file to IMC. The parameter file content is below.
Figure 60 Parameter file content
When an operator intends to generate a report based on the selected template, IMC displays the Set Parameter page.
40
Figure 61 Set Parameter page
7. Click OK .
IMC verifies the uploaded files and then closes the Upload Template page.
Figure 62 Uploading and verifying the report template
If the verification fails, the failure reason appears on the Upload Template page.
41
Figure 63 File verification failure
If the verification succeeds, the system returns to the Add Report Template page.
Figure 64 Add Report Template page
8. On the Add Report Template page, configure other parameters. a. Select the data source for the report template from the Report Data Source List . This example uses the default value Local(127.0.0.1) . b. In the Template Name field, enter a name. This example uses Device Statistics V2 . c. From the Type list, select a report template type. This example uses Resource Statistics
Report . d. Select the operator group(s) that can view the report template.
42
Figure 65 Adding the report template
9. Click OK .
The operation success message appears.
Figure 66 Operation success message
43
Verifying the configuration
1. From the top navigation bar, select Report > Report Template List .
Figure 67 Accessing the report template list
Figure 68 Report template list
2. On the report template list, click Device Statistics V2 .
The report page appears.
44
Figure 69 Viewing the report
3. Click a bar to view details.
Figure 70 Viewing detailed information
45
Using JavaBean data source
When IMC platform runs IMC PLAT 7.1 (E0303P10) or later, iAR V2 can use the JavaBean data source to connect to the IMC database and get data.
Writing and importing JavaBean data source codes
1. Write a data source entity class and a data source provider class in Eclipse.
The data source entity class is similar with a line of records. The data source provider class must inherit from net.sf.jasperreports.engine.data.JRAbstractBeanDataSourceProvider
.
The following attachment provides sample codes of the data source entity class and provider class:
2. Import the data source codes to a .jar file.
3. In the Project Explorer area, right-click the report project and select Build Path > Configure
Build Path .
4. Click Add External JARs and then import the JAR file.
Figure 71 Importing the JAR file
5. Click OK .
46
6. Right-click the report project and then select New > Data Adapter .
Figure 72 Creating the data adapter
7. Configure the name of the data adapter and then click Next .
8. Select JasperReports DataSource Provider Class and then click Next .
9. In the JasperReports DataSource Provider Class Name field, select the JAR file that has been imported.
10. To test the availability of the JAR file, click Test .
Figure 73 Testing the availability of the JAR file
11. Confirm the test result and click Finish .
47
Configuring the JavaBean data source
To ensure that IMC can correctly generate reports, configure the JavaBean data source:
1. Configure the providerClassName property: a. In the Outline area, click the report name. b. In the Properties area, click the Advanced tab and then click the icon next to the
Properties parameter. c. On the Properties page, click Add . d. On the Properties Dialog page, enter the property name providerClassName and its value. Then click OK .
Figure 74 Configuring the providerClassName property e. Click Finish .
2. For each data source provider class, change its inherited class net.sf.jasperreports.engine.data.JRAbstractBeanDataSourceProvider
to the com.h3c.imc.rptviewer.data.provider.CustomJRAbstractBeanDataSourceProvider
class.
The create method parameter for the com.h3c.imc.rptviewer.data.provider.CustomJRAbstractBeanDataSourceProvider
class is Map<String,Object> parameters . Each component gets parameter names from the map.
The com.h3c.imc.rptviewer.data.provider.CustomJRAbstractBeanDataSourceProvider class is stored in the following JAR file:
3. Preview the report. (Details not shown.)
48
Guidelines for using JavaBean data source report configuration files
•
Reports that use the JavaBean data source support the JRXML and JASPER formats.
Predefined reports only use template files in JASPER format.
•
Store all JASPER files and .properties files that are used by JASPER files to the directory
/client/web/apps/imc/reportsV2/en/component name of the IMC installation path.
•
Store the JAR file for the JavaBean classes to the directory
/client/web/apps/rptviewer/WEB-INF/lib of the IMC installation path.
•
The configuration rules for configuration files ( component ID_report.xml
and component
ID_update.xml
) of all components remain unchanged. Store these configuration files in the directory /client/web/apps/imc/reportsV2/en of the IMC installation path and use the report name format component ID_report_en.xml . The reportName property of a new report must be different than old reports.
•
In the deployment file depoy.xml
, perform the following tasks:
Modify the following parameters:
−
Parameters install_report_template_flag and update_report_template_flag in the tbl_sys_para table.
−
Parameters rptviewer_install_report_template_flag and rptviewer_update_report_template_flag in the new report engine.
Insert the installation, delete and update information to the reportplat_db.reportplat.TBL_INSTALL_UPDATE table.
Insert information to the table reportplat_db.reportplat.TBL_RPTVIEWER_INSTALL_UPDATE.
49
About HPE IMC documents
The following are the documents available for Hewlett Packard Enterprise IMC:
Documents Purpose
Hardware specifications and installation
HPE IMC Getting Started Guide Quickly guides you through the IMC main features and troubleshooting common problems.
HPE IMC Centralized Deployment Guide with Embedded Database
Provides a complete guide to IMC platform and components installation and centralized deployment using embedded database.
HPE IMC Centralized Deployment Guide with Local Database
HPE IMC Centralized Deployment Guide with Remote Database
Provides a complete guide to IMC platform and components installation and centralized deployment using local database.
Provides a complete guide to IMC platform and components installation and centralized deployment using remote database.
HPE IMC Distributed Deployment Guide with
Local Database
Provides a complete guide to IMC platform and components installation and distributed deployment using local database.
HPE IMC Distributed Deployment Guide with
Remote Database
Provides a complete guide to IMC platform and components installation and distributed deployment using remote database.
HPE IMC Probe Installation Guide Provides a complete guide to IMC Probe installation and deployment.
HPE IMC RSM Installation Guide
Provides a complete guide to IMC RSM installation and deployment.
Provides a complete guide to IMC iHATool installation.
Guides you through installing SQL Server 2008 for IMC.
HPE IMC iHATool Installation Guide
SQL Server 2008 Installation and
Configuration Guide
SQL Server 2008 R2 Installation and
Configuration Guide
SQL Server 2012 Installation and
Configuration Guide
SQL Server 2014 Installation and
Configuration Guide
Oracle 11g Installation and Configuration
Guide(for Linux)
Guides you through installing SQL Server 2008 R2 for IMC.
Guides you through installing SQL Server 2012 for IMC.
Guides you through installing SQL Server 2014 for IMC.
Guides you through installing Oracle 11g on Linux for IMC.
Oracle 11g R2 Installation and Configuration
Guide(for Linux)
Oracle 12c Installation and Configuration
Guide(for Linux)
Guides you through installing Oracle 11g R2 on Linux for
IMC.
Guides you through installing Oracle 12c on Linux for IMC.
MySQL 5.5 Installation and Configuration
Guide (for Linux)
Guides you through installing MySQL 5.5 on Linux for IMC.
MySQL 5.5 Installation and Configuration
Guide (for Windows)
MySQL 5.6 Installation and Configuration
Guide (for Linux)
Guides you through installing MySQL 5.5 on Windows for
IMC.
Guides you through installing MySQL 5.6 on Linux for IMC.
50
Documents Purpose
MySQL 5.6 Installation and Configuration
Guide (for Windows)
Red Hat Enterprise Linux 6.4 Installation
Guide
Guides you through installing MySQL 5.6 on Windows for
IMC.
Guides you through installing Red Hat Enterprise Linux 6.4 for IMC.
Red Hat Enterprise Linux 7.0 Installation
Guide
Software configuration
HPE IMC Enterprise and Standard Platform
Administrator Guide
HPE IMC Quality of Service Manager
Administrator Guide
HPE IMC Resource Automation Manager
Administrator Guide
HPE IMC Service Health Manager
Administrator Guide
HPE IMC VAN Connection Manager
Administrator Guide
Guides you through installing Red Hat Enterprise Linux 7.0 for IMC.
Describes operation procedures on the IMC platform.
Describes operation procedures on the IMC Quality of
Service Manager.
Describes operation procedures on the Resource
Automation Manager.
Describes operation procedures on the Service Health
Manager.
Describes operation procedures on the IMC VAN
Connection Manager.
HPE IMC VAN Software Defined Network
Manager Administrator Guide
Describes operation procedures on the IMC VAN Software
Defined Network Manager.
HPE IMC VAN Fabric Manager Administrator
Guide
Describes operation procedures on the IMC VAN Fabric
Manager.
HPE IMC Application Manager Administrator
Guide
Describes operation procedures on the IMC Application
Manager.
HPE IMC Branch Intelligent Management
System Administrator Guide
HPE IMC Business Service Performance
Administrator Guide
Describes operation procedures on the IMC Branch
Intelligent Management System.
Describes operation procedures on the IMC Business
Service Performance.
HPE IMC IPsec VPN Manager Administrator
Guide
Describes operation procedures on the IMC IPsec VPN
Manager.
HPE IMC MPLS VPN Manager Administrator
Guide
Describes operation procedures on the IMC MPLS VPN
Manager.
HPE IMC Network Traffic Analyzer
Administrator Guide
HPE IMC Service Operation Manager
Administrator Guide
HPE IMC User Behavior Auditor
Administrator Guide
Describes operation procedures on the IMC Network Traffic
Analyzer.
Describes operation procedures on the IMC Service
Operation Manager.
Describes operation procedures on the IMC User Behavior
Auditor.
HPE IMC UC Health Manager Admin Guide Describes operation procedures on the IMC UC Health
Manager.
HPE IMC Wireless Service Manager
Administrator Guide
Describes operation procedures on the IMC Wireless
Service Manager.
HPE IMC User Access Manager
Administrator Guide
Describes operation procedures on the IMC User Access
Manager.
HPE IMC TACACS+ Authentication Manager
Administrator Guide
Describes operation procedures on the IMC TACACS+
Authentication Manager.
51
Documents Purpose
HPE IMC EAD Security Policy Administrator
Guide
Online Help
Operations and maintenance
Readme
Describes operation procedures on the IMC EAD Security
Policy Manager.
Helps you properly use IMC.
Provides most recent IMC release information.
52
Document conventions
This section describes the conventions used in the documentation.
Port numbering in examples
The port numbers in this document are for illustration only and might be unavailable on your device.
Command conventions
Convention
Boldface
Italic
#
GUI conventions
Description
Bold text represents commands and keywords that you enter literally as shown.
Italic text represents arguments that you replace with actual values.
A line that starts with a pound (#) sign is comments.
Convention
Boldface
Description
Window names, button names, field names, and menu items are in Boldface. For example, the New User window appears; click OK .
Multi-level menus are separated by angle brackets. For example, File > Create >
Folder .
Symbols
>
Convention
WARNING!
CAUTION:
Description
An alert that calls attention to important information that if not understood or followed can result in personal injury.
An alert that calls attention to important information that if not understood or followed can result in data loss, data corruption, or damage to hardware or software.
IMPORTANT:
An alert that calls attention to essential information.
NOTE: An alert that contains additional or supplementary information.
TIP:
An alert that provides helpful information.
53
Support and other resources
Accessing Hewlett Packard Enterprise Support
•
For live assistance, go to the Contact Hewlett Packard Enterprise Worldwide website: www.hpe.com/assistance
•
To access documentation and support services, go to the Hewlett Packard Enterprise Support
Center website: www.hpe.com/support/hpesc
Information to collect
•
Technical support registration number (if applicable)
•
Product name, model or version, and serial number
•
Operating system name and version
•
Firmware version
•
Error messages
•
Product-specific reports and logs
•
Add-on products or components
•
Third-party products or components
Accessing updates
•
Some software products provide a mechanism for accessing software updates through the product interface. Review your product documentation to identify the recommended software update method.
•
To download product updates, go to either of the following:
Hewlett Packard Enterprise Support Center Get connected with updates page: www.hpe.com/support/e-updates
Software Depot website: www.hpe.com/support/softwaredepot
•
To view and update your entitlements, and to link your contracts, Care Packs, and warranties with your profile, go to the Hewlett Packard Enterprise Support Center More Information on
Access to Support Materials page: www.hpe.com/support/AccessToSupportMaterials
IMPORTANT:
Access to some updates might require product entitlement when accessed through the
Hewlett Packard Enterprise Support Center. You must have an HP Passport set up with relevant entitlements.
54
Websites
Website Link
Networking websites
Hewlett Packard Enterprise Networking Information Library www.hpe.com/networking/resourcefinder
Hewlett Packard Enterprise Networking website
Hewlett Packard Enterprise Networking My Support
General websites
Hewlett Packard Enterprise Information Library www.hpe.com/info/networking www.hpe.com/networking/support www.hpe.com/info/enterprise/docs
Hewlett Packard Enterprise Support Center
Contact Hewlett Packard Enterprise Worldwide
Subscription Service/Support Alerts
Software Depot
Customer Self Repair (not applicable to all devices)
Insight Remote Support (not applicable to all devices) www.hpe.com/support/hpesc www.hpe.com/assistance www.hpe.com/support/e-updates www.hpe.com/support/softwaredepot www.hpe.com/support/selfrepair www.hpe.com/info/insightremotesupport/docs
Customer self repair
Hewlett Packard Enterprise customer self repair (CSR) programs allow you to repair your product. If a CSR part needs to be replaced, it will be shipped directly to you so that you can install it at your convenience. Some parts do not qualify for CSR. Your Hewlett Packard Enterprise authorized service provider will determine whether a repair can be accomplished by CSR.
For more information about CSR, contact your local service provider or go to the CSR website: www.hpe.com/support/selfrepair
Remote support
Remote support is available with supported devices as part of your warranty, Care Pack Service, or contractual support agreement. It provides intelligent event diagnosis, and automatic, secure submission of hardware event notifications to Hewlett Packard Enterprise, which will initiate a fast and accurate resolution based on your product’s service level. Hewlett Packard Enterprise strongly recommends that you register your device for remote support.
For more information and device support details, go to the following website: www.hpe.com/info/insightremotesupport/docs
Documentation feedback
Hewlett Packard Enterprise is committed to providing documentation that meets your needs. To help us improve the documentation, send any errors, suggestions, or comments to Documentation
Feedback ( [email protected]
). When submitting your feedback, include the document title, part number, edition, and publication date located on the front cover of the document. For online help content, include the product name, product version, help edition, and publication date located on the legal notices page.
55
Download
Advertisement