Section 4. MCUez Environment. Freescale Semiconductor MCUEZINS
Reklama
Reklama
Freescale Semiconductor, Inc.
User’s Manual — MCUez Installation and Configuration
Section 4. MCUez Environment
4.1 Contents
Setting Path Parameters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
Configuring WinEdit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
Configuring WINEDIT.INI. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35
Storing and Restoring Configuration Files . . . . . . . . . . . . . . . . . . 35
WinEdit Menu Selection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35
WinEdit Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
Configuring Codewright . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
Switching Configurations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
Codewright Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38
Codewright Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38
Configuring Motpad . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
Configuring Notepad . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40
Configuring Wordpad . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41
Configuring Word. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42
MCUez Installation and Configuration
MOTOROLA MCUez Environment
For More Information On This Product,
Go to: www.freescale.com
User’s Manual
31
MCUez Environment
Freescale Semiconductor, Inc.
4.2 Introduction
The MCUez Shell is used to define the MCUez project environment.
Parameters for the environment are stored in the default.env and project.ini files. This section describes how to edit the default.env file parameters and manually configure various editors, such as WinEdit and Codewright.
NOTE: The Make command is used only when the C compiler has been installed. If the
C compiler has not been installed, the assembler will be invoked and the Make command will be inactive.
4.3 Setting Path Parameters
Various parameters of the MCUez environment are set by environment variables. No blanks are allowed in an environment variable definition. The syntax is:
KeyName=ParameterDefinition
Example:
GENPATH=D:\PROJECTS\TESTS
Methods of defining parameters:
• Use system environment variables supported by the operating system.
• Put definitions in a file called default.env in the default directory.
• Put definitions in the file specified in the system environment variable named ENVIRONMENT .
The default directory can be set with the DEFAULTDIR system environment variable. When searching for an environment variable, all MCUez programs search the system environment, then the default.env file, and finally the global environment file given by ENVIRONMENT . If no definition is found, a default value is assigned.
User’s Manual
32
MCUez Installation and Configuration
MOTOROLA MCUez Environment
For More Information On This Product,
Go to: www.freescale.com
Freescale Semiconductor, Inc.
MCUez Environment
Configuring WinEdit
4.3.1 Paths
Most environment variables contain path lists that indicate where to look for files. A path list is a list of directory names separated by semicolons or a directory name preceeded by an asterick and follows this syntax:
DirSpec;DirSpec
*DirectoryName
Example:
GENPATH=C:\PROJECTS\TESTS;D:\PROJECTS\TESTS
GENPATH=*C:\PROJECTS\TESTS
If a directory name is preceded by an asterisk (*), the MCUez program recursively searches the directory tree for a file, not just the given directory.
Directories are searched in the order they appear in the path list.
NOTE: When using WinEdit or Codewright, if the system environment variable
DEFAULTDIR is set, ensure that this variable is assigned the project directory specified in the WinEdit or Codewright project configuration. If the specified directories differ, files may be placed in the wrong directory. This could affect proper execution of the MCUez application.
4.4 Configuring WinEdit
Follow these steps to configure WinEdit. The MCUez Shell automatically creates the editor project file required by WinEdit.
1.
Click the ezMCU icon on the toolbar to start the MCUez Shell.
2.
Click the Change... button in the Configuration dialog box to open the
Current Configuration dialog box.
3.
Select the Editor tab and select WinEdit from the Editor drop down box.
4.
In the Project File edit box, enter a name for the WinEdit project file.
WinEdit project files have a .wpj extension. Do not specify a path in front of the filename.
5.
In the Executable edit box, enter the WinEdit executable file, including path. Use the Browse button to search for the executable file, if necessary.
MCUez Installation and Configuration
MOTOROLA MCUez Environment
For More Information On This Product,
Go to: www.freescale.com
User’s Manual
33
MCUez Environment
Freescale Semiconductor, Inc.
6.
The Options edit box contains options used for error feedback in the
MCUez assembler and linker. After selecting WinEdit, the shell automatically enters the appropriate options.
NOTE: WinEdit version 3.1 or lower cannot be started with a line number (%l) as a parameter. For older versions of WinEdit, options should be changed to %f only.
User’s Manual
34
Figure 4-1. Editor Configuration for WinEdit
7.
Select the Tools tab.
8.
Some tools specified here are automatically associated with WinEdit commands (menu entries and buttons).
ASSEMBLER is automatically associated with the WinEdit
Compile command.
MAKER is associated with the WinEdit Make command.
LINKER is associated with the WinEdit Rebuild command.
DEBUGGER is associated with the WinEdit Debug command.
DECODER is associated with the WinEdit Execute command.
MCUez Installation and Configuration
MOTOROLA MCUez Environment
For More Information On This Product,
Go to: www.freescale.com
Freescale Semiconductor, Inc.
MCUez Environment
Configuring WinEdit
9.
Click OK to close the Current Configuration dialog.
10.
The specified editor project file is created in the project directory and the associated icon is displayed in the MCUez toolbar.
4.4.1 Configuring WINEDIT.INI
WinEdit looks for a file named EDOUT to retrieve information about errors or warnings detected during assembly, linking, or debugging. To ensure that the appropriate file is used, initialize the OUTPUT variable in the WinEdit section of the winedit.ini file:
[WinEdit]
...
OUTPUT=.\EDOUT
4.4.2 Storing and Restoring Configuration Files
After starting WinEdit, select Configure... from the Project menu to open the
Project Management dialog box.
• Select Save... to save the current configuration.
• Select Open... to load a previously saved configuration.
NOTE: Each time the working directory is changed, WinEdit must be closed and restarted.
4.4.3 WinEdit Menu Selection
Select Project | Compile to execute the tool specified in the Compile command line. The MCUez Shell automatically links the MCUez assembler program to this entry.
Select Project | Make to execute the tool specified in the Make command line.
The MCUez Shell automatically links the maker program to this entry.
Select Project | Rebuild to execute the tool specified in the Rebuild command line. The MCUez Shell automatically links the MCUez linker program to this entry.
MCUez Installation and Configuration
MOTOROLA MCUez Environment
For More Information On This Product,
Go to: www.freescale.com
User’s Manual
35
MCUez Environment
Freescale Semiconductor, Inc.
Select Project | Debug to start the tool specified in the Debug command line.
The shell automatically links the MCUez debugger program to this entry.
Select Project | Execute to start the tool specified in the Execute command line. The shell automatically links the program associated with the Decoder tool to this entry.
4.4.4 WinEdit Toolbar
Figure 4-2 shows the association between the command lines in the Project
Configuration dialog and buttons in the toolbar.
COMPILE
COMMAND
MAKE
COMMAND
REBUILD
COMMAND
DEBUG
COMMAND
EXECUTE
COMMAND
Figure 4-2. WinEdit Toolbar
4.5 Configuring Codewright
Follow these steps to configure Codewright. The MCUez Shell automatically creates the project file required by Codewright.
1.
Click the ezMCU icon on the toolbar to start the MCUez Shell.
2.
Click the Change... button in the Configuration dialog box to open the
Current Configuration dialog box.
3.
Select the Editor tab and select Codewright from the Editor drop down box.
4.
In the Project File edit box, enter a name for the Codewright project file.
Usually, Codewright project files have a .pjt extension. Do not specify a path in front of the filename.
5.
In the Executable edit box, enter the Codewright executable file, including path. Use the Browse button to search for the executable file, if necessary.
User’s Manual
36
MCUez Installation and Configuration
MOTOROLA MCUez Environment
For More Information On This Product,
Go to: www.freescale.com
Freescale Semiconductor, Inc.
MCUez Environment
Configuring Codewright
6.
The Options edit box contains options used for error feedback in the
MCUez assembler and linker. After selecting Codewright, the shell automatically enters the appropriate options.
is a typical setup for Codewright.
Figure 4-3. Editor Configuration for Codewright
7.
Select the Tools tab.
8.
Some tools specified here are automatically associated with Codewright commands, such as menu entries and buttons.
ASSEMBLER is automatically associated with the Codewright
Compile and Debug Compile commands.
MAKER is associated with the Codewright Make command.
LINKER is associated with the Codewright Rebuild command.
DEBUGGER is associated with the Codewright Debug command.
DECODER is associated with the Codewright Execute command.
9.
Click OK to close the Current Configuration dialog.
10.
The specified editor project file is created in the project directory and the associated icon is displayed in the MCUez toolbar.
4.5.1 Switching Configurations
Select Project | Open to load a previously saved project configuration file.
MCUez Installation and Configuration
MOTOROLA MCUez Environment
For More Information On This Product,
Go to: www.freescale.com
User’s Manual
37
MCUez Environment
Freescale Semiconductor, Inc.
4.5.2 Codewright Menu
Select Utility | Compile to execute the tool specified in the Compile command line. The MCUez Shell automatically links the MCUez assembler program to this entry.
Select Utility | Compile(Debug) to start the tool specified in the Debug
Compile command line. The shell automatically links the assembler program to this entry.
Select Utility | Make to start the tool specified in the Make command line. The shell automatically links the maker program to this entry.
Select Utility | Rebuild to start the tool specified in the Rebuild command line. The shell automatically links the MCUez linker program to this entry.
Select Utility | Debug to start the tool specified in the Debug command line.
The shell automatically links the MCUez debugger program to this entry.
Select Utility | Execute to start the tool specified in the Execute command line. The shell automatically links the decoder program to this entry.
4.5.3 Codewright Toolbar
Figure 4-4 illustrates the toolbar functions.
COMPILE
COMMAND
MAKE
COMMAND
DEBUG
COMMAND
Figure 4-4. Codewright Toolbar
EXECUTE
COMMAND
User’s Manual
38
MCUez Installation and Configuration
MOTOROLA MCUez Environment
For More Information On This Product,
Go to: www.freescale.com
Freescale Semiconductor, Inc.
MCUez Environment
Configuring Motpad
4.6 Configuring Motpad
Motpad is the default editor. However, if another editor has been defined as the default, redefine Motpad as follows:
1.
Click the ezMCU icon on the toolbar to start the MCUez Shell.
2.
Click the Change... button in the Configuration dialog box to open the
Current Configuration dialog box.
3.
Select the Editor tab and select Motpad from the Editor drop down box.
4.
In the Executable edit box, enter the Motpad executable file, including path. Use the Browse button to search for the executable file, if necessary.
5.
The Options edit box contains options used for error feedback in the
MCUez assembler and linker. After Motpad is selected, the shell automatically enters the appropriate options.
shows a typical
Motpad configuration.
Figure 4-5. Editor Configuration for Motpad
MCUez Installation and Configuration
MOTOROLA MCUez Environment
For More Information On This Product,
Go to: www.freescale.com
User’s Manual
39
MCUez Environment
Freescale Semiconductor, Inc.
6.
Click OK to close the dialog.
7.
Motpad is set as the default project editor and the associated icon is displayed in the MCUez toolbar.
4.7 Configuring Notepad
To define Notepad as the project editor:
1.
Start the MCUez Shell.
2.
Click the ezMCU icon in the toolbar to open the Configuration dialog box.
3.
Select the Change... button in the Configuration dialog box to open the
Current Configuration dialog box.
4.
Select the Editor tab and select Notepad from the Editor drop down box.
5.
In the Executable edit box, enter the Notepad executable file, including path. Use the Browse button to search for the executable file, if necessary.
6.
The Options edit box contains options used for error feedback in the
MCUez assembler and linker. After selecting Notepad, the shell automatically enters the appropriate options.
shows a typical
Notepad configuration.
User’s Manual
40
Figure 4-6. Editor Configuration for Notepad
7.
Click OK to close the dialog.
8.
Notepad is set as the default project editor and the associated icon is displayed in the MCUez toolbar.
MCUez Installation and Configuration
MOTOROLA MCUez Environment
For More Information On This Product,
Go to: www.freescale.com
Freescale Semiconductor, Inc.
MCUez Environment
Configuring Wordpad
4.8 Configuring Wordpad
The MCUez assembler and linker cannot process input files containing
Wordpad format information. Save all source files as ASCII text files.
To define Wordpad as the project editor:
1.
Start the MCUez Shell.
2.
Click on the ezMCU icon in the toolbar to open the Configuration dialog box.
3.
Select the Change... button in the Configuration dialog box to open the
Current Configuration dialog box.
4.
Select the Editor tab and select Wordpad from the Editor drop down box.
5.
In the Executable edit box, enter the Wordpad executable file, including path. Use the Browse button to search for the executable file, if necessary.
6.
The Options edit box contains options used for error feedback in the
MCUez assembler and linker. After selecting Wordpad, the shell automatically enters the appropriate options.
shows a typical
Wordpad configuration.
Figure 4-7. Editor Configuration for Wordpad
7.
Click OK to close the dialog.
8.
Wordpad is set as the default project editor and the associated icon is displayed in the MCUez toolbar.
MCUez Installation and Configuration
MOTOROLA MCUez Environment
For More Information On This Product,
Go to: www.freescale.com
User’s Manual
41
MCUez Environment
Freescale Semiconductor, Inc.
4.9 Configuring Word
The MCUez assembler and linker cannot process input files containing Word format information. Save all source files as ASCII text files.
To define Microsoft Word as the project editor:
1.
Start the MCUez Shell.
2.
Click on the ezMCU icon in the toolbar to open the Configuration dialog box.
3.
Select the Change... button in the Configuration dialog box to open the
Current Configuration dialog box.
4.
Select the Editor tab and select Word from the Editor drop down box.
5.
In the Executable edit box, enter the Word executable file, including path. Use the Browse button to search for the executable file, if necessary.
6.
The Options edit box contains options used for error feedback in the
MCUez assembler and linker. After selecting Word, the shell automatically enters the appropriate options.
shows a typical
Word configuration.
User’s Manual
42
Figure 4-8. Editor Configuration for Word
7.
Click OK to close the dialog.
8.
Word is set as the default project editor and the associated icon is displayed in the MCUez toolbar.
MCUez Installation and Configuration
MOTOROLA MCUez Environment
For More Information On This Product,
Go to: www.freescale.com
Freescale Semiconductor, Inc.
For More Information On This Product,
Go to: www.freescale.com
Freescale Semiconductor, Inc.
For More Information On This Product,
Go to: www.freescale.com
Atsisiųsti
Reklama