Diagnostics. Schneider Electric Premium using EcoStruxure™ Control Expert - TSXETC100 EtherNet/IP Communication Module
Publicitate
Publicitate
Premium using EcoStruxure™ Control Expert
Diagnostics
31008211 09/2020
Diagnostics Chapter 7
Diagnostics
Overview
This chapter describes the diagnostic features of the EtherNet/IP communication module and the
Control Expert EtherNet/IP configuration software.
What Is in This Chapter?
This chapter contains the following sections:
Section
7.1
7.2
7.3
Topic
LED Indicators
Diagnostic Testing Using Control Expert
Diagnostic Testing Using the Control Expert EtherNet/IP Configuration Tool
Page
31008211 09/2020
195
Diagnostics
LED Indicators Section 7.1
LED Indicators
LED Indicators for the TSX ETC 100 Module
LED Indicators
The TSX ETC 100 displays the following LED indicators:
LED Descriptions
Use the LED display to diagnose the state of the module, as follows:
LED
RUN
ERR
Color
Green
Red
Description
Off: Indicates that the module is not communicating with the CPU over the backplane.
Steady Green: Indicates that the module is communicating with the
CPU over the backplane.
Off:
Power is not being supplied to the module.
The module is running a self test.
The module is ready to start operating.
Steady Red:
The module is not operational.
A software operation error has occurred, causing a re-initialization.
Flashing Red: The module is not configured or is being configured.
196
31008211 09/2020
Diagnostics
LED
STS
Color Description
Yellow
Off:
Power is not being supplied to the module.
The module is not ready to start operating.
The module is ready to start operating.
Steady Yellow:
The module is running a self test.
A software operation error has occurred causing a re-initialization.
The module is configured and operational.
Red
Steady or Flashing Yellow The module is not configured or is being configured.
The STS LED also provides diagnostic information by using the following sequence of flashes.
Two flashes: The module does not have a MAC address.
Three flashes: The Ethernet link is not connected.
Four flashes: The module has detected a duplicate IP address.
Five flashes: The module is configured as a BOOTP client and is waiting for a BOOTP server response.
Six flashes: The module is using its default IP configuration (the module is not configured.)
Seven flashes: The module has detected a configuration error.
Note: If more then one of the above conditions is detected, the module will display the condition with the smaller flashing sequence.
Flashing Red: A collision has been detected on the Ethernet link.
COL
RX (Reception Activity) Yellow
Off: There is no reception activity.
Flashes Yellow: Indicates reception activity.
TX
(Transmission Activity)
Yellow
Off: There is no transmission activity.
Flashes Yellow: Indicates transmission activity.
Mod Status
(Module Status)
Net Status
(Network Status)
Green/
Red
Green/
Red
Off: Power is not being supplied to the module.
Steady Green: The module is operating normally.
Flashing Green: The module has not been configured.
Steady Red: The module has detected a major fault.
Flashing Red: The module has detected a recoverable fault.
Off: Power is not being supplied to the module or the module does not have an IP address assigned.
Steady Green: The module has established at least one CIP connection.
Flashing Green: The module has obtained an IP address but has not established any CIP connections.
Steady Red: The module has detected that its IP address is a duplicate IP address.
Flashing Red: One or more CIP connections has timed out and the connection(s) need to be re-established or the module has been reset.
31008211 09/2020
197
Diagnostics
Diagnostic Testing Using Control Expert Section 7.2
Diagnostic Testing Using Control Expert
Overview
This section describes the diagnostic tools available in the Control Expert software.
What Is in This Section?
This section contains the following topics:
Topic
Accessing the Control Expert Diagnostic Tools
Communication Channel Diagnostics in Control Expert
Communication Module Diagnostics in Control Expert
Page
198
31008211 09/2020
Diagnostics
Accessing the Control Expert Diagnostic Tools
Overview
The Control Expert software provides diagnostic tools that let you view the:
communication module status communication module’s:
faults
I/O objects
communication channel’s:
MAC Address
IP Address settings faults
These Control Expert diagnostic tools are available in the Premium EtherNet/IP Module properties window, only when Control Expert is operating online.
31008211 09/2020
199
Diagnostics
Accessing Control Expert Diagnostic Tools
To access diagnostic tools for the TSX ETC 100 EtherNet/IP module:
Step
1
Action
Open the Control Expert project backplane diagram, below:
2 Do one of the following:
double click the left mouse button on the TSX ETC 100 module in the
window above, or click the right mouse button on the TSX ETC 100 module, then select
Open Module... in the popup menu
The Premium EtherNet/IP Module window opens:
200
31008211 09/2020
Step
3
Action
Navigate the Premium EtherNet/IP Module window using the following features:
1 Module status icons These three indicators display the module’s status in online mode.
2 Channel area Select a node to display parameters for either:
the communication module, or a communication channel
3 Page tabs Select a page to display module or channel properties:
for the communication module:
Overview
Fault
I/O Objects
for a communication channel:
Configuration
Debug
Fault
4 General parameters View communication channel parameters:
Function displays the configured communication
function and is read-only.
Task displays the task (configured MAST) and is read-only.
5 Mode parameters Displays parameters for the mode you select by opening a page.
Diagnostics
31008211 09/2020
201
Diagnostics
Communication Channel Diagnostics in Control Expert
Overview
Select a communication channel in the Channel area to access the:
Configuration page, where you can:
edit the EtherNet/IP Module name
edit input and output data size and location settings launch the Control Expert EtherNet/IP configuration tool
Refer to the description of the Configuration page
Debug page, which displays the communication module’s:
MAC Address
IP Address settings
see page 21
for more information.
Fault page, which displays active faults for the communication channel
MAC Address
To display the MAC Address of the communication module:
Step
1
2
Action
In the Channel area, select the communication channel. The following pages are displayed:
Configuration
Debug
Default
To display the communication module’s MAC Address and IP Address settings, click on the Debug page:
202
31008211 09/2020
Channel Faults
To display the active faults on the communication channel:
Step
1
2
Action
In the Channel area, select the communication channel.
To display the communication module’s active faults, click on the Fault page:
Diagnostics
NOTE: You can also access the channel error bit (CH_ERROR) by using the Control Expert
Animation Table to display the %Ir.m.ch.ERR object.
31008211 09/2020
203
Diagnostics
Communication Module Diagnostics in Control Expert
Overview
Use the Premium EtherNet/IP Module window in Control Expert to diagnose the TSX ETC 100 module. In this window, you can access:
three icons that reflect the current status of selected LEDs the Overview page, where you can view a description of the module
Fault page, which displays active faults for the communication module
I/O Objects page, where you can view and manage I/O objects for the module
Module Status Icons
The Premium EtherNet/IP Module window displays three icons that reflect the current status of the following LEDs:
Run
ERR
STS
Refer to the description of LED indicators
icons.
see page 196
) for information on how to use these
204
31008211 09/2020
Accessing Module Faults
To display the active faults on the communication module:
Step
1
2
Action
In the Channel area, select the communication module. The following pages are displayed:
Overview
Fault
I/O Objects
To display the communication module’s active faults, click on the Fault page:
Diagnostics
NOTE: You can also access the module error bit by using the Control Expert Animation Table to display the %Ir.m.MOD.ERR object.
31008211 09/2020
205
Diagnostics
Managing I/O Objects
Use the I/O Objects page to view module I/O objects, and to manage the association of these objects with variables.
Open the I/O Objects page by selecting the I/O Objects tab, after the communication module has been selected in the Channel area:
206
NOTE:
The TSX ETC 100 EtherNet/IP communication module supports only Channel, System, and
Status I/O Objects. Not all bits are used.
Refer to the Control Expert help for instructions on how to use the I/O Objects page.
31008211 09/2020
Diagnostics
Reading I/O Objects
Use a READ_STS function block in Control Expert to update each of the following types of data:
module data channel data
Updating module data:
To display module information, follow these steps:
Step
1
Action
Configure the READ_STS function block, as follows:
2
Where: r = rack, or station, number m = module, or slot, number
MOD = a constant indicating module data
To view the data updated by the READ_STS function block, enter the corresponding direct addresses in the Control Expert Animation table, or use them in your program logic:
Object
%MWr.m.MOD.0
Description
Exchange Status:
Bit 0: reading of module status in progress
%MWr.m.MOD.1
%MWr.m.MOD.2
Exchange Report:
Bit 0: error while reading module status
Bit 0: internal fault
Bit 1: operational fault
Bit 2: not used
Bit 3: self test
Bit 4: not used
Bit 5: configuration fault
Bit 6: missing module or off
Bit 7: not used
31008211 09/2020
207
Diagnostics
Updating channel data:
To display channel information, follow these steps:
Step
1
Action
Configure the READ_STS function block, as follows:
2
Where: r = rack, or station, number m = module, or slot, number ch = channel number—always set to 0 for ETC transactions
To view the data updated by the READ_STS function block, enter the corresponding direct addresses in the Control Expert Animation table, or use them in your program logic:
Object
%MWr.m.ch.0
Description
Exchange Status (EXCH_STS):
Bit 0: reading of status words of the channel in progress
(STS_IN_PROG)
Bit 15: reconfiguration in progress (RECONF_IN_PROG)
%MWr.m.ch.1
%MWr.m.ch.2
Exchange Report (EXCH_RPT):
Bit 0: error while reading channel status (STS_ERR)
Bit 15: error while reconfiguring the channel
(RECONF_ERR)
Standard channel status (low byte):
Bits 0...3: reserved (0)
Bit 4: internal fault
Bit 5: configuration fault
Bit 6: X-Bus communication fault
Bit 7: application fault (conf fault)
High byte:
Bits 0...7: reserved (0)
208
31008211 09/2020
Step
2 cont’d
Action
%MWr.m.ch.3
%MWr.m.ch.4
Ethernet Port Global Status:
Bit 0: configuration error
Bit 1: the Ethernet interface is disabled
Bit 2: duplicate IP address detected
Bit 3: reserved
Bit 4: the Ethernet link is disconnected
Bit 5: the module is in the process of obtaining an IP address
Bits 6...15: reserved
IP address:
During normal operation, the double word %MDr.m.c.4 contains the IP address configured or served to the module.
In No Configuration state, the double word %MDr.m.c.4 contains the default IP address of the module.
In Configuration Error, the double word %MDr.m.c.4 contains the default IP address of the module.
When a duplicate IP address is detected, the double word %MDr.m.c.4 contains the served or configured duplicate IP address.
When the module is waiting for a BOOTP response, the double word %MDr.m.c.4 contains the IP address
0.0.0.0.
Diagnostics
31008211 09/2020
209
Diagnostics
Diagnostic Testing Using the Control Expert EtherNet/IP Configuration Tool Section 7.3
Diagnostic Testing Using the Control Expert EtherNet/IP
Configuration Tool
Overview
This section describes the diagnostic tools available in the Control Expert EtherNet/IP configuration tool.
What Is in This Section?
This section contains the following topics:
Topic
Diagnostic Testing Using the Control Expert EtherNet/IP Software
Ping a Network Device
Viewing Output Messages in the Control Expert EtherNet/IP Configuration Tool
Page
210
31008211 09/2020
Diagnostics
Diagnostic Testing Using the Control Expert EtherNet/IP Software
Overview
Use the Control Expert EtherNet/IP configuration tool to perform a diagnostic test of the
EtherNet/IP module and all other devices in your configuration.
NOTE: Diagnostic testing is performed directly between the Control Expert EtherNet/IP configuration tool software running on your PC and the target EtherNet/IP device.
The software displays the results of the diagnostic test, as follows:
the task bar’s Module State indicator reads Diagnostic the Devices window depicts the state of connections for each device using a:
green icon, indicating all connections are functioning red icon, indicating at least one connection has failed gray icon, indicating a rack optimized module connection
a diagnostic tab is added to the properties window for each EtherNet/IP device and I/O module displaying:
each connection’s status, information, and performance data, and the value of each input and output
31008211 09/2020
211
Diagnostics
Performing a Diagnostic Test
To perform a diagnostic test in the Control Expert EtherNet/IP software:
Step
1
2
Action
Do one of the following: click the Diagnostics toolbar button select Devices → Diagnostic...
, or
The configuration tool enters its diagnostic state.
The EtherNet/IP module enters a diagnostic state and displays the status of each connected device and module. An example of a diagnostic status display appears, below:
212
3
In the above example:
a green icon indicates that all connections are functioning for the device at address [001]
a red icon indicates at least one connection has failed for the device at address [002] red icons indicates that at least one connection has failed for the modules at slots [00] and
[01] a gray icon indicates a rack optimized connection, exists for the module at slot [02]
To exit diagnostic mode, repeat the command in step 2.
31008211 09/2020
Diagnostics
Ping a Network Device
Overview
Use the Control Expert EtherNet/IP configuration tool’s Ping function to send an ICMP echo request to a target EtherNet/IP device to determine:
if the target device is present, and if so the elapsed time to receive an echo response from the target device
The target device is identified by its IP address setting. The Control Expert EtherNet/IP configuration tool will verify that the target address is not a:
loopback address (127.000.000.000 to 127.255.255.255) multicast address (224.000.000.000 to 239.255.255.255) reserved address (240.000.000.000 to 255.255.255.255) broadcast address
The ping function can be performed from either the:
General page of a device’s properties window
Ping page of the Online Action window
Pinging a Network Device
To ping a network device:
Step
1
2
3
4
5
6
7
Action
Be sure the Control Expert EtherNet/IP configuration tool is operating online.
Do one of the following:
Select Network → Online Action, then click on the Ping page, or
Select a device in the Devices window, then select Devices → Properties
If you are working in the Ping page of the Online Action window, type in the IP Address of the target device.
Notes:
The default is the IP address of the device currently selected in the Network Detection list.
If you are working in the General page of a device’s Properties window, the Control Expert
EtherNet/IP configuration tool uses the IP address of the device selected in the Devices window.
To send...
a single ping, de-select the Loop checkbox
a series of pings—1 every 100 ms—select Loop
(Optional) Select Stop on Error to stop pinging if an error occurs.
Click Ping once to begin pinging.
Click Ping a second time to stop looped pinging, where no error has been detected.
31008211 09/2020
213
Diagnostics
Viewing Output Messages in the Control Expert EtherNet/IP Configuration Tool
Overview
Use the Control Expert EtherNet/IP configuration tool’s Output Message window to diagnose the health of your EtherNet/IP network. This window maintains a log of network events. You can:
show or hide the window display for each item in the window its:
date and time level of significance copy the contents of the Output Message window to your PC’s Windows Clipboard clear the contents of the window
Show/Hide the Output Message Window
The Output Message window is displayed in the Control Expert EtherNet/IP configuration tool by default. To hide the window, select: File → Preferences → Output Window.
To reopen the Output Message window, repeat the above command.
Add Date/Time and Level to Output Message Window Items
To show or hide the date and time, or level of significance for Output Message window entries:
Step
1
2
3
Action
Select File → Message View → Configuration. The Output Message View Configuration dialog opens.
Select—or de-select—either or both:
Add Date to Messages
Add Level to Messages
Click OK.
Copy/Clear
To copy the contents of the Output Message window to your PC’s Windows Clipboard, select:
File → Message View → Copy.
To clear the contents of the Output Message window select: File → Message View → Clear.
214
31008211 09/2020
Descarcă
Publicitate