Using Variable Manager. Casio fx-CG500
Pubblicità
Pubblicità
User folder: This is a folder created and named by you. You can make a user folder the current folder, move data to a user folder, etc. You can also delete and rename a user folder as required. You can have up to 87 user folders in main memory at one time.
Tip: You cannot put a folder inside of another folder.
Current Folder
The current folder is the folder where the data (excluding eActivity files) created by applications are stored and from which such data can be accessed. The initial default current folder is the “main” folder. You can also select a user folder you created as the current folder. For more information about how to do this, see “Variable
Manager operations” on page 30.
Using Variable Manager
Variable Manager is a tool for managing user variables, programs, user functions, and other types of data.
Though this section uses only the term “variables”, the explanations provided here also refer to the other types of data that can be managed by Variable Manager.
With Variable Manager you can:
• Create, delete, rename, lock, and unlock folders, and configure current folder settings.
• Delete, copy, rename, move, lock, unlock, search for variables, and view the contents of variables.
About Variable Types
A variable with a letter name like x and y can be a user-created user variable, a system variable, or a local variable.
• System variables are pre-defined reserved variables, and cannot be renamed. For the names of and detailed information about system variables, see the “System Variable Table” on page 299.
• A local variable is a variable that is temporarily created by a defining function, program, or other operation for a particular purpose. For more information about local variables, see the “Local” command under the “12-4
Program Command Reference”.
u To start up Variable Manager
1. While any application (except for the System application) is running, tap O and then tap
[Variable Manager].
• This displays the folder list. The folder list always appears first whenever you start up
Variable Manager.
Folder name
Number of variables contained in the folder
Folder list
2. Tap a folder name twice to open the folder contents; a variable list.
Folder name
Variable name
• To close the variable list and return to the folder list, tap [Close].
Number of variables contained in the folder
Data types (page 28) and sizes (bytes)
Variable list
3. To exit Variable Manager, tap [Close] on the folder list.
Chapter 1: Basics 29
u Variable Manager operations
The operations described in the table below can be performed while Variable Manager is displayed.
To do this: Do this:
Specify the current folder On the folder list, tap the [Current] down arrow button. On the list that appears, select the folder that you want to specify as the current folder.
Create a folder
Open a folder
On the folder list, tap [Edit] - [Create Folder]. On the dialog box that appears, enter the name you want to assign to the folder and then tap [OK].
On the folder list, tap the name of the folder you want to open so it is highlighted, and then tap it again.
Open the “library” folder
Delete a folder
Delete a variable
Tap [View] and then [“library” Folder]. This opens the “library” folder and displays a variable list showing its contents.
Select a folder or variable Select the check box next to the folder or variable name. To select all the folders or variables in the list, tap [All] and then [Select All].
Deselect a folder or variable
Clear the check box next to the folder or variable name. To deselect all the folders or variables in the list, tap [All] and then [Deselect All].
See “To delete a folder” (page 31).
Select the check box next to the variable you want to delete, and then tap [Edit]
- [Delete]. In response to the confirmation dialog box that appears, tap [OK] to delete the selected variable.
Rename a folder or variable
Lock a folder or variable
Highlight the folder or variable you want to rename and then tap [File] -
[Rename]. On the dialog box that appears, enter the name you want to assign to it and then tap [OK].
Select the check box next to the folder or variable you want to lock, and then tap [Edit] - [Lock]. This locks the currently selected folder or variable, and adds a b icon to the left of its name to indicate that it is locked.
Unlock a folder or variable Select the check box next to the folder or variable you want to unlock, and then tap [Edit] - [Unlock].
Display a list of a particular type of variable
On the variable list, tap [View] - [Variable Type]. On the dialog box that appears, tap the down arrow button and then select the data type from the list that appears and then tap [OK].
Copy or move a variable On the variable list, tap [Edit] and then [Copy] or [Move]. On the dialog box that appears, tap the down arrow button and then select the destination folder from the list that appears and then tap [OK].
Tip
• If a variable with the same name already exists in the destination folder, the variable in the destination folder is replaced with the one that you are copying or moving.
• A variable that is locked cannot be moved.
View the contents of a variable
On the variable list, tap the name of the variable whose contents you want to view so it is highlighted, and then tap it again. This displays a dialog box that shows the contents of the variable.
See “To input a folder name or variable name into an application” (page 31).
Input a folder name or variable name into an application
Search for a variable On the folder list, tap [Search]. On the dialog box that appears, enter the variable name you want to find and then tap [OK].
An exclamation point (!) appears in front of all folders containing a variable name that matches the name in your search.
Note: You can use the above procedure to search the “main” folder or a user defined folder for a particular variable name. Note that you cannot search the
“library” folder.
Chapter 1: Basics 30
Selecting a Folder
• If no check box is selected on the folder list, any folder operation that is performed affects the folder whose name is currently highlighted on the list. If any folder check box is selected, only that folder is affected by a folder operation, and the folder whose name is highlighted on the list is not affected.
• Selecting the check box of a folder causes the check boxes of all of the variables inside of it also to become selected.
• When renaming a folder, only the folder whose name is highlighted on the folder list is renamed. Other folders whose check boxes are selected are not affected.
Selecting a Variable
• If no check box is selected on the variable list, any variable operation that is performed affects the variable whose name is currently highlighted on the list. If any variable check box is selected, only that variable is affected by a variable operation, and the variable whose name is highlighted on the list is not affected.
• When renaming a variable, only the variable whose name is highlighted on the variable list is renamed. If other variables are selected (checked), they will not be affected.
Folder and Variable Name Rules
The following are the rules that apply to folder and variable names.
• Folder or variable names can be up to 8 bytes long.
• The following characters are allowed in a folder or variable name: Upper-case and lower-case characters, subscript characters, numbers, underscore (_).
• Folder or variable names are case-sensitive. For example, each of the following is treated as a different folder/variable name: abc, Abc, aBc, ABC.
• A reserved word (system variable names, built-in function names, command names, etc.) cannot be used as a folder or variable name.
• A number, subscript characters or the underscore (_) cannot be used as the first character of a folder or variable name.
u To delete a folder
Important!
Before deleting a folder, make sure you no longer need any of the variables contained inside it. It is probably a good idea to first delete the variables you don’t need, move the variables you do need to another folder, and then delete the empty folder.
1. Open the folder you want to delete and check its contents.
• Make sure you no longer need any of the variables in the folder. If any of the variables are locked, unlock them.
• After checking the contents of the folder, close it to return to the folder list.
2. Select the check box next to the folder you want to delete.
• You can select and delete multiple folders, if you want.
3. On the folder list, tap [Edit] and then [Delete].
4. In response to the confirmation dialog box that appears, tap [OK] to delete the folder.
Tip: You cannot delete the “library” folder or the “main” folder.
u To input a folder name or variable name into an application
1. In the Main application, Graph & Table application, or some other application, move the cursor to the location where you want to input the variable name.
2. Start up Variable Manager to display the folder list.
3. If you want to input a variable name, double-tap the folder that includes the variable whose name you want to input. If you want to input a folder name, advance to the next step.
Chapter 1: Basics 31
Scarica
Pubblicità