Navigation. Dell 7.3
Reklamë
Reklamë
3
Navigation
Main Menu
File Menu
Operations on files and projects, plus the Exit command.
Menu
Icon
Menu Name More Information
New File
Menu Icon Menu Name
HTML File
SQL Script
More Information
New Project Open a new project window. See also
Use File | Reopen Project to return to the previous project.
Open File Open an external file in the
.
Reopen Project Reopen a project window. See also
.
Rename
Project
Rename the current project window. See also
Delete Project Delete the current project window. See also
Save File Save the file to disk.
Save File As
Print Preview
Print Setup
Save the file to disk. Optionally change the file name and location before saving.
Print the file.
Preview the file before printing.
Enter setup options for printing.
Exit Close SQL Navigator
SQL Navigator 7.3
User Guide
20
Edit Menu
Common text and code-editing actions.
Menu
Icon
Menu Name More Information
Undo
Redo
Cut
Reverse the previous editing action.
Reapply the previous editing action
Remove selected text and place it on the clipboard
Copy
Paste
Select All
Copy selected text to the clipboard
Insert the clipboard contents at the cursor location.
Select all text in the item being edited
Nil
Indent
Unindent
Indent the current line
To increase or decrease the indent of selected text in the editor
Unindent the current line
To increase or decrease the indent of selected text in the editor
Comment Enclose the selected text inside PL/SQL comment marks
Uncomment Remove the PL/SQL comment marks from the selected text
Upper Case Convert selected text to upper case
Lower Case Convert selected text to lower case
Convert
Keywords to
Upper Case
Convert all keywords and reserved words in the program to uppercase
Convert
Keywords to
Lower Case
Convert all keywords and reserved words in the program to lowercase
Place selected text in the
Open
Selected
Text in
Code Editor
Insert
Menu
Icon
Menu Name
More Information
File Insert a text file at the current cursor location.
DBMS_
OUTPUT.PUT_
LINE(")
Insert DBMS_OUTPUT.PUT_LINE('') at the current cursor location.
SQL Navigator 7.3
User Guide
21
Menu
Icon
Menu Name More Information
Menu
Icon
Menu Name
Debug
Variable
More Information
Create a debugging statement for the variable at the current cursor location.
l
The statement is copied to the clipboard.
l
Use Edit | Paste to place the statement in the code.
CRUD Matrix Insert a CRUD (Create-Update-Delete) matrix, enclosed in comment markers, at the current cursor location in the
.
This provides a convenient method of documenting a procedure.
SQL Statement CRUD Matrix Dialog
Got to Line Move to a specific line number in the editor.
Move to the other bracket within a given pair of brackets Jump to
Matching
Bracket
Toggle
Bookmark
Go to
Bookmark
List
Bookmarks
Open
Object at
Cursor
Describe
Object at
Cursor
Place a bookmark at the current line.
You can set up to ten bookmarks (identified numerically 0-9).
Return to a bookmarked line in the code.
Example Scenario: Set bookmark number 1 in the DECLARE section and bookmark number 2 at your current editing location. To return to the DECLARE section press
Ctrl+1. After looking at your variable or cursor declarations, return to your editing location by pressing Ctrl+2.
View / Go to / Delete bookmarked lines in the code.
Open the database object referenced at the current cursor location.
Use to instantly find objects from stored programs or scripts, and open them in the
Show DESCRIBE information for the database object referenced at the current cursor location.
See also
.
Search Menu
Find text, code and database objects.
SQL Navigator 7.3
User Guide
22
Menu Icon Menu Name
Find
Replace
More Information
Find a text string.
Find a text string and replace it with another.
Find the next occurrence as per
Find Next
Find previous Find the previous occurrence as per
Code Search
Find Objects
Find source code in the database.
Find one or more database objects matching a search argument.
Find Recycle Bin Objects
Find Recycle Bin Objects Dialog
Requires Oracle 10g or later.
View Menu
Control what is displayed in the main application area.
More Information Menu
Icon
Menu Name
DB Navigator
Code Editor
Visual Object
Editor
Open / Focus
Open / Focus
Menu
Icon
Menu Name More Information
Cluster Editor Open a new instance of the
Constraint Editor
Index Editor
Open a new instance of the
DataBase Link Editor Open a new instance of the
Open a new instance of the
Nested Table Editor Open a new instance of the
SQL Navigator 7.3
User Guide
23
Menu
Icon
Menu Name More Information
Menu
Icon
Menu Name More Information
Profile Editor
Redo Log Group
Editor
Role Editor
Materialized View
Editor
Sequence Editor
Synonym Editor
Table Editor user Editor
Varray Editor
Open a new instance of the
Open a new instance of the
Open a new instance of the
Open a new instance of the
Open a new instance of the
Open a new instance of the
Open a new instance of the
Open a new instance of the
Open a new instance of the
View Editor Open a new instance of the
Java Editor
Instance Property
Editor
Project
Manager
Window
Task Manager
Show / Hide
Show / Hide
Output Window Show / Hide
Code Assistant Show / Hide
Open a new instance of the
Open a new instance of the
Code
Templates
Show / Hide
Auto-Describe
Tool
Show / Hide
Source Preview Show / Hide
Preferences
Set SQL Navigator Preferences:
Screen Layout
SQL Navigator 7.3
User Guide
24
Menu
Icon
Menu Name More Information
Menu
Icon
Menu
Name
Nil Layout
0-9
More Information
The current layout number is highlighted.
When you select a different layout number the current layout is saved before the screen layout switches to the selected layout.
Use Layout 0 as a general-purpose default layout.
Reset
Docking
Restore the current layout to the SQL Navigator default.
Session Menu
Manage and configure your connection to the database.
Menu
Icon
Menu Name More Information
New Session Connect to an Oracle database instance / Open a new Oracle session. Manage your database connections, including to create a database connection.
Select Switch between open Oracle Sessions. Show the current Oracle session.
You can set up multiple sessions with one or many database instances.
Server
Output
Include
Debug Info
Toggle On / Off
Capture Web
Output
Start/Stop
Watch, evaluate or modify a stored program variable.
1. Toggle On Include Debug Info.
2. Compile the program in the
.
See also:
Web
Configuration
Set up Oracle Web development support.
Web Support Configuration Dialog
Wallet
Operations
Features to decrypt the table keys to encrypt or decrypt application data
SQL Navigator 7.3
User Guide
25
Menu
Icon
Menu Name More Information
Suspend
Stop
Commit
Rollback
Change
Password
Menu Icon Menu Name
Generate Master Key
Open Wallet
Close Wallet
Suspend execution of the stored program.
Terminate execution of the stored program.
Commit all pending changes in all open editors for the current Oracle session.
Release any row or table locks held by the session.
Undo some or all of the changes made to the database during the current Oracle session.
Release any row or table locks held by the session.
Modify the logon password of the current Oracle session.
Empty the recycle bin for the current Oracle session.
Empty
Recycle Bin
Reconnect
Close
Close All
Re-establish the database connection.
Close the current session. Close the Oracle connection. Disconnect from the Oracle instance.
You can disconnect from an Oracle instance and remain connected to other instances.
Close all open sessions.
Object Menu
Operations on database objects.
Menu
Icon
Menu
Name
More Information
Create DB
Object
Create a database object.
Open
DB Object
Locate and open a database object.
SQL Navigator 7.3
User Guide
26
Menu
Icon
Menu
Name
Open
Describe
Rename
Drop
Open the selected database object for editing.
Not all database objects can be altered. You may need to drop the object and create a new one.
Show attributes, methods and arguments of the selected procedure, function, package, synonym, table, index or cluster.
Ensure the required database connection is active.
See also
Rename the selected object.
Remove the selected object from the database.
To disable the Drop command:
|
General | "Drop" and "Truncate" safety options
(Oracle 10g and later): A recycle bin is available for handling and restoring dropped objects. You can use
to retrieve objects dropped from the database. See also
Find Recycle Bin Objects Dialog .
Remove the selected object from the database permanently. Do not place the object in the Recycle Bin.
Drop with
Purge
Flashback Restore the selected object from the Recycle Bin.
Use
to select an object in the Recycle Bin.
You can type a new name for the object in the New Name column if required.
Extract
DDL
Extract the DDL or other SQL statements that define the selected object or access control. On requesting Extract DDL the SQL Navigator Preferences open:
.
SQL Navigator encloses non-alphanumeric and mixed-case object names inside doublequotes
You may like to use
to select object(s).
Extract DDL runs as a background task. See
Get the metadata of the selected object(s).
Get
Metadata
Publish
Java to
PL/SQL
Import
Table
Export
More Information
Create a PL/SQL package from the selected Java class stored in the database.
Import objects from a DMP file.
Export objects to a DMP file.
SQL Navigator 7.3
User Guide
27
Menu
Icon
Menu
Name
Table
Compile
More Information
Compile/Rebuild the selected object.
Menu
Icon
Menu Name More Information
Compile/Rebuild Compile the selected object.
Compile
Dependents
Compile
Dependencies
Compile dependents of the selected object.
This eliminates the need to find and compile all dependent objects that became invalid when altering a procedure, table, or other structure.
Compile dependencies of the selected object.
Execute
SQL
Modeler
Quick
Browse
See also
,
.
Watch for feedback in the
Output Window . If the object compiles with errors, open it in
the Code Editor and compile to make use of the Code Editor's error handling facilities.
If the object has been modified, you will need to save it before you can compile it. This is to ensure that the changes in the object have been applied to the database.
Execute the selected stored program and display the results in the
Open the selected object in
.
Scenario Example: Select a table in DB Navigator. Open the table in SQL Modeler. Build a query by selecting and dragging columns.
Execute the SQL query for the selected table object in the
to view chained rows information.
See
,
Edit Data Execute the SQL query for the selected table object in the
with Updateable switched on.
See
,
Analyze View and collect statistics, validate structure and list chained rows for database structures such as tables, clusters and indexes.
Truncate Remove all rows from a table and reset the STORAGE parameters to the values when the table or cluster was created.
See also
.
To disable the Truncate command:
|
General | "Drop" and "Truncate" safety options
SQL Navigator 7.3
User Guide
28
Menu
Icon
Menu
Name
Storage
More Information
Oracle allocates space to objects in segments. Segments consist of contiguous sections called extents.
Menu
Icon
Menu
Name
Allocate
More Information
Explicitly allocate a new extent for a selected table or index.
Deallocate Deallocate unused space at "the end" of a segment and make that space available for other segments within the tablespace.
Coalasce Put together discontinuous fragmented extents.
Enable
Disable
Grant
For more information, see the Oracle documentation on the ALTER TABLE and ALTER
INDEX commands.
Enable/Disable the selected constraint object.
If a constraint is enabled, Oracle automatically enforces it. If a constraint is disabled,
Oracle does not enforce it.
See also
See also
.
Locate objects of type Constraint using
Grant object privileges for the selected object.
Revoke Revoke object privileges for the selected object.
Locate in
Tree
When an object is open in an editing window, and you want to see where that object resides in the schema, you can use Locate in Tree to jump to that object’s node in
Properties Show the properties of the selected object
Add to
Project
Add the selected object to the
Tools Menu
Invoke and control integrated tools.
Menu
Icon
Menu Name
Code Test
More Information
The Code Test panel automates the process of testing PL/SQL programs.
SQL Navigator 7.3
User Guide
29
Menu
Icon
Menu Name More Information
Code Analysis Code Analysis analyzes code against a set of rules for best practices.
View
Difference
Compare two scripts / two objects.
Formatter
Tools
Format PL/SQL, SQL*Forms, Oracle Forms, and SQL*Plus source code.
Menu
Icon
Menu
Name
Format
Code
More Information
Format the entire source currently in the editor.
To format just a selection, select the text you want to format.
Output is displayed in the
Syntax
Check
Profile
Code
Multi-File
Formatting
Formatting
Options
Check the syntax. Output is displayed in the
.
If syntax errors are detected, the text stays unchanged. The errors are displayed in the Output Window.
Create a summary of the code statistics. You can copy to clipboard or save to file.
Open the Multi-File Formatting Selection dialog.
l
Select Folder and enter the folder that directly contains the files you want to format. Or l
Select Files and enter the files you want to format.
Select Backup files to folder to create a backup copy of the files you are about to format.
Define how the Formatter Tool formats code.
Wrap Code
Session
Browser
Access Oracle’s Wrap Code utility.
Manage sessions in the Session Browser.
Search
Knowledge
Xpert
Knowledge Xpert (formerly RevealNet) is a library of more than 900 pre-built PL/SQL routines, written by some of the world's leading PL/SQL experts, that can be integrated into the standard PL/SQL environment.
SQL Optimizer Analyze and tune the execution of SQL scripts.
SQL Navigator 7.3
User Guide
30
Menu
Icon
Menu Name More Information
Explain Plan
Tool
PL/SQL
Profiler
Requires installation of SQL Optimizer for Oracle®.
Create, store and browse execution plans.
Analyze the execution time and efficiency of your stored programs.
SQL Modeler Create the framework of a Select, Insert, Update, or Delete statement.
Code Road
Map
ER Diagram
Job
Scheduler
Java Manager Load and unload multiple Java source files, classes, resources and archives. This is a convenient alternative to the Oracle LoadJava and UnloadJava command line utilities.
Import HTML as PL/SQL
Work with Oracle Job Manager.
Convert a HTML file into a PL/SQL stored procedure, to be output via the Oracle Web
Cartridge.
Dell Code
Tester
Benchmark
Factory
Show the complex PL/SQL inter dependencies within a database.
Model a table and graphically see the dependencies and joins to other tables.
Open Code Tester for Oracle®.
Requires installation of Code Tester for Oracle®.
Open
Requires installation of
Toad Data
Modeler
Profile
Manager
SQL Tracker
Server Side
Installation
Open Toad™ Data Modeler.
Requires installation of Toad™ Data Modeler.
Backup and restore SQL Navigator profiles.
Open SQL Tracker.
Requires installation of SQL Tracker.
Install the server-side components of SQL Navigator
SQL Navigator 7.3
User Guide
31
Menu
Icon
Menu Name
Wizard
Product
Authorization
More Information
Server Side Installation Wizard
Enter A New Authorization Key .
Team Coding Menu
Extensive and flexible Team Coding controls, including integration with third-party version control systems.
Menu
Icon
Menu
Name
More Information
Administer Use the Team Coding Administration page to install, set up, and manage the Team
Coding environment.
Open
.
Configure Set local Team Coding options.
Open
.
Team
Coding
Status
View the status of the Team Coding configuration and features. See
Team
Coding
Manager
Use the Team Coding Manager to manage and work with the objects that are controlled by Team Coding. The Team Coding Manager displays Team Coding status and controlled objects for the current active connection.
Open
.
Team
Coding
Summary info
Provider
Logon
View the summary of all controlled objects for the current active connection.
Logon to the Version Control Product.
Requires that a version control product is in use. See
Add file Add a file to VCS.
Check out
Use to check out and check in an object or script. See
.
To indicate the object or script to check in or check out:
Check in l
Select the object in
,
,
Object editing windows.
l
Open the object in one of the
or
SQL Navigator 7.3
User Guide
32
Menu
Icon
Menu
Name
More Information
Undo
Check Out
Cancel the check-out. You are prompted to confirm that you want to discard any changes you have made and restore the database version of the item as it was prior to checkout.
Confirm
Yes
Confirm
No
You have made and saved changes to the object and you want to discard those changes.
You have made and saved changes to the object and you want those changes to be retained in the database. As a result the version saved in the third party version control system will be different from the version saved in the database.
Check in
All
Compare
Contents
Get Latest
Revision
Check in all changes
Select a database object (in revision.
for example) and compare it with the latest
Get the latest version of an object or script as it is held in the Version Control System.
The Get Latest Revision command overwrites the version of the object or script in the database, replacing it with the latest version held in the Version Control System.
Help Menu
Access to user-assistance
Menu
Icon
Menu Name
Contents
More Information
General and How-To information
Context Help Open context-sensitive help for the current window or dialog
Not all windows and dialogs are linked to help topics.
Shortcuts &
Function Keys
Look up keyboard shortcuts and function keys
Open
Find a
Command
Locate SQL Navigator commands
Open
Visit for all the latest product information, including tips and techniques.
SQL Navigator
Community
Contact
Support
Open the Support Portal. Log issues, search the knowledge base and download products.
http://software.dell.com/support/
Create Create the support bundle file: SupportBundle.dta.
SQL Navigator 7.3
User Guide
33
Menu
Icon
Menu Name
Support
Bundle Files
Check For
Updates
About SQL
Navigator
More Information
This file will contain information about your environment and installation of SQL
Navigator. If you log an issue with support then they may request this file.
SQL Navigator version, licensing version and options, and contact information.
Task Bar
The Task Bar lists all active SQL Navigator windows for the current project.
Use the Task Bar to select a SQL Navigator window to work on. That window is bought to the foreground, giving it focus.
TIP:
l
To show / hide the Task Bar, right click over the Main Menu or Task Bar and click Task Bar (List
of Windows).
l
Point to an item on the Task Bar with your mouse to see a Tool Tip for the associated window.
l
When there are lots of open SQL Navigator windows you may want to organize them on the Task
Bar. Active windows are grouped by session, with the most recent session’s windows appearing on the left.
Toolbars
The following toolbars are available in the main window.
To show / hide a toolbar, right click over the Main Menu, any toolbar or task bar and select the toolbars to show.
Toolbar
Session Toolbar
Description
Duplicates some of the commands from the
TIP:
Pause/Resume and Stop buttons on the Session toolbar allow you to interrupt execution of a current task. A hint on the Stop button dynamically shows which task is running and (if applicable) its current progress.
Edit Toolbar Duplicates some of the commands from the
and
.
Functions Toolbar Duplicates some of the commands from the
,
and
.
Object Toolbar
Team Coding
Duplicates some of the commands from the
and shows the current schema.
Duplicates some of the commands from the
.
SQL Navigator 7.3
User Guide
34
TIP:
l
Some modules within SQL Navigator have their own toolbars. You should refer to the module's documentation for more information.
l
To see a Tool Tip about an item on the toolbar, point to it with the mouse.
Component List
Icon Component
Name
Description
View and collect statistics, validate structure and list chained rows for database structures such as tables, clusters and indexes.
Report on the attributes, methods and arguments of an object type.
See also
.
Simulate user transactions before and during application deployments, enabling performance issues to be addressed before end users are affected.
View / Jump to / Delete bookmarks.
See also
.
Browse Data View chained rows information.
See
.
Modify the logon password of the current session.
Join tables that are closely related for storing on the same area of the disk. This lets you interleave the rows of two or more tables together into a single area called a cluster.
Analyze code against a set of rules for best practices.
Drag and drop PL/SQL syntax, SQL functions, column names, and database object names into code.
Edit SQL and PL/SQL code.
Code
Explorer
Show a hierarchical view the code.
See Code Editor | Toolbox |
Show the complex PL/SQL interdependencies within a database.
Code Search
See
.
Insert ready-made code segments into any active editor window.
Automate the process of testing PL/SQL programs.
SQL Navigator 7.3
User Guide
35
Icon Component
Name
Description
Use the Constraint Editor to specify table constraints.
Use the Database Link Editor to view, create or define database links.
Search stored programs, triggers and views for a character string in the source code.
DB Explorer Find and open database objects.
See Code Editor | Toolbox |
.
Show the entire database structure as a tree with expandable nodes.
Report on the attributes, methods and arguments of an object type.
See also
Compare objects in a split view.
Edit data in a table object.
Model a table and graphically see the dependencies and joins to other tables.
Analyze the execution of a single SQL statement.
Export selected tables.
Extract DDL
See also
.
See also SQL Navigator Preferences:
Find or replace text strings in the current text file.
Find objects in any schema.
Search for objects in the recycle bin.
Configure how the Formatter Tool formats code.
Formatter tools are available from the
.
Show HTML in the integrated viewer.
Convert a HTML file into a PL/SQL stored procedure. The stored procedure will in turn output the HTML code via the Oracle Web Toolkit.
Import tables.
Use the Index Editor to view, create or alter indexes, and to set storage allocation.
SQL Navigator 7.3
User Guide
36
Icon Component
Name
Description
Use the Instance Property Editor to view or specify the startup parameters for the instance.
View and edit Java source.
Load and unload multiple Java source files, classes, resources and archives.
Access the Oracle Job Scheduler.
Jump to the selected object’s node in the
tree.
Use the Materialized (Snapshot) View Editor to view, create or define snapshots.
Use the nested table editor when you require a large, efficient collection.
Open DB
Object
Select and open a database object similar to the standard Windows File | Open command.
See
.
See
.
Open Object at Cursor
Manage your database connections, including to create a database connection.
Outline Show the syntax tree of the current source.
See Code Editor | Toolbox |
.
PL/SQL
Debugger
Show SQL Navigator messages and server output including Oracle errors.
Tools and features for debugging stored programs.
See Code Editor | Toolbox |
Analyze the execution time and efficiency of your stored programs.
Use the Profile Editor to view, create or alter profiles.
Backup and Restore SQL Navigator profiles.
Product
Authorization
See
.
The Project Manager window provides instant access to your frequently used database objects and connections.
Create a PL/SQL package from a Java class stored in the database.
SQL Navigator 7.3
User Guide
37
Icon Component
Name
Description
View chained rows information.
Use the Redo Log Editor to view, create, or alter Redo Logs.
Use the Role Editor to view or create roles.
Screen
Layout
SQL History
Save up to ten layouts of dockable windows and recall them.
See
| Screen Layout
Drag and drop optimized routines directly into your program editor.
Select
Session
Use the Sequence Editor to view, create, or alter sequences.
Install server side objects.
Select and open a database object similar to the standard Windows File | Open command.
Switch between open Oracle Sessions.
Manage sessions in the Session Browser.
Preview the source code of text objects (stored programs, triggers and views), or a package’s individual entry points.
The History tool lists successfully executed SELECT, UPDATE, DELETE commands and
PL/SQL blocks up to 1000 of the most recent ones in the current session.
See Code Editor | Toolbox |
SQL Modeler dialog provides a fast means for creating the framework of a Select,
Insert, Update, or Delete statement. You can select Tables, Views, or Synonyms, join columns, select columns, and create the desired type of statement.
The SQL Optimizer makes observations about a selected SQL statement and the underlying database environment, then recommends several options to improve performance.
Use the Synonym Editor to view or create synonyms.
Use the Table Editor to create, alter, or define tables.
SQL Navigator executes long-running tasks in separate threads in the background. The
Task Manager is a display of all active and complete tasks for the current session.
Use the User Editor to create, grant or revoke roles and privileges to users, including forcing a password to expire.
SQL Navigator 7.3
User Guide
38
Icon Component
Name
Description
Use the Varray Type Editor to create varying arrays.
Use the View Editor to view, create, or alter views.
View
Difference
The Difference Viewer displays the compared objects in a split window.
See
SQL Navigator’s editing tools for database objects.
The Wrap Code utility provides an easy way to access Oracle’s Wrap Code utility.
Connection Category Color
Optionally assign a connection to a category color in the
Possible categories could be: development, test or production. You could create your own categories and assign colors as appropriate.
The color is displayed in the following places in SQL Navigator.
Component Name
Description
The connection entry in Session toolbar.
The border of windows belonging to the connection.
Task Bar icons of windows belonging to the connection.
Tab icons of the Code Editor window.
See also preference settings in
Main Menu Keyboard Shortcuts
Generally available keyboard shortcuts are: Close Current Window = CTRL+F4 | Refresh = F5.
Icon Main Menu
File | Open File
File | Print
Edit | Undo
Edit | Redo
Edit | Indent
Keyboard Shortcut
CTRL+O
CTRL+P
ALT+Backspace
SHIFT+ALT+Backspace
CTRL+I
SQL Navigator 7.3
User Guide
39
Icon Main Menu
Edit | Unindent
Edit | Comment
Edit | Uncomment
Edit | Upper Case
Edit | Lower Case
Edit | Insert | DBMS_OUTPUT.PUT_LINE('')
Edit | Insert | Debug Variable
Edit | Go to Line
Edit | Jump to Matching Bracket
Edit | Toggle Bookmark | Bookmark
Edit | Go to Bookmark | Bookmark
Edit | List Bookmarks
Edit | Open Object at Cursor
Edit | Describe Object at Cursor
Search | Find
Search | Replace
Search | Find Next
Search | Find Previous
Search | Find Objects
Search | Find Recycle Bin Objects
View | Project Manager Window
View | Code Editor
View | DB Navigator
Session | Stop
Object | Create DB Object
Object | Open DB Object
Object | Open
Object | Describe
SHIFT+F3
CTRL+ALT+O
CTRL+ALT+B
CTRL+W
CTRL+M
F12
Scroll Lock
Alt+Insert
CTRL+ALT+D
CTRL+F2
CTRL+F3
Keyboard Shortcut
CTRL+U
ALT+F7
CTRL+ALT+F7
CTRL+ALT+U
CTRL+ALT+L
CTRL+D
F2
CTRL+G
CTRL+J
SHIFT+CTRL+n
CTRL+n
ALT+B
CTRL+Enter
CTRL+F3
CTRL+F
CTRL+H
F3
SQL Navigator 7.3
User Guide
40
Icon Main Menu
Object | Drop
Object | Drop with Purge
Object | Extract DDL
Object | Compile | Compile/Rebuild
Object | SQL Modeler
Open the selected object in SQL Modeler.
Object | Quick Browse
Object | Edit Data
Object | Grant
Object | Locate in Tree
Tools | View Difference
Tools | Formatter Tools | Format Code
Tools | Search Knowledge Expert
Window | More Windows
Help | Contents
Help | Context Help
Keyboard Shortcut
ALT+Delete
SHIFT+Delete
CTRL+D
CTRL+F9
CTRL+B
F3
CTRL+E
ALT+G
CTRL+L
CTRL+ALT+V
CTRL+R
CTRL+K
ALT+0
CTRL+F1
F1
TIP:
Many additional shortcuts are available for the various modules of SQL Navigator. For example, see the
Code Editor Keyboard Shortcuts
.
Customize The Screen Layout
Float / Dock
You can save multiple screen layouts of floating / docked items as per the
| Screen Layout.
TIP:
While moving a dockable item you can prevent it from docking by holding down the CTRL key.
SQL Navigator 7.3
User Guide
41
Items that can be floating or docked
More Information
Main Menu Bar The main menu bar can be floating or docked.
Dockable
Windows
The following windows are dockable. They can be docked to any side of the SQL Navigator application window or any other dockable window. You can dock several windows to the same site.
l
l
l
l
l
l
Dockable windows open in the same state (floating or docked) and in the same screen position or at the same site as when they were last closed. Dockable windows retain size and position between sessions.
The size and location of dockable windows are remembered in screen layouts as per
| Screen Layout.
NOTE:
l
The size and location of the Output Window is remembered only when docked.
l
When the Output Window is docked, the Output Window remains visible ("on top") when other windows are opened. When the Output Window is not docked it can be hidden behind the current window.
Toolbars available in the
Main Window
Task Bar
The toolbars can be docked to any side of the SQL Navigator application window or can float on top of the current window.
The task bar can be docked to any side of the SQL Navigator application window or can float
Toolbars in the Main Window
Customizations
Show/Hide Buttons
Description
1. If the toolbar is docked, click the down arrow to the far right of the toolbar.
If the toolbar is floating, click the down arrow on the title bar.
2. Click Add or Remove Buttons.
3. Select the buttons to show.
SQL Navigator 7.3
User Guide
42
Customizations
Add/Remove Toolbars.
Reorder Items.
Add items from a master list.
Reset the Toolbar to Default.
Description
1. If the toolbar is docked, click the down arrow to the far right of the toolbar.
If the toolbar is floating, click the down arrow on the title bar.
2. Click Add or Remove Buttons | Customize.
TIP:
While the Customize dialog is open, move the mouse pointer over a toolbar button and right click. Choose an option from the shortcut menu. Reset the toolbar, delete or rename the button, change its appearance or add a separator.
1. If the toolbar is docked, click the down arrow to the far right of the toolbar.
If the toolbar is floating, click the down arrow on the title bar.
2. Click Add or Remove Buttons | Reset Toolbar.
Main Menu Bar
Customizations More Information
Customizable
Menu Items
While the menu is docked, click the down arrow in the far right corner. If the menu is floating, click the down arrow on the title bar.
SQL Navigator 7.3
User Guide
43
Shkarko
Reklamë