SAP 9.4 Instant Producer Yükleme Rehberi
PDF
Belge
Reklam
Reklam
客户 目录 1 引言 ................................................................................................................................................................... 3 2 2.1 2.2 2.3 2.4 3 3.1 3.2 配置设置和项目模板 .......................................................................................................................................... 7 导入设置 .................................................................................................................................................................... 7 定义项目模板 ............................................................................................................................................................ 7 4 4.1 浏览器回放设置 ................................................................................................................................................. 9 基本设置 .................................................................................................................................................................... 9 5 5.1 5.2 5.3 5.4 5.5 SAP 客户端设置 ............................................................................................................................................... 11 SAP GUI 脚本 ........................................................................................................................................................... 11 SAP GUI 设置 .......................................................................................................................................................... 12 模态对话框设置....................................................................................................................................................... 12 字体设置 .................................................................................................................................................................. 12 SAP ECC 页面键值中的页面标题 ........................................................................................................................... 12 6 通过链接打开各个工作区 ................................................................................................................................. 14 7 7.1 连接 Manager ................................................................................................................................................. 15 建立连接 .................................................................................................................................................................. 15 8 技术支持 .......................................................................................................................................................... 16 2 1 引言 3 2 以下章节主要介绍 Instant Producer 的系统要求、安装和卸载。 2.1 系统要求 为了成功安装并使用 Instant Producer,您的电脑必须满足下列要求: 类型 规格 操作系统 Windows Vista、Windows 7 和 Windows 8( 无磁贴模式) 32 位和 64 位操作系统 处理器 奔腾 IV 处理器,1 GHz 以上 内存 最小 1 GB 硬盘 200 MB 的可用空间 浏览器 Internet Explorer 7.0 – 11.0 场景 要求 Java 应用程序 文档生成 2.2 安装 注释 o 要安装 Instant Producer,您需要在要安装 Instant Producer 的 PC 上具有管理员权限。 o 假如您已经安装了某个版本的 Instant Producer,请注意以下章节中有关更新流程的注释。 4 2.2.1 如果要更新已经安装的 Instant Producer,请注意以下信息。 2.2.1.1 使用服务版本 (SP) 更新 Instant Producer 如果要将现有 Instant Producer 安装版本更新为较新的服务版本 (SP) 而不更改主要版本,安装程序会识别现有安装并 在安装过程中自动覆盖现有程序组件。 2.2.1.2 如果您想安装一个新的主版本(如 Instant Producer 9.2),请注意,已安装的任何先前主版本(如 Instant Producer 9.1)都不会自动被卸载。 您必须手动卸载先前的 Instant Producer 版本。请在“卸载”一章中阅读相关操作方法。考虑到 Instant Producer 为 所有版本使用同一个工作区。使用先前的 Instant Producer 版本打开更新后的工作区,可能会导致应用程序出现故障 和数据不一致。 2.2.1.3 使用自定义程序路径更新 Instant Producer 如果您将之前版本的 Instant Producer 安装在自定义路径(例如 D:\programs\Instant Producer)中,且想要使用相 同的自定义路径安装新的 Instant Producer 主版本,则在安装新版本之前必须卸载之前版本的 Instant Producer。卸 载之前的版本后,您可以再次使用自定义安装路径。 2.3 工作区 安装 Instant Producer 之后,会通过直接向其中导入必须资源的方式自动创建工作区。工作区是存储所有配置和内容 文件(包括宏集、浮动框样式、trainer 等)的文件夹。 工作区将位于下面的文件夹中: %USERPROFILE%\AppData\Local\Instant Producer Workarea 2.4 卸载 5 注释 卸载 Instant Producer 时,只会删除程序。将保留所创建的工作区以备将来使用。 6 3 配置设置和项目模板 以下章节将讲述针对通过 Instant Producer 创建的任意工作如何定义和导出 Producer 中的设置和项目模板。 3.1 导入设置 Instant Producer 使用预定义的录制设置,因此简化了录制流程。除此之外,还提高了不同作者录制的一致性。 尽管如此,若要修改录制设置,项目管理器可以定义 Producer 的设置,然后将其导入到 Instant Producer 中。这就是 说,您可以将预定义的设置分配给作者,然后以简单方式将它们集成在一起。 可通过以下步骤来实现此操作: 定义设置 1. 通过工具 -> 设置... 菜单,在 Producer 中打开中央配置对话框。 2. 转到应用程序 -> 录制应用程序部分。 3. 定义所需录制设置,然后按确定确认对话栏。 导出归档 1. 以归档文件形式 (*.dkp) 导出设置。为此,请选择菜单项目工作区 -> 管理 -> 导出归档... 2. 配置/样式资源包含录制设置。选择它,然后按确定键确认。 3. 接下来指定目标目录和文件名。单击保存。 2. 在任务栏中,单击导入设置。 3. 选择具有所需资源的归档,然后按打开确认。 4. 导入后,重新启动 Instant Producer 应用设置。对话框会提示您执行此操作。 3.2 定义项目模板 在 Instant Producer 中创建新项目时,您可以创建模板并将其分配至作者。当多个作者处理一个项目时,模板有助于 确保一致性。 在 Producer 中,通过单击项目编辑器的工具栏中的新建项目来创建新项目。建议您将此项目保存在工作区中专门 用于模板的文件夹中。 2. 随即出现一个对话框。输入模板名称,例如“标准模板”。单击“确定”进行确认。 7 3. 然后,根据需要配置项目。为此,可在项目编辑器中打开主要配置对话框,并定义所有项目相关特定设置。 4. 保存项目。 5. 接下来,从工具 -> 设置... 菜单中打开主要配置对话框 6. 在项目模板下,选择刚刚创建的项目,然后单击确定。 导入模板和设置 创建某个项目后,您可以导出该项目及其设置。为此,请按照本用户指南中导出设置部分中的说明进行操作。确保导 出该项目及其资源配置/样式文件。 8 4 浏览器回放设置 为了保证浏览器与产品完美结合,需要更改所使用的浏览器的安全设置。 系统要求 需要满足以下要求才能保证内容成功回放: 浏览器 版本 操作系统 Internet Explorer 7.0 – 11.0 Windows Vista、Windows 7 和 Windows 8 4.1 基本设置 注 本章中所做置配置均假定用户使用 Internet Explorer 缺省设置和缺省安全级别。如果使用自定义安全级别, 请阅读“自定义设置”章节确保设置符合要求。 回放 Internet 上的内容 要应用 Internet Explorer 安全设置,请打开 Internet Explorer 并导航到工具菜单下的 Internet 选项命令。 1. 单击安全标签,根据课程所在位置选择本地 Intranet 或 Internet。 2. 单击自定义级别... 打开“安全设置”对话框。启用显示的以下设置。 部分/设置 设置为 原因 启用 以正确定位的控件要素在 trainer 中 显示课程模式。 其他 允许由脚本初始化的窗口,不受大小 和位置限制 提示 在 Internet Explorer 9 中,关闭内容来源所在网络区域的受保护模式。这可以确保对在新窗口中打开内容的链 接进行正确的窗口处理。不执行此操作可能会导致窗口以全屏模式打开,进而无法在课程结束之前关闭课程。 回放本地内容 如果内容存储到本地硬盘或者将内容以 CD/DVD 形式交付,则必须允许活动内容在本地运行。 1. 打开 Internet Explorer 并导航到工具菜单下的 Internet 选项命令。 2. 单击高级标签并滚动到安全部分。如下表所述启用设置。 9 部分/设置 原因 允许活动内容在我的计算机上的文件中运行* 从本地硬盘中回放内容。如果要在 Instant Producer 中 预览制作好的内容,这一点尤为重要。 允许来自 CD 的活动内容在我的计算机上运行* 回放 CD/DVD 上的已发布内容。 常用设置 10 配置 Internet Explorer 的弹出窗口阻止程序 需要取消激活弹出窗口阻止程序才能在 trainer 中显示课程。该选项可以通过工具 -> 弹出窗口阻止程序菜单访问 。 也可以在弹出窗口阻止程序设置中在弹出窗口启用的页面中输入相应 URL。 5 SAP 客户端设置 如果项目将通过 SAP ECC 客户端录制,则需应用某些设置,以免录制过程中出现故障。 5.1 SAP GUI 脚本 SAP GUI 脚本对于录制而言必不可少。此脚本可确保能够通过 SAP 的脚本界面正确识别 ECC 窗口中的对象。应在服 务器端激活 SAP GUI 脚本,以便能够提取对象信息。 在某些情况下,需要在客户端激活此脚本(请参阅场景)。如果同时在服务器端和客户端激活脚本,则会在右下角显 示一个红色/白色符号。 下表概要介绍了一些录制场景以及所需的 SAP GUI 脚本设置: 场景 设置为(客户端) 设置为(服务器) 深度识别(标准) 取消激活 激活 简单识别 激活 激活 注释 具有嵌入式 SAP GUI 的 NWBC:对于采用深度识别的录制,也是在客户端激活 SAP GUI 脚本。 可在定制本地布局 -> 选项菜单下设置客户端的 SAP GUI 脚本: 区域/设置 已激活的场景 已取消激活的场景 启用脚本 激活 取消激活 当脚本附加到正在运行的 GUI 时发出 通知 关闭 已禁用 当脚本打开连接时发出通知 关闭 已禁用 可访问性和脚本 -> 脚本编写 注释 请注意,当脚本处于活动状态时,无法进行图形对象识别。对于图形对象识别,需满足其他非标准要求。如对 此存在任何疑问,请联系 SAP 顾问。 11 5.2 SAP GUI 设置 可在定制本地布局选项中定义以下设置。 区域/设置 设置为 主题 为相应应用程序参数文件选择主题,例如 SAP 签名, tradeshow… 活动主题 可视化设计 字体设置 缺省设置 交互设计 -> 可视化和交互 屏幕上输入字段的光标宽度 窄光标 交互设计 -> 通知 工具提示延迟 无工具提示 本地数据 关闭 历史记录 5.3 模态对话框设置 激活对话框(模态)选项可优化对模态对话框中对象的识别。该设置位于设置对话框的 F4 帮助标签内,可从帮助 -> 设置菜单中启动。 5.4 字体设置 说明浮动框、交互式表面和突出显示等基于位置的对象依赖于 SAP 中预定义的字体属性;使用不同的设置可更改界面 的布局。在录制模拟和后续在用户计算机上回放模拟时需要使用相同的设置,以确保对象始终能够正常显示。 要在 SAP 系统中调整字体,请转至 SAP GUI 中的字体设置: 字体设置 可以在视觉设计 -> 字体设置下调整设置。 5.5 SAP ECC 页面键值中的页面标题 在 SAP ECC 录制中,高级系统信息可能包含在页面键值中(比如:WA1(1)/000 SAP 轻松访问而不是 SAP 轻松访 问)。若执行重新录制或回放导航,可能会造成页面识别错误。为避免页面键值的附加信息,应在操作系统的注册表 中进行以下调整: 1. 12 用运行… 对话框命令 regedit 打开注册表编辑器。 2. 3. 4. 重启您的 SAP 系统以使注册表项生效。 5. 将注册表中的值改为 0。因此您可以取消激活标题信息的显示。 注释 只有管理员才能更改操作系统的注册表。 13 6 通过链接打开各个工作区 Instant Producer 使用缺省情况下预定义工作区管理资源和项目。如要使用备选工作区,可直接链接到该工作区并在 Instant Producer.中打开该工作区。为此,需要为该链接分配一个初始参数。操作步骤如下: 1. 2. 3. 4. 可添加任意数量的链接。请记住为每个链接指定唯一的名称,以便于正确分配初始参数。 computername - 计算机名称 userprofile - 用户参数文件目录的路径 14 7 连接 Manager SAP Workforce Performance Builder Manager 是基于服务器的生产环境,支持作者组。资源和学习单元在中央工作 区保存、集中和管理。 注释 Manager 并不是 Instant Producer 标准性能范围的一部分,且需要单独获得许可。您可以在客户顾问处获取 更多详细信息。 Manager 中的前提条件 Manager 在将 Instant Producer 连接到 Manager 之前,需要确保满足某些前提条件: 需要为项目和资源的管理设置中央工作区,且 Instant Producer 可以对其进行访问。 需要在 Manager 中设置要使用 Instant Producer 的用户并为这些用户分配所需作者权限。 如果已在 Manager 中预先定义项目,则必须将这些项目分派给相应作者。之后,这些作者才能够在 Instant Producer 中工作时通过获取项目.. 功能自动下载产品。 注释 可以在为该模块提供的帮助文档里获取有关 Manager 的其他详细信息。 7.1 建立连接 当用户登录到 Manager 时,将在工作区屏幕中看到连接 Instant Producer 选项。单击此按钮后,可启动名为 connection.managerConnection 的文件。这是 Instant Producer 的连接文件,其中包含用于连接到 Manager 的所有 必要设置,这些设置与 Manager 环境、登录的用户以及所选工作区有关。 通过双击该文件,作者可通过登录对话框连接到 Manager。随后,系统会将所有可用的中央资源下载到本地工作区, 以便使连接到 Manager 的 Instant Producer 接收相同的资源和设置。更新 Manager 上的可用资源时,Instant Producer 将在下一次启动后自动下载更新后的版本。 15 8 技术支持 请使用 SAP Service Marketplace 上的 SAP 事件向导来提交以下组件的相关事件: 要访问 SAP Support Portal,您需要一个 S-用户标识和密码。您可以从 SAP 超级管理员那里请求访问数据,或者 在 SAP Service Marketplace 上的注册下进行在线注册。 如果您要使用支持应用程序(事件向导、许可密钥请求、系统数据维护、管理远程连接、软件下载等),您需要从 SAP 超级管理员那里获得相应授权。 您可以在支持门户主页上的了解更多下找到新用户和支持应用程序的相关信息。在这里,您还可以通过注册方式获 取 SAP Support Portal 的个人概览演示。 如对 SAP Service Marketplace 有任何疑问,请联系当地客户交互中心。 可在 http://support.sap.com/contactus 上获取一个在线 Web 表单。所有与当地客户交互中心进行的书面沟通都 应使用此表格。可在以下位置找到与事件处理、支持地址、热线号码有关的更多详细信息: http://service.sap.com/sap/support/notes/560499 16 您是否希望通过 SAP Support Portal 进行浏览?注册在线演示。">
/
İndir
Sadece dostça bir hatırlatma. Belgeyi buradan görüntüleyebilirsiniz. Ancak en önemlisi, yapay zekamız zaten okudu. Karmaşık şeyleri basit terimlerle açıklayabilir, sorularınızı herhangi bir dilde yanıtlayabilir ve en uzun veya en karmaşık belgelerde bile hızlıca gezinmenize yardımcı olabilir.
Reklam