Toad
Using the Schema Browser
The object types that display in the left panel depend upon the database version.
All the tabs that show in the details panel are details for the selected object.
The vertical splitter between the objects panel and the details panel can be moved left or right via click and drag.
Any Schema Browser Object can be dragged and dropped into the SQL Editor.
You can also drag and drop multiple objects using multi-select (<CTRL> Click).
Schema Browser options let you control how the object types will be displayed.
You can choose a tabbed interface, an alphabetized dropdown, or a tree view.
The default is a tabbed interface. You can always show or hide tabs (for the tabbed view) or nodes (for the tree view) through the right-click menu.
When viewing Packages and Procedures, you might see "wrapped" rather than the code of the object. This means that the procedure was compiled using the
Oracle wrap utility and is not stored in readable format.
Object Lists
Right-click in the tab area of the objects panel (the left-hand side of the window) to display a menu that lets you show/hide individual tabs. You can show/hide individual tabs. However, you cannot hide the Tables tab. If you only want Views and Synonyms, deselect the rest for a cleaner interface. When you exit, Toad saves your options.
All the left-hand side Object lists (except Favorites) are multi-select enabled.
Icons are also displayed on the left panel tabs and dropdown items. If you don’t want to display the icons, you can turn them off with the Browser Style dropdown on the right panel (Show LHS Images).
In the non-tree view all the Object lists (left-hand side) can be sorted without requerying the database by clicking the column header.
In the non-tree view, all the objects in the list (left-hand side) have micro-help.
For example, hover the mouse over a table and it will display the tablename and the tablespace.
You can double-click an object in the left-hand side list to get to the alter screen for the selected object.
You can press <F4> in the left-hand side lists to get describes for objects that have describes.
160
Schema Browser
In the left-hand side you can select an item and show the popup menu in one action, a right-click.
In the tabbed and tree view modes, you can right-click on the column header and choose more than one column to display. You can sort by any column.
Autosize is configured separately for each Schema Browser tab. Autosize and the column selections and widths are remembered.
161
Toad
Configure Browser Tabs window
The right-click menu in the tab area also includes a Configure menu item which invokes the Configure Browser Tabs window that lets you show, hide, rename and rearrange tabs. This does not affect the alphabetized dropdown list which displays if you have chosen to display the categories in a dropdown by unchecking the Tabbed Schema Browser option.
The Configure Browser Tabs window has a Tab column that lists the actual category names and an editable Caption column that lists the captions Toad is currently displaying for the tabs. You can rename these captions by simply clicking in a caption cell and typing.
In addition, you can rearrange the order of the tabs by clicking in the gray box on the far left of the row of the item you wish to move and dragging the row to its new position on the list. Or you can select a tab or caption cell and click the
Up Arrow or Down Arrow in the window to move the whole row up or down in the list.
The right-click menu in the tree view display lets you configure which nodes of the tree view to show or hide.
Panels Right-Click Menus
The Schema Browser panels contain right-click menus. Many of the pages, such as Tables and Views, have enhanced right-click menus that contain menu items for all the buttons on the objects panel and details panel of the page.
Compare with another object
The Compare with another object right click menu item opens a new Single
Schema object Compare window whenever one or two objects are selected. The menu item is available on all tabs except Constraints, Synonyms, System
Privileges, and Types.
162
Schema Browser
Navigation
When you first open the Schema Browser, the Tables tab is selected by default, and a list of all the tables in the selected schema displays.
The dropdown box above the Object tabs lets you select the desired schema.
If you want to narrow the list of schemas in the schema dropdown list you have two choices, Only show users that own objects in dropdown lists and
Oracle Users List. For details about "Show only schemas that own objects" see the Schema Browser options. To set up a specific list of Oracle users (schemas) that you want to see, select menu item View | Oracle Users List. This opens the Configure User Lists dialog where you can multi-select any combination of users you want to see. This list is saved and restored in a file named schema_databasealias.lst, e.g., SCOTT_ORA8I.LST, in the Toad\User Files folder. From that point forward, any dialog in Toad that presents a schema dropdown list will be restricted to the schemas you select, e.g., the "Table Name
Select" dialog or the "Column Name Select" dialog.
If an Object tab doesn't contain any objects, the Object tab window will be empty for that tab.
The Item History button has a dropdown that contains a list of the most recent object list items that you selected. The history is remembered by connection and can be restored between sessions if the corresponding option is checked on. You can select one of the items to return to it. The number of items the history retains can be set in the Schema Browser options.
The Change Active Session button has a dropdown button next to it. Its dropdown list displays all active sessions. You can click on a session from the list to change the active session. If you want to create another session, click the change active session button. It will bring up the "Select Session" dialog where you can then click the NEW button to create the new session.
The status panel shows what session you're in. The CNT on the status panel shows how many objects are in the object list for the object tab you've selected.
Refresh All
The Refresh All button refreshes everything in the Schema Browser. If you create a table and you don't see it in your table list, click Refresh All which will requery, and the table name should display in the list, subject to any active table filters.
Refresh Current List
The Refresh current list button refreshes the objects panel (left panel) list.
163
Toad
Refresh Detail
The Refresh Detail button refreshes, or requeries, only the details panel. If you dropped a column, you can click on the Refresh Detail button to see the refreshed list.
Clear all data grid filters
A button also lets you clear all data grid filters.
Filter
• When the filter is red it's ON.
• When the filter funnel is gray it's OFF.
• When there are no filters, the filter is gray and it's OFF.
On the Schema Browser page Tables | Data tab and Views | Data tab, a four-way filter button displays a dialog where you can sort and/or filter. The filter can display four states: empty, filtered, ascending/descending filtered, ascending/descending empty.
Here, the data is sorted ascending/descending but not filtered.
Schema Browser Icon Legend
This button opens the Icon Legend for the Schema Browser. It initially opens with the node expanded for the active Schema Browser page. You can expand and collapse individual nodes or all nodes.
Browser Style dropdown
Menu items let you choose from the following styles: Dropdown, Tabbed
(multi-line), Tabbed (single row), and Treeview. You can also check to show left hand side images and/or left hand side hints. The Configure Object Types item displays the Configure Browser Tabs window.
Object name and Date created/altered
The object name (and the date created/altered if available) displays on the top of the details panel for all object types.
Quickfilter
164
Schema Browser
The Quickfilter edit box (below the schema dropdown for the tabbed and dropdown views) is a client-side filter that filters all Schema Browser object lists without requerying the database. It works in conjunction with existing browser filters. Wildcards such as *, ?, and % are accepted. It will not work in the
Favorites tab or the treeview. It keeps a history of the last 25 items, with the most recent one first. You can right-click on the Quickfilter to see the history, clear the history, or clear the filter.
165