Chapter 5. Creating your own reports. Sage 2015
Oglas
Oglas
Chapter 5. Creating your own reports
This chapter describes how you create your own reports with HandiSoft programs.
You can use the Report Designer to create customised reports and forms. You are able to:
Customise forms that you will send to third parties (such as cheques, receipts, deposit slips and statements).
Copy and then modify existing reports and forms (See “ Tutorial - beginners ” on page 51)
Create your own reports and forms (See the " Tutorial - intermediate " on page 54).
To get the most out of the HandiSoft Report Writer, we recommend that you work through the
Beginner and Intermediate Tutorials in that order.
Please note that there may be slight variations in the procedures covered in the tutorials for the different HandiSoft programs. For more information, refer to the user manuals for the programs.
Some definitions
Tables
A table is a collection of records. A table is similar to the drawer of a filing cabinet that is filled with folders. The major table would be the Client Table.
Records
Within a filing cabinet drawer, you will find a number of folders. The folder is effectively the record within a table.
Example: Each client within the Client Table forms a record. Two records in the
HandiSoft Client Table could be (a) Brown, William Joe and (b) Smith, Mary Sue.
Fields
Each record within a table contains a number of fields. In the above diagram, notice how each record has the same fields available to it; however the value of each field can vary from record to record.
Components of a report
Before you can create a meaningful report, you must understand how a HandiSoft report works and where each piece of information comes from.
A HandiSoft report is made from the following components.
Filter expression (optional)
© HandiSoft Software Pty Ltd
47
Chapter 5. Creating your own reports
Page setup
Report bands
Report cells
Report fields and report functions
Advanced Features 2015
Filter expression
A filter expression states the selection criteria that a record must meet if it is to be included in the report. A filter expression takes the form of:
Field@Table = Value
When a HandiSoft program produces a report, it will examine each record within a table and ensure that each record meets the criteria of the filter expression.
Example:
Our report is to contain information ONLY for the client reference code BROW0002. The filter expression we would use would be:
Ref@Clients=BROW0002
When the HandiSoft program produces this report; it will evaluate every record in the
Clients Table as follows:
IF Ref@Clients=BROW0002, is true
THEN include this record in the report.
Page setup
Each report must be associated with a page setup. The page setup specifies the paper size and paper orientation on which the report will be printed. The page setup assigned to a report affects the amount of space that is available for the bands and cells of the report. Therefore, we recommend that the page setup be assigned to a new report before you begin to create report bands and cells.
Report bands
A report is broken down into a number of different sections called bands.
Each band within a report can be assigned a number of different settings and conditions. The details of each band are specified in the “Band Details” window.
48
Figure 17: The "Band Details" window
© HandiSoft Software Pty Ltd
Advanced Features 2015 Components of a report
Tip: For information on the "Band Details" window, press F1 to display the online help.
Report bands - example
Illustrated below is a Clients List Abbreviated report, as it would appear in the “Report Preview” window. The various bands of the report have been highlighted. Notice the middle section of the report relates to three different Bands.
In the Report Designer, this is how the Clients List Abbreviated appears. Notice the report cells that are contained within the various bands (for example, “TFN”).
Figure 18: The “Report Designer” window
Tip: For information on the "Report Designer” window, press F1 to display the online help.
Report cells
Report cells are contained within report bands to add information into your report. If no report cells exist, then nothing will print out when the report is run. Bands form the report structure while cells form the report contents.
Each cell can be assigned a number of different settings and conditions. The details of each cell are specified in the “Cell Details” window.
© HandiSoft Software Pty Ltd
49
Chapter 5. Creating your own reports Advanced Features 2015
Figure 19: The "Cell Details" window
A report cell may contain any of the following:
Text, which you have specified. All text must be in quotation marks (“ “). Any report headings would be specified in this manner.
Fields. For example Ref@Clients, this would print the client reference code for each record within the Clients table.
An Image. You can specify an image file for the image to appear in the report cell.
RTF (Rich Text Format) text. You can create and load formatted text to appear in the report cell.
Tip: For information on the "Cell Details" window, press F1 to display the online help.
Report fields and report functions
Report fields and functions are used to extract information from the HandiSoft database to be included in your report.
Example:
Ref@Clients is a HandiSoft FIELD
GetClientNotes(Ref@Clients) is a HandiSoft FUNCTION
The report fields and functions available depend on the data table the report is able to access.
The report fields and functions that are available for you to use are all listed within the HandiSoft
Report Designer. This information may be accessed from within the Report Designer as follows:
From the Help menu, click HandiSoft and then Functions.
From the Help menu, click the HandiSoft program name and then Functions.
From the Help menu, click the HandiSoft program name and then Fields.
50
© HandiSoft Software Pty Ltd
Advanced Features 2015 The RTF editor
The RTF editor
The “Cell Details” window has an inbuilt RTF (Rich Text Format) editor, which you can use to insert formatted text into reports. You can use the “Cell Details” window to generate the RTF text, or you can load RTF text created in another report or with another RTF editor such as
Microsoft Word.
Creating RFT text
1. In the “Report Designer”, open the “Cell Details” window to create a new cell or edit an existing one.
2. Under Cell Type, select RTF.
3. Under Data Source, select Fixed Text.
4. In the text area, type in your text, as required. Use the toolbar above to select the font and to format the text.
Figure 20:The RTF text area
5. If you want to save your RTF text for use in another report cell, click and specify the location and file name for the saved text.
6. Click OK to close the “Cell Details” window.
Loading RTF text
You can load previously saved RTF text into a report cell. This text could have been generated with the “Cell Details” window RTF editor, or with another RTF editor like Microsoft Word.
1. In the “Report Designer”, open the “Cell Details” window to create a new cell or edit an existing one.
2. Under Cell Type, select RTF.
3. Under Data Source, select Fixed Text.
4. On the tool bar above the RTF text area, click .
5. Select the file with the RTF text and click Open.
The saved RTF text will appear in the RTF text area.
6. If necessary, edit the text.
7. Click OK to close the “Cell Details” window.
© HandiSoft Software Pty Ltd
51
Chapter 5. Creating your own reports Advanced Features 2015
Tutorial - beginners
The easiest way to create your own report is to alter an existing report so that it meets your firm’s requirements. The procedure is as follows:
1. Determine which of the existing reports is closest to the report that you wish to create.
2. Copy the existing report to a new report name.
3. Modify your newly named report to achieve the desired report.
4. Run the new report.
For this tutorial, you will modify the report “Clients List Abbreviated” so that
TFN is displayed before the Client Reference. You will also increase the width of the Client Reference column.
The Clients List Abbreviated Report currently looks like this:
Copy the existing report
Now that you know the “Clients List Abbreviated” is the closest to the report you want to generate, you must copy the report to a new name. The procedure is as follows:
1. From the Reports menu, click Edit Reports to open the "Report Writer" window.
2. Click Find.
3. In the “Find Name” window, type "Clients List Abbreviated" and then click OK.
4. With the “Clients List Abbreviated” report highlighted, click Copy.
Figure 21: The “Copy Report/Form” window
5. Specify the name of your new report. Type "Tutorial - Clients List Abbreviated".
6. Click OK.
You should now be highlighting a report with the name “Tutorial - Clients List Abbreviated”.
Modify the new report
Once you have copied the existing report to a new name, you can modify the report to achieve the desired result.
1. You should be in the "Report Writer" window with the report “Tutorial - Clients List
Abbreviated” highlighted.
2. Click Design. The “Report Designer” window will open.
52
© HandiSoft Software Pty Ltd
Advanced Features 2015 Tutorial - beginners
Figure 22: The “Report Designer” window
3. Take a few minutes to look at the bands of your report.
Notice that the HeaderBand contains column headings, and the MasterBand contains fields.
If you are going to swap the Reference and TFN columns, you will need to also swap the corresponding columns in the Masterband.
4. First, you will switch the position of the “Reference” and “TFN” cells within the HeaderBand.
This is done as follows:
Double-click the
TFN cell. The “Cell Details” window will open. In the Alignment Style field, select a blank alignment style and then click OK.
The TFN cell will move to the left of the band and will partially obscure the "Reference" cell.
Tip: The Alignment Style was originally “Right Edge”. This forced the cell to be at the far right of band, and would prevent you from dragging the cell to a location that was not at the right of the band.
Position the mouse over the section of the “Reference” cell, which you can still see.
Left-click on the Reference cell. This will bring the Reference cell to the foreground, and will turn the cell green.
With the mouse positioned over the Reference cell, drag the cell into the correct position.
Notice that there is a gap between the “TFN” and “Name” cells. Click on the "Name" cell and drag it to the left to eliminate this gap.
5. Now that you have switched the column headings around, it is time to switch the columns.
The detail of your columns is stored in the MasterBand. Switch the “Ref@Clients” with the
“TfnStr@Clients” cell. The procedure is the same as in Step 4 (above).
6. To check the appearance of the report, from the Report menu, click Execute.
Tip: Execute the report regularly. It is far easier to track down and resolve a mistake if you have made only a few changes.
© HandiSoft Software Pty Ltd
53
Chapter 5. Creating your own reports Advanced Features 2015
7. You want to widen the Reference column. You will also need to shorten either the “Name” or the “TFN” cell. For this tutorial, you will shorten the "Name" column. We will need to adjust the size of both cells in both the Header Band and the MasterBand.
To shorten the "Name" cell in the HeaderBand, click the “Name” cell. The cell will turn green. Position the mouse pointer over the right border of the cell. Hold down the left mouse button. The mouse pointer will change to a two-headed arrow
Once you have the two-headed arrow, keep holding down the left mouse button, and move the mouse to the left. The cell will begin to shrink. Reduce the cell by approximately the width of the mouse pointer and then release the mouse button.
As a result of shortening the “Name” cell, a gap will exist between the “Name” and
“Reference” cells. Increase the size of the “Reference” cell and remove this gap.
8. You must now resize the “TfnStr@Clients” and “Ref@Clients” cells in the MasterBand.
You could use the same technique as above. However, to be sure that your column headings and your cells line up, you must specify precisely where the cells are to be displayed on your screen.
To resize the “Ref@Clients” field, simply:
Double-click the “Reference” cell within the HeaderBand. The “Cell Details” window will open. Note the values in the Left and Width position fields of this window. Click OK.
Double-click the “Ref@Clients” cell. The “Cell Details” window will open. In the Left and Width position fields, enter the figures, which you recently noted. Click OK.
Notice that the cell has altered its position.
Use the above procedure to resize the “Name” / “TfnStr@Clients” cells.
9. To check the appearance of the report, from the Report menu, click Execute.
10. Remember to save the report as you exit from the Report Designer.
Running your report
The procedure to run your report is different for all HandiSoft programs. Please refer to the manual for the program you are using.
Tutorial - intermediate
To gain an understanding of how reports work we recommend that you create your own report.
To get you started, this section will walk you step by step through the creation of a Client
Telephone List.
We strongly recommend that you plan a report before you begin to create it. This could save you considerable time later.
Plan the report
Sketch out how you want the report to appear. Make sure your sketch displays the placement of various report items, such as headings, page numbers, totals etc.
Note the areas of the report that are to be repeated record by record.
For this tutorial, we wish to create a report with a similar appearance to the following:
54
© HandiSoft Software Pty Ltd
Advanced Features 2015 Tutorial - intermediate
When creating a report, it is important to consider the following:
Portrait or Landscape
Information to appear at the TOP of each page.
Information to appear at the BOTTOM of each page.
Information to display on the LAST page ONLY.
Will a single record in the report take up multiple lines?
What totals will be required?
Will the report use a filter expression?
In what order is the report to be displayed?
Portrait or landscape
A landscape report can fit more details for each client across the page. However, the total number of clients that you can fit on a landscape page is less than the number you could fit on a portrait page.
For this tutorial, we will print the Client Telephone List in landscape.
Information to appear at the Top of each page
Each page of your report is to display a report name, page, date and column headings.
The date will be useful when new Client Telephone Lists are printed for your firm. Having a date on the report will let you determine which lists are out of date.
Information to appear at the BOTTOM of each page
At the bottom of each page of the report, we require a horizontal line.
Information to display on the LAST page ONLY
The last page will display the total number of clients included in the report, followed by a horizontal line.
Will a single record in the report take up multiple lines?
Your preference is to have each record taking up a single line in the report. However, you need to consider the number of characters that will be printed for each field. Is all of your information going to fit? If the information is too wide, you could:
Reduce the amount of information included in the report; or
Print the report in a landscape format; or
Print two or more lines for each record.
What totals will be required?
Do you only require a total at the end of the report, or will a total be required at the end of each record?
For this tutorial, you will display the total number of clients on the last page of the report only.
No other totals will be required.
© HandiSoft Software Pty Ltd
55
Chapter 5. Creating your own reports Advanced Features 2015
Will the report use a filter expression?
The report will be printed:
For all clients; and
By Partner (This is a field within the Client database). A filter expression will be used to achieve this.
In what order is the report to be displayed?
This report could be ordered either by Client Reference Code or by Surname. Which will be more useful to your firm? For this tutorial, you will order by Reference. If you wish to order by
Surname, you might like to create the report with your columns in a different order.
Set up the Report Designer
Before you can start work on a report, you must first define the report name and complete the initial settings for the Report Designer. Do the following:
1. From the
Reports menu, click Edit reports to open the "Report Writer" window.
2. Click
New.
3. Enter the following information:
Field Information to enter
Name
Type
Tutorial - Client Telephone Listing
Select the sub-menu from which the report is to be accessed. For example, in HandiTax you would select Client to access the report via the
Client sub-menu.
4. Click Save.
5. Click Design. The “Report Designer” window will open. You will use this window to create the report.
6. Before you start creating bands and cells, you must specify the page setup to be used when the report is printed. The paper size dictates if the report will print in portrait or landscape.
Do the following:
From the Report menu, click Edit. The "Report Details” window will open
56
Figure 23: The "Report Details" window
© HandiSoft Software Pty Ltd
Advanced Features 2015
Enter the following information
Field Information to enter
Page Setup
Initialisation
Wide
Count = 0
Tip: You must enter this information to create and initialise the variable “Count”. This variable will be incremented every time the program prints a client in your report. At the end of the report, you will use this value to print the total number of clients.
Click
OK.
Tutorial - intermediate
Create the report
You are now ready to create the bands and cells for the report. Work through the following sections in order:
1. Create the Header Band.
2. Add the date of printing.
3. Add the report title.
4. Adding column headings.
5. Create the MasterBand
6. Add cells to the MasterBand
7. Create the PageFooterBand
8. Add cells to the PageFooterBand
9. Create the GrandTotalBand
10. Add cells to the GrandTotalBand
Create the Header Band
Generally, the first Band displayed by a report will be the Header Band. Information within this band will print at the top of each page of the report. From your initial planning, you will see that you require the following items to appear at the top of each page:
Report name
Date
Page number
Column headings
To create the HeaderBand:
1. From the Band menu, click New. The “Band Details” window will open.
2. Enter the following information in the "Band Details" window.
Field Name Complete with
Name
Parent
Height
HeaderBand
Reporter
All bands must have a parent. 'Reporter' is the top level.
0.
The Height of the band will be determined by the cell contents.
© HandiSoft Software Pty Ltd
57
Chapter 5. Creating your own reports Advanced Features 2015
Field Name
Type
Force Break
Immediate
Page Number Width
Show Total Pages
Complete with
Header
This band will appear at the top of each page in the report.
Cleared.
There is no need to force a page break before this band because it is the first band in the report.
Selected.
The band will be displayed immediately. If this check box is cleared, the band will only be displayed after the first page.
300.
The page number will be displayed in a 3 cm wide cell.
Selected.
The page number display will include the total number of pages in the report.
3. Leave the remaining fields blank
4. Click OK
Add the date of printing
See your original plans for the report. You want to display the date of printing above the page numbers. To create this cell:
1. Click in the HeaderBand. The border around the band will turn red, indicating that the band has been selected.
2. From the Cell menu, click New. The “Cell Details” window will open.
3. Enter the following information:
Field Data to enter
Cell Type Text
Cell Position: Width Left = 0
Top = 0
Width = 500
Height = 30
Cell Value
Justification Style
FullDate(Today)
Tip: To locate the correct syntax to use, from the
Help menu, point to HandiSoft, and then click
Functions.
LeftJustify
4. Click OK.
Add the report’s title
Tip: For information to display for a particular band, that band must contain cells. Before you can add cells into a band, you must select the relevant band.
58
© HandiSoft Software Pty Ltd
Advanced Features 2015 Tutorial - intermediate
To add the title to your report:
1. Click in the HeaderBand. The border around the band will turn red, indicating that the band has been selected.
2. From the Cell menu, click New. The “Cell Details” window will open.
3. Enter the following information:
Field Information to enter
Cell Type
Cell Position
Cell Value
Font
Text
Left = 0
Top = 40
Width = 1696
Height = 30
“Tutorial – Client Telephone Listing”
Tip: Be sure to enter the quotation marks.
Any text that you want to display must be enclosed in quotation marks.
Body Text
Bold = selected
4. Click OK.
Add column headings
Cells need to be created for each of your column headings. To create the column heading
“Reference”:
1. Click in the HeaderBand. The border around the band will turn red, indicating that the band has been selected.
2. From the Cell menu, click New. The “Cell Details” window will open.
3. Enter the following information:
Field Information to enter
Cell Type
Cell Position
Cell Value
Justification Style
Border Style
Text
Left = 0
Top = 100
Width = 300
Height = 30
“Reference”
LeftJustify
Horizontal lines
4. Click OK.
5. Repeat the above procedure for the following column headings. While you can manually
resize each cell (see “ Tutorial - beginners ” on page 51), we have made your job easier by
providing specific sizes for each cell.
These are:
Column heading
“Reference”
“Client Name”
“Casual Name”
“Business”
“Fax”
“Mobile”
Left
0
265
1265
1665
1965
2265
Top
100
100
100
100
100
100
Width Height
300 30
1000 30
400 30
300
300
300
30
30
30
6. Execute the report regularly to ensure that no errors have been made.
© HandiSoft Software Pty Ltd
59
Chapter 5. Creating your own reports Advanced Features 2015
Create the Master Band
The Master Band will create the detail of your report. The Band will need to be executed for each record in the Client Database. Because of this, the Band will be established as a
Looping
Band. For each Client, the following information is to appear in our report:
Client reference
Client name
Casual Name
Business Number
Fax Number
Mobile Phone Number
The first three items are database fields, while the remaining three are functions.
To create the Master Band:
1. As you do not want the MasterBand to be a child of the HeaderBand, click a space in the
"Report Designer" window that is not inside any band.
2. On the “Database Toolbar” window, under Bands, double-click on Clients. This will create a new band.
60
Figure 24: The "Database Toolbar" window
Tip: If necessary, from the View menu, click Database Toolbar to display the
“Database Toolbar” window.
3. Click on the newly created band so that it turns red. From the
Band menu, click Edit. The
"Band Details" window will open.
Tip: The Parent field should state “Reporter”. If it does not, step 1 has not been correctly performed.
4. Enter the following information:
Field Information to enter
Name
Height
Type
MasterBand
0
Looping
© HandiSoft Software Pty Ltd
Advanced Features 2015
Looping List
Looping Conditions – field 1
The band will execute for every record in the table selected in the Looping List field. In this example, it is the 'Clients' table.
Clients
The band will loop through every record in the
'Clients' table.
Leave blank.
The 'while' loop will not have any additional conditions.
Looping Conditions – field 2
Leave blank.
There is no expression to satisfy in order to start the loop.
Band Code – field 1 Leave blank.
There is no pre-band code to execute.
Band Code – field 2 #ClientExpression
Tip: Insert #ClientExpression here to only print the client record if client passes the Filter Expression, which the user specifies prior to generating the report.
Band Code – field 3 Leave blank.
There is no post-band code to execute.
Cell Code – field 1
Leave blank.
There is no code to execute before the cells are processed.
Cell Code – field 2 Count = Count + 1
This code is executed after the cells in each band iteration are processed. The 'Count' variable keeps track of the number of band iterations so that the total number can be inserted at the end of the report.
5. Click
OK.
Tutorial - intermediate
Add cells to the Master Band
You must add six cells into the MasterBand.
Three of the cells have a field as the
Cell Value, so you can use the “Database Toolbar" window to insert them.
1. Click on the MasterBand so that it turns red.
2. On the “Database Toolbar”, with Clients highlighted under Bands, under Cells, doubleclick
Ref. This will automatically create a cell with a Cell Value, Ref@Clients.
3. Create another two cells by repeating the previous step and double-clicking the following values on the “Database Toolbar” window, under Cells.
Cells Cell Value
NameStr
Casual
NameStr@Clients
Casual@Clients
4. Edit the new cells as follows:
Tip: After creating each cell, execute the report to ensure no errors have been made.
Cell Type – No amounts are being printed in this report. Consequently, create each cell with a cell type of 'Text'.
Cell Position – While you can manually resize each cell (see “ Tutorial - beginners ” on
page 51), we have made your job easier by providing specific sizes for each cell.
These are:
© HandiSoft Software Pty Ltd
61
Chapter 5. Creating your own reports Advanced Features 2015
Cell
Client reference
Client name
Casual name
Left Top Width Height
0 0
265 0
1265 0
265
1000
400
30
30
30
Wrapping – select this setting for every cell. The result is that, if the cell information does not fit within the dimensions of the cell, that information will carry down to the next line.
5. The remaining three cells have a function as the Cell Value. Create them by right-clicking in the MasterBand and clicking New Cell. Enter the following values for each cell on the “Cell
Details” window.
Cell Value Cell
Type
Left Top Width Height
GetPhoneNumber(Ref@Clients, “B”) Text 1665 0
GetPhoneNumber(Ref@Clients, “F”) Text 1965 0
GetPhoneNumber(Ref@Clients, “M”) Text 2265 0
300
300
300
30
30
30
Create the page Footer Band
At the bottom of each page, you require a horizontal line. This footer band must have the
MasterBand as its Parent Band; otherwise, the horizontal line will appear only on the last page of your report.
The reason for this is that when the report is executed, the HandiSoft program will find the
Looping Band and will keep looping through the Clients Table until all relevant records have printed in the report. The entire Clients Table will be looped before the Footer Band is executed. If your Footer Band is created with the MasterBand as its parent, each time the
HandiSoft program loops through the Clients Table, it will execute both the MasterBand and the
FooterBand.
To create the Footer Band
1. As the FooterBand must be a child of the MasterBand, click a space within the MasterBand.
2. From the Band menu, click New. The "Band Details" window will open.
Tip: The Parent field should state “MasterBand”. If it does not, step 1 has not been correctly performed.
3. Enter the following information:
Field Information to enter
Name
Height
Type
PageFooterBand
0
Footer
4. Click OK.
Add cells to the PageFooterBand
A single cell is to be added to your PageFooterBand. This cell will take up the full width of the page and will contain a single horizontal line.
To create the cell
1. Click in the PageFooterBand. The border around the band will turn red, indicating that the band has been selected.
2. From the
Cell menu, click New. The “Cell Details” window will open.
3. Enter the following information:
62
© HandiSoft Software Pty Ltd
Advanced Features 2015 Tutorial - intermediate
Field Information to enter
Cell Type Basic
Cell Position: Width Left = 0
Top = 0
Width = 2565
Height = 30
Border Style BottomLine
4. If required, use the mouse to manually adjust the position of the cell.
5. Click OK.
Create the Grand Total Band
Finally, the last page of your report is to display the total number of clients included in the report. You must create a new band, the GrandTotalBand, with the following details:
Field Information to enter
Name
Parent
Height
Type
GrandTotalBand
Reporter
Note: The parent must be Reporter and not
ReportBand so that the total is not displayed with the master band information.
Tip: For the Reporter to be the Parent band, before creating the band, you must click a section of the report that is outside all bands.
0
Normal
Add cells to the GrandTotalBand
Two cells must be added to the GrandTotalBand:
1. Horizontal Line. Enter the following information into the “Cell Details” window.
Field Information to enter
Cell Type Basic
Cell Position: Width Left = 0
Top = 0
Width = 2565
Height = 30
Border Style BottomLine
2. Number of Clients. Enter the following information into the “Cell Details” window.
Field Information to enter
Cell Type Text
Cell Position: Width Left = 0
Top = 30
Width = 600
Height = 30
Cell Value "Client Count: " + Count
Tip: You established and initialised the “Count”
variable in “ Set up the Report Designer ” on page 56.
© HandiSoft Software Pty Ltd
63
Chapter 5. Creating your own reports
Changing fonts and page set-ups
Advanced Features 2015
Using font styles in reports
To adjust the fonts used by various reports, edit the report as follows:
1. From the Reports menu, click Edit Reports.
2. Highlight the report to modify and click
Design.
3. Double-click in the cell to be modified.
4. In the "Cell Details" window, under
Font, select the required font style.
5. Click OK and then, from the Report menu, click Exit.
Standard reports cannot be modified. However, you can copy the report to a new name and then edit the newly created report. This is done as follows:
6. From the Reports menu, click Edit Reports.
7. Highlight the report layout to copy.
8. Click Copy.
9. Specify the new report name.
10. Click OK.
11. Modify the new report as required.
Linking a page setup to a report
If you create your own page setup, you will need to attach it to the required reports. This is achieved as follows.
1. From the Reports menu, click Edit Reports.
2. Highlight the report to modify.
3. Click Design.
4. In the "Report Designer" window, from the Report menu, click Edit.
5. Modify the page setup as required.
6. Click OK.
7. From the Report menu, click Exit.
64
© HandiSoft Software Pty Ltd
Preuzimanje
Oglas