Chapter 11. Additional HandiSoft tools
This chapter provides detailed information on some useful tools that are included with the
HandiSoft programs
.
Use of the ENTER key
The standard for Windows programs is for the ENTER key to save and exit you from the current window, and the
TAB key to move you from field to field. To improve the speed of your data entry, you are able to define the behaviour of the numeric keypad ENTER key on the “Data
Entry Options” ( Options / Data Entry) window.
Copying, cutting and pasting
Within the HandiSoft programs, you can use the Windows Clipboard. This allows you to:
Copy/Cut information from a data entry field into the clipboard
Paste information from the clipboard into a data entry field
To copy an item onto the clipboard, highlight the desired information and press CTRL + C to
copy the information to the clipboard. You may then use CTRL + V to paste the information from the clipboard. You may also use the right mouse button to copy/cut and paste information.
Right-click copying
On any of your HandiSoft programs, you can right-click on a client in the main “Clients” window and select to copy the client’s TFN, ABN, ACN, surname or Reference to the Windows
Clipboard.
The TFN, ABN and ACN are copied without any spaces. This enables you to paste them into the Tax Agent Portal window, which requires the numbers to be entered without spaces.
Keyboard shortcuts
Keyboard shortcuts are provided within the software, allowing the keyboard to be used instead of the mouse. Keyboard shortcuts can be great time savers and we encourage you to use them where possible.
© HandiSoft Software Pty Ltd
135
Chapter 11. Additional HandiSoft tools Advanced Features 2015
Tip: If you are creating macros to simplify your tasks, you will need to use hot keys and function keys to access menu commands because macros do not record mouse movements.
See “ Keyboard macros ” on page 137.
The keyboard shortcuts that you may encounter are:
Hot keys;
Function keys; and
Keyboard macros.
These keyboard shortcuts are discussed in more detail below.
Hot keys
One form of keyboard shortcut offered is hot keys. The secret to using hot keys is to look for the underlined letter in menu options and field names.
Example: Look at the Menu Bar. The letter “V” in View is underlined, indicating that "V" is a
Hot Key. Pressing ALT+V will access the View menu. Once you have pressed these keys, you will notice that the main View menu has been opened.
Function keys
Function keys are attached to the more commonly used menu options.
Example: In all HandiSoft programs, F3 displays or hides the list of clients or entities on the main window.
State from Post Code
On windows that require you to enter the State and Post Code, if you enter the Post Code, the
HandiSoft program will automatically determine the correct State.
Finding and ordering information
You can rapidly find a record, for example a client, prospective client, company or address book entry, by clicking the Find button in the respective window. This will bring up the “Find/Order” window.
To search for an item: under Order select the field on which you want to search, and then, in the Find field, enter the search text.
To change the order in which the items are listed: under Order, select the field by which the items are to be ordered.
The "History" window
If you press F11 while a data entry window is open, the "History" window will open, listing the data you have entered during the current session.
You can select an entry on the history list to be inserted into the field you are currently editing.
There are three ways of doing this
Highlight the entry on the list and click Select.
Type the number displayed in the Key column next to the required entry.
Double-click the required entry on the list.
136
© HandiSoft Software Pty Ltd
Advanced Features 2015 Keyboard macros
Keyboard macros
Macros are used to pre-record tasks that you perform frequently. Macros can be operated using a very small number of keystrokes, and may, therefore greatly reduce the number of keystrokes required to perform a certain task.
Creating a macro
There are two ways of creating a keyboard macro. You can either simply record the keystrokes that make up the macro, or you can enter the macro steps directly.
To record a macro
Caution: When recording a macro, it is important that you begin recording from within the HandiSoft program window that the macro will be played from in the future. If you play the macro from a different area of the program, it will not run or, worse yet, you may inadvertently delete data.
Tip: Macros will only record keystrokes. They cannot record mouse movements. You, therefore, can only use the keyboard when recording a macro.
1. From the Tools menu, click Keyboard Macros. Alternatively, press the F12 key.
The “Macros” window will open.
Figure 90: The "Macros" window
The “Macros” window lists the names of existing keyboard macros with their associated key number.
2. Click the
Record button.
This will return you to the main program window. The title bar of the window will show "–
Recording Macro (F12 to Stop)".
Any keystrokes you make from now on will be
recorded in the Macro.
Tip: It is good practice to press your Esc key to be recorded as the first keystroke.
This will ensure that only the program main window is open when you run the macro.
3. Perform the task that you want the macro to record.
4. After you have completed the task that the macro is to perform, press the F12 key to stop the recording of keystrokes. The "Edit macro" window will open.
© HandiSoft Software Pty Ltd
137
Chapter 11. Additional HandiSoft tools Advanced Features 2015
Figure 91: The "Edit macro" window
The "Edit macro" window displays the steps in the macro. If necessary, you can make changes to them.
5. In the top right field, type a name for the macro.
6. Click Save to save the new macro, and Close to exit the "Edit macro" window.
Your new macro has been recorded.
Tip: For information on the "Macros" and "Edit macro" windows, press F1 to display the online help.
To create a macro directly
You are able to create a macro by directly entering the steps. This can be quicker than recording the macro.
1. From the Tools menu, click Keyboard Macros. Alternatively, press the F12 key.
The “Macros” window will open.
2. On the “Macros” window, click
New. The "Edit macro" window will open.
3. On the "Edit macro" window, enter the steps that make up the macro.
4. Click Save to save the new macro, and Close to exit the "Edit macro" window.
Run a macro
To run a macro that has been previously created, you must be at the location in the program where it was initially recorded.
To run an existing macro
1. Press the
F12 key or, from the Tools menu, click Keyboard Macros to open the "Macros" window.
2. On the “Macros” window, highlight the macro that is to be run.
3. Click the Play button or press Enter.
The program will replay the steps in the macro.
Tip: The quickest way to run a macro is to press Ctrl+Alt+<key number>. For example, to run a macro with a key number of 02, press
Ctrl+Alt+2.
Edit a macro
You are able to edit the steps in existing macros. This is very useful if you have recorded a macro and you want to change a single step without having to record the macro again.
138
© HandiSoft Software Pty Ltd
Advanced Features 2015 Copy a HandiSoft Index File
To edit an existing macro
1. Press the F12 key or, from the Tools menu, click Keyboard Macros to open the “Macros” window.
2. In the “Macros” window, highlight the macro that is to be edited and click
Edit. The "Edit macro" window will open, listing the steps in the highlighted macro.
3. To edit a macro step, highlight the step and, in the right pane, double-click the required action for that step.
4. To add a new step, place the cursor at the required step. (If necessary, press Enter to make a space.) On the right pane, double-click the required action for that step.
5. Click Save to save your changes.
6. Click Close to exit the “Edit macro” window.
To delete an existing macro
1. Press the F12 key or, from the Tools menu, click Keyboard Macros to open the “Macros” window.
2. In the “Macros” window, highlight the macro that is to be deleted.
3. Click Delete.
4. Click OK on to confirm the deletion.
5. Click Close to exit the “Macros” window.
Copy a HandiSoft Index File
All HandiSoft programs require an Index File, which is normally automatically installed from the installation CD. If the Index File does not exist, or if it is out of date, programs may not function.
Updating the Index File
Every now and then HandiSoft may notify you of or send you a new Index File. Whenever you receive a new Index File from HandiSoft, you should load the file onto your computer.
To load an Index File
1. From the Tools menu, click Copy a New HandiSoft Index File. The “Index File Update" window will open.
Figure 92: The "Index File Update" window
2. Select the source of your Index File.
If you are connected to the Internet, you can select Download and click OK to download your Index File from the HandiSoft server.
© HandiSoft Software Pty Ltd
139
Chapter 11. Additional HandiSoft tools Advanced Features 2015
If you have saved an Index File that you have received from us, click Copy and then
OK. Locate the Hs15.ind file and then double-click on the file.
The program will copy the file into the correct location on your network or computer.
3. When the new Index File has been successfully installed, you must restart the HandiSoft program for it to take effect.
Send email message
If you have e-mail access, you can easily create and send an email while you are using a
HandiSoft module.
1. From the
Tools menu, click Send Email Message.
Your default email program will open with a blank email message.
2. Complete all details and then send the email message.
Note: For further information, refer to the instructions you received with your email program.
Using the calculator
HandiSoft provides a handy calculator within all of its products, including HandiTax.
You can access the calculator tool directly from within the HandiSoft program either by using the shortcut keys
Ctrl + F7, or through the Tools menu.
To access the calculator via the Tools menu
From the Tools menu, click Calculator.
Figure 93: The "Calculator" window
Obtaining version and licensing information
The “About” window provides to following information:
The version of the HandiSoft program that you are running
The number of users currently running the program
The location on the drive or network where the program is installed
All the HandiSoft programs that your are licensed to run
The number of users licensed to run your HandiSoft programs.
140
© HandiSoft Software Pty Ltd
Advanced Features 2015 Obtaining version and licensing information
To open the “About” window
1. From the Help menu, click About.
2. To view version and location information, click the About tab.
3. To view your HandiSoft program licensing information, click the Licenses tab.
© HandiSoft Software Pty Ltd
141