Configuring the Web Client. Sage SalesLogix Sage SalesLogix 8.0
Reklama
Reklama
Chapter 8
Configuring the Web Client
Before beginning this chapter...
Use the instructions in this chapter to...
Configure the Sage SalesLogix Web Client. These tasks are required for all Sage
SalesLogix Web installations.
The Sage SalesLogix Web Client is highly customizable using the Application Architect. You can rapidly build, customize, manage, and deploy coded and codeless Web application solutions. After building and deploying the Web Client, you must configure various settings on the Host and Client computers.
For more information, refer to the “Common Tasks in Application Architect” topic in the Application Architect help.
Configuring Windows Authentication
Windows Authentication allows Web users to automatically log on to the Web Client using their Microsoft Windows logon credentials. This method uses a cryptographic exchange with the user's Web browser to confirm the identity of the user.
When Windows Authentication is enabled:
• Users do not see a Sage SalesLogix Web Client log on page.
• To enable users to log on as the administrator, you must configure a second Web Client implementation that does not include Windows Authentication.
Ensure the Use Windows Authentication check box is selected on the User Profile
General tab for each Web Client user. For more information see “Configuring Users” on page 64 .
To configure Windows Authentication you must:
• Configure the WebDLL user
• Configure your Web Server
• Configure your Web Client computers
The following instructions configure Windows Authentication for Web Client users to prevent logging on manually if the Windows user is not mapped to a user in Sage
SalesLogix. This method is referred to as “Forms”. It attempts to log the user on automatically but displays an error message if the user information is not found. For additional configuration scenarios, see the “Enabling Windows Authentication Access for Web Client Users” topic in the Administrator Help.
Sage SalesLogix Implementation Guide v8.0
75
Configuring the Web Client
Configuring the WebDLL User for Windows Authentication
You must configure the WebDLL user for Windows Authentication to allow the Sage
SalesLogix Web Client to open a connection to the Sage SalesLogix database. If you have not
already completed this task, see the steps in Chapter 5, “Installing the Web Components”
.
Configuring the Web Server
Use one of the following sections to configure Windows Authentication on your Web Server.
•
in the following section.
•
Windows 2003
The following instructions configure Windows Authentication for Web Client users on Windows
2003.
Windows Authentication requires the setspn.exe. For download information, go to www.microsoft.com and search on Windows 2003 Support Tools.
To configure
1. On the Web Server computer, log on as a domain administrator or as a user with rights to modify the Active Directory.
This user should be the Application Pool user.
2. Add permissions for Web Client users or groups.
a. In IIS, right-click the Application Pools folder, and then click Properties. b. Click the Identity tab.
c. Verify that the user indicated in the User name: box is the user logged in as the domain administrator or user with rights to modify the Active Directory.
3. Run setspn.exe to manually modify the service account's SPN information to run correctly with Windows Authentication.
Service Principal Names (SPNs) are used to locate a target principal name for running a service. The setspn.exe is included in the Windows 2003 Support Tools.
a. Open a Command Prompt window.
Do not use a colon or second forward slash in the following setspn commands.
Type the commands exactly as documented.
b. At the command prompt, type the following command. setspn -A http/server.domain.com domain\username
The server.domain.com is the fully qualified machine name, the domain is the Sage
SalesLogix domain, and the user name is the user that has rights to modify the active directory (this is the user specified in the application pool). Use the username created
in “Configuring Application Pool Permissions” on page 58 .
c. At the command prompt, type the following command. setspn -A http/server domain\username
The server is the machine name, the domain is the Sage SalesLogix domain, and the user name is the user that has rights to modify the active directory. Use the username
created in “Configuring Application Pool Permissions” on page 58
.
d. At the command prompt, type the following command. setspn -L username
76 Sage SalesLogix Implementation Guide v8.0
Configuring the Web Client
4. On the Web Server computer, add IIS permissions for Web Client users or groups. a. Open Internet Information Services (IIS) Manager.
b. Expand the Web Server computer name, expand Web Sites, and then expand the name of the Web site where you deployed the Sage SalesLogix Web Client portal.
c. Right-click SlxClient, and then click Permissions.
d. On the Security tab, click Add.
e. In the Select Users or Groups dialog box, add your Web Client domain users, and then click OK.
5. On the Web Server computer, enable Windows Authentication for the Web Client using the following method to restrict Web Client users from logging on if the Windows user is not mapped to a Sage SalesLogix.
a. Open Internet Information Services (IIS) Manager.
b. Expand the Web Server computer name, expand Web Sites, and then expand the name of the Sage SalesLogix Web Client Web site.
c. Right-click SlxClient, and then click Properties.
d. In the Properties dialog box, click the Directory Security tab.
e. In the Authentication and access control section, click Edit.
f.
Ensure the Enable anonymous access check box is selected.
g. Ensure the Integrated Windows authentication check box is selected.
h. Click OK.
i.
Modify the Web.config file.
i.
In Application Architect, make the following edits in the web.config file in the Sage
SalesLogix portal. For more information about editing the web.config file see the
"Editing Configuration Files" topic in the Application Architect Help.
ii. Modify the web.config file by commenting out the sections labeled Windows
Authentication – off and removing the comment markup from the sections labeled Windows Authentication – on.
The three sections that must be modified are the <authentication>,
<httpModules>, and <modules>.
Comment markup begins with "<!--" and ends with "-->" j .
(Optional) Remove the Sage SalesLogix Log on screen.
When a user logs off from Sage SalesLogix, a log on button displays that allows the user to log back on. To remove this button, you must edit the Logoff.aspx file.
Change the line:
<div id=”LogoffFormButtonPanel”><a href=”~/Login.aspx” id=”loginLink” runat=”server”><%= GetLocalResourceObject(“ReturnToLoginMessage”)
%></a></div>
To
<div id=”LogoffFormButtonPanel”><a href=”~/Default.aspx” id=”loginLink” runat=”server”><%= GetLocalResourceObject(“ReturnToLoginMessage”)
%></a></div>
6. Enable Integrated Authentication for SData Portal Configuration a. Open Internet Information Services (IIS) Manager.
b. Expand the Web Server computer name, expand Web Sites, and then expand the name of the Sage SalesLogix Web Client Web site.
c. Right-click your SData virtual directory, and then click Properties.
d. In the Properties dialog box, click the Directory Security tab.
e. In the Authentication and access control section, click Edit.
f.
Clear the Enable anonymous access check box.
g. Select the Integrated Windows authentication check box.
Sage SalesLogix Implementation Guide v8.0
77
Configuring the Web Client h. Click OK.
i.
Under the SData folder, open and modify the Web.config file.
Windows 2008
The following instructions configure Windows Authentication for Web Client users on Windows
2008.
To configure
1. On the Web Server computer, log on as a domain administrator or as a user with rights to modify the Active Directory.
This user should be the Application Pool user.
2. Add the WebDLL user to the IIS_IUSRS group.
3. Make sure all Sage SalesLogix Web Client users who will be using Windows
Authentication have the following permissions to the SLXClient and SData folders:
• Read
• Write
• Execute
4. Add Windows Authentication security.
a. In the Server Manager, under Web Server (IIS), click Add Role Services.
b. In the tree view under Security, select Windows Authentication.
c. Click Install.
5. Run setspn.exe to manually modify the service account's SPN information to run correctly with Windows Authentication.
Service Principal Names (SPNs) are used to locate a target principal name for running a service. The setspn.exe is included in Windows 2008.
a. Open a Command Prompt window.
Do not use a colon or second forward slash in the following setspn commands.
Type the commands exactly as documented.
b. At the command prompt, type the following command. setspn -A http/server.domain.com domain\username
The server.domain.com is the fully qualified machine name, the domain is the Sage
SalesLogix domain, and the user name is the user that has rights to modify the active
directory. Use the username created in “Configuring Application Pool Permissions” on page 58
.
c. At the command prompt, type the following command. setspn -A http/server domain\username
The server is the machine name, the domain is the Sage SalesLogix domain, and the user name is the user that has rights to modify the active directory. Use the username
created in “Configuring Application Pool Permissions” on page 58
.
d. At the command prompt, type the following command. setspn -L username
6. On the Web Server computer, enable Windows Authentication in IIS. This method restricts Web Client user from logging on if the user is not found in Sage SalesLogix.
a. Open IIS Manager, and click Advanced Settings.
b. In the Advanced Settings dialog box, click the Physical Path Credentials ellipsis.
c. In the Connect As dialog box, select Application user (pass-through
authentication), and then click OK twice.
78 Sage SalesLogix Implementation Guide v8.0
Configuring the Web Client d. Double-click Authentication and verify that only Windows Authentication is enabled.
By default, Sage SalesLogix uses Basic Authentication.
e. Right-click Windows Authentication, and then click Edit.
f.
Click Advanced settings.
g. Ensure that the Enable Kernel-mode authentication check box is not selected.
h. Click OK. i.
Modify the Web.config file.
i.
In Application Architect, make the following edits in the web.config file in the Sage
SalesLogix portal. For more information about editing the web.config file see the
"Editing Configuration Files" topic in the Application Architect Help.
ii. Modify the web.config file by commenting out the sections labeled Windows
Authentication – off and removing the comment markup from the sections labeled Windows Authentication – on.
The three sections that must be modified are the <authentication>,
<httpModules>, and <modules>.
Comment markup begins with "<!--" and ends with "-->" j .
(Optional) Remove the Sage SalesLogix Log on screen.
When a user logs off from Sage SalesLogix, a log on button displays that allows the user to log back on. To remove this button, you must edit the Logoff.aspx file.
Change the line:
<div id=”LogoffFormButtonPanel”><a href=”~/Login.aspx” id=”loginLink” runat=”server”><%= GetLocalResourceObject(“ReturnToLoginMessage”)
%></a></div>
To
<div id=”LogoffFormButtonPanel”><a href=”~/Default.aspx” id=”loginLink” runat=”server”><%= GetLocalResourceObject(“ReturnToLoginMessage”)
%></a></div>
7. Enable Windows Authentication for the SData Portal.
d. Open Internet Information Services (IIS) Manager.
e. Select the SData virtual directory, and click Advanced Settings.
f.
In the Advanced Settings dialog box, click the Physical Path Credentials ellipsis button.
g. In the Connect As dialog box, select Application user (pass-through
authentication), and then click OK.
h. Click OK to close the Advanced Settings dialog box.
i.
Double-click Authentication and set the following:
• Disable anonymous access.
• Enable Windows Authentication.
• Enable Basic Authentication
By default, Sage SalesLogix uses Basic Authentication.
j.
Right-click Windows Authentication, and then click Advanced Settings.
k. In the Advanced Settings dialog box, verify that Enable Kernel-mode
authentication is not selected, and then click OK.
l.
Under the SData folder, open and modify the Web.config file.
Sage SalesLogix Implementation Guide v8.0
79
Configuring the Web Client
Configure the Web Client Machines
The following instructions configure Windows Authentication for Web Client users accessing
Sage SalesLogix. Use one of the following procedures as appropriate for your browser type.
To enable on Internet Explorer
1. On each Web Client computer, open your browser.
2. On the Tools menu, click Internet Options.
3. Click the Security tab, select Trusted Sites, and then click Sites.
4. In the Add this Web site to the zone: text box, enter either the Web Server name or the IP address to the Web Server (http://10.40.0.35).
For users using Windows Authentication, the URL address must include the windows.aspx page (http://10.40.0.35/slxclient/windows.aspx).
To enable on Firefox
1. On each Web Client computer, open your browser.
2. In the Location Bar, type about:config, and then press Enter.
3. If a warranty message opens, click I’ll be careful, I promise!.
4. Double-click the network.automatic-ntlm-auth.trusted-uris preference.
5. In the Enter string value box, type your Web Host URL using the format http://hostserver:port.
6. Click OK.
Configuring Roles
A role determines what functionality a user can access in the Web Client. Roles use secured actions to control access to user interface elements such as pages, menus, menu items, toolbars, and buttons. When you control access to individual user interface elements, you can control access to actions such as editing, deleting, or printing.
By default, users created in the Web Client are assigned the Standard User role. This role allows add, edit, and delete permissions to Web Client non-administrative entities such as accounts, contacts, and opportunities.
Users created in the Administrator are not assigned a role and role security cannot be set in the Administrator. If you create new Web Client users in the Administrator, you must assign users to the Standard User role.
To assign
1. Open the Users List view in the Web Client.
2. Select the users that should have add, edit, and delete permissions to non-administrative entities in the Web Client.
3. In the User Tasks pane, click Add to Role.
4. In the Select Role dialog box, lookup and select the Standard User role, and click OK.
5. Click OK.
Review the “What are Roles and Secured Actions?” topic in the Web Client help to understand the default roles and how you want to apply them to users.
80 Sage SalesLogix Implementation Guide v8.0
Configuring the Web Client
Testing the Web Site
After you have deployed a Web portal and defined the default document, you are ready to test the Web site.
To test
1. Ensure the following services are running on the Web Host: Indexing Service, IIS Admin
Service, and World Wide Web Publishing Service.
2. Reset IIS.
3. Depending on where you deployed the Web Client portal, use one of the following URLs to test the Web site. If you deployed the Sage SalesLogix Web Client portal to:
• localhost (your Web server), the format is http://localhost/SlxClient or
http://server/SlxClient.
• localhost (your Web server) with Windows Authentication enabled, the format is
http://server:port/SlxClient/Windows.aspx.
• a Web site and port you designated during Web Host installation, or to another Web site you created manually in IIS, the format is http://server:port/SlxClient.
The server is the Web Host server and port is the port number you designated during
Web Host installation.
4. When the Sage SalesLogix Web Client logon page appears, enter your User Name and
Password.
5. (Optional) Sage SalesLogix Web components provide optional extended features in the
Web Client that may require additional components to be downloaded.
• On the login screen, click Enhance SalesLogix.
• In Options, click the General/Search tab and click Enhance SalesLogix.
• If prompted to install Sage SalesLogix Desktop Integration and you want to use this feature, click Yes.
6. Click Log On.
7. If you configured Web Reporting, on the Navigation Bar, click Reports.
8. Ensure the Reports View appears and that you can run a report.
9. Log off the Sage SalesLogix Web Client.
10. Send the Web Client URL to users or create a link from your company’s Web site (detailed in the following section).
Linking from Your Company’s Web Site
When you are ready to make the Web Client accessible to users, you can create a link on your company’s Web site (typically an intranet site) to provide access. For example, you may want to display a link that reads “SalesLogix” in a prominent location on your intranet site.
Create the link in the following format:
<A HREF=”webservername/virtualdirectoryname”>SalesLogix</A>
The server is the name of your Web Host machine. The virtual directory name is SlxClient, unless you specified a different name in the Sage SalesLogix Web portal Deployment
Properties in Application Architect.
Sage SalesLogix Implementation Guide v8.0
81
Configuring the Web Client
Configuring Client Computers
To ensure the Web Client functions correctly, you must configure several options on each user’s computer.
To configure
1. Ensure the user is a member of the local Power Users or Administrators group.
This allows ActiveX controls to work correctly if this user enables and downloads extended features on the Web Client Log On page.
2. Ensure the Scrollbar Item setting is set to 17 or less.
• (XP/2003) The Scrollbar option is set in the Control Panel > Appearance and Themes
> Display properties Appearance tab > Advanced > Item drop-down menu.
• (Vista/7/2008) The Scrollbar option is set in the Control Panel > Personalization >
Window Color > Window Color and Appearance > Item drop-down menu.
3. The default browser settings should be used for the Sage SalesLogix Web site. In addition to your browser defaults, the following options are required.
The option locations and wording may vary depending on your browser version.
For more information on these options, refer to your browser’s Help.
Browser Option
Internet Explorer
Setting
Temporary Internet Files>Settings Check for newer versions of stored pages
Automatically.
Security>Trusted sites>Sites
Security tab
• Add the Sage SalesLogix Web site (SlxClient) to the trusted sites list. Type http:// followed by the Web
Host server name for the Web Client site (for example, http://server).
• Turn OFF protected mode for trusted sites
(Vista/7/2008).
• Enable Script ActiveX controls marked safe for
scripting.
• Enable (or set to prompt) Initialize and script
ActiveX controls not marked safe for scripting.
• Enable Drag and drop or copy and paste files
(Allow access to the clipboard).
Enabling UTF-8 Support for Internet Protocols
(Microsoft Office 2007) If users export extended characters from Sage SalesLogix to e-mail,
UTF-8 support must be enabled.
To enable
1. Open Microsoft Outlook.
2. On the Tools menu, click Options.
3. Click the Mail Format tab, and then click International Options.
4. Under Internet Protocols, select Enable UTF-8 Support.
5. Click OK.
82 Sage SalesLogix Implementation Guide v8.0
Configuring the Web Client
Installing Desktop Integration
Desktop Integration extends Sage SalesLogix Web Client functionality by downloading clientside files for the following features:
• Office Integration encompasses Mail Merge, Export to Excel, and Drag and Drop functionality. Administrators can also drag-and-drop library files.
• Outlook Integration encompasses SendSLX and Record to History.
Before users install and configure these features, ensure you configured SData as detailed in
“Configuring the SData Portal” on page 54 .
To install and configure
1. Open the Web Client login screen.
2. Click Install Enhancements.
3. Do one of the following:
• Click Run to install Desktop Integration from it’s current location.
• Click Save to save the install locally before running it.
4. Follow the steps in the Wizard.
5. At the Setup Type screen, do one of the following:
• Select Complete to install all Desktop Integration features (both Office Integration and Outlook Integration).
• Select Custom to choose between Office Integration and Outlook Integration.
Both options are selected by default. In the Custom Setup screen, click the down arrow to the left of the feature you do not want to install and then click This feature will
not be available.
6. Continue to follow the prompts in the wizard.
7. At the end of the installation, click Finish.
8. After installing, you must open the Desktop Manager and configure it with the appropriate portal information. Click the the Find out more link to open the “Installing and Using
Sage SalesLogix Desktop Integration” help topic for browser specific configuration information.
Users can also install Desktop Integration from the link located in the Sage
SalesLogix Web Client, in User Options, on the General tab.
Creating the SyncSalesLogix Group
If your implementation includes Standard Outlook Integration or Intellisync for SalesLogix, you must create the SyncSalesLogix ad hoc group. Contacts in this group synchronize between Sage SalesLogix and your mail application.
Additional Intellisync for SalesLogix configuration steps are detailed in
“Configuring Intellisync for SalesLogix” .
To create
1. Open the Web Client Contact List view.
2. Select the contacts you want to synchronize with Microsoft Outlook.
3. Right-click the selected contacts, and then click Save Records as Group.
The Add Records to new Group dialog box opens.
4. In the Group Name box, type SyncSalesLogix.
5. Click OK.
Sage SalesLogix Implementation Guide v8.0
83
Configuring the Web Client
Assigning the SyncSalesLogix Group
After creating the SyncSalesLogix group, you must specify that group to be used to transfer information between Microsoft Outlook and Sage SalesLogix.
To assign
1. Open the Sage SalesLogix Web Client.
2. Click Options.
3. In the Intellisync Contact Group box, select SyncSalesLogix.
4. Click Save.
After completing this chapter...
You have completed tasks 13-18 in the
checklist. If your implementation includes:
•
The Mobile Client: proceed with Chapter 9, “Configuring the Sage SalesLogix Mobile Client”
•
Customer Portal: proceed with Chapter 10, “Configuring Customer Portal”
•
Remotes: proceed with Chapter 11, “Configuring Synchronization” .
Otherwise, you can begin using Sage SalesLogix.
84 Sage SalesLogix Implementation Guide v8.0
Preuzimanje
Reklama