Configuring a Remote Office. Sage SalesLogix Sage SalesLogix 8.0
Tangazo
Tangazo
Chapter 13
Configuring a Remote Office
Before beginning this chapter...
Configure the Sync Server as described in
Chapter 11, “Configuring Synchronization”
.
Use the instructions in this chapter to...
Install and configure a Remote Office. These tasks are required for installations that include a Remote Office(s).
A Remote Office consists of a group of users who access a Remote Office database. Unlike
Remote users, these users do not individually synchronize with the main office. Instead, synchronization occurs when the Remote Office database synchronizes with the main office. A
Remote Office may support any combination of Network and Web Client users.
The main office’s Administrator manages the Remote Office and Remote Office users.
Remember that SQL 2005 Native client is required on the computer that creates Remote databases.
Configuring the Remote Office Profile
Before configuring the Remote Office profile, you must have a Remote Office license(s) installed. One license is required for each Remote Office.
To configure
1. On the Administrator Navigation Bar, click Systems, click the Offices tab, and then double-click the Remote Office name.
2. On the Sync Options tab in the Office Description box, type the Remote Office name.
3. Under Remote Office Options: a. Use the Synchronize Changes check box to activate or deactivate synchronization for this remote office.
Select this option only after you install and configure the Remote Office Sync Client, and the database is ready to accept synchronization files.
b. Ensure the Sequence Files Before Apply check box is selected to check for missing, duplicate, or incorrect index numbers in Transaction Exchange Files (TEFs) before changes are made to the main office database.
If this option is selected, the Archives folder stores a copy of all files sent to the main office. Once a confirmation is received from the main office that all files were successfully transferred, the archives are deleted. c. Click Transfer Options. In the Transfer Options dialog box:
• In the Sync Transfer Profile box, select the Remote Office’s method of synchronization.
Your choices depend on the system sync transfer profiles configured in
Synchronization Transfer Profiles” on page 93 .
• Click Custom Settings to enter a login and password for the Remote Office.
• Click OK.
Sage SalesLogix Implementation Guide v8.0
111
Configuring a Remote Office
4. Under Shared Paths: a. In the Logging box, type the location of the Remote Office logging folder using UNC conventions and the shared names.
For example, \\MyServer\RemOffice Sync Logs, not \\MyServer\C:\RemOffice Sync
Logs.
It is not possible to use a logging path on a different (trusted) domain if the
SLX Service is using the local system account. To use a logging path on a different domain, you must change the SLX Service from the local system account to a domain user with rights on both domains.
b. In the Library box, type the location of the Remote Office Library folder using UNC conventions and the shared names.
For example, \\MyServer\Library, not \C:\RemOffice Sync Logs\Library.
c. In the Attachments box, type the location of the Remote Office Documents folder using UNC conventions and the shared names.
For example, \\MyServer\Documents, not \\MyServer\C:\RemOffice Sync
Logs\Documents.
If you are connected to the network, browse to the Remote Office folders.
5. Click OK.
Adding Users to a Remote Office
After configuring the Remote Office profile, assign Network and\or Web Users to the Remote
Office.
To add
1. If necessary, use Administrator to create users as described in “Creating Users” on page 64
.
2. In the User Profile dialog box, click the Sync tab.
3. Under General, in the Location box, select the remote office to which you want to assign the Network user.
4. Click OK.
5. Repeat this procedure for all Remote Office Network users.
Creating a Remote Office Database
Create Remote Office databases using Administrator.
When a remote database is created, it uses the host server collation settings. When the database is sent to the remote it will use the SQL Express installation collation settings.
To create
1. On the Administrator Tools menu, click Create Remote Office Databases.
2. In the Create Databases dialog box, under Available Remote Offices, select the office(s) for which the database(s) will be created, and click the arrow to move them to the Selected Remote Offices box.
The default database settings were configured in
“Setting Database Options” on page 41 . To
change the settings for this office only, click Options and make the changes.
112 Sage SalesLogix Implementation Guide v8.0
Configuring a Remote Office
3. Each database is placed in the folder specified in the Create Remote DB in server
directory box on the Tools > Options > Database tab. To create the database(s), do one of the following.
• To create the database(s) immediately, click Now.
• To create the database(s) at a later time, click Later.
• In the calendar, select a date and time, and then click OK.
The Administrator is unavailable when the timer is active.
• The Create Databases dialog box displays a countdown to the scheduled date and time.
A test is performed to ensure that the settings are configured and that the database can be created in the chosen location.
The database is created with the file name SLX_sitecode_dat.sxd.
4. Click OK to confirm successful completion.
Transfer the database to the remote office database computer. If the computer is connected to the network, create a folder on the Administrative Workstation and copy the database to the folder. Share this folder so the remote office’s computer has access to it.
If the Remote Office computer is not connected to the network, copy the database to the office’s computer using some form of removable media. Another option is to zip the database, e-mail it to the Remote Office, and then copy it to the Remote Office’s computer and unzip it.
Installing the Web Host
If the Remote Office will be using the Sage SalesLogix Web Client or Intellisync for
SalesLogix, you must install the Web Host. Follow the instructions detailed in “Installing the
Installing a Remote Office
The Remote Office is the computer that processes synchronization files and ensures that the main office and Remote Office database contain the same information. Because the synchronization process is resource intensive, do not install the Remote Office on the same computer as the Remote Office database. Rather, install the Remote Office on a dedicated computer with direct access to your network.
To install
1. On the Sage SalesLogix Installation screen, click Standard Server Installation.
2. On the Standard Server Installation screen, click Remote Office Server.
If the installation does not detect the necessary prerequisites, you will be prompted to install them. Click Install to allow Sage to install the required components or Cancel to stop the installation.
3. On the Welcome and License Agreement screens, read the information and accept the agreement, and then click Next.
4. On the Setup Type screen, select an installation type, and then click Next.
• Select Complete to install all components on this computer.
• Select Custom to install only certain components or to change the installation location. Use the Custom Setup screen to enable or disable items for installation.
5. Depending on your installation type, you will be prompted to enter some or all of the following information on the installation screens:
Sage SalesLogix Implementation Guide v8.0
113
Configuring a Remote Office
• Use Local System Account - Select this option if the local user account has the correct security permissions to install Sage SalesLogix.
If you do not select this option, set the information for the Sage SalesLogix Service user you created as described in
“Permissions Required for the SLXService User (without
Administrator rights)” on page 14
.
• Domain - Type the network domain where you created the Sage SalesLogix Service user.
• User Name - Type the name of the Sage SalesLogix Service user (for example,
SLXService).
• Password and Confirm - Type the Sage SalesLogix Service user’s password.
• Port Change button - Changes the port number used for communication between the
Clients and Sage SalesLogix Server. In most implementations, the default port number does not need to be changed. However, if you have another application or service using port 1706, you should change the port number to an unused port.
•
Configure IIS for the Web Server - Select this check box if your installation includes the Sage SalesLogix Web Client and\or Intellisync for SalesLogix portals.
This makes necessary modifications to IIS.
• Create Web Site – Select this check box if your installation includes the Sage
SalesLogix Web Client and\or Intellisync for SalesLogix. This is the site that will be used to deploy the portals to.
• Enter a web site name – Type the name of the Web site. The default name is
SalesLogix.
• Port – Enter the port number that the SalesLogix Web site will use.
• Domain – Enter the network domain where you created the WebDLL user as described in
“The WebDLL User” on page 15 .
• User Account – Enter the name of the WebDLL user you created. The default value is WebDLL. If you used a different name, type it exactly as you did when you created it.
• Password and Confirm Password – Type the WebDLL user’s password.
6. On the remaining screens, click Install and Finish to complete the installation.
Installing the Remote Office Database
Note the following when using SpeedSearch at your remote office:
• If the SpeedSearch Service is started before you install the Remote Office database, no
SpeedSearch indexes are created.
• If the SpeedSearch Service is started after the Remote Office database is installed, but before the first Sync Client cycle, the SpeedSearch indexes are created but there are no documents in either the Library or Documents folder. A search will not find anything until the first schedule for those indexes is run.
• If you rename the database in the Attach Remote utility, you must complete additional steps to ensure the SpeedSearch indexes are created. See the “SpeedSearch Indexes Not
Built For New Database” troubleshooting topic in the Administrator Help for more information.
To install
1. Browse to the location of the Remote Office database. The database file name is
SLX_sitecode_dat.sxd.
2. Double-click the remote database.
3. In the Remote Database Setup dialog box, click OK.
4. In the SalesLogix Attach Remote dialog box click OK.
114 Sage SalesLogix Implementation Guide v8.0
Configuring a Remote Office
If more than one Microsoft SQL Server instance is detected, you must select the instance you want to use in the Select the name of the SQL Server instance to use dialog box.
After installing the Remote Office database, you are ready to start the Remote Office
Synchronization Client.
Creating the Database Login
If you manually attach the SQL databases instead of using Attach Remote, you must enable the sysdba user or the Sage SalesLogix database will not be listed in the Connection
Manager. This task is only necessary if attaching the database manually.
To configure the sysdba user
1. In the SQL Server Management Studio dialog box, on the Tools menu, click SQL
Server Query Analyzer.
2. If you are not connected to the server, the Connect to SQL Server dialog box opens. In the Connect to SQL Server dialog box: a. In the SQL Server box, select your server.
b. Type the system administrator (sa) password.
c. Click OK.
3. On the File menu, click Open, and browse to sysdbafix_script.sql.
This script is located in the Database folder on the DVD.
4. In the Query dialog box: a. In the DB box, select your new database.
b. Click Execute Query (the green arrow) to start the script.
The number of orphaned users fixed with this statement should be 1.
5. Exit the Query dialog box and the SQL Server Management Studio.
After running the sysdbafix_script.sql, refresh the SQL Server Management Studio to display the sysdba user in the database.
Deploying Web Portals for the Remote Office
The Web Portals are:
• Sage SalesLogix Web Client
• Intellisync for SalesLogix
• JobService
• SData
• Web Reporting
If the Remote Office will include these features, you must use the Application Architect installed at the main office to deploy the relevant portal(s).
Ensure you run a synchronization cycle on the Host before deploying the Web site
(see “Starting the Synchronization Server” on page 101 ). The sync cycle creates the
PortalDeployments folder required for the Web site deployment.
To deploy
1. On the Application Architect View menu, click Deployment Explorer.
2. In the Deployments tree view, double-click Remote Sales Client.
3. In the Name box, type a name for the deployment.
Sage SalesLogix Implementation Guide v8.0
115
Configuring a Remote Office
4. In the Description box, type a description for this deployment.
5. In the Deployment Targets tree view, do one of the following:
6. Click Remote Office(s).
The Remote Office Target Settings appear.
a. In the Server box, type the name of your Web Host server.
If you did not install the Web Host, and you are deploying to a separate Web server, type the name of your Web server.
b. Ensure the Deploy Target check box is selected.
This indicates the target is active and should be deployed.
c. In the Port box, type the port number for your Web Host server. It must match the port for the Web site.
d. In the App Pool box, type the name of the application pool for your Web site.
For example, if you used the SalesLogix Web site, the App Pool is SalesLogix.
7. In the Company Name list, select the Remote Office(s) to which you want to deploy the
Web Client.
8. Select the tab for each portal you want to deploy (SlxClient, SlxIntellisync, SData, and\or
SlxJobService): a. In the Virtual Directory box, type the alias name for the virtual directory.
b. In the Sub Directory box, type the folder name where all portal files will be copied under the target’s base directory.
c. Ensure the Deploy Portal check box is selected.
This indicates the portal is active and should be deployed.
When the Inherit from Target check box is selected, the deployment uses the port and application pool settings of the current target to deploy the portal
(these settings are specified under IIS Target Settings). If necessary, clear this check box and set a different Port and App Pool for the portal.
9. Click Save.
10. Do one of the following:
• Click Deploy to deploy portals individually.
• Click Deploy All to deploy all portals in the Remote Office.
The RemoteManifest.xml file is created which contains the settings used by the remote registration services to add an existing IIS Web site or register the site with a server instance. When the Synchronization Server at the main office cycles, the portals are deployed to the remote.
Deploying an Intellisync Portal
If your Remote Office users (Network or Web) will use Intellisync for SalesLogix, you must deploy an Intellisync portal. If you have not already done so, follow the steps outlined in
“Deploying Web Portals for the Remote Office” on page 115
. In step 8, be sure to select the
SLXIntellisync portal for deployment.
Starting the Remote Office Synchronization Client
The first time the Remote Office Synchronization Client runs, the synchronization folders are created under the root RemOffice Sync Logs folder. This process only occurs if you configured the shared paths to the Remote Office (
“Configuring the Remote Office Profile” on page 111
) and shared the RemOffice Sync Logs folder.
116 Sage SalesLogix Implementation Guide v8.0
Configuring a Remote Office
The synchronization cycle processes the portal(s) deployed from the main office and allows access to the Web site.
The following files are created under the main RemOffice Sync Logs folder.
• Archives
• Infiles
• WGLogs
• What’s New.tlg
To start
1. Click Start, point to Programs, point to Sage SalesLogix, and then click
Synchronization Client.
2. In the Log on to dialog box: a. In the Database box, select the Remote Office database to which you want to log on.
b. Click OK.
The Remote Office Sync Client assumes you are logging on as the system administrator.
3. In the Synchronization Client dialog box, click Execute.
The Remote Office Server creates the synchronization folders under the main RemOffice
Sync Logs folder.
4. Click Close when the “Sync Process Completed” message appears.
Remember to select the Synchronize Changes option on the Administrator >
Systems > Offices > Remote Office > Sync Options tab to activate synchronization for this remote office.
You can choose to run the Remote Office Synchronization Client as a service. For more information, see the Sage SalesLogix Client Help topic called “Running the
Remote Office Synchronization Client as a Service”.
Installing Remote Office Network Clients
To install Sage SalesLogix Network Clients in the Remote Office, refer to “Installing the Sage
SalesLogix Network Client” on page 70
Configuring Remote Office Web Clients
After installing and configuring the Web Remote Office, you must provide access to the
Remote Office for Web Client users. Use the following URL format: http://servername:port/<virtual directory name>. For example, http://servername:8086/SlxClient.
Configuring Intellisync for SalesLogix for Remote Office Clients
After installing and configuring the Intellisync for SalesLogix portal, you must provide your users with access. Use the following URL format:
Sage SalesLogix Implementation Guide v8.0
117
Configuring a Remote Office http://servername:port/<virtual directory name>. For example, http://servername:8086/SLXIntellisync.
After completing this chapter...
You have completed the “Remote Office Tasks” checklist. If your implementation includes
Offline Web Clients, proceed with Chapter 14, “Configuring Offline Web Clients”
. If not, you can begin using Sage SalesLogix.
118 Sage SalesLogix Implementation Guide v8.0
Pakua
Tangazo