Job export/import. Kodak Prinergy Connect 5.2
Reklama
Reklama
16
Job export/import
Job export
About exporting jobs
You can transfer a job from one Prinergy system to another by exporting all or part of the job using the export process template, and then importing it into the other system.
There are two types of exports:
●
Complete exports, which exports the whole job.
●
For an export to be successful, the job must contain refined PDF pages.
Incremental or partial exports, which exports portions of a job.
For an incremental export to be successful, the job must contain refined PDF pages and an imposition plan.
The exported file has the same name as the job, plus an extension of .zip, such as jobname.zip. If you export more than once, you can choose to either overwrite an existing export file name or create a new export file name if the job name is the same.
All aspects of exports are controlled by export process template options.
An exported job contains most, but not all aspects of the job, as explained in the following table:
Not Included
Input files
Job history
Included
Imposition plans
PDF files for the job, also known as digital masters
Page sets
Page assignments
Page geometry
Final color separations and color mappings
Color database from the Job tab of the Color
Editor
Job notes
864 Chapter 16—Job export/import
About incremental exports
●
●
Incremental exports are exports of certain parts of a job, based on signatures.
Incremental exports are useful to:
●
●
Break up a large job for printing at multiple sites
Break up a large job into files that are small enough to transfer to a remote site, which gradually reassembles the job
Send jobs to sites with Prinergy Direct software, which requires only signatures, not all aspects of the job. This is called a hub-and-spoke operation, where the Prinergy Connect or Prinergy Powerpack operator creates partial exports for sites with Prinergy Direct.
Update a previous export
For an incremental export to be successful, the job must contain refined PDF pages and an imposition plan.
When a site receives an incremental export, it must do an incremental import to bring the file into Prinergy.
Hot folders with incremental exports
To import incremental exports, remote sites can create a pre-job and link it to an import process template.
When you drop an incremental export into a pre-job hot folder, the file name determines whether Prinergy creates a new job. If the incremental export file name:
●
●
Matches the name of an existing job, Prinergy adds the export to an existing job
Does not match the name of an existing job, Prinergy creates a new job using the export file name
If you want to create more than one incremental export from the same job for use by a remote site with a pre-job hot folder, you need to rename the files. When you first create the incremental exports, give the files different names so that they do not overwrite each other. But before you send the files to the remote site, be sure to rename the file names with the same name so that Prinergy imports the files into the same job.
Exporting a job or partial job 865
Exporting a job or partial job
1. Select what you want to export by doing one of the following actions:
To
Export a job from the Job
Finder
Do This a. Select the job.
b. From the File menu, select Export Job.
Export a job from Job
Manager
Export signatures
From the File menu, select Export Job.
a. In the Signatures view of Job Manager, select one or more signatures.
b. From the File menu, select Export Job
(Incremental).
2. In the Choose Process Template dialog box, choose an export process template, and click OK.
3. In the Start Process dialog box, click Edit Process Template.
4. In the process template, click next to the Export section, set the
Export options, and click OK.
5. If you want to change the name, type the new name in the Zip
Filename box, ensuring it ends in the .zip extension.
6. Set any other options the Start Process dialog box, and click OK.
7. Click OK.
Export process template
The export process template contains one section called Export.
Click to expand this collapsible section and see the options in it.
Select this check box to enable the Export section of the export process template.
JTP
Select the JTP you want to use to export job files.
Include Pages in Job Exports
Select to include the PDF pages in the compressed file that
Prinergy creates when it exports a job.
866
Job import
Chapter 16—Job export/import
Create Export Backwards Compatible with Prinergy 2.0.7
Select when you want the exported job to successfully import into a Prinergy 2.0.7 (or earlier) system.
Export Type
The selection in this box affects the default value displayed in the Export Path box. Select an export type and then provide additional information in the Export Path box.
Select Absolute File to enter the path for a specific network device or file location.
Select Job-Relative File to enter a path that is relative to the location of the job folder.
Note: If you enter a path for a network device in the Export Path box,
Prinergy automatically changes the Export Type option to Absolute File, if it is not selected.
Overwrite Existing Files with Same Name
Select to enable Prinergy to overwrite an existing exported job file (<job name>.zip) with a new exported job file when the files have the same name.
When you enable this feature and export the same job a second time, Prinergy overwrites the first exported job file with the second exported job file.
When you disable this feature and export the same job a second time, Prinergy gives the second exported job file a unique name by giving it version number, for example, job1.zip as opposed to job.zip. Because the two files have unique names, they do not overwrite each other. The result is two exported job files.
Export Path
Specifies the folder to which the system exports a job. Click
Browse to locate and select the folder.
Maximum File Size
Specify the size of the compressed file in kilobytes (KB) to be able to fit the file onto a medium such as a compact disk. (The default is 3145728 KB or about 3 GB.)
About importing jobs 867
About importing jobs
●
●
●
●
●
Importing is the process of creating a job based on a previously exported job. Export files have a .zip extension.
Use any of these methods to import jobs:
Import a job in the Job Finder using the Import Job menu item
Import a job while creating a new job
Import a job using a hot folder
Import a partial job using the Import Job (Incremental) menu item
Import a partial job using a hot folder
Someone must export a job or a partial job before you can import it.
When you import an exported job, Prinergy decompresses the exported job file, and populates the new job with the content from the exported job.
If the exported job has an APA file, Prinergy looks for the APA file with the latest date and time, and then copies the information from it into a new APA file. The filename of the new APA includes a version number, such as Job.v1.apa, to indicate it is a different version than the original
Job.apa file.
All aspects of imports are controlled by an import process template.
Importing an entire job using the menus
1. In Job Finder, from the File menu, select Import Job.
2. In the Import Job dialog box, navigate through the volumes and folders to choose an export job to import.
Ensure that the job is an export file by reviewing the information in the Selected Job Info list.
3. Under Options, read the name of the process template that controls the import process.
If you want to change the template, click Select. In the Choose
Process Template dialog box, select an ImportAll process template, and click OK.
4. Click OK.
5. In the Create New Job dialog box, set the options.
6. Specify the group name and job name you want.
If you are importing to the same Prinergy system as the one from which you exported the job, you must use a different job name.
7. Click Create.
868 Chapter 16—Job export/import
8. If you want to change any processing options: a. In the Start Process dialog box, under Options, click Edit Process
Template.
b. In the Import Process Template, change any settings, and click
OK.
9. Click OK.
The import process starts, and the new job opens in Job Manager.
Importing an entire job using hot folders
1. Create a pre-job.
2. Create a hot folder for the pre-job, and link it to an ImportAll type of import process template.
3. Using a file browser, drop the export .zip file into the hot folder.
Prinergy creates a job on the server where the pre-job is located.
Importing a partial job using the menus
1. Open an existing job.
2. In Job Manager, from the File menu, select Import Job
(Incremental).
3. In the Import Job dialog box, navigate through the volumes and folders to choose an export job to import.
Ensure that the file is an export file by reviewing the information in the Selected Job Info list.
4. Under Options, read the name of the process template that controls the import process.
If you want to change the template, click Select. In the Choose
Process Template dialog box, select an ImportJobIncremental process template, and click OK.
By default, the ImportJobIncremental process template keeps the existing page set and imposition.
5. Click OK to start the import process.
6. If you want to change any processing options: a. In the Start Process dialog box, under Options, click Edit Process
Template.
b. In the Import Process Template, change any settings, and click
OK.
7. Click OK.
8. Click OK.
The ImportJobIncremental process starts.
Importing a partial job using hot folders 869
Importing a partial job using hot folders
1. Start with an existing job.
2. Create a hot folder for the job, and link it to an ImportIncremental type of import process template.
3. Using a file browser, drop the partial export .zip file into the hot folder.
Prinergy imports the partial job into the existing job. If an imported signature has the same name as an existing signature, Prinergy adds a suffix of "01" to the imported signature.
Import Job dialog box
Unlabeled list and results area
●
●
Selecting an item in the list at the top left of the dialog box displays that item's contents in the box below.
When you select:
●
Volumes, the volumes in your system appear
A volume name, folders at the root of the selected volume appear
A folder name, files within the folder appear
The path of the displayed item in the list appears in reverse order, for example, folder name followed by volume name.
Volumes
Displays all volumes in the Prinergy system.
Job Folder
(Visible only when you reach this dialog box by clicking Import
Job in Job Finder, not Import Job (Incremental) in the Job
Manager)
Opens the job folder for the current job.
Selected Job Info
Displays information about the job that is selected in the
Choose Job lists. It displays either the job name or a warning that the job is not an export file.
Show Hidden Files
Select this check box to include hidden files, such as system files, in the results.
870 Chapter 16—Job export/import
Select
You can set the default selection of this check box on the View tab of the Workshop Preferences dialog box.
Click this button to open the Choose Process Template dialog box, where you can change the import process template that controls the current import.
Import process template (jobs)
This topic applies only if you are importing jobs, not importing impositions.
To import entire jobs, use the ImportAll process template. To import partial jobs, use the ImportJobIncremental process template.
Import section
Select this check box to enable the Import section of the import process template.
It determines how Prinergy imports impositions, exported jobs, and exported job files.
If Page Set Already Exists
Determines what happens if a page set with the same name already exists.
●
●
Note: When importing an imposition plan via a hot folder, choose any option except Keep existing page set and imposition.
The options are:
●
●
Fail import: Stops the import process.
Delete existing page set and imposition: Replaces the existing page set and imposition with the page set and imposition being imported.
Create alternate page set and imposition: Creates a new page set and links it to the imposition plan, without affecting the existing page set or its assignments. This is the default in the ImportAll process template.
Keep existing page set and create new imposition: Retains the original page set and links it to the new imposition. The imported and existing sets must have the same number of
Job import 871
● positions. Selecting this option enables the check boxes in the Page Sets Options area of the import process template.
Keep existing page set and imposition: Retains the existing page set and imposition. The imported and existing sets must have the same number of positions. This is the default in the ImportJobIncremental process template. Selecting this option enables the check boxes in the Page Sets
Options area of the import process template.
Page Set Options
A set of check boxes that specify how to handle page assignments in an existing page set when the new imposition is linked to that page set. The check boxes are:
●
●
●
Existing assignments replaced by new assignments:
Prinergy replaces the old page assignments with the new page assignments in the imported file. In the
ImportIncremental process template, this check box is selected by default.
Existing assignments replaced by new unassignments:
Prinergy removes page assignments from pages that are not assigned (blank) in the imported file. When this check box is selected, the other two check boxes in Page Set Options are automatically selected.
Existing unassigned replaced by new assignment: Prinergy retains existing assignments and applies any new assignments from the imported job or populated PJTF to any unassigned positions in the existing page set. This check box is always selected.
The check boxes are available only if the If Page Set Already
Exists list is set to either Keep existing page set and create new
imposition or Keep existing page set and imposition .
These check boxes are especially important when you want to manually assign pages to a page set and then link the page set to multiple imposition plans.
Set Initial Separations After Imposition Import
In the imposition software, you may inadvertently add marks that contain separations that are not present in the content of the refined pages.
●
●
Select this check box when you want Prinergy to ignore the additional separations in the marks.
Clear this check box when you want Prinergy to show the additional colors in the marks.
872 Chapter 16—Job export/import
Important: Clear this check box if you are doing color mapping in the imposition software. Otherwise, Prinergy may ignore your color mapping changes.
Overwrite Existing Automated Page Assignment File
Select this check box if you want Prinergy to overwrite the existing APA file and use the assignments specified in the job you are importing.
Continue Job Import if CRC Error Found
Select this check box when you want Prinergy to skip any files with CRC errors without failing the import. The names of the files with errors are logged in the History view, so you can correct and reimport these files into the job.
Do Auto Page Assignment After Unpopulated Imposition Import
Select this check box when you want Prinergy to perform APA assignment and allow pages to be automatically assigned whether they have been refined before or after an imposition import.
Important: Do not select this check box unless you have an APA file with the assignments that you want applied to the selected page set. Any existing assignments are deleted if you have an empty or invalid APA file and this check box is selected.
If you clear this check box, pages can NOT be automatically assigned if they have been processed before an unpopulated imposition import (or before a page set is created).
Center Pages in Imposition
(For imposition imports only)
Specify the placement of each PDF page trim box (or media box) within its assigned imposition trim box during the job import.
The options are:
●
●
●
Honor Existing—Preserves the existing placement of each
PDF page (centered or not centered) when the job is imported.
Centered— Each PDF page trim box is centered within its imposition trim box. You can then reassign pages to different positions without worrying about the image shifts caused by different trim box sizes on different PDF pages.
Not Centered-Each PDF page trim box is positioned in the lower-left corner of its imposition trim box.
Job import 873
Signature ID Code
Use these settings to override the default signature ID code syntax that is specified in Administrator.
Template—Type the code syntax. For example, %jobname<7>
%%signature<2>%
Number of sections per signatures in one imposition---Type the total number of sections for each signature. For example, if you import an imposition with five signatures and signatures 2 and 5 each contains two sections, enter 1,2,1,1,2.
See Overriding default signature ID codes .
Normalize for PDF Marks File section
This section does not apply when you are importing jobs or partial jobs.
Normalize for PostScript Marks Files section
This section does not apply when you are importing jobs or partial jobs.
Optimize for PostScript Marks Files section
This section does not apply when you are importing jobs or partial jobs.
Import Raw Imposition Files section
This section does not apply when you are importing jobs or partial jobs.
Import Metadata section
Select XSLT File
If you use Business Link software, you can use this panel to import a defined XSLT file that you can use to create custom fields automatically. After you import the XSLT file, select the file in the Custom Fields Manager dialog box.
Instead of creating custom fields by typing information into the
Custom Fields Manager dialog box, you can select an XSLT file and import pre defined custom fields. Currently, only JDF-type imposition files can be imported.
874 Chapter 16—Job export/import
Stáhnout
Reklama