OMRON NJ -series Machine Automation Controller, 3G3MX2 Series Type V1 Multi-function Compact Inverter, 3G3AX -MX2-ECT EtherCAT Communication Unit Connection Guide
Reklaam
Reklaam
Machine Automation Controller NJ-series
EtherCAT(R)
Connection Guide
OMRON Corporation
Multi-function Compact Inverter
(3G3MX2 Series Type V1)
P640-E1-01
About Intellectual Property Rights and Trademarks
Microsoft product screen shots reprinted with permission from Microsoft Corporation.
Windows is a registered trademark of Microsoft Corporation in the USA and other countries.
EtherCAT(R) is registered trademark and patented technology, licensed by Beckhoff Automation
GmbH, Germany.
Sysmac is a trademark or registered trademark of OMRON Corporation in Japan and other countries for OMRON factory automation products.
Company names and product names in this document are the trademarks or registered trademarks of their respective companies.
Table of Contents
Applicable Devices and Device Configuration ........................................ 5
EtherCAT Connection Procedure ............................................................. 11
Checking the EtherCAT Communications............................................. 28
1.Related Manuals
1. Related Manuals
To ensure system safety, make sure to always read and heed the information provided in all
Safety Precautions and Precautions for Safe Use of manuals for each device which is used in the system.
The table below lists the manuals related to this document.
Cat. No.
W500
Model
NJ501-[][][][]
Manual name
NJ-series CPU Unit Hardware User's Manual
W501
W505
W504
I585
I574
NJ301-[][][][]
NJ101-[][][][]
NJ501-[][][][]
NJ301-[][][][]
NJ101-[][][][]
NJ501-[][][][]
NJ301-[][][][]
NJ101-[][][][]
SYSMAC-SE2[][][]
3G3MX2-A[][][][]-V1
3G3AX-MX2-ECT
NJ/NX-series CPU Unit Software User's Manual
NJ/NX-series CPU Unit Built-in EtherCAT(R) Port
User's Manual
Sysmac Studio Version 1 Operation Manual
Inverter Multi-function Compact Inverter
MX2 Series Type V1 User’s Manual
Inverter MX2/RX Series
EtherCAT(R) Communication Unit User’s Manual
1
2.Terms and Definitions
2. Terms and Definitions
Term
PDO communications
(Communications using
Process Data Objects)
SDO Communications
(Communications using
Service Data Objects)
Slave unit
Node address
Explanation and Definition
This method is used for cyclic data exchange between a master unit and slave units.
PDO data (i.e., I/O data that is mapped to PDOs) that is allocated in advance is refreshed periodically each EtherCAT process data communications cycle (i.e., the period of primary periodic task).
The NJ-series Machine Automation Controller uses the PDO communications for commands to refresh I/O data in a fixed control period, including I/O data for slaves, and the position control data for servomotors.
It is accessed from NJ-series Machine Automation Controller in the following ways.
・With device variables for a slave I/O
・With axis variables for a servo drive and an encoder input slave to which assigned as an axis
This method is used to read and write the specified slave unit data from a master unit when required.
The NJ-series Machine Automation Controller uses SDO communications for commands to read and write data, such as for parameter transfers, at specified times.
The NJ-series Machine Automation Controller can read/write the specified slave data (parameters and error information, etc.) with the EC_CoESDORead (Read CoE SDO) instruction or the
EC_CoESDOWrite (Write CoE SDO) instruction.
There are various types of slaves such as servo drives that handle position data and I/O terminals that handle bit signals.
A slave unit receives output data sent from a master, and sends input data to a master.
A node address is an address to identify a unit connected to
EtherCAT.
2
3.Precautions
3. Precautions
(1) Understand the specifications of devices which are used in the system. Allow some margin for ratings and performance. Provide safety measures, such as installing safety circuit, in order to ensure safety and minimize risks of abnormal occurrence.
(2) To ensure system safety, make sure to always read and heed the information provided in all Safety Precautions and Precautions for Safe Use of manuals for each device which is used in the system.
(3) The user is encouraged to confirm the standards and regulations that the system must conform to.
(4) It is prohibited to copy, to reproduce, and to distribute a part or the whole of this document without the permission of OMRON Corporation.
(5) The information contained in this document is current as of September 2015. It is subject to change without notice for improvement.
The following notations are used in this document.
Indicates a potentially hazardous situation which, if not avoided, will result in minor or moderate injury, or may result in serious injury or death. Additionally there may be significant property damage.
Indicates a potentially hazardous situation which, if not avoided, may result in minor or moderate injury or property damage.
Precautions for Correct Use
Precautions on what to do and what not to do to ensure proper operation and performance.
Additional Information
Additional information to read as required.
This information is provided to increase understanding or make operation easier.
Symbol
The filled circle symbol indicates operations that you must do.
The specific operation is shown in the circle and explained in text.
This example shows a general precaution for something that must do.
3
4.Overview
4. Overview
This document describes the procedures for connecting 3G3MX2 Series Type V1
Multi-function Compact Inverter (hereinafter referred to as Inverter) of OMRON Corporation
(hereinafter referred to as OMRON) to NJ-series Machine Automation Controller (hereinafter referred to as Controller) via EtherCAT and the procedures for checking their connections.
Refer to Section 6. EtherCAT Settings and Section 7. EtherCAT Connection Procedure to understand the setting method and key points to operate PDO Communications via EtherCAT.
In this document, the operations for PDO communications via EtherCAT are checked by the output frequency setting and the status check of Inverter.
4
5.Applicable Devices and Device Configuration
5. Applicable Devices and Device Configuration
5.1. Applicable Devices
The applicable devices are as follows:
Manufacturer
OMRON
Name
NJ-series CPU Unit
OMRON
OMRON
Model
NJ501-[][][][]
NJ301-[][][][]
NJ101-[][][][]
Inverter 3G3MX2-A[][][][]-V1
EtherCAT Communication Unit 3G3AX-MX2-ECT
Precautions for Correct Use
As applicable devices above, the devices with the models and versions listed in 5.2. Device
Configuration are actually used in this document to describe the procedure for connecting devices and checking the connection.
You cannot use devices with versions lower than the versions listed in 5.2.
To use the above devices with models not listed in 5.2. or versions higher than those listed in
5.2., check the differences in the specifications by referring to the manuals before operating the devices.
Additional Information
This document describes the procedures to establish the network connections.
It does not provide information on operation, installation, wiring method, device functionality, or device operation which is not related to the connection procedures. Refer to the manuals or contact the device manufacturer.
5
5.Applicable Devices and Device Configuration
5.2. Device Configuration
OMRON
OMRON
The hardware components to reproduce the connection procedures of this document are as follows:
Personal computer
(Sysmac Studio installed,
OS: Windows 7)
NJ501-1500
(Built-in EtherCAT port)
Ethernet cable
3G3MX2-A2002-V1 +
3G3AX-MX2-ECT
USB cable
Manufacturer
OMRON
OMRON
OMRON
-
-
OMRON
Name
CPU Unit (Built-in EtherCAT port)
Power Supply Unit
Sysmac Studio
Personal computer (OS: Windows 7) -
USB cable (USB 2.0 type B connector) -
Ethernet cable XS5W-T421-[]M[]-K
(with industrial Ethernet connector)
Inverter
EtherCAT Communication Unit
Model
NJ501-1500
NJ-PA3001
SYSMAC-SE2[][][]
3G3MX2- A2002-V1
3G3AX-MX2-ECT
Version
Ver.1.10
Ver.1.13
V2.0
Rev.1.1
Precautions for Correct Use
The connection line of EtherCAT communications cannot be shared with other Ethernet networks. Do not use devices for Ethernet such as a switching hub.
Use the Ethernet cable (double shielding with aluminum tape and braiding) of Category 5 or higher, and use the shielded connector of Category 5 or higher.
Connect the cable shield to the connector hood at both ends of the cable.
Precautions for Correct Use
Update Sysmac Studio to the version specified in this clause or higher version.
If you use a version higher than the one specified in this clause, the procedures and related screenshots described in Section 7. and subsequent sections may not be applicable.
In that case, use the equivalent procedures by referring to the Sysmac Studio Version 1
Operation Manual (Cat. No. W504).
Additional Information
For specifications of the Ethernet cables and network wirings, refer to Section 4. EtherCAT
Network Wiring of the NJ/NX-series CPU Unit Built-in EtherCAT(R) Port User's Manual (Cat.
No. W505).
Additional Information
The system configuration in this document uses USB for the connection to Controller.
For information on how to install a USB driver, refer to A-1 Driver Installation for Direct USB
Cable Connection of the Sysmac Studio Version 1 Operation Manual (Cat. No. W504).
6
6.EtherCAT Settings
6. EtherCAT Settings
This section describes the specifications of parameters, PDO mappings, and device variables that are set in this document.
Hereinafter, Inverter is referred to as ''Slave Unit" in some descriptions.
6.1. Parameters
The parameters required for connecting Controller and Inverter via EtherCAT are given below.
Use the following settings when you perform 7.2.1. Hardware Settings and 7.2.2. Parameter
Settings.
Name
Inverter Node address
Item Set value
1
04
-
Description
Option (Using EtherCAT A001
(1st Frequency Reference Selection)
A002 04
Communication Unit mounted on Inverter.)
( 1st RUN Command Selection )
C102 (Reset Selection) 03 Trip reset only
7
6.EtherCAT Settings
6.2. PDO Mappings
The PDO entries (objects) of Inverter required to connect Controller and Inverter via EtherCAT are shown below for the connection checks described in this document.
Use the following settings when you perform 7.3.2. PDO Map Settings.
■Output (Controller to Inverter)
Index PDO entry name
0x5000:00
0x5010:00
Command
Frequency reference
■Input (Inverter to Controller)
Index PDO entry name
0x5100:00
0x5110:00
Status
Output frequency monitor
0x2002:01 Sysmac Error Status
Additional Information
For details on PDO mappings of Inverter, refer to Section 4. Inverter Control of the Inverter
MX2/RX Series EtherCAT(R) Communication Unit User’s Manual (Cat. No. I574).
8
6.EtherCAT Settings
6.3. Device Variables
The PDO communications data for Inverter are allocated to the Controller's device variables.
The device variables and the data types are shown below.
The contents described in this clause are set in 7.3.3. Setting the Device Variables.
■Output area (Controller to Inverter)
Device variable name Data type Index Description
E001_Command WORD
0x5000:00 Command: Operation command to
Inverter
E001_Frequency_reference INT
0x5010:00 Frequency reference: Gives an output frequency (Unit: 0.01 Hz)
Precautions for Correct Use
Do not give a negative value to E001_Frequency_reference (frequency reference).
*Details of bit data allocations for the command
Bit
0
1
7
Name
Forward/stop
Reverse/stop
Fault reset
Other (Reserved)
Meaning
0: Stop
1: Forward command
0: Stop
1: Reverse command
: Resets an error or trip for EtherCAT Communication Unit or Inverter.
The reserved area. Set 0.
9
6.EtherCAT Settings
■Input area (Inverter to Controller)
Device variable name Data type Index Description
E001_Status WORD
E001_Output_frequency_monitor INT
E001_Sysmac_Error_Status
E001_Observation
E001_Minor_Fault
BYTE
BOOL
BOOL
0x5100:00 Status: The present state of
EtherCAT Communications Unit.
0x5110:00 Output frequency monitor:
Displays an output frequency
(Unit: 0.01 Hz).
0x2002:01 Sysmac Error Status
Error description of observation
Error description of minor fault level
Details of bit data allocations for the status
Bit Name
0
1
3 Fault
7 Warning
9 Remote
12 Frequency matching
15
Forward operation in progress
Reverse operation in progress
Connection error between the optional unit and
Inverter
Other (Reserved)
Meaning
0: Stopped/during reverse operation
1: During forward operation
0: Stopped/during forward operation
1: During reverse operation
0: No error or trip occurred for EtherCAT Communication Unit or Inverter.
1: Error or trip occurred for EtherCAT Communication Unit or
Inverter.
0: No warning occurred for EtherCAT Communication Unit or
Inverter.
1: Warning occurred for EtherCAT Communication Unit or
Inverter.
0: Local (Operations from EtherCAT are disabled)
1: Remote (Operations from EtherCAT are enabled)
0: During acceleration/deceleration or stopped
1: Frequency matched
0: Normal
1: Error (Cannot update data for the inverter. To restore, turn the power OFF and then ON again.)
The reserved area. Set 0.
Additional Information
The device variables are named automatically from a combination of the device names and the port names.
The default device names are “E" followed by a serial number that starts from 001.
Additional Information
For details on the allocations of input and output areas, refer to Section 4. Inverter Control of the Inverter MX2/RX Series EtherCAT(R) Communication Unit User’s Manual (Cat. No. I574).
10
7.EtherCAT Connection Procedure
7. EtherCAT Connection Procedure
This section describes the procedures for connecting Controller to Inverter via EtherCAT.
In this document, the explanations of procedures for setting up Controller and Inverter are based on the factory default settings.
For the initialization, refer to Section 8. Initialization Method.
7.1. Work Flow
Take the following steps to perform PDO Communications of EtherCAT.
7.2. Setting up Inverter
Set up Inverter.
↓
7.2.1. Hardware Settings.
↓
Set the hardware switches on Inverter and connect the cables.
7.2.2. Parameter Settings Set the parameters for Inverter.
↓
Set up Controller.
7.3. Setting up Controller
↓
7.3.1. Starting Sysmac Studio and
Setting the EtherCAT Network
Start Sysmac Studio and set the EtherCAT network configuration.
Configuration
↓
7.3.2. PDO Map Settings
Set PDO mappings to use for Inverter.
↓
7.3.3. Setting the Device Variables
↓
Set the device variables to use for Slave Unit.
7.3.4. Transferring the Project Data
Transfer the project data from Sysmac Studio to
Controller.
↓
7.4. Checking the EtherCAT
Communications
Check that the PDO communications of EtherCAT are performed normally.
↓
7.4.1. Checking the Connection Status
↓
Check the connection status of EtherCAT.
7.4.2. Checking the Sent and
Check that the correct data are sent and received.
Received Data
11
7.EtherCAT Connection Procedure
7.2. Setting up Inverter
Set up Inverter.
7.2.1. Hardware Settings
Set the hardware switches on Inverter and connect the cables.
Precautions for Correct Use
Make sure that the power supply is OFF when you perform the setting up.
1
Make sure that the power supply to Inverter is OFF.
*If the power supply is turned
ON, settings may not be applicable as described in the following procedure.
2
Remove Option Unit Cover from the Inverter front panel as shown in the right figure.
1. Loosen the mounting screw (x 1) from Option Unit Cover of the Inverter front panel.
2. Remove Option Unit Cover.
Option Unit Cover
Mounting screw
3
Connect 3-Phase 200 VAC power supply to Main power supply input terminal on Inverter.
*For details on wiring specifications of the power supply, refer to 2-3 Wiring of the Inverter Multi-function
Compact Inverter MX2 Series
Type V1 User’s Manual (Cat.
No. I585).
Main power supply input terminal
3-Phase 200 VAC power supply
Power supply cable
12
7.EtherCAT Connection Procedure
4
Mount EtherCAT
Communication Unit onto
Inverter as shown in the right figure.
*For mounting EtherCAT
Communication Unit, refer to
2-5 Mounting and Wiring for the
EtherCAT Communication Unit of the Inverter MX2/RX Series
EtherCAT(R) Communication
Unit User’s Manual (Cat. No.
I574).
*For details on the FG cable to ground, refer to 2-3 Wiring of the Inverter Multi-function
Compact Inverter MX2 Series
Type V1 User’s Manual (Cat.
No. I585).
1. Mount EtherCAT Communication Unit onto the location where Inverter
Option Unit Cover that you removed was attached.
Check that the connector is firmly connected.
EtherCAT
Communication Unit
Note: When EtherCAT Communication Unit is mounted, the main circuit and control circuit terminals of Inverter are hidden. For this reason, be sure to wire the main circuit and control circuit terminals before mounting EtherCAT Communication Unit.
2. Tighten the bottom right screw of EtherCAT Communication Unit with the specified torque (46 N•cm, 4.7 kgf•cm).
Mounting screw
3. Ground the FG cable of EtherCAT Communication Unit.
Cut the ground wire of the unit's FG cable to an appropriate length and ground it to the closest possible ground location.
FG cable
Note: Do not force the FG cable into EtherCAT Communication Unit during wiring.
13
7.EtherCAT Connection Procedure
5
Check the positions of the hardware switches and the connectors on EtherCAT
Communication Unit by referring to the right figure.
Status indicator
(L/A IN, L/A OUT, RUN, ERR)
Rotary switches for node address setting
(× 10, × 1)
6
Set the rotary switches for node address setting as follows:
X10: 0
X1: 1
*Set the node address to 1.
Communications connectors
(IN, OUT)
Rotary switch for node address setting (× 10)
7
Connect an Ethernet cable to
Communications connector (IN).
Ethernet cable
Rotary switch for node address setting (× 1)
14
7.EtherCAT Connection Procedure
7.2.2. Parameter Settings
Set the parameters for Inverter.
In this document, the parameters are set by Digital Operator (display operation panel) on
Inverter.
Additional Information
If you set the parameters for Inverter by Sysmac Studio, refer to 5-4 Setting EtherCAT Drives of the Sysmac Studio Version 1 Operation Manual (Cat. No. W504) and the Inverter MX2/RX
Series EtherCAT(R) Communication Unit User’s Manual (Cat. No. I574).
1
Check the positions of Data display and Operation keys on
Digital Operator.
Data display
Operation keys
Digital Operator
2
Turn ON the power supply to
Inverter.
15
7.EtherCAT Connection Procedure
3
Use the procedure on the right to set the parameters as follows:
A001 (1st Frequency
Reference Selection): 04
(Option)
A002 (1st RUN Command
Selection) : 04 (Option)
0.00
The output frequency is displayed in
Data display.
Press the Mode Key 3 times. a001
A001 parameter is displayed.
Press the Enter Key. a0 02
The initial data is displayed.
Press the Increment Key twice.
04
The data changes to "04".
Press the Enter Key. a001
A001 parameter is displayed again.
Press the Increment Key twice. a002
A002 parameter is displayed.
Press the Enter Key.
02
The initial data is displayed.
Press the Increment Key twice. a0 04
The data changes to ''04''.
Press the Enter Key. a002
A002 parameter is displayed again.
16
7.EtherCAT Connection Procedure
4
Use the procedure on the right to set the parameter as follows:
C102 (Reset Selection):
03 (Trip reset only) a002
Check that A002 parameter is displayed.
Press the Mode Key twice c001
C001 parameter is displayed.
Press the Increment Key to display C102 parameter. c102
C102 parameter is displayed.
Press the Enter Key.
02
The initial data is displayed.
Press the Increment Key once.
03
The data changes to ''03''.
Press the Enter Key. c102
C102 parameter is displayed again.
5
Press and hold the Mode
Key for more than 3 seconds.
6
Check that the output frequency monitor is displayed.
The following items are displayed.
Data display: 0.00 Hz
(output frequency)
Monitor LED (Hz): Green lit
17
7.EtherCAT Connection Procedure
7.3. Setting up Controller
Set up Controller.
7.3.1. Starting Sysmac Studio and Setting the EtherCAT Network
Configuration
Start Sysmac Studio and set the EtherCAT network configuration.
Install Sysmac Studio and a USB driver on Personal computer beforehand.
1
Connect an Ethernet cable to
Built-in EtherCAT port (PORT2)
Personal computer
Controller
CPU Unit on Controller, and connect a
USB cable to the peripheral
(USB) port. As shown in 5.2.
Device Configuration, connect
Personal computer and Inverter
USB cable
Power Supply Unit
End Cover
Ethernet cable
Inverter to Controller.
2
Turn ON the power supply to
Controller.
3
Start Sysmac Studio.
*If a confirmation dialog for an access right is displayed at start, execute a selection to start.
4
Sysmac Studio starts.
Click Connect to Device.
5
The Connect to Controller
Dialog Box is displayed.
Select Direct connection via
USB for Connection type.
Uncheck Upload the project and
Display the Troubleshooting
Dialog Box for Operation after
Connection.
Click Connect.
18
7.EtherCAT Connection Procedure
6
A confirmation dialog box is displayed. Check the contents and click Yes.
*The displayed dialog depends on the status of Controller.
Check the contents and click
OK or Yes to proceed with the processing.
7
A dialog box on the right is displayed. Check the contents and click OK.
8
The Auto Connect Project
Dialog Box is displayed online.
When an online connection is established, a yellow bar is displayed under the toolbar.
The following panes are displayed in this window.
Left: Multiview Explorer
Top right: Toolbox
Bottom right: Controller Status Pane
Middle top: Edit Pane
The following tab pages are displayed at the middle bottom of the window.
Output Tab Page
Build Tab Page
Multiview
Explorer
Output Tab
Page
Edit Pane
Build Tab
Page
Toolbox
Controller
Status
Pane
Additional Information
For details on online connections to Controller, refer to Section 6. Online Connections to a
Controller of the Sysmac Studio Version 1 Operation Manual (Cat. No. W504).
9
Double-click EtherCAT under
Configurations and Setup in the Multiview Explorer.
19
10
The EtherCAT Tab Page is displayed in the Edit Pane.
11
Right-click Master on the
EtherCAT Tab Page and select
Compare and Merge with
Actual Network Configuration.
A screen is displayed stating
"Get information is being executed".
12
The Compare and Merge with
Actual Network Configuration
Dialog Box is displayed.
Node address 1 and
3G3AX-MX2-ECT Rev:1.1 are added to the Actual network configuration after the comparison.
Click Apply actual network
configuration.
13
A confirmation dialog box is displayed. Check the contents and click Apply.
The dialog box on the right is displayed. Click Close.
7.EtherCAT Connection Procedure
20
14
E001 3G3AX-MX2-ECT Rev:1.1 is added as a node address 1 to the Network configuration on
Sysmac Studio.
Check that the data above is added. Click Close.
15
Node address 1 and the E001
3G3AX-MX2-ECT Rev:1.1 slave are added to the EtherCAT Tab
Page in the Edit Pane.
7.EtherCAT Connection Procedure
21
7.3.2. PDO Map Settings
Set PDO mappings to use for Inverter.
1
Select Offline from the
Controller Menu.
The yellow bar under the toolbar disappears.
2
Select the slave unit for the node address 1 added in the previous sub-clause on the
EtherCAT Tab Page.
7.EtherCAT Connection Procedure
3
Click Edit PDO Map Settings in the PDO Map Settings Field.
4
The Edit PDO Map Settings
Dialog Box is displayed.
Select Output 258th receive
PDO Mapping.
''PDO entries included in 258th receive PDO Mapping'' is displayed on the right side of the dialog box.
22
5
Check that the following objects are set.
・0x5000:00
・0x5010:00
6
Select Input 258th transmit PDO
Mapping.
''PDO entries included in 258th transmit PDO Mapping'' is displayed on the right side of the dialog box.
7
Check that the following objects are set.
・0x5100:00
・0x5110:00
8
Select Input 512th transmit PDO
Mapping.
''PDO entries included in 512th transmit PDO Mapping'' is displayed on the right side of the dialog box.
9
Check that the following objects are set.
・0x2002:01
10
Click OK.
11
Check that the same PDO entries as those listed in 6.2.
PDO Mappings are displayed in the PDO Map Settings Field.
7.EtherCAT Connection Procedure
23
7.3.3. Setting the Device Variables
Set the device variables to use for Slave Unit.
1
Double-click I/O Map under
Configurations and Setup in the Multiview Explorer.
2
The I/O Map Tab Page is displayed in the Edit Pane.
Check that Node1 is displayed in the Position Column and the added Slave Unit is displayed in the Port Column.
*To manually set a variable name for Slave Unit, click a column under the Variable
Column and enter a name.
3
Right-click Node1 and select
Create Device Variable.
7.EtherCAT Connection Procedure
4
The variable names and variable types are set.
Additional Information
The device variables are named automatically from a combination of the device names and the port names. The default device names are “E" followed by a serial number that starts from 001.
Additional Information
In this document, device variables are automatically named for a unit (a slave).
Device variables can also be manually named for ports.
24
7.EtherCAT Connection Procedure
7.3.4. Transferring the Project Data
Transfer the project data from Sysmac Studio to Controller.
When you transfer a user program, configuration data, setup data, device variables, or values in memory used for CJ-series Units from Sysmac Studio, the devices or machines may perform unexpected operation regardless of the operating mode of CPU Unit.
Always confirm safety at the destination node before you transfer the project data.
After transferring the project data, CPU Unit restarts and communications with slaves are cut off. During the period, the outputs of slaves behave according to the slave settings. The time that communications are cut off depends on the
EtherCAT network configuration.
Before you transfer the project data, confirm that the slave settings will not adversely affect the device.
A slave will be reset after performing the synchronization in step 7 and subsequent steps, and the device may perform unexpected operations.
Always confirm safety before performing the synchronization.
1
Select Check All Programs from the Project Menu.
2
The Build Tab Page is displayed.
Check that "0 Errors" and "0
Warnings" are displayed.
3
Select Rebuild Controller from the Project Menu.
25
4
A confirmation dialog box is displayed. Check that there is no problem and click Yes.
5
Check that "0 Errors" and "0
Warnings" are displayed on the
Build Tab Page.
6
Select Online from the
Controller Menu.
When an online connection is established, a yellow bar is displayed under the toolbar.
7
Select Synchronization from the Controller Menu.
8
The Synchronization Dialog Box is displayed.
Check that the data to transfer
(NJ501 in the right dialog box) is selected. Then, click Transfer
To Controller.
*After executing Transfer To
Controller, the Sysmac Studio data is transferred to
Controller, and the data is compared.
7.EtherCAT Connection Procedure
26
9
A confirmation dialog box is displayed. Check that there is no problem and click Yes.
A screen stating "Synchronizing" is displayed.
A confirmation dialog box is displayed. Check that there is no problem and click No.
*Do not return to RUN mode.
10
Check that the synchronized data is displayed with the color specified by "Synchronized" and that a message is displayed stating "The synchronization process successfully finished".
If there is no problem, click
Close.
*A message stating "The synchronization process successfully finished" is displayed if the Sysmac Studio project data coincides with the
Controller data.
*If the synchronization fails, check the wiring and repeat from step 1.
7.EtherCAT Connection Procedure
27
7.EtherCAT Connection Procedure
7.4. Checking the EtherCAT Communications
Check that the PDO communications of EtherCAT are performed normally.
7.4.1. Checking the Connection Status
Check the connection status of EtherCAT.
1
Check with LED indicators on
Controller that PDO communications via EtherCAT are performed normally.
The LED indicators in normal status are as follows:
NET RUN: Green lit
NET ERR: Not lit
LINK/ACT: Yellow flashing
2
Check the LED indicators on
EtherCAT Communication Unit.
The LED indicators in normal status are as follows:
L/A IN: Green flickering
RUN: Green lit
ERR: Not lit
28
7.EtherCAT Connection Procedure
7.4.2. Checking the Sent and Received Data
Check that the correct data are sent and received.
The following procedure describes the steps required for checking that the correct data are sent orreceived by setting the output frequency of Inverter in the device variables for output area of Controller and by checking the output frequency monitor stored in the device variables for input area of Controller and the status of Inverter.
In this procedure, Inverter is output, which may perform unexpected operations.
Take sufficient safety precautions and proceed to this operation check.
If you cannot confirm safety, do not proceed to this section after completing until
7.4.1. Checking the Connection Status. If you proceed to this operation check, make sure to complete all the steps and place Inverter in the safe state.
If you wire the I/O in the state where the power supplies to the devices are turned ON, doing so may cause damage to the devices.
Always read and heed the information provided in all safety precautions of manuals for each device to be wired.
If you change the values of variables on a Watch Tab Page in the online state, the devices connected to the output unit may operate regardless of the operating mode of CPU Unit.
Sufficiently confirm safety before you change the values of variables on a Watch
Tab Page when Sysmac Studio is online with CPU Unit.
1
Select Watch Tab Page from the
View Menu.
2
Select the Watch1 Tab.
3
As shown below, enter the following name of the variables for monitoring. Click Input Name in the
Name Column to enter a new name.
E001_Command
E001_Frequency_reference
E001_Status
E001_Output_frequency_monitor
29
4
Check that the display formats are as follows:
E001_Command: Hexadecimal
E001_Frequency_reference:
Decimal
E001_Status: Hexadecimal
E001_Output_frequency_monitor:
Decimal
5
Check that the online value for the
E001_Status variable is 0200.
*This means that the status bit 9 is
''1'' (Remote: Operations from
EtherCAT are enabled).
6
Check that the display on Inverter shows as follows:
RUN LED: Not lit
Data display: 0.00
(Output frequency: 0.00 Hz)
Monitor LED (Hz): Green lit
*If the output frequency monitor is not displayed, take step 5 in 7.2.2.
Parameter Settings to display.
7.EtherCAT Connection Procedure
7
Enter 200 (2.00 Hz) in the Modify
Column of the
E001_Frequency_reference variable on the Watch1 Tab Page of
Sysmac Studio.
''200'' is displayed in the Online
value Column of the
E001_Frequency_reference variable.
8
Enter 1 in the Modify Column of the
E001_Command variable.
*Set the command bit 0 to 1
(Forward command).
30
9
Check that the online values of variables are as follows.
E001_Status: 1201
E001_Output_frequency_monitor:
200 (Output frequency: 2.00 Hz)
*This means that the status bit 0 is
''1'' (During forward operation) and bit 12 is ''1'' (Frequency matched).
10
Check that the display of Inverter shows as follows:
RUN LED: Green lit
Data display: 2.00
(Output frequency: 2.00 Hz)
Monitor LED (Hz): Green lit
11
Enter the following values in the
Modify Column on the Watch1 Tab
Page of Sysmac Studio..
E001_Command: 0
E001_Frequency_reference:
0 (0.00 Hz)
*Set the command bit 0 to ''0''
(Stop).
12
Check that the online values of variables are as follows:
E001_Status: 0200
E001_Output_frequency_monitor:
0 (Output frequency: 0.00 Hz)
*This means that the status bit 0 is
''0'' (Stopped/during reverse operation) and bit 12 is ''0'' (During acceleration/deceleration or stopped).
13
Check that the display of Inverter is as follows:
RUN LED: Not lit
Data display: 0.00
(Output frequency: 0.00 Hz)
Monitor LED (Hz): Green lit
7.EtherCAT Connection Procedure
31
8.Initialization Method
8. Initialization Method
This document provides explanations of procedures based on the factory default settings.
Some settings may not be applicable as described in this document unless you use the devices with the factory default settings.
8.1. Initializing the Controller
To initialize the settings of Controller, it is necessary to initialize CPU Unit.
Change the operating mode of Controller to PROGRAM mode before the initialization. Select
Clear All Memory from the Controller Menu in Sysmac Studio. The Clear All Memory Dialog
Box is displayed. Check the contents and click OK.
8.2. Initializing Inverter
For information on how to initialize Inverter, refer to 5-1-2 Parameter Initialization of the
Inverter Multi-function Compact Inverter MX2 Series Type V1 User’s Manual (Cat. No. I585).
32
9.Revision History
9. Revision History
Revision code
01
Date of revision
September 18, 2015 First edition
Revision reason and revision page
33
34
P640-E1-01
2015
0915- (-)
Laadi alla
Reklaam