AMS Eval Kit AS7024 Quick Start Guide
AMS AS7024 is a versatile biosensor evaluation kit designed to assess all its functions and explore various applications. With a detachable breakout board featuring AS7024, temperature sensor, accelerometer, and electrodes, it offers flexibility for customized setups. The kit also includes an add-on board and wristband for diverse use cases. Its PC software enables configuration changes and real-time measurement visualization. Algorithms for HRM and HRV are provided, with GSR and BP coming soon.
Reklama
Reklama
ams
Shaping the world with sensor solutions
Teresa Meier
Martin Dedek
2018-06-08
AS7024 Eval Kit 1v2
User Guide
Introduction
How to Use
Safety Requirements
Buildup
Glass Holder
Break-off Board
Add-On Board
Wristband
AS7024 PC Software
FW Upgrade over USB
Introduction
The AS7024 Eval Kit is designed to evaluate all functions of the
AS7024 biosensor and test them in various applications.
For full flexibility, biosensor (AS7024), temperature sensor
(AS6200), accelerometer (LIS2DH12) and electrodes are located on the break out board, which can be used in any application and reconnected to the main board via FPC cable. There is also the option to attach different electrodes.
After breaking off the Board it is also possible to connect the Add-
On Board with the FPC cable or the Wristband with the PicoBlade connector.
The Eval Kit works with USB connection to the PC and comes with a GUI, which enables the user to change AS7024 register settings and see measurement results.
The SDK currently containing algorithms for HRM and HRV (GSR and BP will be available in the near future) is supplied with the Eval
Kit and flashed onto the STM32 ARM Cortex-M4 low power MCU.
Any signals important for development can be probed easily at the pin headers.
Confidential © ams AG
Page 3
How to use
PC or Laptop
USB Cable
Green Power
On LED
AS7024
ECG INN (negative) signal
1) Install the SDK on your computer
2) Start the PC GUI
3) Connect the Micro USB to USB cable to the Eval Kit and plug it into your computer
4) The green power LED will turn ON as soon as the board is powered
5) The green AS7024 LEDs will turn on
6) Hold the ECG INP and reference electrodes with pointer and middle finger of your left hand, put the pointer finger of your right hand on the ECG INN electrode and the middle finger of your right hand on the AS7024 to measure
7) The raw pulse and ECG data will be displayed in the GUI
ECG INP (positive) signal
ECG Reference signal
Confidential © ams AG
Page 4
Safety Requirements
The AS7024 Eval Kit is supplied by USB connection to the PC. In order to avoid a direct connection from the electrodes to the power grid, an IEC 60601 compliant RECOM DCDC converter (R0.25S-0505/H) is assembled on the board as well as isolator ICs for any other signals, which means that there is no physical connection between the break out part of the board and the power grid.
Isolation (IEC 60601)
USB Power
Supply
DC/DC
Converter and
Isolators
AS7024 Eval Kit
Break-off Part
Confidential © ams AG
Page 5
Buildup Top Side
SWD
Interface
IEC 60601 Compliant
DCDC Converter
AS7024
Connection for
SIGREF
AS6200 ECG INN Electrode
Pin Header
DFU Button
Micro USB
Pin Header
Connection for External ECG REF Electrode
Connection for External ECG INN Electrode
Connection for External ECG INP Electrode
STM32L476RET6
MCU
Isolators for all signals
ECG INP Electrode
Break out line
ECG REF Electrode
Confidential © ams AG
Page 6
Buildup Bottom Side
ADC
ADS1113
For Current Consumption
Accelerometer
LIS2DH12
Jumper for Electrodes on Board
Connector for External Electrodes
(Molex PicoBlade 53261-0471)
Connector for Break out Board
Hirose FH12A-10S-0.5SH(55)
Top Contact
Confidential © ams AG
Page 7
Glass Holder
Glass Holder Glass
Material: Plexiglas
10mm Ø and 0.5 mm thickness
1) Mount glass holder on PCB
2) Insert glass into holder
Confidential © ams AG
Page 8
Break-off Board
Mainboard
Connector for Break-off Board
Hirose PN: FH12-10S-0.5SH(55),
Bottom contact, 10 contacts
FPC Cable
Molex PN: 15020-0105,
10 contacts
Pin 1
– 3V3_ISO
Pin 2
– 4V75_ISO
Pin 3
– LIS2DH12_INT_ISO
Pin 4
– I2C1_SDA_ISO
Pin 5
– I2C1_SCL_ISO
Pin 6
– AS7024_INT_ISO
Pin 7
– AS7024_GPIO_ISO
Pin 8
– AS7024_EN_ISO
Pin 9
– GND_ISO
Pin 10
– GND_ISO
Break-off Board
Connector for Break-off Board (on rear side)
Hirose PN: FH12A-10S-0.5SH(55),
Top contact, 10 contacts
1) Break off the board at the break out line
2) Connect the mainboard to the
Break-off Board (connector on rear side) by the FPC cable
3) It is
not
required to twist the cable, since one connector is a bottom contact connector and the other one is a top contact connector
Confidential © ams AG
Page 9
Add-On Board
Mainboard
Connector for Add-On Board
Hirose PN: FH12-10S-0.5SH(55),
Bottom contact, 10 contacts
FPC Cable
Molex PN: 15020-0105,
10 contacts
Pin 1
– 3V3_ISO
Pin 2
– 4V75_ISO
Pin 3
– 3V3_ISO
Pin 4
– 3V3_ISO
Pin 5
– I2C1_SDA_ISO
Pin 6
– I2C1_SCL_ISO
Pin 7
– AS7024_INT_ISO
Pin 8
– AS7024_GPIO_ISO
Pin 9
– AS7024_EN_ISO
Pin 10
– GND_ISO
Temperature sensor
AS6200
Connector for FPC cable
Hirose FH12-10S-0.5SV(55),
Vertical orientation, 10 contacts
Test points to connect external electrodes
Accelerometer
LIS2DH12
BOTTOM SIDE
AS7024
TOP SIDE
Confidential © ams AG
Page 10
Wristband
AS7024
Mainboard
Connector for Wristband
Molex PN: 53261_1071,
10 contacts
Connect the Wristband to the mainboard with the red custom cable,
10 contacts
Pin 10
– GND_ISO
Pin 9
– AS7024_EN_ISO
Pin 8
– AS7024_GPIO_ISO
Pin 7
– AS7024_INT_ISO
Pin 6
– I2C1_SCL_ISO
Pin 5
– I2C1_SDA_ISO
Pin 4
– 3V3_ISO
Pin 3
– 3V3_ISO
Pin 2
– 4V75_ISO
Pin 1
– 3V3_ISO
The Wristband also includes the accelerometer
(LIS2DH12) and 2 x AS6200
Confidential © ams AG
Page 11
AS7024 PC Software
Working with the software
1) Connect the evaluation board to your computer using a Micro USB cable
– the board will register as virtual COM board in Windows.
2) The green power LED will turn ON as soon as the board is powered
3) Select the correct COM port in the in the selection box in the lower left corner of the application. If no COM ports are listed click on
“Refresh COM ports” button
4) Use the
“Connect” button to start up a connection to your board. The two status fields in the bottom status bar will turn green upon successful connection
5) After pressing the
“Start” button the measurement of PPG and ECG starts.
6) Touch the ECG INP and reference electrodes with index and middle finger of your left hand, put the index finger of your right hand on the
ECG INN electrode and the middle finger of your right hand on the AS7024 to measure
Confidential © ams AG
Page 12
AS7024 PC Software
AS7024 Configuration Settings
At power up the board starts with default a configuration:
•
The two green LEDS - LED1(VD1) and LED2(VD2) are enabled, the LED current set to 50 mA
•
Sequencer period set to 2000 microseconds
•
Photodiode Trans-Impedance amplifier (TIA) is on and used
•
All filters are on and used
•
ADC is set to measure only the optical front end 1 after the gain stage (ofe1)
The individual settings of each of the AS7024 blocks can be viewed/changed in the dedicated configuration sub menu (see next slides)
Confidential © ams AG
Page 13
AS7024 PC Software
Sub Menu Selection
AS7024 Configuration settings
LEDs -> Datasheet pg. 14 ff.
TIA -> Datasheet pg. 29 ff.
Photodiodes -> Datasheet pg. 24 ff.
OFE -> Datasheet pg. 34 ff.
Light to frequency -> Datasheet pg. 54 ff.
Electrical analog frontend -> Datasheet pg. 61 ff.
ECG amplifier -> Datasheet pg. 70 ff.
ADC -> Datasheet pg. 75 ff.
Sequencer -> Datasheet pg. 35 ff.
Interrupts -> Datasheet pg. 84 ff.
GPIOs -> Datasheet pg. 84 ff.
To enter the submenus press the corresponding button
Confidential © ams AG
Page 14
AS7024 PC Software
LEDs Configuration
LED current and LED mode can be set in the
“LEDs configuration” window. It is recommended to configure the current only when the output is not active as there is no latch implemented to keep the 10 bits consistent. New values are applied directly and immediately.
Confidential © ams AG
Page 15
AS7024 PC Software
TIA Configuration
The TIA has to be configured according to the information in the AS7024 datasheet (table in figure
30).
It is recommended to
always
set
“OpAmp Offset” to 15.
Confidential © ams AG
Page 16
AS7024 PC Software
Photodiodes Configuration
Select the photodiodes which to connect to the TIA input. The offset current is optional, this allows cancellation of constant light sources like sunlight. Default for the input offset current is 0 for both
– LEDs off and any LED on.
For an external photodiode or any other sensor with (low) current output, the pins GPIO0 and GPIO1 can be used as input.
The sequencer controls the diodes
– see diode_ctrl described in register MAN_SEQ_CFG.
Confidential © ams AG
Page 17
AS7024 PC Software
OFE Configuration
Synchronous demodulator
The AS7024 has two optional synchronous demodulators that can be used to detect small optical signals in the presence of large unwanted noise (ambient light). They have an input filer (the
Prefilter block on the schematics - high pass at 200Hz, adjustable low pass) and a 2nd order adjustable output low pass
(ofe_gs_aa). The demodulator itself multiplies the signal by +1 / 0
/ -1 with a timing which is controlled by the sequencer.
High Pass Filter
Two optional high pass filters can be used to remove DCcomponents from the signal and allow further amplification - four cutoff frequencies can be chosen.
Gain Stage
Two optional gain stage can be used to amplify the signal after the DC-component has been removed.
?
Confidential © ams AG
Page 18
AS7024 PC Software
OFE Configuration
Check OFE1 and/or OFE2 check box to enable the corresponding OFE block shown on the previous slide.
The
“Prefilter” tab is setting the configuration of the input filters of the two synchronous demodulators.
For reference, please see OFE_CFGA, OFE_CFGB,
OFE_CFGC and OFE_CFGD register descriptions in the
AS7024 datasheet.
Confidential © ams AG
Page 19
AS7024 PC Software
Light to Frequency Configuration
Light to frequency can be used to convert a light source into a frequency signal. Several settings can be done. For details check the
AS7024 datasheet.
The following registers can be shown/configured in the dialog: ITIME, LTF_CONFIG, LTF_SEL and LTF_GAIN.
When selecting sensor diodes for LTF0/LTF1, make sure the selected diode is not connected to the TIA at the same time (its checkbox in the
“Photodiodes” window should be unchecked), currently the SW will not take care of that
.
Confidential © ams AG
Page 20
AS7024 PC Software
Electrical Analog Frontend Configuration
The electrical analog front end consists of three identical signal paths with independent settings of bias condition, gain and offset.
Here the EAF_CFG, EAF_GST, EAF_BIAS, EAF_DAC and EAF_DAC_CFG registers are set.
Confidential © ams AG
Page 21
AS7024 PC Software
ECG Amplifier Configuration
The ECG (electrocardiography) amplifier is a high impedance, low noise instrumentation amplifier with analog circuitry to band pass filter the signal and amplify it before converting it with the ADC.
The ECG signal can be used independently or together with PPG in further computation. (eg. Blood pressure)
Confidential © ams AG
Page 22
AS7024 PC Software
ADC Configuration
The ADC is a 14bit successive-approximation register (SAR) type. It supports 14bit with conversion time up to 50ksps.
At the output of the ADC converter a digital threshold can be enabled. If the output of the ADC exceeds the threshold adc_threshold, it triggers an interrupt. This mechanism can be used to identify if an object is in proximity of the sensor and then to interrupt the host. In cases where no object is detected, the host can be sleeping therefore reducing power consumption of the system.
For detailed description of the threshold calculation see the register ADC_THRESHOLD and ADC_THRESHOLD_CFG description.
Confidential © ams AG
Page 23
AS7024 PC Software
Sequencer Configuration
In order to synchronize the LED-currents, the integration time and the ADC-sampling time, a built in sampling Sequencer is used.
The sequencer generates the 8 bit-timings based on a 1
μs clock. The input clock can be pre-scaled with the “Clock divider” (SEQ_DIV register). The sequencer will trigger the ADC do a measurement of its enabled channels (configured in the
“ADC Configuration” dialog) with a period of (Period * (Clock divider +1 ) * 1
μs. For the default configuration this gives a period of 2000 μs.
Confidential © ams AG
Page 24
AS7024 PC Software
Interrupts Configuration
An interrupt output pin INT can be used to interrupt the host.
The following interrupt sources can be selected:
• ADC: End of ADC conversion
• Sequencer: End of sequencer sequence reached.
• LTF: A light-to-frequency conversion is finished.
• ADC threshold: ADC threshold triggered – see ADC threshold.
• FIFO threshold: FIFO almost full (default is each sample triggers an interrupt)
• FIFO overflow: FIFO overflow (error condition, data is lost
• Cipdetect: TIA output and/or SD output exceeded threshold– see details in
CLIPSTATUS
• LED supply low: led supply low comparator triggered – see details in
LEDSTATUS
Confidential © ams AG
Page 25
AS7024 PC Software
GPIOs Configuration
To set a GPIO to analog mode check the check box from the
“GPIO mode” group box. If left unchecked, then the
GPIO is a digital output or input, depending on the state of the
“GPIOx enable output” check boxes - unchecked means the pin is digital input. If the pin is set as digital output, it’s state can be set via the corresponding check box in the
“Output state” group box.
Confidential © ams AG
Page 26
AS7024 PC Software
Additional ADC channels and Light-to-Frequency data display
To display a data plot of an ADC channel other than OFE1 and
ECG Output, click on menu “View ADC Channels” and then on the desired ADC channel.
For Light-to-
Frequency data output, click on “View LTF”.
A separate plot window will open.
Confidential © ams AG
Page 27
AS7024 PC Software
Register map
The “Register Map” window is used to view/change the contents of the complete set of AS7024 user register. To open it, click on the “View Register Map” menu.
Changing a register value can be done either by modifying its value in the relevant “Value” field or by toggling a bit by clicking on the relevant bit cell. Changing a value in the register map will not update the current selection in the configuration windows of the GUI. Also, a change in any of the configuration windows will not trigger an automatic update of the already opened register map window. To update the values, click on the refresh button marked with the orange rounded rectangle on the “Register
Map” picture on the right.
Confidential © ams AG
Page 28
AS7024 PC Software
Saving current configuration settings to a file
The current configuration settings can be exported to a file. To do this, click on the
“File
Save
Configuration” menu. This will open the
“Save Configuration File” dialog box on the second picture on the right. Enter file name and choose the file location, then click
“Save”.
Confidential © ams AG
Page 29
AS7024 PC Software
Loading configuration settings from file
To load a previously exported configuration settings, click on the
“File
Load
Configuration” menu. This will open the “Select
Configuration
File” dialog box. Select the configuration file from which to load settings and click
“Open” button.
The settings imported from the file can be reviewed in the relevant configuration windows.
If the GUI is connected to the board, the newly imported settings will be applied immediately, otherwise upon successful connection to the board.
Confidential © ams AG
Page 30
AS7024 PC Software
Raw data logging and exporting
By default, during measurement the raw data from the AS7024 is logged in memory. When a measurement is stopped, this data can be exported to a comma delimited file by clicking on the
“File
Export Raw
Data” menu and selecting the file location and file name in the save file dialog box.
Raw data file format:
first raw has the column captions
first column has the timestamp in milliseconds
columns 2 nd to the last have the data from the enabled ADC channels
Raw data logging can be disabled by unchecking the
“Log raw data” check box in the “Settings” menu.
Confidential © ams AG
Page 31
Firmware Update over USB
Starting in DFU mode
In order to update the FW over USB on the AS7024 Evaluation
Board the MCU has to be started in DFU mode. To do so follow the steps below:
Start the DfuSeDemo.exe from the
“extras\DFU” folder located at the installation folder of the GUI (if not changed during installation should be
“\Program
Files
(x86)\ams\AS7024
_Vital_Sign_Sensor”.
Connect a USB cable to the AS7024 Evaluation Board
Press the button marked with yellow on the picture below
Connect the USB cable to the computer whilst keeping the button pressed
Release the button as soon as the device appears in the
DfuSeDemo tool
Confidential © ams AG
Page 32
Firmware Update over USB
Starting in DFU mode
If the MCU was booted in DFU mode successfully, the device will be listed and selected in the drop down menu under
“Available DFU Devices”.
The next step is to flash the new FW onto the MCU. Under
“Upgrade or Verify Action” press the “Choose” button.
Confidential © ams AG
Page 33
Firmware Update over USB
Flashing the FW onto device
Select the .dfu file containing the new FW and click on
“open”.
After loading the .dfu file press the
“Upgrade” button, which will be available.
The pop-up window shown in the figure below will then open.
Click on
“Yes” to continue.
Confidential © ams AG
Page 34
Firmware Update over USB
Flashing the FW onto device
The flashing will start and the progress is shown as a green bar at the bottom of the tool. The process takes only a few seconds.
When finished the message
“Upgrade successful” is shown.
Last and to finish the FW update, press
“Leave DFU mode”.
The AS7024 Evaluation Board is ready for use again.
Confidential © ams AG
Page 35
Thank you!
Please visit our website www.ams.com
Preuzimanje
Reklama