The Interface. Quark QuarkXPress
Annonce
Annonce
Introduction
The Interface
QuarkXPress menus and dialog boxes adhere to Microsoft Windows conventions — with a few enhancements. This section provides a quick look at standard interface controls, and highlights features unique to QuarkXPress.
If you are new to Windows, we recommend that you consult the documentation resources provided with your computer for complete information about using Windows. If you are new to QuarkXPress, we recommend that you perform the tutorial contained in A Preview to QuarkXPress.
Figure 1: Like other QuarkXPress menus, the File menu contains groups of related commands separated by lines.
QuarkXPress menus
The menu bar displays the nine menus available in QuarkXPress: File,
Edit, Style, Item, Page, View, Utilities, Window, and Help. The menu bar can also display QuarkXTensions. Each menu contains groups of related commands separated by lines. Many menu entries are followed by keyboard shortcuts using the CTRL , ALT , and SHIFT keys. See Figure 1.
Although the mouse serves as the primary means of accessing the menus, they can also be accessed using the keyboard. This is accomplished by pressing the ALT key and the underlined character within the menu name. For example, to access the File menu, press ALT + F . The functions within the menu are then activated by pressing the underlined character within the function name. For example, once the File menu is displayed, simply press P to print.
xxviii A Guide to QuarkXPress
The Interface
Context-sensitive menus
QuarkXPress menus are context-sensitive (menu items change according to the active item, the current situation, or the tool selected).
• The commands listed under a menu may change. For example, the
Style menu commands change depending on whether text, a picture, or a line is active.
• An individual menu command may change. For example, the Undo command (Edit menu) changes to reflect your last action (such as
Undo Typing or Undo Item Deletion).
• The availability of menu entries may change. For example, when a picture is selected, Save Text (File menu) is dimmed and not available.
• The availability of entire menus may change. For example, the Style menu entries for text are available only when a text box is active and the Content tool
E is selected.
Check mark
A check mark j in a menu indicates one of the following:
• A function has been performed. For example, a check mark is displayed next to Flip Vertical (Style menu) when the contents of a box are flipped vertically. See Figure 2.
• A feature is turned on. For example, a check mark next to Snap to
Guides (View menu) means that items in your document will snap to the guides you’ve created.
• A format from a list has been applied. For example, a check mark is displayed in the Font submenu (Style menu) next to the font applied to selected text. When multiple formats have been applied to a selection, check marks are displayed next to formats common to the entire selection only.
Figure 2: The check mark next to Flip
Vertical in the Style menu for text indicates that the contents of the active text box are flipped vertically.
A Guide to QuarkXPress xxix
Introduction
Figure 3: The Modify dialog box (Item menu) includes tabs, areas, fields, dropdown lists, check boxes, and buttons.
Figure 4: The Box tab of the Modify dialog box (Item menu) includes a bordered
Blend area.
QuarkXPress dialog boxes
Choosing a menu entry followed by an ellipsis (…) displays a dialog box.
Dialog boxes contain related commands that allow you to specify exactly what you want to happen. The context-sensitive controls in QuarkXPress dialog boxes consist primarily of tabs, areas, fields, drop-down lists, radio
(option) buttons, check boxes, and buttons. See Figure 3.
Tabs
Many dialog boxes provide multiple functions through tabs. By clicking a tab icon, you can display different sets of controls. Pressing
CTRL
+
TAB takes you to the next tab in a dialog box.
Area
Related commands within a dialog box or tab are grouped into an
“area,” which is named and surrounded by a border. For example, the
Box tab in the Modify dialog box (Item menu) has a Blend area, which lets you specify a custom blend for a box. See Figure 4.
List
Some dialog boxes include lists of elements for you to select or edit. For example, the Colors dialog box (Edit menu) displays a list of colors. You can navigate through lists using the up and down arrow keys. Depending on the type of list, you may be able to multiple-select items to edit.
For example, in the Tool tab of the Document Preferences dialog box
(Edit
& Preferences & Document), you can select multiple tools and edit common attributes. To select a group of continuous elements, click the first element then press the
SHIFT key while clicking the last element in the range. To select a group of noncontinuous elements, press the
CTRL key while clicking them.
xxx A Guide to QuarkXPress
The Interface
Field
A field is a rectangular box for entering a specific value. For example, in the Text tab of the Modify dialog box (Item menu), you can enter the number of columns for an active text box in the Columns field. Fields have the following characteristics:
• You can enter measurements in any of the supported measurement systems, using the following abbreviations: inches or inches decimal ("), picas (p), points (pt), millimeters (mm), centimeters (cm), ciceros (c), and agates (ag).
• You only need to specify units of measure with an abbreviation when you are not using the default measurement system. For example, if your measurement preferences are set to inches, and you want to specify an indent in points, you can enter “6 pt” in the field. The measurement will be converted to inches the next time you open the dialog box.
• The default measurement system is specified in the Horizontal Mea-
sure and Vertical Measure drop-down lists in the General tab of the
Document Preferences dialog box (Edit
& Preferences & Document).
• You can tab to highlight the next field in a dialog box and
SHIFT
+
TAB to highlight the previous field.
• You can perform math in fields using these operators: + (addition),
– (subtraction), * (multiplication), or / (division). For example, to double the width of a box, you can multiply the width by 2 by entering *2 to the right of the current value. You can even perform multiple operations — such as dividing a value by 4, then adding 2. See Figure 5.
R QuarkXPress performs multiplication and division first, followed by subtraction and addition, from left to right; you cannot use parentheses when performing math in fields. You can add and subtract specific measurements, such as 2".
Figure 5: You can perform math in
QuarkXPress fields. The formula in the
Width field multiplies the width of the box by 2, then adds 1 point. The formula in the Height field divides the height of the box by 2, then subtracts .25 inch.
A Guide to QuarkXPress xxxi
Introduction
Figure 6: A drop-down list offers a list of options, and often includes a field that accepts custom values. For example, the
Width drop-down list in the Frame tab of the Modify dialog box (Item menu) includes a list of frame widths and a field.
Drop-down list
A drop-down list is a small menu within a dialog box or palette.
A drop-down list contains a list of options and may also have an editable field in which you can enter a custom value (such as a percentage) or a word (like a font name) rather than choosing an option from the list. See Figure 6.
Check box
A check box lets you turn options on and off . Checking a box may activate other controls; checking or unchecking a box may expand a dialog box to display more controls.
Radio (Option) button
A radio button lets you select from mutually exclusive options. For example, in the XTensions tab (Edit
& Preferences & Application), you can choose when to display the XTensions Manager dialog box by clicking a radio button.
Button
A button, shaped like this bold outline
, performs an action. If a button has a
, you can press
ENTER when in any field of a dialog box to activate the button, rather than clicking the button with the mouse. If a button has a dotted outline around the text , you can also press the
SPACE bar to activate the button. A button may also include a drop-down list that lets you choose a type of action. For example, the New button in the Style Sheets dialog box (Edit menu) lets you create either a character style sheet or a paragraph style sheet.
Many dialog boxes in QuarkXPress include an Apply button so you can preview your changes before closing the dialog box. For example, the
Apply button in the Paragraph Attributes dialog box (Style
& Formats) lets you see how your changes affect selected paragraphs. Some Apply buttons have an “Auto-apply” feature, which allows you to view all your changes as you enter them without having to click the Apply button again. This feature is activated by pressing the
CTRL key the first time you select Apply.
xxxii A Guide to QuarkXPress
The Interface
Open, Save as dialog boxes
These dialog boxes are used to open, import, export, or save files; they include standard Windows controls for navigating through disks and folders so you can locate files, or choose where you want to save files. See
Figure 7. Dialog boxes in QuarkXPress with open, save as navigational dialog box elements include: New Library, New Book, Open, Save as,
Get Text, Save Text, Append, Save Page as EPS, Collect for Output, and Auxiliary Dictionary.
Warning dialog box
A warning is a dialog box that alerts you when there is a problem and often suggests a solution. For example, if you enter an invalid value in a field, a warning notifies you and often provides an acceptable range of values for the field. The “Error Messages” section of Chapter 24, “Appendices” lists and explains the warnings you may encounter in QuarkXPress.
Figure 7: The Save as dialog box (File menu) is an example of an open, save as dialog box. It includes the Save in dropdown list, the Up One Level, Create
New Folder, List, and Details buttons, the File name field, drop-down lists for the file type and version, and buttons for
Save and Cancel.
A Guide to QuarkXPress xxxiii
A G U I D E T O Q U A R K X P R E S S
Introducing QuarkXPress
Tools
The Tool Palette
Tool Overview
Item Tool and Content Tool
Rotation Tool
Zoom Tool
Standard-Shape Text Box Tools
Standard-Shape Picture Box Tools
Straight Line Tools
1
1.3
1.5
1.7
1.12
1.14
1.16
1.18
1.20
1.22
Straight Text-Path Tools
Bézier Tools
Freehand Tools
Linking/Unlinking Tools
Page Grabber Hand Tool
1.24
1.26
1.28
1.30
For internal use by licensee only. The information in this electronic file may not be disseminated in any form to any unlicensed person or entity without prior written consent of Quark Technology Partnership or its licensee, Quark, Inc.
Tools
1
QuarkXPress preserves the cliché “you need the right tools to get the job done.” The Tool palette provides easy access to powerful tools that allow you to accomplish the most basic — and the most sophisticated — publishing tasks.
Tools let you create and place boxes, lines, pictures, and text; rotate items; link text boxes so text flows from page to page; and enlarge and reduce the document view. You can customize the Tool palette by rearranging and hiding tools, and you can customize many individual tools using preferences.
Download
Annonce