Libraries
17
Creating New Libraries 17.3
Opening Libraries 17.4
Working with Libraries 17.5
Working with Labels 17.8
Saving Libraries 17.10
For internal use by licensee only. The information in this electronic file may not be disseminated in any form to any unlicensed person or entity without prior written consent of Quark Technology Partnership or its licensee, Quark, Inc.
Libraries
17
Libraries are QuarkXPress files that provide easy access to frequently-used items. You can store any item or group of items in a library, including text boxes, text paths, picture boxes, lines, and groups.
Libraries are displayed as palettes that contain thumbnail displays of items.
You build a library by copying selected items from a document or another library into an open library.
You retrieve library items by dragging them out and placing them on document pages.
Creating New Libraries
Creating New Libraries
You can create a new library any time, as long as you have fewer than 25 files open. To create a new library:
1 Choose File
& New & Library (
CTRL
+
ALT
+
N
).
S Tips
Library palettes remain open
When you create a new library, it stays open until you close it. When you launch QuarkXPress, any library palettes that were previously open are reopened automatically and placed in their previous positions.
Specify a name and location for a new library in the New Library dialog box (File
& New).
2 Use the controls in the New Library dialog box to specify a location for the new library file.
3 Enter a name for the library in the File name field. The Save as
type field will automatically display the appropriate extension
“Libraries (*.qxl).”
4 Click Create. The new l ibrary is displayed as a palette in front of all open documents.
New library palettes are displayed in the upper right corner of the screen.
A Guide to QuarkXPress 17.3
Libraries
S Tips
Libraries are palettes
You manipulate a library palette like all other palettes: Click and drag the title bar to move it and click the close icon to close it.
Library compatibility
QuarkXPress libraries can also be opened by QuarkXPress Passport, but not vice versa.
Opening Libraries
QuarkXPress lets you open any combination of 25 documents, templates, or libraries at one time. Libraries stay open until you close them — they’re even reopened automatically when you quit and relaunch QuarkXPress. To open a library:
1 Choose File
& Open (
CTRL
+
O
).
Use the Open dialog box (File menu) to locate and open QuarkXPress libraries.
2 Use the controls in the Open dialog box to locate the library you want to open. QuarkXPress libraries are automatically saved with the
“*.qxl” extension to distinguish library files from other file types.
3 Select the library from the list.
4 Click Open.
Library palettes remember their position on-screen and open in their previous position. Click and drag the title bar to move the palette.
17.4
A Guide to QuarkXPress
Working with Libraries
Working with Libraries
Libraries are convenient for storing frequently-used page items such as logos, publication mastheads, legal text, and photographs. You can store up to
2,000 entries in an individual library. A library entry can be a text box, text path, picture box, line, multiple-selected items, or a group. To move entries in and out of libraries, you simply drag them or cut/copy and paste them.
Adding library entries
When you add entries to a library, copies of the items are placed in the library and displayed as thumbnails. The original items are not removed from the document. To add entries to an open library:
1 Select the Item tool e.
2 Select the item(s) or group to place in the library. To select multiple items, press the SHIFT key while clicking them. However, if you select multiple items, they will be saved in the library as one entry and not as individually items.
3 Drag the item(s) or group over the library and release the mouse button when the Library pointer l appears. The library entry is placed between the arrow icons
> J.
S Tips
Placing contents in libraries
To store text or pictures (contents) in a library, drag its bounding box into a library. You cannot drag highlighted text or a selected picture into a library without its box.
Libraries vs. templates
Before you store all your frequently used page elements in a library, consider whether the items would be more useful as part of a template. For example, you may want to store a nameplate for a newsletter in a template rather than dragging it in from a library for each issue. If you feature different columnists in each issue of your newsletter, you may want to store the columnists’ photographs in a library rather than in a template.
Drag selected items from a document into a library; release the mouse button when the Library pointer l appears.
A Guide to QuarkXPress 17.5
Libraries
S Tips
Good candidates for libraries
Libraries are good for storing items that may be needed at any time in a layout. For example, corporate logos, legal information, commonly used pictures and verbiage, chart formats, and clip art are all good candidates for library entries. Items with hardto-remember formatting can also be saved in a library.
Retrieving library entries
To put a library entry into a document, select any tool and click the library entry. Drag the entry into the document. A copy of the library entry is placed in the document.
Drag entries from libraries into documents with any tool selected.
The effect on document defaults and preferences
When you drag a library entry into a document, the following defaults and preferences are affected:
• Any style sheets, colors, dashes & stripes, lists, or H&Js used in the library entry are automatically added to the document.
However, if any of the library entry’s specifications have the same name as a specification in the document, the document specification is used.
(For example, if a color has the same name but is defined differently, the item will change color from the library to the document.) Likewise, if a new library entry has a specification with the same name as an existing library entry, the existing library entry’s specification is used.
(In this situation, if a color has the same name but is defined differently, the item will change when it is dragged into the library.)
• If the XPress Preferences used in the library are different from those used in the document, text reflow may occur.
17.6
A Guide to QuarkXPress
Working with Libraries
• When you place an item that includes a high resolution picture into a library, QuarkXPress saves the full path of the picture file with the library entry. If the picture file is on an available disk, QuarkXPress can find it.
Manipulating library entries
You can rearrange the order of entries within a library, move entries from one library to another, replace library entries, and delete library entries.
• To rearrange an entry within a library, click it and drag it to a new position. The arrow icons
> J indicate the entry’s new position.
Drag entries up or down to rearrange them; the arrow icons
> J indicate the placement of entries.
• To move an entry from one library into another, click it and drag it to the other open library. Delete the entry from the first library.
• To replace an entry in a library, select the replacement items in a document; then choose Edit
& Copy (
CTRL
+
C
) from the application menu.
Click the entry in the library to select it and choose Paste (
CTRL
+
V
) from the Edit menu on the library palette. A warning asks you to confirm the deletion.
• To remove an entry from a library, click it and choose Edit
& Delete. A warning asks you to confirm the deletion.
S Tips
Moving pictures
If you move high resolution pictures from the original location, you will have to relocate the file by using the
Get Picture command or update the path by using the Usage command
(Utilities menu).
Using Edit menu commands in the
Library palette
In addition to manipulating library entries with the mouse, you can use
Cut, Copy, Paste, and Delete in the library’s Edit menu. For example, you can cut an item from a document, then click in a library palette and paste it.
Navigating within a library
Use the library palette’s scroll bar to scroll vertically through library entries.
To resize the library palette, place the arrow cursor x on the border of the palette until the resizing icon 78 displays, and then click and drag.
A Guide to QuarkXPress 17.7
Libraries
S Tips
Categorizing library items
Although you can put up to 2,000 items in a single library, it’s not necessarily a good idea to do so. Even if you use labels, it may be difficult to locate the items you need. You may want to create separate libraries for separate publications or topics.
Working with Labels
QuarkXPress lets you manage your library entries by applying labels to them. You can apply the same label to multiple entries and you can selectively display library entries according to their labels. For example, if you have a library full of different corporate logos, you can label each entry with the appropriate company name.
Labeling library entries
Once you label one library entry, you can reuse that label for other entries. Or, you can give each of your library entries a unique name. To label library entries:
1 Double-click a library entry to display the Library Entry dialog box.
Double-click a library entry to display the Library Entry dialog box. Enter a new label or choose one from the drop-down list.
2 Type a descriptive name in the Label field or choose one from the
Label list. To rename a library entry, type in a new label or choose a different label from the list.
3 Click OK; the label now appears in the Label menu.
R When you copy an entry from one library to another, its label is copied as well.
17.8
A Guide to QuarkXPress
Working with Labels
Displaying library entries by label
To display entries by label, click the Labels menu in the upper left corner of a library palette. Choose labels to display associated entries.
• The drop-down list displays All, Unlabeled, as well as any labels you created and applied to entries.
• You can choose more than one label to display multiple categories of entries; each selected label is shown checked in the drop-down list.
• To view all library entries, regardless of label, choose All.
• To view entries to which no label has been applied, choose Unlabeled.
You can choose Unlabeled in addition to other labels.
• To hide entries to which a label is applied, choose the label again.
S Tips
Displaying All labels
If you have All checked in the dropdown list of a library palette, and then you uncheck All, all the other labels are automatically checked.
Choose labels from the drop-down list in the upper left corner of a library palette to indicate which library entries to display.
A Guide to QuarkXPress 17.9
Libraries
S Tips
Quitting QuarkXPress
When you quit QuarkXPress, any open libraries are automatically closed and saved.
Saving Libraries
When you click the close box on a library palette, QuarkXPress automatically saves changes made to the library. If you prefer, you can use the Auto Library
Save feature to save changes automatically. To enable Auto Library Save:
1 Choose Edit
& Preferences & Application (
CTRL
+
ALT
+
SHIFT
+
Y
); then click the Save tab.
Check Auto Library Save in the Save tab of the Application Preferences dialog box
(Edit
&
Preferences
&
Application) to automatically save changes to libraries.
2 Check Auto Library Save.
3 Click OK.
R The one disadvantage to using Auto Library Save is that it can make working with libraries slightly slower. If you’re adding 100 items to a library, QuarkXPress pauses to save each item. To protect libraries from a system failure when you’re not using Auto Library
Save, be sure to close your libraries periodically to save them.
17.10
A Guide to QuarkXPress