Operation. Imagine communications v11 ADC
Reklama
Reklama
ADC Device Server v11.61.4
Installation, Configuration, and Operations Reference
Operation
Operation
To Start the Device Server
On the Device Server’s desktop, double-click the Device Server icon. This launches the ADC
Device Server application. (Note: In some installations this icon may be named ADCNT.)
When the Device Server application is running, an application bar is displayed at the top of the screen similar to the one illustrated below.
To Exit the Device Server
Use this procedure to exit and close the main Device Server.
From the Device Server main menu select File > Exit
Or
Click the X button in the upper right corner of the Device Server display.
To View Connections
Use the following procedure to view of the Device Server and client applications currently logged into this Device Server.
1. From the Device Server main menu select View > Connections. The Connections window is displayed showing all connections made via the automation Network to this
Device Server
© 2014 Imagine Communications Corp. Proprietary and Confidential 22-April-2014 | Page 16 of 410
ADC Device Server v11.61.4
Installation, Configuration, and Operations Reference Operation
2. From the Connections window main menu an operator can choose:
• File > Close: Close the Connections window
• View > Refresh: (or Press F5) to refresh the display
• Help > …: Launch Help System.
To View Help Information
From the Device Server main menu select Help > About... The About Device Server window is displayed.
NOTE: When calling Technical Support to report a problem, make sure you have the
displayed version number handy.
To Disable/Enable Cloning
Using Alternate Handle (Recommended Method)
To disable cloning because a cloning-related problem has been identified or is suspected- or simply to disable it for an extended period of time- then the following the 'Alternate Handle' technique provides a more complete de-activation of cloning.
Change Rules
When the DS application is running as "Main With Clone", any attempt to change the alternative handle to 0, displays a popup message informing the user to set the alternative handle to 0 on the clone DS application first.
© 2014 Imagine Communications Corp. Proprietary and Confidential 22-April-2014 | Page 17 of 410
ADC Device Server v11.61.4
Installation, Configuration, and Operations Reference Operation
Once the alternative handle on the clone DS application is changed to 0, the main DS application becomes "Main Without Clone". Now the user can set its alternative handle to
0.
If the main DS application is not running as "Main With Clone", it is OK to set its alternative handle to 0.
Disable cloning feature
Once the clone Device Server (DS) is running in synchronization with the main DS, if disabling of the cloning feature is required, implement the following procedure, exactly.
1. On the clone DS from the main menu select File > Alternate Handle and change the alternate handle to 0.
When this is done, there will be empty caption on clone DS and the caption on main DS becomes “Main Without Clone”. The relay position is on the main DS.
2. On the main DS from the main menu select File > Alternate Handle and change the alternate handle to 0.
When this is done, the cloning feature code is completely bypassed. The caption on the main DS becomes empty. The relay position is still on main DS.
Why change the Clone DS Alternate Handle to 0 first?
When the alternative handle on the clone DS application is not 0 (is the handle of main DS), and the alternative handle on the main DS application is changed to 0 first, the clone DS takes over control. The relay position is on the clone DS. This behavior is explained as follows:
When the cloning feature is disabled on the main DS application, the heart beat between the main DS application and the cloning control panel is stopped. However, the clone DS application continues to send heart beat signals to the cloning control panel. In this scenario, the cloning control panel judges that the main DS has failed and that the clone DS is still active. This results in the relay being incorrectly switched from the main DS to the clone DS.
Enable cloning feature again
1. Put back alternate handle on the main Device Server (DS).
The caption on the main DS application will become “Main Without Clone” in RED color.
The relay position is on main DS.
2. Put back alternative handle on the clone DS.
The caption on the clone DS application will become “Clone Of Main”, at the same time, the caption on the main DS application will become “Main With Clone”.
Using Device Server Menu Options (for Information
Only)
IMPORTANT: Do Not Use the Start and Stop Cloning menu options. While the following menu options may be displayed for a Cloning-enabled build of Device Server, they are not
© 2014 Imagine Communications Corp. Proprietary and Confidential 22-April-2014 | Page 18 of 410
ADC Device Server v11.61.4
Installation, Configuration, and Operations Reference Operation
to be used at this time. The following information is provided as a reference for future functionality only. Please contact Automation Support for further information.
For some mission critical TV channels, it is desirable to have a back up (or clone) ADC
Device Server to take over automation control when the main device server fails.
Cloning is optional functionality purchased by a customer.
This cloning feature has two basic functions.
To copy the device status, device storage, list contents, list status, and other state machines from the main device server application to the clone device server application.
To dynamically maintain the synchronization by means of feedback close control looping.
To disable cloning because a cloning-related problem has been identified or is suspected use the Device Server menu options: Stop Cloning and Start Cloning.
To Stop Cloning
The Cloning process may be stopped or started manually from the CLONE Device Server.
This feature is only supported on Devices Servers that contain a 1GHz (or faster) CPU.
To stop the Cloning process manually, from the CLONE Device Server’s main menu select
File > Stop Cloning”.
The Cloning Process halts, and the MAIN Device Server displays “Main Without Clone” and the clone DS displays "Cloning Stopped".
NOTE: This ceases the mirroring of list and status data between the MAIN and CLONE device servers, and disables automatic failover. However, the device servers will continue to generate cloning heart beat across the network connection between them. This has the same effect as setting the CLONE Device Server’s Alternate Server Handle to “0”.
To Restart Cloning
To restart the Cloning process, from the CLONE Device Server’s main menu select File >
Start Cloning.
The Cloning Process starts, and the MAIN Device Server displays “Main With Clone” and the clone DS displays "Clone Of Main".
NOTE: This begins the mirroring process between the device servers, which when complete will restore automatic failover – provided the front panel controls of the Cloning Control panel are correctly set. This has the same effect as setting the CLONE Device Server’s Alternate
Server Handle back to its original value.
© 2014 Imagine Communications Corp. Proprietary and Confidential 22-April-2014 | Page 19 of 410
Pobierz
Reklama