Import and Export Utility. IntelliTrack V8.1
โฆษณา
โฆษณา
CHAPTER 10
Import and Export Utility
Reaching the Import Export Utility
Using the Import Export Utility
Supported Import Export Utility File Types
Exporting and Importing Inventory Data
Exporting and Importing Item Data
Exporting and Importing Location Data
Exporting and Importing Picking Order Data
Exporting and Importing Receiving Order Data
Exporting Receiving Order Data
Importing Receiving Order Data
161
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
Introduction
IntelliTrack ISRP provides an Import Export utility to import data into its database tables and export data from them. Import and export data is stored in text files [files with a (.txt) extension]. A folder is created during installation to hold these files and is found in your program directory
(\IntelliTrack\ISRP\Import Export). When you are running in line number mode, the ISRP Import-Export Utility requires line number information.
Warning: DO NOT IMPORT data that contains special characters or quotes with the exception of dashes, dots, and spaces. Except for dashes, dots, and spaces, if you data contains special characters or quotes, the database will become corrupted. For more information, please refer to
“Precautions when Entering Data” on page 15 .
Reaching the Import Export Utility
The Import Export Utility may be configured to begin automatically after the workstation restarts, or it can be started from the Windows Start menu.
It is connected directly to the ISRP database to provide better performance.
Data access is configured during installation. If the location or login information changes, you will be prompted to re-enter your login and password information to regain access to the database from this utility (the server name, database name, user name, and password are required).
Once access to the database is established, you must login to the ISRP
Import Export Utility. Your ISRP username and password are required, as per your security settings in the IntelliTrack ISRP workstation application.
To open the Import Export Utility:
1.
2.
Select Start > Programs > IntelliTrack > ISRP > Import-Export
Utility. The Login window appears.
Enter your ISRP user name in the User Name field. If a password is required, enter your ISRP user password in the Password field. Click
OK. The ISRP Import Export Utility opens.
162
Chapter 10
Import and Export Utility
Menu Bar
Configuration
Settings
Data
Fields
•
Command
Buttons
The top section of the main form contains a menu bar and the import or export interface configuration settings.
Caution: Do not change the export template setting unless you create a new destination file for the exported data or purge old data from the existing destination file. When exporting data, the data does not replace the destination file data, it merely appends to the existing file. A file with data from two (2) template settings can be difficult to import into another application.
•
•
The middle section displays a grid that lists the data fields that are available for selection. It serves as an interface template.
The bottom section of the form contains command buttons that are used to execute the selected interface, view the text files, and exit the application.
Using the
Import Export
Utility
The Import Export Utility contains a top line menu bar with four menu headings: File, View, Tools, and Help.
163
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
File Menu
Provides an option to exit the application. Click File > Exit to exit the
Import Export Utility.
View Menu
•
•
Allows you to view the import and export text files and the error log.
Click View > Text File to open Notepad.
Click View > Error log to open the Import Export error log:
164
• The Import Export error log displays the following information:
Date: Displays the date and time the error occurred. Important for automated references.
Order: Holds the error number in the order it occurred. The Order is reset to one (1) each time a process runs.
Type: Identifies the interface used (i.e., item import, receiving import, etc.) used when the error occurred.
Message: If the description extends past the end of the column’s available space, place the cursor in the field to scroll through it.
Record: Identifies the data sequence in the text file that produced the error.
Delete button: Click to clear the error messages.
Close button: Click to exit the error log.
Tools Menu
Provides access to application Options and Filter and Language settings.
•
Chapter 10
Import and Export Utility
Click Tools > Options to display the Options form. You are able to change Import Export Utility configuration settings at this form.
•
•
Language: Choose the language preference by clicking the drop-down arrow in the Language field and selecting the desired language from the list that appears.
Auto-start Import Export when computer starts: Check this box to launch the Import Export Utility each time the computer is rebooted.
Auto Load Filters: Check this box to load the data query filters automatically.
Click Tools > Load Filter to load the filter settings from the previous
Import-Export Utility session.
Click Tools > Language to open the Language Settings form:
The Language Settings form is used for language substitutions.
1.
2.
3.
To use this form, first select the Interface by clicking the drop-down arrow in the Interface field and selecting the interface from the selections that appear. The fields available for import or export with this interface populate the form.
Next, select the field that you want to change. (Be sure you have selected the proper language table: English, Reserved, User-Defined).
Change the field, as desired (i.e., Alternate Number to ALT #).
165
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
4.
5.
Continue with steps 1 through 3 until you have made all of your language substitutions.
When are finished, select the Close button to close the form and save your changes. The changes will appear in the import or export fields for each interface field that was changed. (Make sure that the default language setting matches the fields you have changed.)
Help Menu
Click Help > About to display the About form, which contains relevant version information for the Import Export Utility.
Import-Export Interfaces
With the Import Export Utility, you are able to import inventory, item, location, picking order, and receiving order data into ISRP. You are also able to import picking and receiving order data from a host system into
ISRP. The Import Export Utility also supports exporting inventory, item, location, picking order, and receiving order data into ISRP into a text file or fixed width file. To import or export data, you must select the “interface” type in the utility. The data interface types available in the utility are found in “Import-Export Utility Interfaces” on page 166 .
TABLE 14. Import-Export Utility Interfaces
Data Interfaces Description
Host Picking Communicates picking order activity back to a host system.
Host Receiving
Note: The system will communicate line number information back and forth.
Communicates receiving order activity back to a host system.
Note: The system will communicate line number information back and forth.
Inventory Export Exports specified inventory data to a specified text file.
Inventory Import Imports inventory data from a specified text file into the ISRP database.
Item Export Exports specified item data to a specified text file.
166
Chapter 10
Import and Export Utility
TABLE 14. Import-Export Utility Interfaces (Continued)
Data Interfaces Description
Item Import Imports item data from a specified text file into the
ISRP database.
Location Export Exports specified location data to a specified text file.
Location Import Imports location data from a specified text file into the ISRP database.
Picking Export Exports specified picking data to a specified text file.
Picking Import
Note: The system will communicate line number information back and forth.
Imports picking data from a specified text file into the
ISRP database.
Receiving
Export
Receiving
Import
Note: The system will communicate line number information back and forth.
Exports specified receiving data to a specified text file.
Note: The system will communicate line number information back and forth.
Imports receiving data from a specified text file into the ISRP database.
Note: The system will communicate line number information back and forth.
Supported
Import Export
Utility File
Types
When using the Import Export Utility for importing a data file, the file must be a tab delimited or fixed width file, which must include a specific format. The file type options and the file requirements are explained in this section.
Import File Type Options
The supported Import/Export file type options are provided here.
167
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
TABLE 15. Import File Type Options
File Type
Tab Delimited
FixedWidth
Description
Expects a delimited file (.txt) with each field separated by tabs only.
A very specific and less flexible file; it is for systems that can only provide fixed width output; each field must be the same width in every record.
Selecting an
Interface
The data fields available for importing data or exporting data vary, depending on the import or export interface chosen. Before you are able to import or export data, you must select an interface and configure the import or export settings.
1.
2.
3.
4.
5.
To select an interface, click the drop-down arrow in the Interface field and select one of the choices from the drop-down menu that appears.
If you select an export option, the Filter button is enabled. Click the
Filter button to display the filter options for the selected export interface.
If you select an order import or host export interface that communicates with another system, you are able to set a time interval for importing or exporting data automatically. Enter an amount of time in the Interval field, then check the Hours, Minutes, or Seconds radio button to select the time parameter. If you do not want to set a time interval, enter a zero in the Interval field.
If you selected an import interface, click the ellipsis button (...) in the
Import filename field to open the Open window and navigate to the imported file to select it.
If you selected an export filename, click the ellipsis button (...) in the
Export filename field to open the Open window and navigate to the exported file to select it. If the file exists when the export process is started, new records are added. If the file does not exist, it is created.
Finally, select either a tab delimited or fixed width file type.
Tab Delimited: Click the radio button next to this selection to select tab delimited files. To set up tab delimited files, assign a numerical order to the data in the file.
Fixed Width: Click the radio button next to this selection to select fixed width files. To set up fixed width files, you must have an additional entry that defines each field’s data length (empty spaces are included for unused portions of a field).
168
Chapter 10
Import and Export Utility
The Interface Template
The grid in the middle of the form displays a list of fields available to be imported or exported in the selected interface and serves as the interface template:
•
•
•
•
•
•
The Field Name field displays the ISRP fields with information that can be imported or exported.
If the box in the Required field is checked, this field must be selected.
The field must have a numeric position greater than zero, and it must be contained in your import file.
To include a field that is not required, enter the position that represents the order where this field’s data appears in the imported or exported file. (An entry of zero excludes a field from inclusion in the selected interface.)
If a fixed width file type is selected, the Length column appears and requires an entry when a position has been assigned. It is the length of this field in the import or export file. This column is hidden when tab delimited fields are selected.
The Max Length field shows the size of the existing fields in ISRP and is not editable. It is a required reference for length entries when using the fixed length file type or comparing imported field sizes from external systems.
You are able to change the data order by selecting the column name.
Use this feature to organize the numeric order during position assignment.
169
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
A Note About Importing Data
When importing data, your import file must contain exactly the same number of fields for which you assign positions in the interface template grid.
Enter a position number in the Position field for each field that is included in the file being imported.
For example, if you select the Item Import interface, and you want to import the Item Number, Item Description, Unit of Measure, and Each
Count, the each data line in the import file must have four fields.
In the utility, assign a position for 1, 2, 3, 4 in the interface template. (Be sure that each field is assigned a position. If you assign positions to 1, 3, and 4 while ignoring position 2, the data import will not work properly.)
For the Item Import interface, the utility may look something like this:
1 - Item Number
2 - Item Description
3 - Unit of Measure
4 - Each Count
In the import file, the data in the file being imported must include the fields selected in the utility; these fields must be ordered according to the assigned positions in the utility; hence, for our example, the data in each line of a tab delimited file would look something like this:
New Item Test Item Entry EA 10
New Item2 Testing EA 20
For detailed information about each interface, please refer to the sections that follow.
Warning: When importing data in the application, make sure that the data
DOES NOT CONTAIN special characters or quotes with the exception of dashes, dots, and spaces. Except for dashes, dots, and spaces, if you use special characters when importing data into the application, the database will become corrupted. For more information, please refer to
“Precautions when Entering Data” on page 15
.
170
Chapter 10
Import and Export Utility
The Host Picking Interface
The Host Picking Interface communicates picking order activity back to a host system. The fields are selected and ordered; however, you may reorder the selected fields, if desired. The file type and name are set by the user. Quantities that are shipped against a picking order are exported to a text file in a specified folder location.
To configure the host picking interface, please refer to the following instructions:
Note: The host system is responsible for importing this data into its systems.
1.
Click the drop-down arrow in the Interface field, and select Host Picking from the list that appears.
2.
The list of fields available for the selected interface are displayed. If desired, you may reorder the field order positions.
Set a time interval for communicating with the host system, if desired, by entering a time in the Interval field, and then selecting the radio button next to the desired time parameter (Hours, Minutes, or Sec-
onds). Data communication will occur automatically per the Interval setting. Entering zero (0) in the Interval field discontinues the service.
171
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
3.
4.
5.
6.
Select the ellipsis (...) button in the Export filename field. The Open window appears. Navigate to the export file location to enter it in the
Export filename field. Or, manually enter the export file name and location in the Export filename field. (By default the file will be exported to your Program Files\Intelli-
Track\ISRP\Utility\Export folder.) The exported file is a text file.
Next, click the Fixed Width or Tab Delimited radio button to select the file type.
If the file is a fixed width file, you must enter the file length for each field in the Length field of the template grid.
Select the Do It button to process the Host Picking export. If the export is unsuccessful, the error log is displayed.
Select the Preview/View button found along the bottom of the form to view the exported file.
The Host Receiving Interface
The Host Receiving Interface communicates receiving order activity back to a host system. The fields are selected and ordered; however, you may reorder the selected fields, if desired. The file type and name are set by the user. Quantities that are received against a receiving order are exported to a text file in a specified folder location.
To configure the host receiving interface, please refer to the following instructions:
Note: The host system is responsible for importing this data into its systems.
1.
Click the drop-down arrow in the Interface field, and select Host
Receiving from the list that appears:
172
Chapter 10
Import and Export Utility
2.
3.
4.
5.
6.
The list of fields available for the selected interface are displayed. If desired, you may reorder the field order positions.
Set a time interval for automatically communicating with the Host
Receiving system, if desired, by entering an amount of time in the
Interval field, and then selecting the radio button next to the desired time parameter (Hours, Minutes, or Seconds). Communication with the host system will occur automatically at this interval. Entering zero
(0) in the Interval field discontinues the service.
Select the ellipsis (...) button in the Export filename field. The Open window appears. Navigate to the export file location to enter it in the
Export filename field. Or, manually enter the export file name and location in the Export filename field. (By default the file will be exported to your Program Files\IntelliTrack\ISRP\Utility\Export folder.) The exported file is a text file.
Next, click the Fixed Width or Tab Delimited radio button to select the file type.
If the file is a fixed width file, you must enter the file length for each field in the Length field of the template grid.
Select the Do It button to process the Host Receiving export. If the export does not operate successfully, you will receive an Error log. If the export is unsuccessful, the error log is displayed.
Select the Preview/View button found along the bottom of the form to view the exported file.
173
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
Exporting and Importing Inventory Data
Inventory data may be exported from IntelliTrack ISRP or imported into
IntelliTrack ISRP through the Import-Export Utility. For more information about exporting and importing inventory data, please refer to the following sections.
Exporting
Inventory Data
Inventory data is exported to the specified file based on the configuration settings, the data filtering that is applied, and the selected field name position. To export inventory data:
1.
Click the drop-down arrow in the Interface field and select Inventory
Export from the list that appears:
174
2.
The list of inventory fields available to be exported are displayed.
Next, click the Filter button. The Filter Inventory dialog appears.
3.
By default, the filter settings from your last session are applied. If no filtering parameters are set, all items in all locations in all sites will be exported. This is indicated by an asterisk in each field, as shown in the
4.
5.
6.
7.
8.
•
•
Chapter 10
Import and Export Utility
Filter Inventory dialog example above. You are able to specify the following data:
Site: To filter Inventory by a specific site, click the drop-down arrow in this field and select a Site from the list that appears.
Location: Becomes enabled if you choose a Site for filtering. To filter inventory by a specific site location, click the drop-down arrow in this field and select a location from the list that appears.
• Item: To filter inventory by a specific item, click the drop-down arrow and select an item from the list that appears.
Click the Apply button to apply the filter settings to the Inventory
Export Interface template and close the Filter Inventory dialog.
Click the Clear button to clear the filter settings in the Filter Inventory dialog.
Click the Save button to apply the filter settings to the Inventory Export
Interface template and close the Filter Inventory dialog.
Click the Cancel button to cancel the filter settings you have chosen and close the Filter Inventory dialog (the system will revert back to the filtering from your previous session).
Select the ellipsis (...) button in the Export filename field. The Open window appears. Navigate to the export file location to enter it in the
Export filename field. Or, manually enter the export file name and location in the Export filename field. (By default the file will be exported to your Program Files\IntelliTrack\ISRP\Utility\Export folder.) The exported file is a text file.
Next, select the file type by clicking the Fixed Width or Tab Delim-
ited radio button.
If Fixed Width is selected, you must enter a character Length entry for each selected field in the Length field of the template grid.
Enter the position of each field that is to be included. Enter a zero (0) to exclude a field. Verify the order by clicking on the Position column heading. Sites, UOM, Serial Number and Expiration Date selections are available based on application option settings.
Select the Do It button to export the inventory data. If the export is unsuccessful, the Error log displays.
Select the View/Preview button to display the exported file.
Importing
Inventory Data
To add inventory data from an external file to the IntelliTrack ISRP database:
1.
Click the drop-down arrow in the Interface field and select Inventory
Import from the list that appears:
175
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
176
2.
3.
4.
5.
6.
7.
The list of fields available to be imported are displayed.
Select the ellipsis (...) button in the Import filename field. The Open window appears. Navigate to the file location to enter it in the Import
filename field. Or, manually enter the file name and location in the
Import filename field. (By default the Open window points to the
Program Files\IntelliTrack\ISRP\Utility\Import folder.) The imported file must be a text file.
Next, select the file type. Click the radio button next to Tab Delimited if this is a tab delimited file. Or, click the radio button next to Fixed
Width if this is a fixed width file.
Enter a position number in the Position field for each field that is included in the file being imported. To exclude a field, enter zero (0).
To verify the position order, click in the Position column heading.
Sites, UOM, Serial Numbers, and Expiration Date selections are available, based on application option settings for the IntelliTrack ISRP
Workstation.
If the Fixed Width field type is selected, a file Length entry must be entered in the Length field for each selected field.
Select the Do It button to import the inventory data. If a problem occurs when importing the data, it will be recorded in the Error Log.
Select the View/Preview button to display the imported file.
Chapter 10
Import and Export Utility
Exporting and Importing Item Data
Item data may be exported from IntelliTrack ISRP or imported into Intelli-
Track ISRP through the Import-Export Utility. For more information about exporting and importing item data, please refer to the following sections.
Exporting
Item Data
Item Data may be exported to a specified file, based on the configuration settings, the data filtering that is applied, and the selected field name position.
1.
Click the drop-down arrow in the Interface field and select Item
Export:
2.
The list of available fields for exporting item data are displayed.
Next, click the Filter button. The Filter Item dialog appears.
3.
By default, the filtering from your last session is applied. If no filtering is set, all item types in the database will be exported. This is indicated by an asterisk in the Type field, as shown in the form example above,
177
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
4.
5.
6.
7.
8.
•
• and the unchecked Serialized Only and Kit Masters Only check boxes. You are able to filter the following data:
Type: To filter item data by a specific item type (or category), click the drop-down arrow in this field and select the item type from the list that appears.
Serialized Only: Check this box to filter item data by serialized items.
• Kit Masters Only: Check this box to filter item data by Kit Masters.
Click the Apply button to apply the filter settings to the Item Export
Interface template and close the Filter Item dialog.
Click the Clear button to clear the filter settings in the Filter Item dialog.
Click the Save button to apply the filter settings to the Item Export
Interface template and close the Filter Item dialog.
Click the Cancel button to cancel the filter settings you have chosen and close the dialog (the system will revert back to the filtering from your previous session).
Click the ellipsis (...) button to open the Open window and navigate to the export file location and select it, or enter the file name and location manually. (The default file location is Program Files\Intelli-
Track\ISRP\Utility\Export.) The exported file is a text file.
Next, select the file type by clicking the Fixed Width or Tab Delim-
ited radio button.
If Fixed Width is selected, you must enter a file length Length entry for each selected field in the Length field of the template grid.
Enter the position of each field that is to be included. Enter a zero (0) to exclude a field. Verify the order by clicking on the Position column heading.
Select the Do It button to export the inventory data. If the export is unsuccessful, the Error log displays.
Select the View/Preview button to display the exported file.
Importing
Item Data
To import item data into the IntelliTrack ISRP database from a specified file, please refer to the instructions that follow:
1.
Click the drop-down arrow in the Interface field and select Item
Import from the list that appears:
178
Chapter 10
Import and Export Utility
2.
3.
4.
5.
6.
7.
The list of available fields for importing item data is displayed.
Select the ellipsis button (...) by the Import filename field to open the
Open window and navigate to the import file location and select it; or enter the file location in this field. The import file must be a text file.
(The default import file location is Program Files\Intelli-
Track\ISRP\Utility\Import.)
Next, select the file type. Click the radio button next to Tab Delimited if this is a tab delimited file. Or, click the radio button next to Fixed
Width if this is a fixed width file.
Enter a position number in the Position field for each field that is included in the file being imported. To exclude a field, enter zero (0).
To verify the position order, click in the Position column heading. Kit
Master may not be selected as an import field.
If the Fixed Width field type is selected, a Length entry must be entered in the Length field for each selected field.
Select the Do It button to import the item data. If the import is unsuccessful, an error log appears.
Select the View/Preview button to display the imported file.
179
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
Exporting and Importing Location Data
Location data may be exported from IntelliTrack ISRP or imported into
IntelliTrack ISRP through the Import Export Utility. For more information about exporting and importing location data, please refer to the following sections.
Exporting
Location Data
Location data is exported to a specified file based on the configuration settings, the data filtering that is applied, and the selected field name position.
To export location data:
1.
Click the drop-down arrow in the Interface field and select Location
Export from the list that appears:
180
2.
Click the Filter button. The Filter Location dialog appears:
3.
By default, the filtering from your last session is applied. If no filtering is set, all location data in the database will be exported. This is indicated by an asterisk in the Site field, as shown in the form example above, and the unchecked Location Hold Only check box. You are able to filter the following data:
4.
5.
6.
7.
8.
•
Chapter 10
Import and Export Utility
Site: To filter location data by Site, click the drop-down arrow in this field and select the Site from the list that appears.
• Location Hold Only: Check this box to filter location data by locations with a hold (or quarantine) designation.
Click the Apply button to apply the filter settings to the Location
Export Interface template and close the Filter Location dialog.
Click the Clear button to clear the filter settings in the Filter Location dialog.
Click the Save button to apply the filter settings to the Location Export
Interface template and close the Filter Location dialog.
Click the Cancel button to cancel the filter settings you have chosen and close the dialog (the system will revert back to the filtering from your previous session).
Click the ellipsis (...) button to navigate to the export file location and select it, or enter the file name and location manually.
Next, select the file type by clicking the Fixed Width or Tab Delim-
ited radio button.
If Fixed Width is selected, you must enter a file length entry for each selected field in the Length field of the template grid.
Enter the position of each field that is to be included. Enter a zero (0) to exclude a field. Verify the order by clicking on the Position column heading. The Site selection is available based on application option settings in the IntelliTrack ISRP workstation.
Select the Do It button to export the location data. If the export is unsuccessful, the Error Log is displayed.
Select the View/Preview button to display the exported file.
Importing
Location Data
Location data from the specified file is added to the ISRP database. To import location data:
1.
Click the drop-down arrow in the Interface field and select Location
Import from the list that appears.
181
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
2.
3.
4.
5.
6.
7.
Select the ellipsis button (...) by the Import filename field to navigate to the import file location and select it; or enter the file location in this field.
Next, select the file type. Click the radio button next to Tab Delimited if this is a tab delimited file. Or, click the radio button next to Fixed
Width if this is a fixed width file.
Enter a position number in the Position field for each field that is included in the file being imported. To exclude a field, enter zero (0).
To verify the position order, click in the Position column heading. The
Site selection is available based on application option settings for the
IntelliTrack ISRP Workstation.
If the Fixed Width field type is selected, a Length entry must be entered in the Length field for each selected field.
Select the Do It button to import the location data. If the import is unsuccessful, an error log appears.
Select the View/Preview button to display the imported file.
Exporting and Importing Picking Order Data
Picking order data may be exported to a specified file or imported into the
IntelliTrack ISRP database through the Import Export Utility.
182
Exporting
Picking Order
Data
Chapter 10
Import and Export Utility
To export picking order data to a specified file:
1.
Click the drop-down arrow in the Interface field and select Picking
Export from the list that appears:
2.
Next, click the Filter button. The Order Filter dialog appears:
3.
•
•
•
By default, the filtering from your last session is applied. If no filtering is set, all picking orders in the database will be exported. This is indicated by an asterisk in the Site and Customer field, as shown in the form example above, and by the selection of Both order types, and
Order Date with no date range restrictions. You are able to filter the following data:
Site: To filter picking order data by a specific Site, click the dropdown arrow in this field and select the Site from the list that appears.
Customer: To filter picking order data by a specific Customer, click the drop-down arrow in this field and select the Customer from the list that appears.
Order Type: To filter data by open orders, select the radio button next to the Open Only selection. To filter data by closed orders,
183
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
4.
5.
6.
7.
8.
select the radio button next to the Closed Only selection. To filter data by both open and closed orders, select the radio button next to the Both selection.
• Date Range for Order Date or Due Date: To filter data by order date, select the radio button next to the Order Date selection. To filter data by due date, select the radio button next to the Due Date selection. To filter the order date or due date by a date range, enter the starting date in the From field and the ending date in the To field.
Click the Apply button to apply the filter settings to the Picking Export
Interface template and close the Order Filter dialog.
Click the Clear button to clear the filter settings in the Order Filter dialog.
Click the Save button to apply the filter settings to the Picking Export
Interface template and close the Order Filter dialog.
Click the Cancel button to cancel the filter settings you have chosen and close the dialog (the system will revert back to the filtering from your previous session).
Click the ellipsis (...) button to navigate to the export file location and select it, or enter the file name and location manually.
Next, select the file type by clicking the Fixed Width or Tab Delim-
ited radio button.
If Fixed Width is selected, you must enter a Length entry for each selected field in the Length field of the template grid.
Enter the position of each field that is to be included. Enter a zero (0) to exclude a field. Verify the order by clicking on the Position column heading. Sites, Customer ID, and Ship To ID selections are available based on application option settings in the IntelliTrack ISRP workstation.
Select the Do It button to export the picking order data. If the export is unsuccessful, the error log displays.
Select the View/Preview button to display the exported file.
Importing
Picking Order
Data
Picking orders created from a host system may be imported through this interface. The import data structure must include the Order’s header information as well as the detailed item information. While creating the order all dependent tables are updated. This means that new Sites, Line Numbers, Items, and Units of Measure are added to their respective tables. Customer data may also be updated, but this is optional.
To import picking order data:
184
1.
Chapter 10
Import and Export Utility
Click the drop-down arrow in the Interface field and select Picking
Import.
2.
3.
4.
5.
6.
7.
8.
Set the time interval, if desired, for importing data to the specified file location. Enter the amount of time in the Interval field and then select the parameter: Hours, Minutes, or Seconds, by selecting the radio button next to the desired choice. Data will be imported automatically per the Interval setting. Entering a zero (0) in the Interval field discontinues this service.
Click the ellipsis button (...) in the Input filename field and navigate to the import file location to select it, or enter it in this field.
Next, select the file type. Click the radio button next to Tab Delimited if this is a tab delimited file. Click the radio button next to Fixed Width if this is a fixed width file.
Enter the position of each field that is to be included. Enter a zero (0) to exclude a field. Verify the order by clicking in the Position column heading. The Site, Customer ID, and Ship To ID selections are available based on the application option settings in the IntelliTrack ISRP
Workstation application.
If this is a fixed width file, a length entry must be entered in the Length field for each required field.
Select the Do It button to import the picking order. If the import is unsuccessful an error log is displayed.
Select the View/Preview button to display the imported file.
185
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
Exporting and Importing Receiving Order Data
Based on the configuration settings, the data filtering that is applied, and the field name position, the receiving order data is exported from Intelli-
Track ISRP into a specific file, or imported into the IntelliTrack ISRP database from a specific file.
Exporting
Receiving
Order Data
To export receiving order data to a specific file, please refer to the instructions that follow:
1.
Click the drop-down arrow in the Interface field and select Receiving
Export from the list that appears:
186
2.
Click the Filter button. The Order Filter dialog appears:
3.
By default, the filter settings from your last session are applied. If no filtering is set, all orders, from all sites, all customers, and all dates will be exported. You are able to filter a receiving order by the following data restrictions:
4.
5.
6.
7.
8.
•
•
•
Chapter 10
Import and Export Utility
Site: To filter receiving order data by a specific site, click the dropdown arrow in this field and select a Site from the list that appears.
Customer: To filter receiving order data by customer, click the drop-down arrow in this field and select a Customer from the list that appears.
Order Type: To filter receiving order data by open orders, select the radio button next to Open Only. To filter receiving order data by closed orders, select the radio button next to Closed Only. To retrieve receiving order data from both open and closed receiving orders (i.e., not filter order data by an order type), select the radio button next to Both.
• Date: To filter receiving order data by order date, select the radio button next to Order Date. To filter receiving order data by order due date, select the radio button next to Due Date. To filter the order date or due date by a date range, enter a starting date in the From field and an ending date in the To field.
Click the Apply button to apply the filter settings to the Receiving
Export Interface template and close the Order Filter dialog.
Click the Clear button to clear the filter settings in the Order Filter dialog.
Click the Save button to apply the filter settings to the Order Filter dialog.
Click the Cancel button to cancel the filter settings you have chosen and close the dialog (the system will revert back to the filter settings that you previously applied or saved).
Click the ellipsis (...) button to navigate to the export file location and select it, or enter the file name and location manually in the Export
filename field.
Next, select the file type by clicking the Fixed Width or Tab Delim-
ited radio button. If Fixed Width is selected, you must enter a Length entry for each selected field in the Length field of the template grid.
Enter the position of each field that is to be included. Enter a zero (0) to exclude a field. Verify the order by clicking in the Position column heading. Site and Vendor selections are available based on the application option settings in the IntelliTrack ISRP workstation.
Select the Do It button to export the receiving order. If the export is unsuccessful, the error log appears, with a message detailing why the data did not export to the specified file.
Select the View/Preview button to display the exported file.
187
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
Importing
Receiving
Order Data
Receiving orders may be created from an external host through this import function. The import data structure must include the order’s header information as well as the detail item information. While creating the order all dependent tables are updated. This means that new sites, items, line numbers, and units of measure are added to their respective tables. Vendor data may be updated also, but it is optional.
To import receiving order data, please refer to the instructions that follow:
1.
Click the drop-down arrow in the Interface field and select Receiving
Import from the list that appears.
188
2.
3.
4.
•
If desired, set a time interval for data importing by entering a time unit in the Interval field and then selecting a time parameter by clicking the radio button next to the desired choice:
Hours
•
•
Minutes
Seconds
Data will be imported automatically at the interval specified. Entering a zero (0) in the Interval field discontinues this service.
Select the file type by clicking the radio button next to the desired choice:
•
•
Fixed Width
Tab Delimited
Enter the position of each field that is to be included. Enter a zero (0) to exclude a field. Verify the order by clicking on the Position column
5.
6.
7.
Chapter 10
Import and Export Utility heading. Site and Vendor ID selection are available based on application option settings.
If the Fixed Width file type is selected a Length entry is required for each selected field.
Select the Do It button to import the Receiving Order. If the import does not operate successfully the error log is displayed.
Select the View/Preview button to display the imported file.
189
I
NTELLI
T
RACK
ISRP
V
8.1
User Manual
190
ดาวน์โหลด
โฆษณา