Using the FlowSheet Editor. e-MDs Solution Series 8.0
Hirdetés
Hirdetés
Using the FlowSheet Editor
The FlowSheet Editor is a module that is included with e-MDs Chart application. It can be used to edit the existing FlowSheets that are provided with the product or to create completely new ones.
Accessing the FlowSheet Editor
The FlowSheet Editor can be opened as a standalone application or as a module from within Chart.
To open the FlowSheet Editor in standalone mode:
1. Click the Windows Start menu at the bottom left corner of your desktop
The FlowSheet Editor will open
To open the FlowSheet Editor from Chart:
1. Login into Chart using your normal e-MDs username and password.
2. From the main Chart menu system, click Tools then select FlowSheets from the pop-up menu.
The FlowSheet Editor will open.
To access a specific FlowSheet from a list of currently open FlowSheets:
1. Click the drop-down arrow at the right-side of the field.
The drop-down will open and display all opened FlowSheets.
2. Click the desired FlowSheet to switch the view to that particular FlowSheet.
Understanding the FlowSheet Editor Interface
The main window of the FlowSheet Editor contains a File menu item in the top left corner, a FlowSheet
selection drop down field and a Close all FlowSheets button.
The File menu item contains menu selections that allow the user to Open a Patient FlowSheet, Open a
FlowSheet, access Categories, access Data Elements and access Fields.
File Menu
Open Patient FlowSheet
Open FlowSheet
Categories
Data Elements
Fields
Exit
Allows the user to open a specific patient's FlowSheet from within the FlowSheet
Editor. The patient's chart does not have to be open to do this.
Note:
Data entered into any of the fields of a patient FlowSheet will associate that information to the patient just as if you were in the patient's chart. This IS NOT a test environment!
Allows access to the FlowSheet Select window where you can search for and open a specific FlowSheet for editing purposes OR create a new FlowSheet from scratch.
Allows access to the Categories Select window. See the Categories section for details about categories.
Allows access to the Data Element Select window. See the Data Element section for details about data elements.
Allows access to the Field Select window. See the "Fields" section for details about
FlowSheet fields.
Allows the user to close the FlowSheet Editor module. This performs the same action as the X in the upper right corner of the module. e-MDs Solution Series Chart User Guide 8.0 R01
318
Tools Menu
Lab Linker
Merge Data Elements
FlowSheet Selection
Dropdown
Accesses the Lab Linker module that allows users to link Data Elements to Master
Lab Codes. See Link a Data Element to a Master Lab Code for details.
Allows access to a module that merges Data Elements. Sometimes more than one
Data Element that represents the same item will be created. Merging of these Data
Elements takes all the information from the different elements and merges them into one.
Allows users to access any FlowSheets that have been opened in the current session. Multiple FlowSheets can be opened at one time within a session of the
FlowSheet Editor and users can flip between them using the FlowSheet selection field.
If multiple FlowSheets are opened within a session of the FlowSheet Editor they can all be closed at one time by clicking the Close All FlowSheets button
Close All FlowSheets
Button
Editing the Details of a FlowSheet
There are details associated with each FlowSheet that can be edited. These details include the
FlowSheet Name, Description and Category.
To edit the details of a FlowSheet:
1. Open the FlowSheet Select window by clicking File in the main FlowSheet Editor module.
4. Type the name of the FlowSheet to be edited into the Name search field
6. A list of FlowSheets matching the search criteria will appear in the bottom part of the form.
7. Select the desired FlowSheet by clicking it and click the Edit button on the toolbar.
9. Make the desired changes to the Name or Description or change the designated Category .
10. Click the Save button when finished.
Editing a FlowSheet
Once a FlowSheet has been created they may be a reason to edit it. New FlowSheet fields may need to added or removed or the sequence of the fields may need to be changed.
To edit a FlowSheet:
1. Open the FlowSheet Select window by clicking File in the main FlowSheet Editor module.
4. Type the name of the FlowSheet to be edited into the Name search field
6. A list of FlowSheets matching the search criteria will appear in the bottom part of the form.
7. Select the desired FlowSheet by clicking it and click the Select button on the toolbar OR press the Enter key on your keyboard. e-MDs Solution Series Chart User Guide 8.0 R01
319
OR
Double-click the name of the FlowSheet.
9. Changes to the FlowSheet or the FlowSheet Fields can be made. See the following sections for details.
10. When finished making changes simply close the FlowSheet by clicking the X on the blue
FlowSheet header bar (the one where the FlowSheet name is displayed).
Note:
Clicking the X and the top right corner (instead of the X on the blue FlowSheet header bar) will close the entire FlowSheet Editor module and not just the current FlowSheet.
Adding Existing Fields to a FlowSheet
The FlowSheet module comes pre-populated with FlowSheet fields that can be used to augment existing
FlowSheets or to create new ones. These fields cover a wide variety of data such as vital signs, lab tests, immunizations, best practice items, etc. These pre-existing fields can easily be added to an existing or new FlowSheet.
To add an existing field to a FlowSheet:
1. Open the FlowSheet Select window by clicking File in the main FlowSheet Editor module.
4. Type the name of the FlowSheet to be edited into the Name search field
OR
Press the Enter key on your keyboard.
6. A list of FlowSheets matching the search criteria will appear in the bottom part of the form.
7. Select the desired FlowSheet by clicking it and click the Select button on the toolbar OR press the Enter key on your keyboard OR double-click the name of the FlowSheet.
9. The fields in the FlowSheet, along with details about each, will be listed in a grid on the right side of the form.
10. Click the Add button in the left pane of the window to add an existing field.
11. The Field Select window will open.
12. Type the name of the field (full description or partial) that is to be added into the Name field.
13. Click the Search button on the toolbar OR hit the Enter key on your keyboard.
14. Highlight the desired field from the search results and click the Select button on the toolbar OR double click the item OR hit the Enter key on your keyboard to select the field.
15. The field will be added to the list of fields already in the FlowSheet and placed in alphabetical order.
16. The sequence of items displayed in the FlowSheet can be changed by clicking the Sequence button (see "Change the Sequence of Fields" for details). e-MDs Solution Series Chart User Guide 8.0 R01
320
Changing the Sequence of Fields
When editing a FlowSheet please note that in edit mode the fields are displayed alphabetical order and not necessarily in the order they are displayed in the FlowSheet when it is being used. The order of the fields can be changed.
To change the FlowSheet field sequence:
1. Open the FlowSheet Select window by clicking File in the main FlowSheet Editor module.
4. Type the name of the FlowSheet to be edited into the Name search field
OR
Press the enter key on your keyboard.
A list of FlowSheets matching the search criteria will appear in the bottom part of the form.
6. Select the desired FlowSheet by clicking it and click the Select button on the toolbar.
OR
Press the Enter key on your keyboard.
OR
Double-click the name of the FlowSheet.
The FlowSheet form will open. The fields in the FlowSheet, along with details about each, will be listed in a grid on the right side of the form.
This will open the Field Sequence window with all the fields listed in the order that they display in the FlowSheet.
8. Select the field to reorder by clicking to highlight it.
9. Move the field to the desired location by using the blue up or down arrow at the top left side of the window.
10. Repeat the process for any fields that need to be re-ordered.
11. When finished, click the Save button to save changes.
Creating and Adding New Fields
Fields can be created from within a FlowSheet at the time the FlowSheet is being created (on the fly).
To add new fields:
1. Edit the desired FlowSheet.
There are five choices for add a new Field. These choices allow the user to create a completely new Field from scratch or to copy certain parts of existing Fields to create new ones. This functionality is intended to save time when creating FlowSheet Fields. The five choices are described below. e-MDs Solution Series Chart User Guide 8.0 R01
321
○ Create a New Field and New Data Element: This choice is the same as creating a new Field outside of a FlowSheet. If this option is selected:
The Data Element Maintenance form will open and you can choose an existing Data
Element or add a new one. See “Add a New Data Element” for details.
Once a Data Element is chosen the Field Maintenance form will open and you can finish creating the Field. See “Create a FlowSheet Field Outside a FlowSheet” for details.
○ Copy an Existing Field: This choice allows the user to copy an existing field and then make changes as necessary. This can save time when creating a Field that is similar to an existing one but may only need small changes. For example if you have a patient whose normal temperature us 99 you might want to copy the temperature Field, rename it (ex. Low Grade
Temp) and make changes to the Validation so that 99 will show up as a normal value for this patient. If this option is selected:
The Field Select form will open and you can choose an existing Field to Edit. See “Edit a
FlowSheet Field” for details.
○ Copy an Existing Field but create a New Data Element: This choice can be used when you want keep the same Validation values (normal ranges or pick lists) but want to use a different
Data Element. Copying of a Field that contains a Yes/No type Data Element is a good example of this choice. Rather than having to recreate the pick list for a Yes/No type question this option can be chosen and a different Yes/No type Data Element can be selected. If this option is chosen:
The Field Select form will open and you can search for and choose an existing Field to use.
After a field is selected the Field Maintenance form will open will all the information filled out
EXCEPT the Data Element.
Pick an existing Data Element to use or create a new one. See “Add a New Data Element” for details.
○ Create a New Field Based on an Existing Data Element: This option allows the user to pick a Data Element first and then enter information into the FlowSheet Field properties to create the Field. If this option is chosen:
The Data Element Select form will open.
Pick an existing Data Element or create a new one. See “Add a New Data Element” for details.
After a Data Element is chosen the Field Maintenance window will open with ONLY the
Data Element field filled out.
Fill out the required information for the Field. See “Create a FlowSheet Field Outside a
FlowSheet” for details.
○ Create a New Field based on an Existing Field’s Data Element: This option allows the user to select an existing Field and use ONLY its Data Element to create a new Field. For example a Pulse FlowSheet Field exists that has an underlying Data Element called Heart
Rate. This is the same Data Element that would be used to create a Fetal Heart Rate
FlowSheet Field. Use of this option would allow you to pick the FlowSheet Pulse field so that you can use the Heart Rate Data Element to create a completely new FlowSheet Field.
Field Select form will open and you can search for and choose an existing Field that contains the Data Element you want to use.
5. After the field is selected, the Field Maintenance window will open with ONLY the Data Element field filled out.
6. Fill out the required information for the Field. See “Create a FlowSheet Field Outside a
FlowSheet” for details. e-MDs Solution Series Chart User Guide 8.0 R01
322
7. After one of these options is selected, the Field Maintenance form will open. Depending on the choice made some, none or all of the fields on this form may be filled out.
8. Make changes or additions to the fields as desired. See the “General Tab” and “Validation Tab” sections for details.
Editing Fields Associated with a FlowSheet
From within the FlowSheet Editor, FlowSheet Fields can be edited at any point after they have been created. However, from within a patient’s chart the only FlowSheet Fields that can be edited are those that have been specifically added to that patient’s chart.
To edit a FlowSheet field:
1. Edit the desired FlowSheet
2. Select the Field to be edited by clicking it.
5. Make desired changes to the items in the General tab (Name, Display Name, Data Element or
Note) or to the items on the Validation tab (Range From, Range To, Abnormal Color, Valid
Values, Valid Color, Invalid Values and Invalid Color). See The Field Maintenance Form.
Important!
Editing of a FlowSheet Field may affect data that has already been collected in some patient specific FlowSheets if the Field is part of that FlowSheet and depending on the changes that have been made to the FlowSheet Field. Keep in mind that any changes to a field will b e transferred to every
FlowSheet that the Field is linked to.
Removing Fields from a FlowSheet
Fields that are unneeded or unwanted can be removed from a FlowSheet.
To remove a field from a FlowSheet:
1. Edit the desired FlowSheet
2. Select the Field to be removed by clicking it.
4. In the Remove confirmation window click Yes to remove the field.
5. The field will be removed from the FlowSheet.
Notes:
○ The field will be simply removed from the FlowSheet but NOT deleted. It will continue to exist in other FlowSheets and it can be added back to the FlowSheet it was deleted from if desired.
○ Removing a field from an original or "master" FlowSheet will remove the field from every patient specific FlowSheet that the master FlowSheet is linked to. Keep this in mind when removing fields.
Adding a New FlowSheet
To add a new FlowSheet:
1. Open the FlowSheet Select window by clicking File in the main FlowSheet Editor module. e-MDs Solution Series Chart User Guide 8.0 R01
323
Letöltés
Hirdetés