Exporting. Adobe InDesign CS5, InDesign CS5.5
જાહેરાત
જાહેરાત
USING INDESIGN
Working with documents
• If InDesign cannot locate the original link to a graphic, a warning appears asking you to repair the link in
PageMaker.
• InDesign does not support OLE (object linking and embedding). Consequently, when you open files that contain
OLE graphics, those graphics will not appear in the InDesign document.
Color and trapping conversion issues
Note the following:
• Colors are converted exactly to InDesign colors. PageMaker HLS colors are converted to RGB colors, and colors from other color libraries are converted based on their CMYK values.
• Tints are converted as percentages of the parent color. If the parent color isn’t in the Swatches panel, it’s added during conversion. When an object with a tint is selected, the parent color is selected in the Swatches panel, and the tint value appears in the pop-up menu.
• Color profiles for PageMaker files are converted directly. All Hexachrome colors are converted to RGB values.
Profiles that are not ICC-compliant are replaced using the default CMS settings and profiles you specified for
InDesign.
• All strokes and lines (including paragraph rules) are converted to the default stroke styles they most closely resemble. Custom strokes and dashes are converted to custom strokes and dashes in InDesign.
• InDesign does not support screen patterns or angles applied to TIFF images in Image Control; it drops these from imported TIFF files.
• When Auto-Overprint Black Strokes or Fills (or both) is selected in the Trapping Preferences dialog box in
PageMaker, the setting carries over to InDesign, but Overprint Stroke or Overprint Fill is deselected in the
Attributes panel.
For information about other PageMaker conversion issues, check the support documents on the Adobe website.
114
Exporting
Export text
You can save all or part of an InDesign story in file formats that you can open later in other applications. Each story in a document exports to a separate document.
InDesign can export text in several file formats, which are listed in the Export dialog box. The formats listed are used by other applications, and they may retain many of the type specifications, indents, and tabs set in your document.
You can save sections of commonly used text and page layout items as snippets.
1
2
Using the Type tool , click in the story you want to export.
3 Specify a name and location for the exported story, and select a text file format under Save as Type (Windows) or
If you don’t see a listing for your word-processing application, you can save the document in a format the application can import, such as RTF. If your word-processing application doesn’t support any other InDesign export formats, use a text-only format. Note, however, that exporting in text-only format removes all character attributes from the text.
4 Click Save to export the story in the format you’ve selected.
Last updated 11/16/2011
USING INDESIGN
Working with documents
To retain all formatting, use the Adobe InDesign Tagged Text export filter. For more information, view the Tagged
Text PDF at www.adobe.com/go/learn_id_taggedtext_cs5_en (PDF).
More Help topics
“ Export to PDF for printing ” on page 501
Export to JPEG format
JPEG uses a standardized image compression mechanism to compress full-color or grayscale images for onscreen display. Use the Export command to export a page, spread, or selected object in JPEG format.
1
2
If desired, select an object to export. (You do not need to select anything to export a page or spread.)
3
4
Specify a location and a filename.
The Export JPEG dialog box appears.
5 In the Export section, do one of the following:
Selection Export the currently selected object.
Range Enter the number of the page or pages you want to export. Separate numbers in a range by using a hyphen, and separate multiple pages or ranges by using commas.
Select All Export all pages in the documents.
Spreads Export facing pages in a spread to a single JPEG file. Deselect this option to export each page in a spread as a separate JPEG file.
6 For Quality, choose from a range of options that determine the trade-off between file compression (smaller file size) and image quality:
• Maximum includes all available high-resolution image data in the exported file and requires the most disk space.
Choose this option if the file will be printed on a high-resolution output device.
• Low includes only screen-resolution versions (72 dpi) of placed bitmap images in the exported file. Choose this option if the file will be displayed onscreen only.
• Medium and High include more image data than Low, but use varying levels of compression to reduce file size.
7 For Format Method, choose one of the following options:
• Progressive displays a JPEG image in increasing detail as it is downloaded to a web browser.
• Baseline displays a JPEG image after it has been downloaded completely.
8 Select or type the resolution for the exported JPEG image.
9 Specify the color space of the exported file. You can choose to export as RGB, CMYK, or Gray.
10 Select any of the following items, and then click Export.
Embed Color Profile When this option is selected, the document’s color profile is embedded in the exported JPEG file. The name of the color profile is displayed in small text to the right of the option. You can select the desired profile for the document by choosing Edit > Assign Profiles before exporting to JPEG.
If Gray is chosen from the Color Space menu, the Embed Color Profile option is disabled.
115
Last updated 11/16/2011
USING INDESIGN
Working with documents
Use Document Bleed Settings If this option is selected, the bleed area specified in Document Setup appears in the resulting JPEG. This option is disabled if the Selection option is chosen.
Anti-Alias Anti-aliasing smooths the jagged edges of text and bitmap images.
Simulate Overprint This option is similar to the Overprint Preview feature but works for any of the selected color spaces. If selected, the JPEG file that InDesign exports simulates the effects of overprinting spot inks with different neutral density values by converting spot colors to process colors for printing.
More Help topics
“ JPEG (.jpg) files ” on page 376
Exporting content for the web
To repurpose InDesign content for the web, you have several options:
Dreamweaver (XHTML) Export a selection or the entire document to a basic, unformatted HTML document. You can link to images on a server or create a separate folder for images. You can then use any HTML editor, such as Adobe
Copy and paste Copy text or images from the InDesign document and paste it into your HTML editor.
Adobe PDF Export a document to Adobe PDF and post the PDF on the web. The PDF can include interactive elements
Flash (SWF) Export to a SWF file that’s ready to be viewed immediately in Flash Player or on the web. A SWF file can
(Flash) files for the web ” on page 523.
Flash (FLA)
Digital Editions (EPUB) Export a document or book as a reflowable XHTML-based eBook that is compatible with the
Adobe Digital Editions reader software. See “ Export content for EPUB (CS5) ” on page 121.
XML For advanced repurposing workflows, export the content from InDesign in XML format, which you can then
import into an HTML editor such as Dreamweaver. See “ Working with XML ” on page 567.
Export content to Dreamweaver (CS5)
Exporting to XHTML is an easy way to get your InDesign contents into web-ready form. When you export contents to XHTML, you can control how text and images are exported. InDesign preserves the names of paragraph, character, object, table, and cell styles applied to the exported contents by marking the XHTML contents with CSS style classes of the same name. Using Adobe Dreamweaver or any CSS-capable HTML editor, you can quickly apply formatting and layout to the contents.
What gets exported InDesign exports all stories, linked and embedded graphics, SWF movie files, footnotes, text variables (as text), bulleted and numbered lists, internal cross-references, and hyperlinks that jump to text or web pages. Tables are also exported, but certain formatting, such as table and cell strokes, is not exported. Tables are assigned unique IDs, so they can be referenced as Spry data sets in Dreamweaver.
What doesn’t get exported InDesign does not export objects you draw (such as rectangles, ovals, and polygons), movie files (except for SWF), hyperlinks (except for links to web pages and links applied to text that jump to text anchors in the same document), pasted objects (including pasted Illustrator images), text converted to outlines, XML
116
Last updated 11/16/2011
USING INDESIGN
Working with documents tags, books, bookmarks, SING glyphlets, page transitions, index markers, objects on the pasteboard that aren’t selected and don’t touch the page, or master page items (unless they’re overridden or selected before export).
1 If you’re not exporting the entire document, select the text frames, range of text, table cells, or graphics you want to export.
2
3
4
Specify the name and location of the HTML document, and then click Save.
In the XHTML Export Options dialog box, specify the desired options in the General, Images, and Advanced areas, and then click Export.
A document with the specified name and an .html extension (such as “newsletter.html”) is created; if specified, a web images subfolder (such as “newsletter-web-images”) is saved in the same location.
XHTML export options
117
General options
The General area includes the following options.
Export Determines whether only the selected items or the entire document is exported. If a text frame is selected, the entire story—including overset text—is exported.
If Document is selected, all page items from all spreads are exported, except for master page items that have not been overridden and page items on invisible layers. XML tags and generated indexes and tables of contents are also ignored.
Bullets Select Map To Unordered List to convert bullet paragraphs into List Items, which are formatted in HTML using the <ul> tag. Select Convert To Text to format using the <p> tag with bullet characters as text.
Ordering Use either the page order or XML structure to determine the reading order of page objects.
If Base On Page Layout is selected, InDesign determines the reading order of page objects by scanning left to right and top to bottom. In some instances, especially in complex, multi-column documents, the design elements may not appear in the desired reading order. Use Dreamweaver to rearrange and format the contents.
If Same As XML Structure is selected, the XML Structure panel controls the ordering of the exported content and which content gets exported. If your content is already tagged, you can simply drag the tags in the XML Structure panel to set the XHTML Export order. If your content is not tagged, you can choose Add Untagged Items from the Structure panel menu to generate tags that you can reorder. If you do not want an item to be included in the export, you can simply delete the tag in the XML Structure panel. (Deleting a tag does not delete the content from the INDD file.) See
“ Tag page items ” on page 520.
Numbers Determines how numbers are converted in the HTML file.
• Map To Ordered List Converts numbered lists into List Items, which are formatted in HTML using the <ol> tag.
• Map To Static Ordered List Converts numbered lists into List Items, but assigns a <value> attribute based on the paragraph’s current number in InDesign.
• Convert To Text Converts numbered lists into paragraphs that begin with the paragraph’s current number as text.
Images options
From the Copy Images menu, determine how images are exported to HTML.
Original Exports the original image to the web images subfolder. When this option is selected, all other options are dimmed.
Last updated 11/16/2011
USING INDESIGN
Working with documents
Optimized Lets you change settings to determine how the image is exported.
• Formatted Preserves InDesign formatting, such as rotation or scale, as much as possible for web images.
• Image Conversion Lets you choose whether the optimized images in your document are converted to GIF or JPEG.
Choose Automatic to let InDesign decide which format to use in each instance.
• GIF Options (Palette) Lets you control how InDesign handles colors when optimizing GIF files. The GIF format uses a limited color palette, which cannot exceed 256 colors.
Choose Adaptive (No Dither) to create a palette using a representative sample of colors in the graphic without any dithering (mixing of small spots of colors to simulate additional colors). Choose Web to create a palette of web-safe palette using the built-in system color palette. This choice may cause unexpected results.
• JPEG Options (Image Quality) Determines the trade-off between compression (for smaller file sizes) and image quality for each JPEG image created. Low produces the smallest file and lowest image quality.
• JPEG Options (Format Method) Determines how quickly JPEG graphics display when the file containing the image is opened on the web. Choose Progressive to make the JPEG images display gradually and in increasing detail as they are downloaded. (Files created with this option are slightly larger and require more RAM for viewing.) Choose
Baseline to make each JPEG file display only after it has been completely downloaded; a placeholder appears in its place until the file displays.
Link To Server Path Rather than exporting images to a subfolder, this option lets you enter a local URL (such as
“images/”) that appears in front of the image file. In the HTML code, the link attribute displays the path and extension you specify. This option is especially effective when you’re converting images to web-compatible images yourself.
Note: InDesign does not check the path you specify for Java ™ scripts, external CSS styles, or image folders, so use
Dreamweaver to verify paths.
Advanced options
Use the Advanced area to set CSS and JavaScript options.
CSS Options Cascading Style Sheets (CSS) are a collection of formatting rules that control the appearance of content in a web page. When you use CSS to format a page, you separate content from presentation. The content of your page— the HTML code—resides in the HTML file itself, while the CSS rules defining the presentation of the code reside in another file (an external style sheet) or within the HTML document (usually in the Head section). For example, you can specify different font sizes for selected text, and you can use CSS to control the format and positioning of blocklevel elements in a web page.
• Embedded CSS When exporting to XHTML, you can create a list of CSS styles that appears in the Head section of the HTML file with declarations (attributes).
If Include Style Definitions is selected, InDesign attempts to match the attributes of the InDesign text formatting with
CSS equivalents. If this option is deselected, the HTML file includes empty declarations. You can edit later these declarations in Dreamweaver.
If Preserve Local Overrides is selected, local formatting such as italic or bold is included.
• No CSS Selecting this option omits the CSS section from the HTML file.
• External CSS Specify the URL of the existing CSS style sheet, which is usually a relative URL, such as
“/styles/style.css.” InDesign does not check whether the CSS exists or is valid, so you’ll want to use Dreamweaver to confirm your external CSS setup.
JavaScript Options Select Link To External JavaScript to run a JavaScript when the HTML page is opened. Specify the
URL of the JavaScript, which is usually a relative URL. InDesign does not check whether the JavaScript exists or is valid.
118
Last updated 11/16/2011
USING INDESIGN
Working with documents
Export content to HTML (CS5.5)
Export to HTML
Exporting to HTML is an easy way to get your InDesign content into web-ready form. When you export content to
HTML, you can control how text and images are exported. InDesign preserves the names of paragraph, character, object, table, and cell styles applied to the exported contents by marking the HTML contents with CSS style classes of the same name. Using Adobe Dreamweaver or any CSS-capable HTML editor, you can quickly apply formatting and layout to the contents.
What gets exported InDesign exports all stories, linked and embedded graphics, SWF movie files, footnotes, text variables (as text), bulleted and numbered lists, internal cross-references, and hyperlinks that jump to text or web pages. Tables are also exported, but certain formatting, such as table and cell strokes, is not exported. Tables are assigned unique IDs, so they can be referenced as Spry data sets in Dreamweaver. Placed audio and h.264 video files are enclosed in HTML5 <audio> and <video> tags.
What doesn’t get exported InDesign does not export objects you draw (such as rectangles, ovals, and polygons), hyperlinks (except for links to web pages and links applied to text that jump to text anchors in the same document), pasted objects (including pasted Illustrator images), text converted to outlines, XML tags, books, bookmarks, SING glyphlets, page transitions, index markers, objects on the pasteboard that aren’t selected and don’t touch the page, or master page items (unless they’re overridden or selected before export).
1 If you’re not exporting the entire document, select the text frames, range of text, table cells, or graphics you want to export.
2
3
4
Specify the name and location of the HTML document, and then click Save.
In the HTML Export Options dialog box, specify the desired options in the General, Image, and Advanced areas, and then click OK.
A document with the specified name and an .html extension (such as “newsletter.html”) is created; if specified, a web images subfolder (such as “newsletter-web-images”) is saved in the same location.
HTML export options
In the HTML dialog box, specify the following options.
General options
The General area includes the following options.
Export Determines whether only the selected items or the entire document is exported. If a text frame is selected, the entire story—including overset text—is exported.
If Document is selected, all page items from all spreads are exported, except for master page items that have not been overridden and page items on invisible layers. XML tags and generated indexes and tables of contents are also ignored.
Ordering lets you specify the reading order of page objects.
• Base On Page Layout The location of the items on the page determines the reading order.
If Base On Page Layout is selected, InDesign determines the reading order of page objects by scanning left to right and top to bottom. In some instances, especially in complex, multi-column documents, the design elements may not appear in the desired reading order. Use Dreamweaver to rearrange and format the contents.
• Same As XML Structure If Same As XML Structure is selected, the XML Structure panel controls the ordering of the exported content and which content gets exported. If your content is already tagged, you can simply drag the tags in
119
Last updated 11/16/2011
USING INDESIGN
Working with documents the XML Structure panel to set the XHTML Export order. If your content is not tagged, you can choose Add Untagged
Items from the Structure panel menu to generate tags that you can reorder. If you do not want an item to be included in the export, you can simply delete the tag in the XML Structure panel. (Deleting a tag does not delete the content
from the INDD file.) See “ Tag page items ” on page 520.
• Same As Articles Panel The order of elements in the Articles panel determines the reading order. Only the checked
articles are exported. See “ Include articles for export ” on page 148.
Margin Specify a simple margin in Ems or pixels. Specifying margins in Ems is better for multiscreen compatibility.
The same value is applied to all margins: top, bottom, left, and right.
Bullets Select Map To Unordered List to convert bullet paragraphs into List Items, which are formatted in HTML using the <ul> tag. Select Convert To Text to format using the <p> tag with bullet characters as text. If you have used native InDesign auto-bullets, sub-bullets are also included.
Numbers Determines how numbers are converted in the HTML file. If you have used native InDesign autonumbering, sub-bullets are also included
• Map To Ordered List Converts numbered lists into List Items, which are formatted in HTML using the <ol> tag.
• Map To Static Ordered List Converts numbered lists into List Items, but assigns a <value> attribute based on the paragraph’s current number in InDesign.
• Convert To Text Converts numbered lists into paragraphs that begin with the paragraph’s current number as text.
View HTML After Exporting Starts the browser, if present.
Image options
Copy Images Specify how images are exported to HTML.
• Original Exports the original image to the “<document_name>-web-images” subfolder. When this option is selected, all other options are dimmed.
• Optimized Lets you change settings to determine how the image is exported.
• Link To Server Path Rather than exporting images to a subfolder, this option lets you enter a local URL (such as
“images/”) that appears in front of the image file. In the HTML code, the link attribute displays the path and extension you specify. This option is especially effective when you’re converting images to web-compatible images yourself.
Preserve Appearance from Layout Check to inherit the image object attributes from the layout.
Resolution (ppi) Specify the resolution of the images in pixels per inch (ppi). While operating systems have standardized on either 72 ppi or 96 ppi, mobile devices range from 132 ppi (iPad), to 172 ppi (Sony Reader), to over
300 ppi (iPhone 4). You can specify a ppi value for each object selected. Values include 72, 96, 150 (average for all ebook devices today), and 300.
Image Size Specify if image size must remain fixed or resized relative to the page. Relative to Page Size sets a relative percentage value based on the size of the image relative to the InDesign page width. This option causes the images to rescale proportionally, relative to the width of the reading area.
Image Alignment and Spacing Specify the image alignment, left, center, right, and the top and bottom padding.
Settings Apply to Anchored Objects Check to apply these settings to all anchored objects.
Image Conversion Lets you choose whether the optimized images in your document are converted to GIF, JPEG, or
PNG. Choose Automatic to let InDesign decide which format to use in each instance. Choosing PNG disables the image compression settings.; use PNG for lossless images or for images that include transparency.
GIF Options (Palette) Lets you control how InDesign handles colors when optimizing GIF files. The GIF format uses a limited color palette, which cannot exceed 256 colors.
Last updated 11/16/2011
120
USING INDESIGN
Working with documents
Choose Adaptive to create a palette using a representative sample of colors in the graphic without any dithering
(mixing of small spots of colors to simulate additional colors). Choose Web to create a palette of web-safe colors that the built-in system color palette. This choice may cause unexpected results.
Select Interlace to load the images progressively by filling in missing lines. If this option is not selected, an image looks fuzzy and gradually becomes clear as the image reaches full resolution.
JPEG Options (Image Quality) Determines the trade-off between compression (for smaller file sizes) and image quality for each JPEG image created. Low produces the smallest file and lowest image quality.
JPEG Options (Format Method) Determines how quickly JPEG graphics display when the file containing the image is opened on the web. Choose Progressive to make the JPEG images display gradually and in increasing detail as they are downloaded. (Files created with this option are slightly larger and require more RAM for viewing.) Choose Baseline to make each JPEG file display only after it has been completely downloaded; a placeholder appears in its place until the file displays.
Ignore Object Conversion Settings
Advanced options
Use the Advanced area to set CSS and JavaScript options.
CSS Options Cascading Style Sheets (CSS) are a collection of formatting rules that control the appearance of content in a web page. When you use CSS to format a page, you separate content from presentation. The content of your page— the HTML code—resides in the HTML file itself, while the CSS rules defining the presentation of the code reside in another file (an external style sheet) or within the HTML document (usually in the Head section). For example, you can specify different font sizes for selected text, and you can use CSS to control the format and positioning of blocklevel elements in a web page.
• Embedded CSS When exporting to XHTML, you can create a list of CSS styles that appears in the Head section of the HTML file with declarations (attributes).
If Include Style Definitions is selected, InDesign attempts to match the attributes of the InDesign text formatting with
CSS equivalents. If this option is deselected, the HTML file includes empty declarations. You can edit later these declarations in Dreamweaver.
If Preserve Local Overrides is selected, local formatting such as italic or bold is included.
• No CSS Selecting this option omits the CSS section from the HTML file.
• External CSS Specify the URL of the existing CSS style sheet, which is usually a relative URL, such as
“/styles/style.css.” InDesign does not check whether the CSS exists or is valid, so you’ll want to use Dreamweaver to confirm your external CSS setup.
JavaScript Options Select Link To External JavaScript to run a JavaScript when the HTML page is opened. Specify the
URL of the JavaScript, which is usually a relative URL. InDesign does not check whether the JavaScript exists or is valid.
Export content for EPUB (CS5)
You can export a document or book as a reflowable eBook in EPUB format that is compatible with the Adobe Digital
Editions reader software.
1
2 Specify a filename and location, and then click Save.
121
Last updated 11/16/2011
USING INDESIGN
Working with documents
3 In the Digital Editions Export Options dialog box, specify the desired options in the General, Images, and Contents areas, and then click Export.
InDesign creates a single .epub file containing the XHTML-based content. The exported file includes a JPEG thumbnail image from the first page in the specified document (or the style source document if a book was selected).
This thumbnail is used to depict the book in the Digital Editions Reader library view. To view the file, you need the
Digital Editions software, which you can download free from the Adobe website.
The .epub file is essentially a .zip file. To view and edit the contents of the .epub file, change the extension from .epub to .zip, and then extract the contents. This is especially useful for editing the CSS file.
EPUB resources
For a list of EPUB articles and resources, see www.adobe.com/go/learn_id_epub_en .
For more information on the EPUB format, see www.idpf.org
.
Download a free copy of the Digital Editions reader at www.adobe.com/products/digitaleditions .
See the blog Digital Editions for information on Digital Editions.
For information on exporting to Kindle, see the InDesign to Kindle white paper .
Digital Editions General export options
The General section of the Digital Editions Export Options dialog box includes the following options.
Include Document Metadata The metadata from the document (or the style source document if a book was selected) is included with the exported file.
Add Publisher Entry Specify the publisher information that appears in the eBook metadata. You may want you to specify a URL for the publisher so that someone who receives the eBook can visit the web page and purchase the eBook.
Unique Identifier Every EPUB document requires a unique identifier. You can specify the unique identifier attribute.
If you leave this field empty, a unique identifier is automatically created.
Reading Order If you select Base On Page Layout, the reading order of the page items in the EPUB is determined by their location on the page. InDesign reads from left to right and top to bottom. If you want more control over the reading order, use the XML Tags panel to tag your page items. If you select Same As XML Structure, the order of the
tags in Structure View determines the reading order. See “ Tag page items ” on page 520.
Bullets Select Map To Unordered List to convert bullet paragraphs into List Items, which are formatted in HTML using the <ul> tag. Select Convert To Text to format using the <p> tag with bullet characters as text.
Numbers Determines how numbers are converted in the HTML file.
• Map To Ordered List Converts numbered lists into List Items, which are formatted in HTML using the <ol> tag.
• Map To Static Ordered List Converts numbered lists into List Items, but assigns a <value> attribute based on the paragraph’s current number in InDesign.
• Convert To Text Converts numbered lists into paragraphs that begin with the paragraph’s current number as text.
View eBook After Exporting Starts the Adobe Digital Editions Reader, if present. An alert message appears if your system doesn’t have a reader configured to view .epub documents.
122
Last updated 11/16/2011
USING INDESIGN
Working with documents
Digital Editions Images options
The Images section of the Digital Editions Export Options dialog box includes the following options. From the Image
Conversion menu, determine how images are exported to HTML.
Formatted Preserves InDesign formatting, such as rotation or scale, as much as possible for web images.
Image Conversion Lets you choose whether the optimized images in your document are converted to GIF or JPEG.
Choose Automatic to let InDesign decide which format to use in each instance.
GIF Options (Palette) Lets you control how InDesign handles colors when optimizing GIF files. The GIF format uses a limited color palette, which cannot exceed 256 colors.
Choose Adaptive to create a palette using a representative sample of colors in the graphic without any dithering
(mixing of small spots of colors to simulate additional colors). Choose Web to create a palette of web-safe colors that the built-in system color palette. This choice may cause unexpected results.
Select Interlace to display a slowly loaded image gradually by filling in missing lines. If this option is not select, an image looks fuzzy and gradually becomes clear as the image reaches full resolution.
JPEG Options (Image Quality) Determines the trade-off between compression (for smaller file sizes) and image quality for each JPEG image created. Low produces the smallest file and lowest image quality.
JPEG Options (Format Method) Determines how quickly JPEG graphics display when the file containing the image is opened on the web. Choose Progressive to make the JPEG images display gradually and in increasing detail as they are downloaded. (Files created with this option are slightly larger and require more RAM for viewing.) Choose Baseline to make each JPEG file display only after it has been completely downloaded; a placeholder appears in its place until the file displays.
Digital Editions Contents options
The Contents section of the Digital Editions Export Options dialog box includes the following options.
Format For EPUB Content Specify whether you want to use the XHTML or DTBook format.
Include InDesign TOC Entries Select this option if you want to generate a table of contents on the left side of the eBook.
From the TOC Style menu, specify the TOC style you want to use in the eBook. You can choose Layout > Table Of
Contents Styles to create a special TOC style for your eBook.
Suppress Automatic Entries For Documents Select this option if you don’t want the document names to appear in the eBook table of contents. This option is especially useful when you’re creating an eBook from a book.
Use First Level Entries As Chapter Breaks Select this options to split the ebook into multiple files, with each file beginning with the first level TOC entry. If a content file exceeds 260kb, a new chapter begins at the start of a paragraph between first level entries to help avoid the 300kb limit.
Generate CSS Cascading Style Sheets (CSS) are a collection of formatting rules that control the appearance of content in a web page. When you use CSS to format a page, you separate content from presentation.
• Include Style Definitions When exporting to EPUB, you can create a list of CSS styles that can be edited.
• Preserve Local Overrides If this option is selected, local formatting such as italic or bold is included.
• Include Embeddable Fonts Includes in the eBook all fonts that are allowed to be embedded. Fonts include embedding bits that determine whether the font is allowed to be embedded.
Style Names Only Selecting this option includes only undefined style names in the EPUB stylesheet.
Use Existing CSS File Specify the URL of the existing CSS style sheet, which is usually a relative URL, such as
“/styles/style.css.” InDesign does not check whether the CSS exists or is valid, so you’ll want to confirm your CSS setup.
Last updated 11/16/2011
123
USING INDESIGN
Working with documents
Export content for EPUB (CS5.5)
You can export a document or book as a reflowable eBook in EPUB format that is compatible with the Adobe Digital
Editions reader software, and other eBook reader software.
1 Do one of the following:
• Open the document and choose File
• Open a book and from the Book panel menu, choose Export Book to EPUB.
2
3
Specify a filename and location.
4
From the Save as Type list choose EPUB, and then click Save.
In the EPUB Export Options dialog box, specify the desired options in the General, Image, and Contents areas.
InDesign creates a single .epub file containing the XHTML-based content. If specified, the exported file may include a cover image. The cover image is created from an image, or created from a JPEG thumbnail image from the first page in the specified document (or the style source document if a book was selected). The thumbnail is used to depict the book in the EPUB readers or the Digital Editions Reader library view. To view the file, you need an EPUB reader. You can also use the Adobe Digital Editions software, which you can download free from the Adobe website.
The .epub file is essentially a .zip file. To view and edit the contents of an .EPUB file, change the extension from .epub to .zip, and then extract the contents. This is especially useful for editing the CSS file.
Note:
InDesign objects such as shapes, lines, text frames, and objects that contain placed images, are always exported when you choose the Based on Page Layout ordering option. Empty objects are not exported unless you have applied a setting to the InDesign object via the Object Export Options to make it export as a JPEG, GIF, or PNG.
EPUB resources
Use the following links to learn about EPUB format.
• For a list of EPUB articles and resources, see www.adobe.com/go/learn_id_epub_en .
• For more information on the EPUB format, see www.idpf.org
.
• Download a free copy of the Digital Editions reader at www.adobe.com/products/digitaleditions .
• See the blog Digital Editions for information on Digital Editions.
• For information on exporting to Kindle, see the InDesign to Kindle white paper .
• Learn how to convert your InDesign files to the EPUB format and start selling your eBooks for viewing on the Apple iPad. See the InDesign to iPad white paper .
EPUB General export options
The General section of the EPUB Export Options dialog box includes the following options.
Include Document Metadata The metadata from the document (or the style source document if a book was selected) is included with the exported file.
Add Publisher Entry Specify the publisher information that appears in the eBook metadata. You can specify a URL for the publisher so that someone who receives the eBook can visit the publisher’s website.
Unique Identifier Every EPUB document requires a unique identifier. You can specify the unique identifier attribute.
If you leave this field empty, a unique identifier is automatically created.
EPUB Cover Specifies the cover image for the eBook. Choose one of the following:
• No Cover Image If this option is selected no cover image is added to the eBook.
124
Last updated 11/16/2011
USING INDESIGN
Working with documents
• Rasterize First Page cover.
If this option is selected creates an image file from the first page of the eBook to use as the
• Use Existing Image File If this option is selected you can specify an image on your computer to use as the cover.
Ordering lets you specify the order in which the page elements are exported.
• Base On Page Layout The location of the items on the page determines the reading order.
If Base On Page Layout is selected, InDesign determines the reading order of page objects by scanning left to right and top to bottom. In some instances, especially in complex, multicolumn documents, the design elements may not appear in the desired reading order. Use Dreamweaver to rearrange and format the contents.
• Same As XML Structure
• Same As Articles Panel The order of elements in the Articles panel determines the reading order. Only the checked
articles are exported. See “ Include articles for export ” on page 148.
Book Margin Specify a simple margin in Ems or pixels. Specifying margins in Ems is better for multiscreen compatibility. The same value is applied to all margins: top, bottom, left, and right.
Bullets Select Map To Unordered List to convert bullet paragraphs into List Items, which are formatted in HTML using the <ul> tag. Select Convert To Text to format using the <p> tag with bullet characters as text. If you have used native InDesign auto-bullets, subbullets are also included.
Numbers Determines how numbers are converted in the HTML file. If you have used native InDesign autonumbering, subbullets are also included
• Map To Ordered List Converts numbered lists into List Items, which are formatted in HTML using the <ol> tag.
• Map To Static Ordered List Converts numbered lists into List Items, but assigns a <value> attribute based on the paragraph’s current number in InDesign.
• Convert To Text Converts numbered lists into paragraphs that begin with the paragraph’s current number as text.
View EPUB After Exporting Starts the Adobe Digital Editions Reader, if present.
EPUB Images options
The Images section of the Digital Editions Export Options dialog box includes the following options. From the Image
Conversion menu, determine how images are exported to HTML.
Preserve Appearance from Layout Check to inherit the image object attributes from the layout.
Resolution (ppi) Specify the resolution of the images in pixels per inch (ppi). While operating systems have standardized on either 72 ppi or 96 ppi, mobile devices range from 132 ppi (iPad), to 172 ppi (Sony Reader), to over
300 ppi (iPhone 4). You can specify a ppi value for each object selected. Values include 72, 96, 150 (average for all eBook devices today), and 300.
Image Size Specify if image size must remain fixed or resized relative to the page. Relative to Page Size sets a relative percentage value based on the size of the image relative to the InDesign page width. This option causes the images to rescale proportionally, relative to the width of the reading area.
Image Alignment and Spacing Specify the image alignment, left, center, right, and the top and bottom padding.
Insert Page Break Check to insert page breaks with images. Page breaks can be inserted Before Image, After Image, or
Before and After Image.
Settings Apply to Anchored Objects Check to apply these settings to all anchored objects.
125
Last updated 11/16/2011
USING INDESIGN
Working with documents
Image Conversion Lets you choose whether the optimized images in your document are converted to GIF, JPEG, or
PNG. Choose Automatic to let InDesign decide which format to use in each instance. Choosing PNG disables the image compression settings.; use PNG for lossless images or for images that include transparency.
GIF Options (Palette) Lets you control how InDesign handles colors when optimizing GIF files. The GIF format uses a limited color palette, which cannot exceed 256 colors.
Choose Adaptive to create a palette using a representative sample of colors in the graphic without any dithering
(mixing of small spots of colors to simulate additional colors). Choose Web to create a palette of web-safe colors that the built-in system color palette. This choice may cause unexpected results.
Select Interlace to load the images progressively by filling in missing lines. If this option is not selected, an image looks fuzzy and gradually becomes clear as the image reaches full resolution.
JPEG Options (Image Quality) Determines the trade-off between compression (for smaller file sizes) and image quality for each JPEG image created. Low produces the smallest file and lowest image quality.
JPEG Options (Format Method) Determines how quickly JPEG graphics display when the file containing the image is opened on the web. Choose Progressive to make the JPEG images display gradually and in increasing detail as they are downloaded. (Files created with this option are slightly larger and require more RAM for viewing.) Choose Baseline to make each JPEG file displays only after it has been downloaded; a placeholder appears in its place until the file displays.
Ignore Object Conversion Settings
EPUB Contents options
The Contents section of the EPUB Options dialog box includes the following options.
Format For EPUB Content Specify whether you want to use the XHTML or DTBook format. DTBook is a specialized format that is intended for sight impaired end readers.
Use InDesign TOC Style Select this option if you want to generate a table of contents based on the selected TOC style.
From the TOC Style menu, specify the TOC style you want to use to build the table of contents in the eBook. You can choose Layout > Table Of Contents Styles to create a special TOC style for your eBook.
Break Document at Paragraph Style You can split the eBook at the specified paragraph style. Splitting results in a larger number of HTML files in the EPUB package, but can be helpful for breaking up long files and increases performance in the EPUB readers.
Place Footnote After Paragraph Check to place footnotes after the paragraph. If deselected, footnotes are converted to endnotes.
Remove Forced Line Breaks Check to remove all soft-returns in the exported eBook.
Generate CSS Cascading Style Sheets (CSS) are a collection of formatting rules that control the appearance of content in a web page. When you use CSS to format a page, you separate content from presentation.
• Include Style Definitions When exporting to EPUB, you can create a list of CSS styles that can be edited.
• Preserve Local Overrides If this option is selected, local formatting such as italic or bold is included.
• Include Embeddable Fonts Includes all fonts that are embeddable, in the eBook. Fonts include embedding bits that determine if the font is enbeddable.
Style Names Only Includes only undefined style names in the EPUB style sheet.
126
Last updated 11/16/2011
USING INDESIGN
Working with documents
Use Existing CSS File Specify the URL of the existing CSS style sheet, which is usually a relative URL, such as
“/styles/style.css.” InDesign does not check whether the CSS exists or is valid, so you’ll want to confirm your CSS setup.
Export content to Buzzword
Buzzword is a web-based text editor that lets users create and store text files on a web server. When you export a story to Buzzword, you create a text file on the Buzzword server.
1
2
Select text or place the insertion point in a text frame that is part of the story you want to export.
Do one of the following:
• In InDesign choose File > Export For > Buzzword.
• In InCopy choose File > Export to Buzzword.
3 If you haven’t already signed in to CS Live, click Sign In, specify your e-mail address and password, and then click
Sign In.
4 In the Export Story For Buzzword dialog box, specify the name of the Buzzword document to be created and then click OK.
The Buzzword document is opened on Acrobat.com. You can then move the document to a different workspace and share it with other people.
More Help topics
“ Import Buzzword documents ” on page 141
Use the web color swatch library
InDesign includes a color swatch library called Web, which consists of the colors most web browsers use to display text and graphics in web pages. The 216 colors in the library, often called web-safe colors, are consistent across platforms,
InDesign are the same as those in the Adobe Photoshop web-safe color palette and the Adobe Illustrator browser-safe color palette.
Each color in the library is named by its RGB values. Each color’s hexadecimal code, which HTML uses to define the color, is stored within the color swatch.
1 Choose New Color Swatch in the Swatches panel menu.
2
3
For Color Mode, choose Web.
127
Last updated 11/16/2011
ડાઉનલોડ કરો
જાહેરાત