Registers Window. freescale IDE 5.7
Werbung
Werbung
Working with Memory
Registers Window
Table 20.4 Opening an Array Window by Using a Contextual Menu ( continued)
On this host…
Solaris
Linux
Do this…
Click and hold on the array, then select View Array.
Click and hold on the array, then select View Array.
Registers Window
The Registers window reveals a hierarchical view of these register types:
• general registers—contents of the central processing unit (CPU) of the host computer
• floating-point unit (FPU) registers—contents of the FPU registers
• registers specific to the host computer
You can use the Register window to perform these tasks:
• expand the hierarchical items in the window and view their contents
• select and modify register values
• view documentation for individual registers (depending on the register)
shows a sample Registers window.
Figure 20.3 Registers Window
244 IDE 5.7 User’s Guide
Working with Memory
Registers Window
General Registers
The General Registers are the register contents of the central processing unit (CPU) of the host computer. The exact listing of these registers depends on the host CPU and current build target. See the Targeting documentation for additional information.
FPU Registers
The FPU Registers are the register contents of the floating-point unit (FPU) of the host computer. The exact listing of these registers depends on the host FPU and current build target. See the Targeting documentation for additional information.
Host-specific Registers
The Registers window also lists additional register contents for registers specific to the host. The exact listing of these registers depends on the host computer and current build target. See the Targeting documentation for additional information.
Opening the Registers Window
Open the Registers window to inspect and modify various register contents.
explains how to open the Registers window.
Table 20.5 Opening the Registers Window
On this host…
Windows
Macintosh
Solaris
Linux
Do this…
Select View > Registers
Select Window > Registers Window
Select Window > Registers Window
Select Window > Registers Window
Viewing Registers
View registers to inspect and modify their contents.
IDE 5.7 User’s Guide 245
Working with Memory
Registers Window
1. Open the Registers window.
2. Expand the hierarchical list to view register groups.
Expanding the list shows the register groups that you can view or change.
3. Expand a register group.
Expanding a group shows its contents, by register name and corresponding value.
Changing Register Values
Change register values during program execution in order to examine program behavior.
1. Open the Registers window.
2. Expand the hierarchical list to view the names and corresponding values of the register that you want to modify.
3. Double-click the register value that you want to change.
The value highlights.
4. Enter a new register value.
5. Press Enter or Return.
The register value changes.
Changing Register Data Views
Change register data views to see register contents in a different format. For example, you can change the view of a register from binary to hexadecimal format.
1. Open the Registers window.
2. Expand the hierarchical list to view the names and corresponding values of the register.
3. Select the register value that you want to view in a different format.
The value highlights.
4. Select Data > View as format, where format is the data format in which you want to view the register value. The register value changes format.
Available formats depend on the selected register value.
5. Select Data > View as Default to restore the original data format.
Alternatively, you can use a contextual menu to change the data format, as Table 20.6
explains.
246 IDE 5.7 User’s Guide
Herunterladen
Werbung