Process window. Model Technology Special EE/SE, Elite EE/SE
Pubblicità
Pubblicità
Process window
Process window
The Process window displays a list of processes (either active or in region) and indicates the pathname of the instance in which the process is located.
Window updated
Each HDL item in the scrollbox is preceded by one of the following indicators:
• <Ready>
Indicates that the process is scheduled to be executed within the current delta time.
• <Wait>
Indicates that the process is waiting for a VHDL signal or Verilog net or variable to change or for a specified time-out period.
• <Done>
Indicates that the process has executed a VHDL wait statement without a time-out or a sensitivity list. The process will not restart during the current simulation run.
If you select a "Ready" process, it will be executed next by the simulator.
When you click on a process in the Process window the following windows are updated:
Result
shows the region in which the process is located shows the VHDL variables and Verilog register variables in the process shows the associated source code shows the process, the signals and nets the process reads, and the signals and nets driven by the process.
ModelSim EE/SE User’s Manual ModelSim EE Graphic Interface
10-189
Process window
The Process window menu bar
The following menu commands and button options are available from the Process window menu bar.
File menu
Save As
Environment
Close save the process tree to a text file viewable with the ModelSim
notepad
(CR-104)
Follow Process Selection: update the window based on the selection in the
; Fix to Process: maintain the current view, do not
update close this copy of the Process window; you can create a new window with
View > New from the
Edit menu
Copy
Sort
Select All
Unselect All
Find...
copy the selected process sort the process list in either ascending, descending, or declaration order select all signals in the Process window deselect all signals in the Process window find specified text string within the structure tree; choose the Status (ready, wait or done) or Process label to search and the search direction: forward or reverse
View menu
Active
In Region
Displays all the processes that are scheduled to run during the current simulation cycle.
Displays any processes that exist in the region that is selected in the Structure window.
Window menu
Initial Layout
Cascade
Tile Horizontally restore all windows to the size and placement of the initial full-screen layout cascade all open windows tile all open windows horizontally
10-190
ModelSim EE Graphic Interface ModelSim EE/SE User’s Manual
Process window
Tile Vertically
Icon Children
Icon All
Deicon All
Customize
<window_name> tile all open windows vertically icon all but the Main window icon all windows deicon all windows use
to define and add a button to either the menu bar, tool bar, or status bar of the specified window lists the currently open windows; select a window name to switch to, or show that window if it is hidden; when the source window is available, the source file name
is also indicated; open additional windows from the "View menu"
Main window, or use the
view
command
(CR-180)
ModelSim EE/SE User’s Manual ModelSim EE Graphic Interface
10-191
Scarica
Pubblicità