Structure window. Model Technology Special EE/SE, Elite EE/SE
Advertentie
Advertentie
Structure window
Structure window
The Structure window provides a hierarchical view of the structure of your design.
An entry is created by each HDL item within the design. (Your design structure can remain hidden if you wish, see
"Source code security and -nodebug"
.)
HDL items you can view
The following HDL items for VHDL and
Verilog are represented by hierarchy within
Structure window.
VHDL items
(indicated by a dark blue square icon) signals, variables, component instantiation, generate statement, block statement, and package
Verilog items
(indicated by a lighter blue circle icon) parameters, registers, nets, module instantiation, named fork, named begin, task, and function
Virtual items
(indicated by an orange diamond icon) virtual signals, buses, and functions, see
"Virtual Objects (User-defined buses, and more)"
for more information.
You can expand and contract the display to view the hierarchical structure by clicking on the boxes that contain "+" or "-". Clicking "+" expands the hierarchy so the subelements of that item can be seen. Clicking "-" contracts the hierarchy.
The first line of the Structure window indicates the top-level design unit being simulated. By default, this is the only level of the hierarchy that is expanded upon opening the Structure window.
10-206
ModelSim EE Graphic Interface ModelSim EE/SE User’s Manual
Structure window
Instance name components in the Structure window
An instance name displayed in the Structure window consists of the following parts: instantiation label entity or module
(architecture) where:
• instantiation label
Indicates the label assigned to the component or module instance in the instantiation statement.
• entity or module
Indicates the name of the entity or module that has been instantiated.
• architecture
Indicates the name of the architecture associated with the entity (not present for
Verilog).
When you select a region in the Structure window, it becomes the current region and is highlighted; the
change dynamically to reflect the information for that region. This feature provides a useful method for finding the source code for a selected region because the system keeps track of the pathname where the source is located and displays it automatically, without the need for you to provide the pathname.
Also, when you select a region in the Structure window, the
is updated if In Region is selected in that window; the Process window will in turn update the
The Structure window menu bar
The following menu commands are available from the Structure window menu bar.
File menu
Save_As
Environment
Close save the structure tree to a text file viewable with the ModelSim
notepad
(CR-104) changing of current environment between open datasets; or, establish a New
Context by opening a new dataset close this copy of the Structure window; you can create a new window with
View > New from the "The Main window menu bar"
ModelSim EE/SE User’s Manual ModelSim EE Graphic Interface
10-207
Structure window
Edit menu
Copy
Sort
Expand Selected
Collapse Selected
Expand All
Collapse All
Find...
copy the current selection in the Structure window sort the structure tree in either ascending, descending, or declaration order expands the hierarchy of the selected item collapses the hierarchy of the selected item expands the hierarchy of all items that can be expanded collapses the hierarchy of all expanded items find specified text string within the structure tree; choose the label for instance, entity/module or architecture to search for and the search direction: forward or reverse
Window menu
Initial Layout
Cascade
Tile Horizontally
Tile Vertically
Icon Children
Icon All
Deicon All
Customize
<window_name> restore all windows to the size and placement of the initial full-screen layout cascade all open windows tile all open windows horizontally tile all open windows vertically icon all but the Main window icon all windows deicon all windows use
to define and add a button to either the menu bar, tool bar, or status bar of the specified window lists the currently open windows; select a window name to switch to, or show that window if it is hidden; when the source window is available, the source file name
is also indicated; open additional windows from the "View menu"
Main window, or use the
view
command
(CR-180)
10-208
ModelSim EE Graphic Interface ModelSim EE/SE User’s Manual
Downloaden
Advertentie